Verktyg Visningsval
2011-02-05, 10:04   #1

Polomononen

Medlem

Registrerad: mar 2006

Skriva {} i emacs på en mac (Shift + alt + 8 fungerar ej)


Hej, jag håller på att bli tokig på detta problem. Först hittade jag inte kommandot för "{" och "}" alls. Men det visade sig vara Shift + Alt + 8. Men detta fungerar inte alls i GNU Emacs. Den tolkar kommandona på sitt eget sätt. Jag kan inte gå in under "specialtecken" varje gång jag ska skriva den typen av klammer när jag programmerar?!

Visste inte om jag skulle posta här eller under programmering då det egentligen berör emacs.
__________________
Inet - Fraktfritt
Polomononen är inte uppkopplad
2011-02-05, 10:17   #2

Sidde

Medlem

Siddes avatar

Plats: Sundsvall

Registrerad: feb 2002

Kör du emacs lokalt på din mac? För jag kan göra måsvingarna helt normalt i emacs lokalt på maskinen.

Jag kör då iso latin 1 som encoding på terminal.app
Sidde är inte uppkopplad
2011-02-05, 10:20   #3

widL

Moderator

widLs avatar

Registrerad: maj 2006

*Trådrubrik redigerad*
__________________
Om du har synpunkter eller klagomål på min moderering kontaktar du mig enklast via PM.
Core i5 760 | 8 GB DDR3 | GTX 570 | Samsung 840 250 GB | Dell U2711 | MacBook Air mid 2011
Visste du att SweClockers har en egen Mumble-server? Välkommen in!
widL är inte uppkopplad Folding
2011-02-05, 10:22   #4

Polomononen

Medlem

Registrerad: mar 2006

Citat:
Ursprungligen inskrivet av Sidde Visa inlägg
Kör du emacs lokalt på din mac? För jag kan göra måsvingarna helt normalt i emacs lokalt på maskinen.

Jag kör då iso latin 1 som encoding på terminal.app
Ta det där en gång till. Förstår inte äns vad du menar med att köra lokalt. Min kunskapsnivå är väldigt låg när det gäller detta.

EDIT:

Lokalt? Alltså jag kör ju programmet direkt i min dator eller vad menas?
iso latin 1 är aktiverad i terminalen

Senast redigerad av Polomononen 2011-02-05 klockan 10:32.
__________________
Inet - Fraktfritt
Polomononen är inte uppkopplad
2011-02-05, 10:42   #5

b0bzor!

Medlem

b0bzor!s avatar

Plats: Landskrona

Registrerad: jan 2004

Citat:
Ursprungligen inskrivet av Polomononen Visa inlägg
Ta det där en gång till. Förstår inte äns vad du menar med att köra lokalt. Min kunskapsnivå är väldigt låg när det gäller detta.

EDIT:

Lokalt? Alltså jag kör ju programmet direkt i min dator eller vad menas?
iso latin 1 är aktiverad i terminalen
Jag förmodar att han menar om du kör på emacs på Mac:en eller om du SSH:at in på en maskin där du kör emacs?
__________________
iMac 27" | Mid 2010 | Core i7 2.93Ghz | 20 GB | HD5850 M | Samsung 830 256 GB | 1TB WD
MacBook Pro 15" | Late 2011 | Core i7 2.2Ghz | 8 GB | HD6750 M | Samsung 840 500 GB
Citera gärna om du svarar på mina inlägg, så hittar jag tillbaka igen! :)
b0bzor! är inte uppkopplad
2011-02-05, 11:02   #6

Polomononen

Medlem

Registrerad: mar 2006

Kommandot Shift + Ctrl + 8 tolkas som "()" och markören hamnar i parentesen.
__________________
Inet - Fraktfritt
Polomononen är inte uppkopplad
2011-02-05, 11:52   #7

Polomononen

Medlem

Registrerad: mar 2006

Finns det några bra alternativ istället för emacs då? Finns det någon kompilator istället för xcode? xcode är ju på flera GB!
__________________
Inet - Fraktfritt
Polomononen är inte uppkopplad
2011-02-05, 14:56   #8

Polomononen

Medlem

Registrerad: mar 2006

Har nu även testat Aquaemacs och det är samma problem där. Bindningen för tangentbordskombinationen är helt enkelt upptagen. Men hur kommer det sig att Sidde inte har samma problem då? Fungerar det att byta språk eller liknande för att komma förbi problemet? Jag har försökt ändra den upptagna "keybind" i emacs utan resultat. Finns det någon annan bra editor som inte har GNU Emacs som bas?

Hjälp uppskattas!
__________________
Inet - Fraktfritt
Polomononen är inte uppkopplad
2011-02-07, 09:06   #9

MarcusW

Medlem

Plats: ~

Registrerad: aug 2005

Vad blir "Höger alt" + 8?
__________________
Debian
MarcusW är inte uppkopplad
2011-02-07, 10:26   #10

Polomononen

Medlem

Registrerad: mar 2006

Citat:
Ursprungligen inskrivet av MarcusW Visa inlägg
Vad blir "Höger alt" + 8?
Är ingen skillnad på höger- och vänster alt. Båda ger [ och använder jag Shift höger alt 8 så är det samma problem som tidigare.
__________________
Inet - Fraktfritt
Polomononen är inte uppkopplad
2011-02-07, 11:32   #11

laserlars

Medlem

Plats: Uppsala

Registrerad: dec 2009

För aquamacs


Jag har bara använt aquamacs på mac men det skulle kunna vara samma sak till vanliga grafiska emacs. Nu var det ett tag sen men jag är hyfsat säker på att jag använde följande.

Skriv in i den dolda filen .emacs som ligger i din hemmapp:
(setq mac-option-modifier nil
mac-command-modifier 'meta
x-select-enable-clipboard t)

Du kan öppna den med att skriva tex pico .emacs i en terminal.


http://www.emacswiki.org/emacs/AquamacsFAQ
laserlars är inte uppkopplad
2011-02-07, 14:15   #12

Polomononen

Medlem

Registrerad: mar 2006

Citat:
Ursprungligen inskrivet av laserlars Visa inlägg
Jag har bara använt aquamacs på mac men det skulle kunna vara samma sak till vanliga grafiska emacs. Nu var det ett tag sen men jag är hyfsat säker på att jag använde följande.

Skriv in i den dolda filen .emacs som ligger i din hemmapp:
(setq mac-option-modifier nil
mac-command-modifier 'meta
x-select-enable-clipboard t)

Du kan öppna den med att skriva tex pico .emacs i en terminal.


http://www.emacswiki.org/emacs/AquamacsFAQ
Tack för länken. I aquaemacs hittade jag options -> option, command, meta keys. När jag valde "options for composed characters" så började allt fungera som det ska. Hittade inte samma på GNU Emacs tyvärr.
__________________
Inet - Fraktfritt
Polomononen är inte uppkopplad
2012-11-18, 13:50   #13

Piece of Cake

Medlem

Piece of Cakes avatar

Plats: Partille-Göteborg

Registrerad: jun 2009

Sorry för att jag väcker en gammal tråd, men jag hittade denna tråden när jag googlade för att hitta en lösning till samma problem.
Min föreläsare hittade till slut lösningen till detta problem, och jag tänkte därför dela med mig av den lösningen här.

Kopiera och klistra in exakt följande i er .emacs-fil:
(setq default-input-method "MacOSX")

(setq mac-command-modifier 'meta
      mac-option-modifier nil
      mac-allow-anti-aliasing t
      mac-command-key-is-meta t)
Detta kommer att göra att alla tecken funkar som vanligt, med de vanliga tangentkombinationerna. Esc-tangenten funkar nu som meta-tangent.
__________________
Den här texten är helt j*vla onödig, men den ska vara här helt enkelt.
The Sleeper: Intel Core i7 930+Noctua NH-C12P SE14, Gigabyte GA-X58A-UD3R, XFX HD6970, Corsair 6GB 1600MHz, be quiet! Dark Power Pro P8 750W, WD Black 640GB, Lian Li PC-A77F
MacBook Pro 4,1 17" iMac 12,2 27"
CITERA VID SVAR PÅ MINA INLÄGG SÅ ATT JAG KAN HITTA TILLBAKA!
Piece of Cake är inte uppkopplad
Senaste nyheterna

Redaktionens senaste nyhetsrubriker

Sök jobb