Verktyg Visningsval
2013-04-09, 13:41   #1

Nollprocent

Medlem

Registrerad: mar 2013

Arch AUR helper - autoaur - problem vid konfigurering


Jag är ny på Linux och Arch men börjar komma igång med mitt system. Jag skulle behöva tanka ett tiotal paket från AUR, vilket kändes som en lite omständig process med att tanka tarballs, skapa paket, osv, så jag skaffar mig ett program som kan sköta det där lite smidigare, typ autoaur. Men efter mycket om och men kommer jag inte förbi det här steget i konfigureringen. Enligt instruktioner ska jag gå till mappen jag vill använda och sedan peka på xgl.autoaur, vilket jag gör och får då följande resultat:

[root@archprocent glproto-git]# sudo autoaur ~/downloads/aur/autoaur/pkg/autoaur/usr/share/doc/autoaur/xgl.autoaur
enter version number for glproto-git
20121017-1
Removing old archive 'glproto-git.tar.gz'...
Downloading package 'glproto-git'...
2013-04-09 15:34:23 URL:https://aur.archlinux.org/packages/gl/glproto-git/glproto-git.tar.gz [787/787] -> "glproto-git.tar.gz" [1]
Extracting 'glproto-git.tar.gz' archive...
glproto-git/
glproto-git/PKGBUILD

Deleting glproto-git.tar.gz
Changing pkgver in 'glproto-git' to '20121017-1'...
Generating md5sums for 'glproto-git' package...
==> FEL:  Running makepkg as root is a BAD idea and can cause permanent,
catastrophic damage to your system. If you wish to run as root, please
use the --asroot option.
Md5sums in 'glproto-git' can't be generated. Skipping this package...

==> Building package glproto-git...
==> FEL:  Running makepkg as root is a BAD idea and can cause permanent,
catastrophic damage to your system. If you wish to run as root, please
use the --asroot option.
Jag har använt --asroot för att bygga mina egna paket men jag förstår inte hur jag ska få den här installationen att göra det åt mig...? Hjälp!
Nollprocent är inte uppkopplad
2013-04-09, 15:34   #2

ToJa92

Medlem

ToJa92s avatar

Registrerad: aug 2010

Makepkg behöver inte köras som root för att fungera. Nu vet jag inte hur autoaur fungerar, jag kör med yaourt och där så installerar den automatiskt paket som root, man kör alltså inte verktyget som root.
__________________
Citera mig gärna om du svarar på något jag skrivit.
MacBook Pro Retina (128GB, i5, OS X Yosemite, Late 2013) iPhone 6 Plus (64GB, rymdgrå)
Asus Gryphon Z87 (Silverstone SG09, 2TB+2*128GB SSD, Intel 4670k, Nvidia 560Ti, Windows 8.1 Pro) PC Engines Alix.2d3 (Arch Linux)
ToJa92 är uppkopplad nu
2013-04-09, 15:55   #3

perost

Medlem

perosts avatar

Plats: Linköping

Registrerad: jun 2007

autoaur ser inte ut att ha uppdaterats på två år enligt AUR, så det kanske inte är att rekommendera. Kör med yaourt som ToJa92 säger istället, det är ett riktigt bra verktyg. Det fungerar ungefär som pacman, och sköter beroenden och sånt automatisk. Enklast är att bara använda deras paketförråd, se yaourts hemsida.
perost är inte uppkopplad
2013-04-11, 16:03   #4

Nollprocent

Medlem

Registrerad: mar 2013

Jag körde på Yaourt istället, allt funkar som det ska, tack! :-)
Nollprocent är inte uppkopplad
2013-04-13, 01:48   #5

Rist

Medlem

Registrerad: jan 2005

Beroende på hur mycket du vill att din aurhelpern ska göra finns det ju olika alternativ. Jag gillar cower. Den är väldigt snabb och smidig. Men har inte lika mycket funktionalitet som yaourt. Den laddar ner pkgbuildsen som ska uppdateras istället för att helt automatisera det.
Rist är inte uppkopplad
Senaste nyheterna

Redaktionens senaste nyhetsrubriker