Sidan 1 av 2 1 2
 
Verktyg Visningsval
2009-01-29, 16:28   #1

kokobong

Medlem

Plats: Bromma

Registrerad: jan 2004

Installera Windows 7 via USB?


Hej

*bort*

köpte mig ett USB.

pluggade in det i maskinen och körde följande kommandon i cmd:

diskpart
list disk
select disk 1(den som är usb minnet)
clean
create partition primary
select partition 1
active
format fs=fat32
assign
exit

därefter packade jag upp ison med hjälp utav Winrar direkt på USB minnet.

tog därefter samma pc som jag gjorde inställningarna på, gick in i bios och ändrade till Boot options till USB-HDD

vips så var det bara att installera.

Därefter tog jag USB-minnet till den datorn jag egentligen ville installera det på gick in under BIOS-Boot option och bockade i Boot USB-HDD.

precis när den ska boota kommer det upp nåt i stilen med "Bad partition table"

prövade på en annan pc där det fungerar prima.

Någon som vet vad jag gör fel?


Har en core2duo + lite annat skit som jag definitivt vet är 64 bitars kompatibelt.

extremt Tacksam för hjälp!

Något man måste preparera datorn för Windows 7?

Senast redigerad av kokobong 2009-01-30 klockan 13:47.
kokobong är inte uppkopplad
2009-02-04, 23:57   #2

Jens Ek

Medlem

Plats: Alvesta/Göteborg

Registrerad: aug 2005

Lyfter denna då jag har planer att göra samma sak inom de närmsta dagarna. Har ingen optik på min htpc, så får koka ihop något sånt här...
Borde ju inte vara några problem tycker man??
Jens Ek är inte uppkopplad
2009-02-05, 00:04   #3

joar

Medlem

joars avatar

Plats: Luleå

Registrerad: jun 2002

Re: Installera Windows 7 via USB?


Citat:
Ursprungligen inskrivet av kokobong

/.../tog därefter samma pc som jag gjorde inställningarna på, gick in i bios och ändrade till Boot options till USB-HDD

vips så var det bara att installera.

/.../

prövade på en annan pc där det fungerar prima.

Någon som vet vad jag gör fel?


Bra idé! Jag har en bärbar utan optisk, så det här kan vara till god hjälp.

Men jag måste bara få förtydligat: Du har alltså testat din USB-installation på två separata datorer där det fungerat fint?

Men nej, jag vet inte vad som kan vara fel. Vad jag vet ska inte någon PC behöva prepareras på något sätt för att det ska fungera.


/joar.
__________________
Lyssna till vad jag menar, inte vad jag säger!
||Win7 x64 Pro -- Intel i5 2500K @3,3GHz -- Asus P8P67-M Pro -- Asus GeForce GTX560 1GB -- 8GB Corsair Vengeance DDR3 @1600MHz -- Samsung 840 Pro 256GB -- 700W OCZ ModXStream Pro||
joar är inte uppkopplad
2009-02-05, 16:12   #4

FoxOne

Medlem

FoxOnes avatar

Plats: ―

Registrerad: feb 2006

Följ instruktionerna för att installera Vista från en USB-drive så funkar det fint; http://kurtsh.spaces.live.com/blog/c...38D!1665.entry
__________________
Dator1|Dator2|Dator3|Dator4|Dator5|Dator6
Raid is not backup
FoxOne är inte uppkopplad
2009-02-05, 19:53   #5

joar

Medlem

joars avatar

Plats: Luleå

Registrerad: jun 2002

Citat:
Ursprungligen inskrivet av FoxOne
Följ instruktionerna för att installera Vista från en USB-drive så funkar det fint; http://kurtsh.spaces.live.com/blog/c...38D!1665.entry
Tack, det ska jag testa!
__________________
Lyssna till vad jag menar, inte vad jag säger!
||Win7 x64 Pro -- Intel i5 2500K @3,3GHz -- Asus P8P67-M Pro -- Asus GeForce GTX560 1GB -- 8GB Corsair Vengeance DDR3 @1600MHz -- Samsung 840 Pro 256GB -- 700W OCZ ModXStream Pro||
joar är inte uppkopplad
2009-02-05, 22:21   #6

Blubbb

Medlem

Blubbbs avatar

Plats: här

Registrerad: dec 2003

Det jag gjorde var endast att formatera minnet, sen kopierade jag över innehållet från iso till usb minnet sen vare klart.
Blubbb är inte uppkopplad
2009-02-06, 00:19   #7

joar

Medlem

joars avatar

Plats: Luleå

Registrerad: jun 2002

Citat:
Ursprungligen inskrivet av Blubbb
Det jag gjorde var endast att formatera minnet, sen kopierade jag över innehållet från iso till usb minnet sen vare klart.
Seriöst? Fungerade minnet som en startdisk sen? Låter otroligt!

Vore ju föredömligt slött o bekvämt om så vore, dock.

/j.
__________________
Lyssna till vad jag menar, inte vad jag säger!
||Win7 x64 Pro -- Intel i5 2500K @3,3GHz -- Asus P8P67-M Pro -- Asus GeForce GTX560 1GB -- 8GB Corsair Vengeance DDR3 @1600MHz -- Samsung 840 Pro 256GB -- 700W OCZ ModXStream Pro||
joar är inte uppkopplad
2009-02-06, 02:46   #8

Blubbb

Medlem

Blubbbs avatar

Plats: här

Registrerad: dec 2003

Citat:
Ursprungligen inskrivet av joar
Seriöst? Fungerade minnet som en startdisk sen? Låter otroligt!

Vore ju föredömligt slött o bekvämt om så vore, dock.

/j.
Jepp formatera det i fat32 bara så är det inga problem, gjorde det nyss förövrigt
Blubbb är inte uppkopplad
2009-02-06, 07:50   #9

joar

Medlem

joars avatar

Plats: Luleå

Registrerad: jun 2002

Citat:
Ursprungligen inskrivet av Blubbb
Jepp formatera det i fat32 bara så är det inga problem, gjorde det nyss förövrigt
Coolt. Ska testas senare idag då jag ska försöka att knuffa in Win7 på min Eee 1000H.

/j.
__________________
Lyssna till vad jag menar, inte vad jag säger!
||Win7 x64 Pro -- Intel i5 2500K @3,3GHz -- Asus P8P67-M Pro -- Asus GeForce GTX560 1GB -- 8GB Corsair Vengeance DDR3 @1600MHz -- Samsung 840 Pro 256GB -- 700W OCZ ModXStream Pro||
joar är inte uppkopplad
2009-02-09, 14:07   #10

Jens Ek

Medlem

Plats: Alvesta/Göteborg

Registrerad: aug 2005

Testade nyss detta, fick inte usb-stickan till att fungera som bootdisk.
Inga problem med bios eler så, men när den ska till att boota får jag "Fel på systemdisk".

Formaterade stickan i xp med fat32, och kopierade över innehåller i 7x64 ison mha winrar. Har googlat andra sidor som säger att man ska formatera i ntfs? Spelar det någon roll??

OM man följer instruktionerna ovan i CMD, gör det någon skillnad mot att låta göra en "vanlig" formatering i utforskaren? (vilket jag gjorde)

Ska leka lite till när jag kommer hem från jobbet inatt.
Jens Ek är inte uppkopplad
2009-02-09, 19:25   #11

joar

Medlem

joars avatar

Plats: Luleå

Registrerad: jun 2002

Citat:
Ursprungligen inskrivet av Jens Ek
Testade nyss detta, fick inte usb-stickan till att fungera som bootdisk.
Inga problem med bios eler så, men när den ska till att boota får jag "Fel på systemdisk".

Formaterade stickan i xp med fat32, och kopierade över innehåller i 7x64 ison mha winrar. Har googlat andra sidor som säger att man ska formatera i ntfs? Spelar det någon roll??

OM man följer instruktionerna ovan i CMD, gör det någon skillnad mot att låta göra en "vanlig" formatering i utforskaren? (vilket jag gjorde)
Jag har testat både att formatera med diskpart i CMD och som vanligt i Windows, och för mig fungerar båda delarna. Har installerat om min Eee 1000H tre gånger senaste dygnet bara för att experimentera lite.

Har dock hela tiden kört i FAT32 eftersom att det här ovan påstods att man var tvungen att göra så - men vad jag läst på andra forum så ska det inte heller spela någon roll.

Mitt tips är att du igen kollar så att USB-stickan verkligen är först i BOOT-ordningen (min EEE tyckte att mitt minne var en "USB harddrive" inte en "Removable storage", vilket gjorde mig förvirrad i början), formaterar i CMD (verkar fungera för de flesta) och försöker igen.

Lycka till!

/joar.

Senast redigerad av joar 2009-02-09 klockan 20:13.
__________________
Lyssna till vad jag menar, inte vad jag säger!
||Win7 x64 Pro -- Intel i5 2500K @3,3GHz -- Asus P8P67-M Pro -- Asus GeForce GTX560 1GB -- 8GB Corsair Vengeance DDR3 @1600MHz -- Samsung 840 Pro 256GB -- 700W OCZ ModXStream Pro||
joar är inte uppkopplad
2009-02-09, 19:54   #12

karelin

Medlem

Plats: Stockholm

Registrerad: jan 2003

Jag kan bekräfta att det går lika bra med NTFS som filssystem för en bootbar USBsticka.
karelin är inte uppkopplad
2009-02-09, 22:35   #13

Tenkan

Medlem

Plats: Stallarholmen

Registrerad: maj 2007

Om jag inte får upp mitt USB minne synligt i cmd när jag kollar "list disk" vad är då felet? Hur får jag den synlig?

Noggrann beskrivning är varmt välkommen.

mvh Tenggren
__________________
Antec 1200, intel i7 920, Corsair 8 gb 1600mhz, Asus P6T Deluxe, SDD Intel 320 80 gb, SSD Corsair x32, WD Raptor 74 gb, WD Raptor 150 gb, Samsung 400 gb, XFX HD6990 4gb,Creative X-fi Extreme musik, Corsair HX 750 W, Logitech Z-5500, Win 7 Pro 64bit
Tenkan är inte uppkopplad
2009-02-09, 23:44   #14

Jens Ek

Medlem

Plats: Alvesta/Göteborg

Registrerad: aug 2005

Citat:
Ursprungligen inskrivet av Tenkan
Om jag inte får upp mitt USB minne synligt i cmd när jag kollar "list disk" vad är då felet? Hur får jag den synlig?

Noggrann beskrivning är varmt välkommen.

mvh Tenggren
Har samma problem, hittar den som volym (list volume) men ej som disk.
Vet inte varför. (ska tilläggas att jag är rätt grön på detta område, även om man var med på dos-tiden ) Ska pula vidare lite...

Jag har inte usb 2.0 på min arbetsburk (där jag gör allt detta), kan det spela roll?
Jens Ek är inte uppkopplad
2009-02-10, 00:40   #15

Jens Ek

Medlem

Plats: Alvesta/Göteborg

Registrerad: aug 2005

Upptäckte vad som är problemet:
Diskpart är av en äldre version (v5) i xp, och kan inte se flyttbara media som disk, endast volym. Iom vista ska Diskpart vara av en nyare version och klara detta.

Återkommer om jag hittar något 3:e part program som löser detta...

Senast redigerad av Jens Ek 2009-02-10 klockan 00:45.
Jens Ek är inte uppkopplad
2009-02-11, 01:29   #16

Jens Ek

Medlem

Plats: Alvesta/Göteborg

Registrerad: aug 2005

Problemet löst (efter en hel del googlande och testande), så här behöver du göra om du kör xp:

1. Ladda ned HP USB disk storage format tool tex här:
Länk

2. Installera och kör den => formatera din USB-sticka. (Jag använde ntfs, men spelar nog ingen roll)

Om du har xp64 och har win7x64 ison: (har inte xp64 själv, så har inte testat detta men tror det går)
3. Packa upp bootsect.exe ur win7 ison. (ligger i BOOT katalogen) Denna är 64bit och borde kunna köras direkt i xp64.

Om du har xp32 och har win7x64 ison: (Som jag, detta vet jag funkar)
3. Leta reda på och packa upp 32bit bootsect.exe, jag hittade den i detta utility pack, USB MultiBoot 10: Länk (Ligger i makebt katalogen)

4: I CMD gå till katalogen du packade upp bootsect till, och kör: "bootsect /nt60 f:" (ersätt f: med den volym din usb har, min råkade vara f)

5. Extrahera Win7 ison (jag gjorde det med winrar) direkt till stickan.

6. Kllaaaaaart!

Har precis installerat Win7 på min nybyggda htpc burk utan optik, funkade kanon när man väl fått detta till att lira.

Om du har Win7x32 ison borde du kunna använda bootsect.exe som ligger med i den oavsett om du har xp32 eller xp64. (Jag antar att 32bit går att köra i 64bit miljö?)
Jens Ek är inte uppkopplad
2009-02-15, 22:00   #17

depplis

Medlem

Plats: Gävle

Registrerad: feb 2005

Citat:
Ursprungligen inskrivet av Blubbb
Det jag gjorde var endast att formatera minnet, sen kopierade jag över innehållet från iso till usb minnet sen vare klart.
När du säger att du kopierar över innehållet, menar du att du packar upp innehållet från iso´n till usbminnet eller att du lägger isofilen med windows på det formaterade usb-minnet?

Jag har testat båda varianterna nu och inget av dom fungerar.

Väljer att USB ska vara första boot device, men allt blir bara svart. Jag byter ut hårddisken till usb-minnet i bios och rebootar. Svart!

Jag har ett "Sandisk Cruzer Micro USB Device" 8GB.
__________________
ASUS P5B | Hiper Type-R 530W | Intel Core 2 Duo E6300 @ lite klock | 3GB - 667MHZ | XFX 8800GTS | 500GB Seagate | AGM A-19" & Samsung Q96, 42" | - Pro.2 PH-U585 | MX300 @ Func sUrface 1030 och allt hackar och krånglar på ett Windows Vista Ultimate -os
depplis är inte uppkopplad
2009-02-15, 22:16   #18

janee

Medlem

Plats: Örnsköldsvik

Registrerad: aug 2006

Jag bootar Puppy Linux från Sandisk Cruzer men jag har avinstallerat U3 från minnet med hjälp av ett litet program som ligger på Sandisk hemsida.

Det är kanske U3 funktionen som hindrar dig.
__________________
janee
janee är uppkopplad nu
2009-02-16, 08:19   #19

Jens Ek

Medlem

Plats: Alvesta/Göteborg

Registrerad: aug 2005

depplis usb't måste även vara formaterat enligt något av förslagen ovan innan du extraherar iso-filen till usb't.
Jens Ek är inte uppkopplad
2009-02-16, 09:12   #20

depplis

Medlem

Plats: Gävle

Registrerad: feb 2005

Citat:
Ursprungligen inskrivet av janee
Jag bootar Puppy Linux från Sandisk Cruzer men jag har avinstallerat U3 från minnet med hjälp av ett litet program som ligger på Sandisk hemsida.

Det är kanske U3 funktionen som hindrar dig.
Ok, jag har formaterat minnet. Borde inte den funktionen försvinna?

Citat:
depplis usb't måste även vara formaterat enligt något av förslagen ovan innan du extraherar iso-filen till usb't.


Jag formaterade minnet i fat32 genom att bara högerklicka på det i utforskaren. Sedan extraktade jag isofilen till minnet, ställde minnet som första boot device. Det funkade inte så formaterade om minnet och lade .iso-filen på minnet. Inget där heller.
__________________
ASUS P5B | Hiper Type-R 530W | Intel Core 2 Duo E6300 @ lite klock | 3GB - 667MHZ | XFX 8800GTS | 500GB Seagate | AGM A-19" & Samsung Q96, 42" | - Pro.2 PH-U585 | MX300 @ Func sUrface 1030 och allt hackar och krånglar på ett Windows Vista Ultimate -os
depplis är inte uppkopplad
2009-02-16, 16:16   #21

Timp_da_gimp

Medlem

Plats: Stockholm

Registrerad: jan 2004

Man måste använda diskpart första gången (ny usb sticka), då sätts det att stickan ska vara bootbar. Det måste också vara diskpart i vista eller windows 2008.

1. diskpart
2. list disk
3. select disk 1 (eller vilken siffra usb-stickan nu är enligt kommandot ovan)
4. clean
5. create partition primary
6. select partition 1
7. active
8. format fs=fat32 quick
9. assign
10. exit

I cmdpromten skrivs sedan: xcopy d:\*.* /s/e/f e:\

Där d:\ är er cdrom (eller virtuell mountad drive)
och e:\ är enhetsbokstaven för USB stickan

Dena metod fungerar sedan utmärkt att använda vid installation av samtliga windowsversioner. Då använder ni bara xcopy, diskpart behöver ej köras igen.

Jag har med denna metod lyckats installerat xp, 2k3, vista, 2k8 och W7.

Senast redigerad av Timp_da_gimp 2009-08-27 klockan 13:25.
Timp_da_gimp är inte uppkopplad
2009-02-16, 18:40   #22

joar

Medlem

joars avatar

Plats: Luleå

Registrerad: jun 2002

Citat:
Ursprungligen inskrivet av depplis
Ok, jag har formaterat minnet. Borde inte den funktionen försvinna?


Jag formaterade minnet i fat32 genom att bara högerklicka på det i utforskaren. Sedan extraktade jag isofilen till minnet, ställde minnet som första boot device. Det funkade inte så formaterade om minnet och lade .iso-filen på minnet. Inget där heller.
Nej, det är inte säkert att det räcker att formatera. SanDisk kan rent teoretiskt ha gjort en speciell parition för sitt program. Använd deras avinstallationsprogram så som janee tipsade om.

Och NEJ, det är inte helt säkert att det duger att fomatera i Windows, du måste kanske göra det med diskpart i CMD. Testa att göra så som alla sagt att du ska göra så ska du se att det kan gå. Timp_da_gimp skrev här ovan ännu en gång sammanfattat hur du ska göra. Jag har testat både med diskpart och i Win, båda fungerade för Win7 på mitt USB-minne.

Och du ska inte lägga över .iso-filen, du ska lägga över INNEHÅLLET i isofilen. Så som du gjorde första gången.

Sist, men inte minst, kolla det jag nämnde tidigare i den här tråden: Att det är rätt enhet du sätter som första startenhet i BIOS. Koppla FÖRST in USB-minnet, starta SEN datorn, starta BIOS, kolla BOOT-ordningen och se till att USB-minnet är först - oavsett om datorn uppfattar det som en extern håddisk (som min Eee tyckte), eller som en "Removable device" (som min WS uppfattade det).

Lycka till!
/joar.
__________________
Lyssna till vad jag menar, inte vad jag säger!
||Win7 x64 Pro -- Intel i5 2500K @3,3GHz -- Asus P8P67-M Pro -- Asus GeForce GTX560 1GB -- 8GB Corsair Vengeance DDR3 @1600MHz -- Samsung 840 Pro 256GB -- 700W OCZ ModXStream Pro||
joar är inte uppkopplad
2009-08-26, 21:19   #23

Ramirex

Medlem

Plats: Rättvik

Registrerad: aug 2009

Hej,
Hur skriver man i diskpart att man vill formatera usb minnet till ntfs.

(format fs=fat32 quick) hur skriver man de till ntfs?

min version på w7 är för stor att kopiera till fat32.

tack för svar
Ramirex är inte uppkopplad
2009-08-26, 21:33   #24

joar

Medlem

joars avatar

Plats: Luleå

Registrerad: jun 2002

Citat:
Ursprungligen inskrivet av Ramirex
Hej,
Hur skriver man i diskpart att man vill formatera usb minnet till ntfs.

(format fs=fat32 quick) hur skriver man de till ntfs?

min version på w7 är för stor att kopiera till fat32.

tack för svar
Då är det något annat som är fel... Jag har mitt 8GB minne formaterat till FAT32, och den största versionen som finns av Win7 är mindre än så. Dessutom behöver du inte använda diskpart överhuvudtaget när du ska installera Win7, bara vid install av WinXP.

Men det raka svaret är att man skriver "format fs=ntfs", det är inte svårare än så. Starta diskpart i CMD och skriv "HELP FORMAT" så får du upp alla kommandon och exempel.

/joar.
__________________
Lyssna till vad jag menar, inte vad jag säger!
||Win7 x64 Pro -- Intel i5 2500K @3,3GHz -- Asus P8P67-M Pro -- Asus GeForce GTX560 1GB -- 8GB Corsair Vengeance DDR3 @1600MHz -- Samsung 840 Pro 256GB -- 700W OCZ ModXStream Pro||
joar är inte uppkopplad
2009-08-26, 21:37   #25

Ramirex

Medlem

Plats: Rättvik

Registrerad: aug 2009

Okey, för jag har ett 16Gb minne, men när jag har de i FAT32 så säger bara dator att disken är full, w7 versionen jag har är på 6.8Gb.

Får prova igen, vill kunna bota så jag kan ta bort Vista versionen helt.

Tack för Hjälpen
Ramirex är inte uppkopplad
2009-08-27, 13:27   #26

Timp_da_gimp

Medlem

Plats: Stockholm

Registrerad: jan 2004

Citat:
Ursprungligen inskrivet av joar
Dessutom behöver du inte använda diskpart överhuvudtaget när du ska installera Win7, bara vid install av WinXP.
Diskpart måste alltid köras åtminstone 1 gång för att den ska bli aktiv (bootbar).
__________________
Asus P5Q / C2D 3.0 GHZ / Corsair 4GB DDR2 / Asus 5850 1GB / ~4 TB HD
Timp_da_gimp är inte uppkopplad
2009-08-27, 13:27   #27

joar

Medlem

joars avatar

Plats: Luleå

Registrerad: jun 2002

Citat:
Ursprungligen inskrivet av Timp_da_gimp
Diskpart måste alltid köras åtminstone 1 gång för att den ska bli aktiv (bootbar).
För att kunna bota från ett USB-minne för att installera Win7 behöver du inte köra diskpart alls. Jag har testat, och fler med mig.
__________________
Lyssna till vad jag menar, inte vad jag säger!
||Win7 x64 Pro -- Intel i5 2500K @3,3GHz -- Asus P8P67-M Pro -- Asus GeForce GTX560 1GB -- 8GB Corsair Vengeance DDR3 @1600MHz -- Samsung 840 Pro 256GB -- 700W OCZ ModXStream Pro||
joar är inte uppkopplad
2009-08-27, 13:30   #28

Timp_da_gimp

Medlem

Plats: Stockholm

Registrerad: jan 2004

Kan tänka mig att det stämmer med nyare moderkort där bios bortser från att stickan inte är en "hårddisk".
Men lika bra att vara på säkra sidan ochs lippa göra om det
__________________
Asus P5Q / C2D 3.0 GHZ / Corsair 4GB DDR2 / Asus 5850 1GB / ~4 TB HD
Timp_da_gimp är inte uppkopplad
2009-08-27, 13:32   #29

joar

Medlem

joars avatar

Plats: Luleå

Registrerad: jun 2002

Citat:
Ursprungligen inskrivet av Timp_da_gimp
Kan tänka mig att det stämmer med nyare moderkort där bios bortser från att stickan inte är en "hårddisk".
Hm. Möjligt. Har inte haft möjlighet att testa.
__________________
Lyssna till vad jag menar, inte vad jag säger!
||Win7 x64 Pro -- Intel i5 2500K @3,3GHz -- Asus P8P67-M Pro -- Asus GeForce GTX560 1GB -- 8GB Corsair Vengeance DDR3 @1600MHz -- Samsung 840 Pro 256GB -- 700W OCZ ModXStream Pro||
joar är inte uppkopplad
2009-08-27, 15:33   #30

JohannesKBA

Medlem

Plats: Kungsbacka

Registrerad: jul 2009

Citat:
Ursprungligen inskrivet av Ramirex
Okey, för jag har ett 16Gb minne, men när jag har de i FAT32 så säger bara dator att disken är full, w7 versionen jag har är på 6.8Gb.

Får prova igen, vill kunna bota så jag kan ta bort Vista versionen helt.

Tack för Hjälpen

Det beror på att du försöker lägga över ISOn, vilket du inte skulle göra. FAT32 stöder inte filer över 4GB så det är inte så konstigt att du får detta "felet". Mounta ISOn och kör xcopy som beskrivs några inlägg upp!
JohannesKBA är inte uppkopplad
Senaste nyheterna

Redaktionens senaste nyhetsrubriker