HP Insight Manager på ESX 3.5

Trädvy Permalänk
Medlem
Plats
Mjölby
Registrerad
Maj 2009

HP Insight Manager på ESX 3.5

Försöker installera HP's insight manager på min DL380G3 med ESX 3.5 installerat, då detta verkar vara det enda sättet att styra fläktarna på.

Jag följer denna guide: http://discardme.com/blog/2009/01/22/installing-hp-insight-manager-agents-under-esx-server/

Startar upp command linen med unsupported och loggar in som root. Följer sedan detta:

PREP:

Download the correct Insight Manager agents for VMware.
Unzip the tgz file using WinRAR or something similar, and peruse the readme for up-to-date info.
Using the ILO utility or the physical console, hit Alt-F1, login as root at the command line.
To allow root ssh access in ESX as well as enable sshd client access (SFTP, SSH), we have to change the local sshd_config file.
At the command line, type: “vi /etc/ssh/sshd_config”
Go to the line that says PermitRootLogin, change from “no” to “yes”
If you are unfamiliar with vi, use arrow keys to navigate, put cursor on the “n” of “no”, hit the i key to insert, then type in “yes” and delete/backspace “no”. Then hit ESC twice to exit Insert mode. Type colon (:) to get the in-editor command line, type “wq!” and hit enter. This will save the doc and exit vi.
Back at the command line type: “service sshd restart”, hit enter.
After the service restarts, type “logout” to exit the console, hit alt-f11 to go back to the esx screen.

Dold text

Jag kommer till den delen där man ska gå in i vi /etc/ssh/sshd_config. När jag går in i denna fil så hittar jag ingenting, skärmen är bara svart med en massa ~ tecken längs med den vänstra raden utav skärmen. Hur ska jag gå vidare med det här?!

''Du kanske kan spela, MEN KAN DU KÖTTA?!?!?!''

Spelrigg: Intel i5 3570k 3.4Ghz [/B], Asus Nåt med Z77 4Gb DDR3, Asus GTX560Ti, 500gb HDD,Tagan Twoforce II 500w
Server: DL380G3, 6Gb ECC-minne, 2x Xeon @ 2,4Ghz, 72Gb 10k rpm SCSI, ESX Hypervisor 3.5

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Jul 2001

Märkligt, har du tabbat dig fram hela vägen så att du är säker på att det är rätt sökväg och fil du editerar?

Intel Core i7 3770k @ 4.4GHz | Asus Maximus V Formula | 16GB Kingston HyperX DDR3 2133MHz | EVGA GeForce GTX 980ti SC+ | Supermicro Xeon-D 1528 | Asus MG279Q, Dell U2515H

Trädvy Permalänk
Medlem
Plats
Mjölby
Registrerad
Maj 2009
Skrivet av Calle:

Märkligt, har du tabbat dig fram hela vägen så att du är säker på att det är rätt sökväg och fil du editerar?

När jag väl är i editorn så kommer jag inte ur den, då jag inte kan skriva (:) för att hoppa ut ur input mode och starta command linen igen .. men ska väl pröva att inte skriva hela sökvägen direkt!

''Du kanske kan spela, MEN KAN DU KÖTTA?!?!?!''

Spelrigg: Intel i5 3570k 3.4Ghz [/B], Asus Nåt med Z77 4Gb DDR3, Asus GTX560Ti, 500gb HDD,Tagan Twoforce II 500w
Server: DL380G3, 6Gb ECC-minne, 2x Xeon @ 2,4Ghz, 72Gb 10k rpm SCSI, ESX Hypervisor 3.5

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Jul 2001
Skrivet av zekkexavior:

När jag väl är i editorn så kommer jag inte ur den, då jag inte kan skriva (:) för att hoppa ut ur input mode och starta command linen igen .. men ska väl pröva att inte skriva hela sökvägen direkt!

Det är väl antagligen fel teckentabell, tror : brukar ligga på ö om man kör engelsk layout.

Intel Core i7 3770k @ 4.4GHz | Asus Maximus V Formula | 16GB Kingston HyperX DDR3 2133MHz | EVGA GeForce GTX 980ti SC+ | Supermicro Xeon-D 1528 | Asus MG279Q, Dell U2515H

Trädvy Permalänk
Medlem
Plats
Mjölby
Registrerad
Maj 2009
Skrivet av Calle:

Det är väl antagligen fel teckentabell, tror : brukar ligga på ö om man kör engelsk layout.

Nu har jag kommit in i filen, men lyckas fortfarande inte skriva : tecknet för att komma ut .. känner att galenskapen lurar runt hörnet

EDIT: lyckades nu, underbart

''Du kanske kan spela, MEN KAN DU KÖTTA?!?!?!''

Spelrigg: Intel i5 3570k 3.4Ghz [/B], Asus Nåt med Z77 4Gb DDR3, Asus GTX560Ti, 500gb HDD,Tagan Twoforce II 500w
Server: DL380G3, 6Gb ECC-minne, 2x Xeon @ 2,4Ghz, 72Gb 10k rpm SCSI, ESX Hypervisor 3.5

Trädvy Permalänk
Medlem
Plats
Mjölby
Registrerad
Maj 2009

Som man kanske förstått så är jag ju ingen linux-grabb direkt. Men när jag ska använda .sh filerna så får jag restore_file_info.sh: not found utprintat i ssh-konsolen. När jag sedan kör en pwd och ls så ser jag ju att filen faktiskt ligger där .. vafalls?

''Du kanske kan spela, MEN KAN DU KÖTTA?!?!?!''

Spelrigg: Intel i5 3570k 3.4Ghz [/B], Asus Nåt med Z77 4Gb DDR3, Asus GTX560Ti, 500gb HDD,Tagan Twoforce II 500w
Server: DL380G3, 6Gb ECC-minne, 2x Xeon @ 2,4Ghz, 72Gb 10k rpm SCSI, ESX Hypervisor 3.5

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Jul 2001
Skrivet av zekkexavior:

Som man kanske förstått så är jag ju ingen linux-grabb direkt. Men när jag ska använda .sh filerna så får jag restore_file_info.sh: not found utprintat i ssh-konsolen. När jag sedan kör en pwd och ls så ser jag ju att filen faktiskt ligger där .. vafalls?

Nu var det ett tag sedan jag laddade in nått i ESX 3.x. Men vad står det i instruktionerna?
Räcker det inte att köra sh filnamn.sh typ?

Intel Core i7 3770k @ 4.4GHz | Asus Maximus V Formula | 16GB Kingston HyperX DDR3 2133MHz | EVGA GeForce GTX 980ti SC+ | Supermicro Xeon-D 1528 | Asus MG279Q, Dell U2515H

Trädvy Permalänk
Medlem
Plats
Mjölby
Registrerad
Maj 2009
Skrivet av Calle:

Nu var det ett tag sedan jag laddade in nått i ESX 3.x. Men vad står det i instruktionerna?
Räcker det inte att köra sh filnamn.sh typ?

Enligt instruktionerna så ska man köra PreInstall_Setup.sh och sedan låta datorn reboota/starta om en tjänst. Sedan ska man köra installvm840.sh för att starta självaste instruktionen. Men det spelar ingen roll vilken av filerna jag försöker köra, konsolen säger att det inte finns någon infofil. Har prövat att köra chmod 777 på alla tre filerna utan någon respons.

''Du kanske kan spela, MEN KAN DU KÖTTA?!?!?!''

Spelrigg: Intel i5 3570k 3.4Ghz [/B], Asus Nåt med Z77 4Gb DDR3, Asus GTX560Ti, 500gb HDD,Tagan Twoforce II 500w
Server: DL380G3, 6Gb ECC-minne, 2x Xeon @ 2,4Ghz, 72Gb 10k rpm SCSI, ESX Hypervisor 3.5

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Jul 2001

Du är säker på att du har rätt SIM paket?
Google lite snabbt, du kanske har sett den här siten: http://therealshrimp.blogspot.com/2009/12/installing-hp-sim-a...

Prova att ta ner paketet igen och följ den där guiden...

Intel Core i7 3770k @ 4.4GHz | Asus Maximus V Formula | 16GB Kingston HyperX DDR3 2133MHz | EVGA GeForce GTX 980ti SC+ | Supermicro Xeon-D 1528 | Asus MG279Q, Dell U2515H

Trädvy Permalänk
Medlem
Plats
Mjölby
Registrerad
Maj 2009
Skrivet av Calle:

Du är säker på att du har rätt SIM paket?
Google lite snabbt, du kanske har sett den här siten: http://therealshrimp.blogspot.com/2009/12/installing-hp-sim-a...

Prova att ta ner paketet igen och följ den där guiden...

Jo, satt och funderade på det i skolan, ska nog pröva en tidigare version, typ 8.1.0

''Du kanske kan spela, MEN KAN DU KÖTTA?!?!?!''

Spelrigg: Intel i5 3570k 3.4Ghz [/B], Asus Nåt med Z77 4Gb DDR3, Asus GTX560Ti, 500gb HDD,Tagan Twoforce II 500w
Server: DL380G3, 6Gb ECC-minne, 2x Xeon @ 2,4Ghz, 72Gb 10k rpm SCSI, ESX Hypervisor 3.5