SAS Kontroller problem emot PCI-E 3.0/2.0 slot

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Aug 2007

SAS Kontroller problem emot PCI-E 3.0/2.0 slot

Hej folket,

Har nyligen köpt in ett nytt modekort med i5 CPU till hemmaservern min. Under denna procedur installerade jag även om servern från Ubuntu till Debian.
Efter detta uppstod det problem med mitt SAS/SATA kort. Det som är att vid boot hittas kortet samt alla diskar, diskarna hittas även efter att Debian har bootas och raiden står som Read-only (pga disk omstrukturering).

Vad jag gör näst efter boot är att sätta mdadm raiden i RW läge och en sync börjar köras, vilket är helt normalt.
Efter några % sync i 40-50Mb/s falerar kontrollerkortet och jag tappar alla diskar vilket gör att raiden sätts som inaktiv.

Har checkat dmesg och det första man ser är detta meddelande:

Citat:

Apr 26 00:58:15 kernel: [ 5132.551005] /build/buildd-linux-2.6_2.6.32-41squeeze2-amd64-NDo8b7/linux-2.6-2.6.32/debian/build/source_amd64_none/drivers/scsi/mvsas/mv_sas.c 1608:mvs_query_task:rc= 5
Apr 26 00:58:15 kernel: [ 5132.551008] /build/buildd-linux-2.6_2.6.32-41squeeze2-amd64-NDo8b7/linux-2.6-2.6.32/debian/build/source_amd64_none/drivers/scsi/mvsas/mv_sas.c 1669:mvs_abort_task:rc= 5

Lite längre ned hittar vi ett

Citat:

INFO: task md1_raid6: blocked for more than 120 seconds.
end_request: I/O error, dev sdX, sector *********
md: super_written gets error=-5, uptodate=0
raid5: Disk failure on sdX, disabling device

Detta meddelande kommer upp för samtliga diskar på detta kontrollerkort, men det är inte helt ologiskt då jag tappar kontakten med kontrollerkortet.
Tidigare har det suttigt upp emot 21 diskar och skyfflat data mellan raids i detta chassi och nätagg, och nu vid detta sista test satt det endast 13 diskar (raid=12 disk) så strömproblem bör det inte vara.

Uppskattar gärna idér då jag i dagsläget har kört fast!

De viktiga sakerna som sitter i servern:
Moderkort: http://www.asus.com/Motherboards/Intel_Socket_1155/P8Z77V/#specifications
PSU: http://www.corsair.com/power-supply-units/enthusiast-series-power-supply-units/enthusiast-series-tx950-80-plus-bronze-certified-power-supply.html
SAS/SATA kort: http://www.supermicro.com/products/accessories/addon/AOC-SASLP-MV8.cfm

Skicka PM eller citera för svar

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Jul 2001

Inte ett helt lätt problem, har du möjlighet att testa kontrollerkortet i någon annan maskin för att se om du kan återskapa problemet?

Intel Core i7 3770k @ 4.4GHz | Asus Maximus V Formula | 16GB Kingston HyperX DDR3 2133MHz | EVGA GeForce GTX 980ti SC+ | Supermicro Xeon-D 1528 | Asus MG279Q, Dell U2515H

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Aug 2007

Då jag hade ett annat moderkort och cpu i söndags, och med det hade jag PCI IRQ routing table error. Men när det väl gick att boota fungerade alla korten klockrent.
Googlade runt en del och hittade att Marvel inte har stöd för kortet i denna kernel, http://cotdp.com/blog/2011/03/supermicro-aoc-saslp-mv8-driver...
Målet blir nog att dra tillbaka till ubuntu och nyare kernel. Stödet fanns ju där tidigare.

Skicka PM eller citera för svar

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Aug 2007

Då det är en bugg med dessa drivare i debian kerneln blev ominstall till ubuntu lösningen. Raiden är nu syncad och allt snurrar igen.

Forum solved!

Skicka PM eller citera för svar