Trädvy Permalänk
Medlem
Plats
Falun
Registrerad
Jul 2012

Processor fläkt problem

Tjenare! Jag ska försöka förklara så bra jag kan! är inte något snille :)!
Jag köpte en dator från Inet.se och byggde ihop den med en vän.
sen efter 4 veckor så kom 2 extra chassi fläktar + neonljus.
men när jag sat in båda fläktarna och ljuset så märkte jag att min
processor fläkt började gå på och av. jag använde att program som heter speedfan och
såg att en fläkt som jag tidigare har kollat på gick mellan 0 till 1300, normalt så var den stilla över 1000.

http://www.inet.se/produkt/5308692/amd-fx-4100-x4-3-6ghz

http://www.inet.se/produkt/5322073/cooler-master-tx3-evo

hoppas att någon kan hjälpa mig :/ om ni behöver mer info så skriver jag det :)!

"Add"
vad jag har i burken.

Gigabyte GA-970A-UD3
1TB Seagate Barracuda 7200rpm
Corsair 8GB (4x2048MB) CL9 1333Mhz XMS3
AMD FX-4100 X4 3,6GHz
Cooler Master TX3 EVO
KFA2 GeForce GTX 570 EX OC MDT X4 1280MB
Cooler Master Elite 430 Svart
Antec VP650PM 650W

Trädvy Permalänk
Medlem
Plats
Sala
Registrerad
Okt 2009

Du har för klent nätaggregat.

Trädvy Permalänk
Medlem
Plats
Kristianstad
Registrerad
Dec 2011
Skrivet av punchline82:

Du har för klent nätaggregat.

Hur kan du dra den slutsatsen med given information?

Dator: SoloII | Asus P8H67-M Evo | i5-2405S | MSI R9-270X Gaming |Noctua NH-U9B SE2 | 16 GB RAM Vengeance LP | Seasonic X-460 FL | SSD OS: Samsung 830 256 GB | Temp/dl: Intel G2 80 GB | HDD upphängd i SoloII| Dell 3008WFP 30" skärm
Bärbar dator: MBA 13" NAS: QNap TS-509 & Synology DS3612xs, DS416
Skrev jag något vettig? "Bra inlägg":a så vet jag att det fanns nytta i min post.

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Feb 2009
Skrivet av Gustav-P:

Hur kan du dra den slutsatsen med given information?

Är det inte universal lösningen på detta forum? Förutom att säga åt AMD användare att byta till Nvidia då?

||NZXT H440 Black/Red||Intel i5 2500k @ 4,2GHz ||Noctua NH-D14 ||GA-Z77X-UD3H ||8 gb Corsair Vengeance 1600mhz DDR3 ||MSI GeForce GTX 970 ||OCZ Agility 3 120GB SSD ||Samsung Spinpoint F3 1TB ||Corsair HX750W||
Software is like sex, it's better when it's free. - Linus Torvalds

Trädvy Permalänk
Medlem
Plats
Kristianstad
Registrerad
Dec 2011
Skrivet av Tumnus:

Är det inte universal lösningen på detta forum? Förutom att säga åt AMD användare att byta till Nvidia då?

För att komma med något konstruktivt till TS.

Har du provat att koppla ut de saker som du fick senast, det är efter detta som jag uppfattar att du fick problem.

Sedan är det den vanliga felsökning metodiken. Koppla in grejjorna en och en, kör ett tag mellan och se när det konstiga inträffar.
Med de resultaten så har du (vi) sedan möjlighet att försöka dra en slutsats.

Du säger också att du kör speedfan, kontrollera att du inte har ställt in en temperaturkurva som stänger av fläktarna helt.
Använder inte speedfan aktivit själv men du kan få lite tips i denna artikel, annars är google din vän.

Om jag nu ska spekulera (för det gör vi också på forumet som standard de där två extra fläktarna du har, blåser de på något sätt som gör att temperaturen för CPU skulle kunna bli så pass låg att den går under ett inställt gränsvärde som gör att fläktarna stannar (speedfan teorin ovan)? När de stannat så stiger temperaturen och de går i gång igen - för att tillsammans med dina två nya fläktar efter en stund kylt ner samma område igen osv ...

Dator: SoloII | Asus P8H67-M Evo | i5-2405S | MSI R9-270X Gaming |Noctua NH-U9B SE2 | 16 GB RAM Vengeance LP | Seasonic X-460 FL | SSD OS: Samsung 830 256 GB | Temp/dl: Intel G2 80 GB | HDD upphängd i SoloII| Dell 3008WFP 30" skärm
Bärbar dator: MBA 13" NAS: QNap TS-509 & Synology DS3612xs, DS416
Skrev jag något vettig? "Bra inlägg":a så vet jag att det fanns nytta i min post.

Trädvy Permalänk
Medlem
Plats
Falun
Registrerad
Jul 2012

Hej Gustav-P!
Skulle det hjälpa om jag tar en bild i datorn så får ni se hur det ser ut?
Jag är inte hemma just nu men jag ska pröva att dra ut fläktarna + neon lampan och se om det funkar. Om det skulle vara så att det funkar "what do i do?" mitt nätagg är Antec VP650PM 650W och har en datakunnig vän som säger att det inte ska vara något problem med nätagget.

och om speedfan har något automatic program i sig, hur gör jag för att göra så att det går på deafault (ursäkta för min svenska / stavning)

Trädvy Permalänk
Medlem
Plats
/dev/null
Registrerad
Aug 2008

Så länge det inte är något fel på nätagget så finns där kapacitet som gott och väl räcker till dina prylar.

På vilket sätt yttrar sig problemet? Varvar fläkten upp för att omedelbart varva ned till noll igen eller verkar avstängningarna ske slumpmässigt? Har du kollat om det verkar finnas något samband mellan processortemperaturen och när avstängningarna sker? Du kan för det mesta avläsa både temperatur och fläktens RPM i BIOS. Man kan ibland även, i BIOS, ställa in lite småsaker som påverkar hur processorfläkten agerar vid olika förhållanden, kanske du hittar något där. Förresten, kolla så att processorfläktens kontakt sitter ordentligt.

Desktop: Intel C2Q Q9550 | 4GB RAM | Radeon 4850 | 120GB SSD | 3x500GB HDD
HTPC (Intel NUC): Intel i5-4250U | 8GB RAM | 250GB SSD
Laptop (HP 8460p): Intel i7-2620M | 8GB RAM | 14" 1600x900 | 120GB SSD |

Trädvy Permalänk
Medlem
Plats
Falun
Registrerad
Jul 2012

Hej PeCe

Alltså processor fläkten går upp och ner, kan gå från 1000 till 0 sen up till 900 sen 60 sen 1200 kan det vara så att den kanske är kall och snörrar om processorn skulle bli varm?

Trädvy Permalänk
Medlem
Plats
Lidköping
Registrerad
Feb 2011
Skrivet av martin921210:

Hej PeCe

Alltså processor fläkten går upp och ner, kan gå från 1000 till 0 sen up till 900 sen 60 sen 1200 kan det vara så att den kanske är kall och snörrar om processorn skulle bli varm?

Ja, med två extra chassifläktar kan jag tänka mig att den varvar ner oftare än innan.

Sen kan det bli falska värden ibland medan den håller på att justeras, så det kan stå 0 en kort stund fast fläkten snurrar snabbare, har sett det på någon av mina datorer ibland. Om du kör med sidan öppen, ser du ju enkelt om fläkten faktiskt stannar någonsin eller om det bara blir felmätning.

Sen beror det på vilket program du kollar rpm med, mest korrekt för mig är ASUS Suite för mitt ASUS Sabertooth, HWMonitor brukar stämma också. SpeedFan kan vara lite mer buggigt med hur det rapporterar.

Som default gör SpeedFan ingen kontrollering av hastigheter, det är inget auto-läge utan man måste in och koppla ihop en viss temperatur med en fläkt och ställa in temperaturer och min/max-nivå.

Om man bara ändrar på värdena i huvudfönstret så ändras bara "inställning nummer 1" liksom, har du ingen fläkt kopplad till den i programmet så ändras ingen rpm. Tog ett tag innan jag fick igång det när jag faktiskt ville styra fläktar med det på min HTPC. Slutade med att jag bytte alla chassifläktar till Arctic Cooling PWM och seriekopplade med CPU-fan och styrde i BIOS X)

På mitt Sabertooth funkar ASUS Suite kanon som sagt med inställbara kurvor för alla fläktarna. Vet inte om Gigabytes EasyTune har samma inställningar kanske?

Shadows never sleep...
* Pegasos, 1GHz G4, Radeon 9200SE, MorphOS 2.x (Amiga compatible)
* PC1 - Spel: Sabertooth 990FX+AMD 1090T@4.0GHz +16GB Vengeance 1600,CM HAF 912 Plus, Antec HCG620m PSU, 240GB Crucial MX100 SSD, Sapphire Radeon HD7870 XT, Phanteks PH-TC14PE kylare
*PC2 - Film: AMD A10-5800k Trinity, Asrock m-ITX, SUGO SG02, Samsung EVO 850 250GB SSD

Trädvy Permalänk
Hedersmedlem
Plats
Akalla
Registrerad
Mar 2009

Kan flika in med en kortis som kan förklara varför den visar 0 RPM, saxad från SpeedFan's FAQ:

Citat:

My fans are showing odd RPMs or 0 when slowed down
Fan speed control is achieved by accessing some features available in some hardware monitor chip or some other special hardware. These chips might be able to controls fan speeds. They usually do this by using PWM output. A PWM digital ouput is a digital signal that alternates some levels very fast, thus simulating some intermediate average level. The net result is a perceived average voltage lower than the usual one. Please note that some chips (very few of them) are able to lower the voltage without PWM simulation.
The fans, on the other hand, can report their speeds (RPM) by using some internal sensors that report how often some current flows between two plates. Fans are built assuming nominal voltages and a continuous signal. When voltages are lowered or modulated through PWM, some fans are no longer able to properly trigger when those plates face each other and resulting fan speeds may show odd values.

http://www.almico.com/sffaq.php

CPU: Intel i5-4670K MB: Asus Maximus VI Gene RAM: Patriot Viper3 16GB 2133MHz CL11 GPU: Zotac GeForce GTX 780 PSU: Corsair AX860 Chassi: Silverstone Temjin TJ08-E Kylning: Corsair H80i Lagring: 1x Samsung 840 Pro 256GB, 2x Seagate Barracuda 3TB

Trädvy Permalänk
Medlem
Plats
Falun
Registrerad
Jul 2012

jo men jag har kollat i datorn och jag har sett att den stannar helt, var så jag märkte det förut.

Trädvy Permalänk
Medlem
Plats
/dev/null
Registrerad
Aug 2008
Skrivet av martin921210:

Hej PeCe

Alltså processor fläkten går upp och ner, kan gå från 1000 till 0 sen up till 900 sen 60 sen 1200 kan det vara så att den kanske är kall och snörrar om processorn skulle bli varm?

Hur ofta sker dessa "hopp"? Handlar det om enstaka sekunder? (Uppstarten är inget idealiskt testförhållande, så ha gärna datorn på några minuter innan du studerar fläktens beteende.)

Här är vad jag skulle ha testat:
1. Ställt ned tröskelvärdet (i BIOS) för vid vilken processortemp datorn automatiskt stängs av (för att förhindra hårdvaruskada) med 5-10C för att öka säkerhetsmarginalen.
2. Laddat ned och kört ett program som belastar processorn rejält (=höjer dess temp), exempelvis SuperPi. Låt det köra en stund så tempen får tid att öka.
3. a) Om detta leder till att processorfläkten varvar upp och håller sig på höga varvtal så hade jag dragit slutsatsen att processorfläkten fungerar, och att den helt enkelt anpassar hastigheten efter kylningsbehoven.
3. b) Om fläkten fortsätter att stanna till (eller sjunka till låga varvtal) trots att processorn belastas hårt så hade jag fortsatt felsöka.

Desktop: Intel C2Q Q9550 | 4GB RAM | Radeon 4850 | 120GB SSD | 3x500GB HDD
HTPC (Intel NUC): Intel i5-4250U | 8GB RAM | 250GB SSD
Laptop (HP 8460p): Intel i7-2620M | 8GB RAM | 14" 1600x900 | 120GB SSD |

Trädvy Permalänk
Medlem
Plats
Lidköping
Registrerad
Feb 2011
Skrivet av martin921210:

jo men jag har kollat i datorn och jag har sett att den stannar helt, var så jag märkte det förut.

Det låter ju inte bra nej. Om du kör HWMonitor, vad står det på Fans PWM, är det 0% på allt eller ändras någon styrsignal där.

Som PeCe skrev, kolla vilket värde det står i BIOS på fläktstyrning också, eller kör Gigabyte Easytune och titta på fläktkurvor för CPUn om du inte redan har det igång i bakgrunden.

Shadows never sleep...
* Pegasos, 1GHz G4, Radeon 9200SE, MorphOS 2.x (Amiga compatible)
* PC1 - Spel: Sabertooth 990FX+AMD 1090T@4.0GHz +16GB Vengeance 1600,CM HAF 912 Plus, Antec HCG620m PSU, 240GB Crucial MX100 SSD, Sapphire Radeon HD7870 XT, Phanteks PH-TC14PE kylare
*PC2 - Film: AMD A10-5800k Trinity, Asrock m-ITX, SUGO SG02, Samsung EVO 850 250GB SSD

Trädvy Permalänk
Medlem
Plats
Falun
Registrerad
Jul 2012

Tjenare! jag har nu tästat att ta dra ut kontakten för fläktarna och den hoppar fortfarande. sen på "SpeedFan står det Pwn1 0% pwn2 0% Pwn3 0%, men sen åt höger står dete pwn1 100% pwn 2 100% och pwn 3 100%. ska kolla in det där programmet HWMonitor som blackeagle sa.
sen har jag Core Temp och den säger att min CPU (är processor CPU? blandar ihop den med GPU) ligger på 6-20 celcius, "Min 7c Max 21c"

Trädvy Permalänk
Medlem
Plats
Falun
Registrerad
Jul 2012

Jag ska ta en screenshot på HwMonitor så får ni se, eftersom jag är så seg

Trädvy Permalänk
Medlem
Plats
Falun
Registrerad
Jul 2012

här har ni vad HwMonitor visar

http://imageshack.us/photo/my-images/708/bild3bf.png/

Bild 2 är ungefär 7 sekunder efter bild 1

Trädvy Permalänk
Medlem
Plats
Lidköping
Registrerad
Feb 2011
Skrivet av martin921210:

här har ni vad HwMonitor visar

http://imageshack.us/photo/my-images/708/bild3bf.png/

Bild 2 är ungefär 7 sekunder efter bild 1

För det första, gör inte tre inlägg i rad, det är mot reglerna för forumet, redigera ditt senaste istället och lägg till så man ser vad som är nytt, t.ex.

EDIT: Blablabla ny text...

Tillbaka till problemet, något är ju definitivt fel eftersom max dessutom visar över 13000rpm, vilket är flera gånger högre än max på fläkten.

Prova att byt plats på CPU-fläkten och chassi-fläkten om kablarna når, bara för att testa om CPU-fläkten snurrar på max hela tiden då. Om den fortfarande stannar ibland är det fel på själva fläkten, annars är det styrningen.

Shadows never sleep...
* Pegasos, 1GHz G4, Radeon 9200SE, MorphOS 2.x (Amiga compatible)
* PC1 - Spel: Sabertooth 990FX+AMD 1090T@4.0GHz +16GB Vengeance 1600,CM HAF 912 Plus, Antec HCG620m PSU, 240GB Crucial MX100 SSD, Sapphire Radeon HD7870 XT, Phanteks PH-TC14PE kylare
*PC2 - Film: AMD A10-5800k Trinity, Asrock m-ITX, SUGO SG02, Samsung EVO 850 250GB SSD

Trädvy Permalänk
Medlem
Plats
Falun
Registrerad
Jul 2012

Tjenare! Uräskta för tripplemedelandet!
Nu står det på FANIN0 "Value: 1771 RPM. Min 1683 RPM. Max 1885 RPM" låter det bättre?

Trädvy Permalänk
Medlem
Plats
Kristianstad
Registrerad
Dec 2011

Martin - Jag tycker att felsökningen som PeCe föreslår kan vara nyttig.

En annan fråga - började detta efter att du installerade SpeedFan?
Om du avinstallerar SpeedFan, startar om dator - är samma symptom kvar?
Vet att det låter som en lång-shot, men om svaret på fråga 1 är "Ja" så är den kanske värd att testa.

Du har inte kopplat din NEON-belysning till någon kontakt på moderkortet - kollar bara ?

Dator: SoloII | Asus P8H67-M Evo | i5-2405S | MSI R9-270X Gaming |Noctua NH-U9B SE2 | 16 GB RAM Vengeance LP | Seasonic X-460 FL | SSD OS: Samsung 830 256 GB | Temp/dl: Intel G2 80 GB | HDD upphängd i SoloII| Dell 3008WFP 30" skärm
Bärbar dator: MBA 13" NAS: QNap TS-509 & Synology DS3612xs, DS416
Skrev jag något vettig? "Bra inlägg":a så vet jag att det fanns nytta i min post.

Trädvy Permalänk
Medlem
Plats
Falun
Registrerad
Jul 2012

NEON ljuset är inkopplat med sid och bakfläkten.

Och finns det någon guide hur man gör det där Steg 1 med BIOS?
vill inte pilla utan en guide

Trädvy Permalänk
Medlem
Plats
Kristianstad
Registrerad
Dec 2011
Skrivet av martin921210:

NEON ljuset är inkopplat med sid och bakfläkten.

Och finns det någon guide hur man gör det där Steg 1 med BIOS?
vill inte pilla utan en guide

Är sid och bakfläkten kopplade till moderkortet eller får de ström direkt från PSU?
Det jag tänker är att NEON ljuset kanske inte ska ha ström från moderkortet utan endast vara kopplat till PSU.
(Jag antar att det är ett separat NEON ljus, och inte fläktar med NEON ljus - för de ska gå bra att koppla på MB (jag har ivf inte hört något om att de ska ha orsakat problem)).

Du fick med en manual till ditt moderkort. I den så finns det beskrivet vad de olika inställningarna gör i BIOS (eller UEFI på nyare moderkort). Titta i den och leta upp funktionen som beskriver när datorn ska stängas av pga för hög temperatur. Den kan nämligen heta lite olika mellan olika tillverkare.

Men om att ändra i BIOS är en stor grej för dig så prova de andra sakerna först. Koppla ut allt det som du kopplade in (fläktarna och NEON) och se om det fungerar som det ska om datorn "ser ut om innan".
Avinstallera SpeedFan (starta om) - long-shot men om det fungerade innan du installerade den programvaran så värd att prova.

(Skriv gärna om något löser ditt problem...)

Dator: SoloII | Asus P8H67-M Evo | i5-2405S | MSI R9-270X Gaming |Noctua NH-U9B SE2 | 16 GB RAM Vengeance LP | Seasonic X-460 FL | SSD OS: Samsung 830 256 GB | Temp/dl: Intel G2 80 GB | HDD upphängd i SoloII| Dell 3008WFP 30" skärm
Bärbar dator: MBA 13" NAS: QNap TS-509 & Synology DS3612xs, DS416
Skrev jag något vettig? "Bra inlägg":a så vet jag att det fanns nytta i min post.

Trädvy Permalänk
Medlem
Plats
Falun
Registrerad
Jul 2012

Tjenare Gustav!

Jag har kopplat in mitt neon ljus in i samma kontakt som fläktarna, sen in i PSU'n inte in i moderkortet