Windows Media Center MKV/FullHD Stream laggar

Trädvy Permalänk
Medlem
Plats
Uddevalla
Registrerad
Jun 2009

Windows Media Center MKV/FullHD Stream laggar

Tja! Vår familjs mediaspelare slutade fungera häromdagen av någon mysko anledning men som tur var hade vi ett xbox 360 som vi kunde använda istället. Det fungerade hur bra som helst, men vi körde igenom den inbyggda standard video-spelaren på xbox'et.
Efter att vi kollat klart så kom jag på idén att xbox'et har ju möjligheten att koppla upp sig till en PC och streama media från en dator på samma nätverk till xbox'et. Självklart satte jag och farsan igång det och fixade uppkoppling till xbox'et på både hans och min dator. Vi testade att köra en vanlig avi-film och det gick jättebra. Sen kom min idé att testa en mkv-fil med full-hd upplösning, för det är det vi egentligen vill ha för mkv ser så mycket bättre ut i de flesta fallen än vad en vanlig dvd-komprimerad film gör typ. Så vi grejade lite och fick in min mkv-fil i medie-biblioteket på xbox'et, och så startade vi. Det som kom upp var bra ljud, men bilden laggade något enormt. Det var som att se en riktigt äckligt komprimerad avi-film, pixligt och ingen skärpa eller bra bild alls, och bildrutorna var färre än jag vet inte vad man ska jämföra med...
Som en envis galning försökte jag hitta en lösning på nätet, men utan resultat. Många tipsade om att använda en annan spelare men det vill jag helst slippa då windows media center ändå fungerar rätt smidigt.

Så jag har en fråga till er här på swec:
Är det någon som vet vad problemet är?! Varför laggar filmen så mycket när man streamar mkv-filen men inte avin? Har det med att mkv'n överbelastar nätet eller vad är det? Kom gärna med en hyffsat enkel och gratis lösning! Vill gärna kunna njuta av lite full-hd film utan att behöva greja allt för mycket när de andra filerna räcker med att ladda ner och sen uppdatera xbox'et och starta.

MAIN: Metis | Z97I-Plus | 4690K | MSI 970 Gaming | 16GB HyperX | 120GB SSD + 250GB SSD + 256GB M.2 + 1TB HDD | H60 V2 | SF600
HIDs: S27D590 60Hz 27" | Logitech G403 + Qck | K70 MX Brown | Beyerdynamic DT250 + Blue Yeti
HTPC: Rapsberry Pi2 + Raspberry Pi3
PHONE: ZTE Axon 7

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jan 2012
Skrivet av vompen:

Tja! Vår familjs mediaspelare slutade fungera häromdagen av någon mysko anledning men som tur var hade vi ett xbox 360 som vi kunde använda istället. Det fungerade hur bra som helst, men vi körde igenom den inbyggda standard video-spelaren på xbox'et.
Efter att vi kollat klart så kom jag på idén att xbox'et har ju möjligheten att koppla upp sig till en PC och streama media från en dator på samma nätverk till xbox'et. Självklart satte jag och farsan igång det och fixade uppkoppling till xbox'et på både hans och min dator. Vi testade att köra en vanlig avi-film och det gick jättebra. Sen kom min idé att testa en mkv-fil med full-hd upplösning, för det är det vi egentligen vill ha för mkv ser så mycket bättre ut i de flesta fallen än vad en vanlig dvd-komprimerad film gör typ. Så vi grejade lite och fick in min mkv-fil i medie-biblioteket på xbox'et, och så startade vi. Det som kom upp var bra ljud, men bilden laggade något enormt. Det var som att se en riktigt äckligt komprimerad avi-film, pixligt och ingen skärpa eller bra bild alls, och bildrutorna var färre än jag vet inte vad man ska jämföra med...
Som en envis galning försökte jag hitta en lösning på nätet, men utan resultat. Många tipsade om att använda en annan spelare men det vill jag helst slippa då windows media center ändå fungerar rätt smidigt.

Så jag har en fråga till er här på swec:
Är det någon som vet vad problemet är?! Varför laggar filmen så mycket när man streamar mkv-filen men inte avin? Har det med att mkv'n överbelastar nätet eller vad är det? Kom gärna med en hyffsat enkel och gratis lösning! Vill gärna kunna njuta av lite full-hd film utan att behöva greja allt för mycket när de andra filerna räcker med att ladda ner och sen uppdatera xbox'et och starta.

Streamar du trådlöst? Kommer ihåg att jag hade lite problem med det på både mitt 360 och PS3. Men det funkade fint med kabel.

Laptop |OS: Foresight Linux |CPU: Intel Core i3-370M |VGA: NVIDIA Geforce 310M / 1GB DDR3 |RAM: DDRIII 4GB (2GB*2) |HDD: 500GB |

Trädvy Permalänk
Medlem
Plats
Uddevalla
Registrerad
Jun 2009
Skrivet av SamWin:

Streamar du trådlöst? Kommer ihåg att jag hade lite problem med det på både mitt 360 och PS3. Men det funkade fint med kabel.

Det är just det jag inte gör, jag kör kabel igenom båda med en hastighet på ca 100 upp och 10 ner.

MAIN: Metis | Z97I-Plus | 4690K | MSI 970 Gaming | 16GB HyperX | 120GB SSD + 250GB SSD + 256GB M.2 + 1TB HDD | H60 V2 | SF600
HIDs: S27D590 60Hz 27" | Logitech G403 + Qck | K70 MX Brown | Beyerdynamic DT250 + Blue Yeti
HTPC: Rapsberry Pi2 + Raspberry Pi3
PHONE: ZTE Axon 7

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jan 2012
Skrivet av vompen:

Det är just det jag inte gör, jag kör kabel igenom båda med en hastighet på ca 100 upp och 10 ner.

Okej.

Berätta hur du har kopplat allt och med vilka kablar.
Vilka inställningar har du gjort i ditt xbox?
Vad är det för filer du försöker spela upp? Ladda gärna ner Media Player Classic och öppna en av filmerna med det tryck sedan File > Properties > MediaInfo och kopiera det som står där.

Laptop |OS: Foresight Linux |CPU: Intel Core i3-370M |VGA: NVIDIA Geforce 310M / 1GB DDR3 |RAM: DDRIII 4GB (2GB*2) |HDD: 500GB |

Trädvy Permalänk
Medlem
Registrerad
Dec 2005

360 klarar inte MKV. Du får använda PMS eller liknande som kan transcode'a filmerna åt dig.
http://www.homemultimedianetwork.com/Guides/How-to-stream-med...

Trädvy Permalänk
Medlem
Registrerad
Aug 2002

Fuck fruit! Sitting around being all smug on trees and in pies.
En vänlig liten puff blev en hatisk knuff.
Keso är köttfärs gjord på mumintroll.

Trädvy Permalänk
Medlem
Plats
Uddevalla
Registrerad
Jun 2009
Skrivet av SamWin:

Okej.

Berätta hur du har kopplat allt och med vilka kablar.
Vilka inställningar har du gjort i ditt xbox?
Vad är det för filer du försöker spela upp? Ladda gärna ner Media Player Classic och öppna en av filmerna med det tryck sedan File > Properties > MediaInfo och kopiera det som står där.

Öööh jag har xbox'et kopplat med hdmi till tv'n, och en ethernet-sladd kopplad till modemet, och sen så är datorn kopplad via en router till modemet...
Jag försöker spela upp mkv.
Fatta ingenting av det sista du skrev...

Skrivet av ozo64:

360 klarar inte MKV. Du får använda PMS eller liknande som kan transcode'a filmerna åt dig.
http://www.homemultimedianetwork.com/Guides/How-to-stream-med...

Ok? Tycker det är jättekonstigt att den faktiskt kan få fram bild och ljud om det nu inte funkar... Funkar det inte så borde det ju stå kan inte spela upp eller nåt... :S

Skrivet av P-NILZ:

Ska testa det!

MAIN: Metis | Z97I-Plus | 4690K | MSI 970 Gaming | 16GB HyperX | 120GB SSD + 250GB SSD + 256GB M.2 + 1TB HDD | H60 V2 | SF600
HIDs: S27D590 60Hz 27" | Logitech G403 + Qck | K70 MX Brown | Beyerdynamic DT250 + Blue Yeti
HTPC: Rapsberry Pi2 + Raspberry Pi3
PHONE: ZTE Axon 7

Trädvy Permalänk
Medlem
Plats
sektor 001
Registrerad
Aug 2003
Skrivet av vompen:

Ok? Tycker det är jättekonstigt att den faktiskt kan få fram bild och ljud om det nu inte funkar... Funkar det inte så borde det ju stå kan inte spela upp eller nåt... :S

då är det antagligen din dator som omkodar filmen till nått boxen gillar, men den är för långsam och hinner inte med i realtid, därav "lagg". kanske.

Operativsystemet som löser nästan alla problem: Mint

Trädvy Permalänk
Medlem
Plats
Uddevalla
Registrerad
Jun 2009
Skrivet av AndreaX:

då är det antagligen din dator som omkodar filmen till nått boxen gillar, men den är för långsam och hinner inte med i realtid, därav "lagg". kanske.

Ja asså sett utifrån bilden och hur det beter sig så verkar det mer troligt att filmen är för stor och har för hög kvalité för att kunna streamas bra över nätet, än att det är kompabilitetsproblem...

MAIN: Metis | Z97I-Plus | 4690K | MSI 970 Gaming | 16GB HyperX | 120GB SSD + 250GB SSD + 256GB M.2 + 1TB HDD | H60 V2 | SF600
HIDs: S27D590 60Hz 27" | Logitech G403 + Qck | K70 MX Brown | Beyerdynamic DT250 + Blue Yeti
HTPC: Rapsberry Pi2 + Raspberry Pi3
PHONE: ZTE Axon 7

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jan 2012
Skrivet av vompen:

Ja asså sett utifrån bilden och hur det beter sig så verkar det mer troligt att filmen är för stor och har för hög kvalité för att kunna streamas bra över nätet, än att det är kompabilitetsproblem...

Kan vara att filmen är 10Bit?

Laptop |OS: Foresight Linux |CPU: Intel Core i3-370M |VGA: NVIDIA Geforce 310M / 1GB DDR3 |RAM: DDRIII 4GB (2GB*2) |HDD: 500GB |

Trädvy Permalänk
Medlem
Plats
Uddevalla
Registrerad
Jun 2009
Skrivet av SamWin:

Kan vara att filmen är 10Bit?

Que? Vadå 10bit..?

MAIN: Metis | Z97I-Plus | 4690K | MSI 970 Gaming | 16GB HyperX | 120GB SSD + 250GB SSD + 256GB M.2 + 1TB HDD | H60 V2 | SF600
HIDs: S27D590 60Hz 27" | Logitech G403 + Qck | K70 MX Brown | Beyerdynamic DT250 + Blue Yeti
HTPC: Rapsberry Pi2 + Raspberry Pi3
PHONE: ZTE Axon 7

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jan 2012
Skrivet av vompen:

Que? Vadå 10bit..?

Om du kan ladda ner Media Player Classic och starta en av filmerna med det. Sedan uppe i menyn så trycker du på File > Properties > MediaInfo och under Video så leta efter raden Bit depth : 8 bits står det Bit depth : 10 bits så titta i denna tråden eller så kopierar det som står där och postar här eller om du skickar det i PM.

Du kan också testa att byta container på filmen från MKV till M2TS

Ladda ner tsMuxeR och packa upp det i en ny mapp. Öppna sedan programmet och dra in filmen och släpp den i input files:. Sedan längre ner så står det Output kryssa i M2TS Muxing och sedan Start Muxing. Testa sedan att streama filmen.

Laptop |OS: Foresight Linux |CPU: Intel Core i3-370M |VGA: NVIDIA Geforce 310M / 1GB DDR3 |RAM: DDRIII 4GB (2GB*2) |HDD: 500GB |

Trädvy Permalänk
Medlem
Plats
sektor 001
Registrerad
Aug 2003
Skrivet av vompen:

Ja asså sett utifrån bilden och hur det beter sig så verkar det mer troligt att filmen är för stor och har för hög kvalité för att kunna streamas bra över nätet, än att det är kompabilitetsproblem...

även en mkv kan förvisso innehålla nått som funkar och att det bara packas upp och strömmas från datorn, men det är mer troligt att det är som jag säger än att maskinen försöker spela ett format den inte alls klarar av. men du får kanske ändå ge lite mer detaljerad beskrivninga av exakt vilka komponenter som är inblandade samt vilka program, och hur de är inställda.

att det är ett bandbreddsproblem är inte troligt alls om du kör trådat, du får i princip upp i rena BD-kvaliter för att det ska bli ett problem med ens halvkass nätverksutrustning. (typ 30-40GB filmfiler mao)

/ ska du förresten omkoda "on the fly" så kan även ett mindre komplext format (mer bandbredd) funka bättre än nåt som gör motsatt verkan. jag är som sagt skeptiskt till bandbreddsproblem som källa här.

Operativsystemet som löser nästan alla problem: Mint

Trädvy Permalänk
Medlem
Plats
Jkpg
Registrerad
Jun 2011
Skrivet av vompen:

Så jag har en fråga till er här på swec:
Är det någon som vet vad problemet är?! Varför laggar filmen så mycket när man streamar mkv-filen men inte avin? Har det med att mkv'n överbelastar nätet eller vad är det? Kom gärna med en hyffsat enkel och gratis lösning! Vill gärna kunna njuta av lite full-hd film utan att behöva greja allt för mycket när de andra filerna räcker med att ladda ner och sen uppdatera xbox'et och starta.

Har precis fixat så att min xbox spelar upp mkv och det går som smort. Tänkte därför dela med mig om hur jag gjorde. Första steget var att avinstallera alla codec pack jag hade och sedan installerade jag dessa 2 paket. Ena är för 32bit och sen finns det en addon fil om man kör 64bit. Sedan i inställningarna finns det en ruta man kan klicka i med rekommenderade intsällningar om man inte orkar pilla själv.
Efter detta spelar både WMP och Media center upp mkv filer utan problem. Sedan lade jag bara till xboxen som en media extender (funkar ej i xboxens egna media spelare) i windows media center i xboxen. Nu spelar den upp mkv filer utan några som helst problem. Jag kör med kabel till router och har inte märkt något alls att filmerna hackar. Kör bara 1080p mkv filer.

ASUS Maximus VIII Hero | i7 6700K @ stock | ASUS GTX 1080 Strix | 32 GB Corsair Vengeance LPX 2666MHz | Samsung 850 Pro 256GB | Intel 520 240GB SSD | Seagate Barracuda Green 2TB | EVGA Supernova G2 750W | Corsair 400Q |