Server vill inte boota, felmeddelande.

Trädvy Permalänk
Medlem
Registrerad
Jul 2009

Server vill inte boota, felmeddelande.

Hej!

Skulle starta servern imorse (Körs virtuellt i Vmware ESXi) och den kör Debian. Hostnamet är Shell, Ifall ni undrar varför det står i felmeddelandet.

Får detta felmeddelande:

Är det någon som har en idè på vad jag kan göra?

Tack på förhand!

Tillägg: Såhär ser boot.. koden eller vad man kallar det ut. I GRUB:

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Okt 2008

Ja... det låter ju som att den inte hittar din lvm-volgroup... Antingen saknar den moduler för att kunna ladda den eller så har den fallit bort sen installationen. Du kan ju tex testa starta den med en liveskiva och dra igång lvm och kolla om det finns några LVMer på disken. Och att dom har rätt namn, som stämmer överens med det som står i grub-menyn. Är detta altså en nyinstallerad virtuell maskin eller har den funkat förut?

Jobbar som nätverkskonsult på PWNY.
Flerårig erfarenhet från ISP-branchen och Linux-nörd.
Favoritdist: Arch linux. Datarymden

Trädvy Permalänk
Medlem
Registrerad
Jul 2009
Skrivet av fisk1n:

Ja... det låter ju som att den inte hittar din lvm-volgroup... Antingen saknar den moduler för att kunna ladda den eller så har den fallit bort sen installationen. Du kan ju tex testa starta den med en liveskiva och dra igång lvm och kolla om det finns några LVMer på disken. Och att dom har rätt namn, som stämmer överens med det som står i grub-menyn. Är detta altså en nyinstallerad virtuell maskin eller har den funkat förut?

Den har funkat i runt 3 veckor. har kunnat reboota den flera gånger förut, Men igår stängde jag bara av den under en timme för att jag skulle kolla på film. Och mitt rackskåp står i filmrummet (Ville inte att den skulle störa så mycket). Sen när jag startade den igen så är det såhär..

Får ta o göra det du skrev, vilken livecd ska jag använda?

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Okt 2008

Vilken skiva som helst funkar väl, bara den har stöd för lvm2. Skivan du installerade med borde ju funka tex om det går att få upp en terminal i den, eller nån annan relativt ny linux-skiva. Ubuntu (tex server, vanliga funkar också) eller arch linux har trevliga liveskivor imo.

Jobbar som nätverkskonsult på PWNY.
Flerårig erfarenhet från ISP-branchen och Linux-nörd.
Favoritdist: Arch linux. Datarymden

Trädvy Permalänk
Medlem
Registrerad
Jul 2009

Startade Ubuntu server cd och valde rescue system. Den bad mig att skriva in lösenordet till den krypterade hårddisken osv. Nu kom jag till det här:

Vad ska jag välja/göra?

Trädvy Permalänk
Avstängd
Registrerad
Aug 2012

förmodligen sda1

Trädvy Permalänk
Medlem
Registrerad
Jul 2009
Skrivet av e-lite:

förmodligen sda1

Jo men den ville förut att jag skulle skriva in lösenordet till den krypterade, vilket var sda5. Ville bara vara säker, df jag frågade

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Okt 2008

Kolla med tex fdisk -l i en terminal (brukar finnas extra-terminaler om du trycker på alt-f2 tex) så ser du vad alla diskar och partitoner heter. Det kan skilja från gång till gång du bootar om du har otur, så det är alltid bäst att kolla.

Jobbar som nätverkskonsult på PWNY.
Flerårig erfarenhet från ISP-branchen och Linux-nörd.
Favoritdist: Arch linux. Datarymden

Trädvy Permalänk
Medlem
Registrerad
Jul 2009
Skrivet av fisk1n:

Kolla med tex fdisk -l i en terminal (brukar finnas extra-terminaler om du trycker på alt-f2 tex) så ser du vad alla diskar och partitoner heter. Det kan skilja från gång till gång du bootar om du har otur, så det är alltid bäst att kolla.

så, Har försökt med olika live-cd för att fixa detta. körde med supergrub2 skiva också. /dev/Shell/root finns, men grub kan inte boota den, grub säger att den inte finns. Skumt som fan.

Sen verkar det också som att grub inte kan boota lvm. Har kört det där kommandot och allt stämmer, Förstår ingenting. Behöver lvm en egen bootloader?

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Okt 2008

Det behöver inte en egen bootloader, men det kräver att dina bootfiler har stöd för lvm. Jag vet inte hur debian jobbar, men i arch linux är det /etc/mkinitcpio.conf du lägger till moduler, lvm ska då finnas med i listorna där. Sen kör man mkinitcpio -p linux för att generera nya boot-images. Har linuxkärnan eller några andra liknande viktiga paket uppdaterats sen sist du rebootade den?

Jobbar som nätverkskonsult på PWNY.
Flerårig erfarenhet från ISP-branchen och Linux-nörd.
Favoritdist: Arch linux. Datarymden

Trädvy Permalänk
Medlem
Registrerad
Jul 2009
Skrivet av fisk1n:

Det behöver inte en egen bootloader, men det kräver att dina bootfiler har stöd för lvm. Jag vet inte hur debian jobbar, men i arch linux är det /etc/mkinitcpio.conf du lägger till moduler, lvm ska då finnas med i listorna där. Sen kör man mkinitcpio -p linux för att generera nya boot-images. Har linuxkärnan eller några andra liknande viktiga paket uppdaterats sen sist du rebootade den?

Det är det jag misstänker. Tror jag körde en apt-get upgrade innan rebooten :/

Ska kolla det du skrev

Trädvy Permalänk
Medlem
Registrerad
Jul 2009

nepp /etc/mkinitcpio.conf fanns inte :/

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Okt 2008

Som sagt vet jag inte exakt hur debian jobbar, dom kanske har nåt annat upplägg. Så som jag brukar lösa sånna problem är att boota en liveskiva och sen montera diskarna och chroota in i det system som behöver fixas och fixa problemet direkt i den miljön. I detta fall editera rätt konf-filer och återgenerera boot-images. Ibland har jag behövt nedgradera paket också pga sneduppdateringar.

Edit: Okej, då vet jag inte hur debian jobbar riktigt, men det bör google kunna svara på.

Jobbar som nätverkskonsult på PWNY.
Flerårig erfarenhet från ISP-branchen och Linux-nörd.
Favoritdist: Arch linux. Datarymden

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Okt 2008

initramfs nånting bör du leta efter tror jag, efter lite googling

Jobbar som nätverkskonsult på PWNY.
Flerårig erfarenhet från ISP-branchen och Linux-nörd.
Favoritdist: Arch linux. Datarymden

Trädvy Permalänk
Medlem
Registrerad
Jul 2009
Skrivet av fisk1n:

initramfs nånting bör du leta efter tror jag, efter lite googling

Hamnar i initramfs efter den inte hittar något. Tack för svaren i förra posten.

Kan komma in i en shell i systemet med att mounta med rescue, Så ska försöka downgrada servern. Hur gör man det?

Ska googla runt lite. Men om du vet ett direkt svar så kan du gärna svara

Edit, tillägg: Tror jag råkade göra detta: http://serverfault.com/questions/302938/i-accidentally-upgrad...

Har för mig att jag körde en full-upgrade innan reboot (följde en guide för något) Aja, nu hoppas jag att det är felet för då finns en lösning