Har ett problem med Directpath i VMware 5.0

Trädvy Permalänk
Medlem
Plats
Hudiksvall
Registrerad
Okt 2004

Har ett problem med Directpath i VMware 5.0

Hej!

Jag har ett problem som jag skulle vilja få fixat!

Det är så att jag har en server som för tillfället kör esxi 5.0, och jag skulle vilja köra en directpath av mitt grafikkort via min pci-e port på servern till ett av mina guest OS.

Hårdvaran jag har i min server är en gammal 1156 socket i5 750 processor, och ett moderkort vid namn Gigabte GA-P55A-UD3 (rev. 2.0).
grafikkortet är ett ati 4850, vilket ska efter lite forskning fungera att få directpathad!

problemet som jag har är att jag får upp att min host inte har någon stöd för passthrough, inte ens för mitt NIC, som ska vara ett realtek 8111d NIC. (Network interface).

Vilket får mej att fundera på om detta nu har nått med min hårdvara att göra?

Jag vill gärna ha hjälp för att lösa detta problem. kan det lösa sej om jag uppdaterar mitt BIOS? kör för tillfället F3.

det är väldigt irriterande när jag vet att chipsetet ska fungera med vmwares passthrough!

EDIT: Som det verkar har inte min processor stöd för VT-d, vilket den måste stödja, men den har stöd för vt-x. då kommer det ännu en fråga. vad är skillnaden? jag trodde att vt-x var samma sak som vt-d, bara att det var flera saker i vt-x.

..:: Workstation ::.. ..:: Asus P8Z77-v LX ::.. ..:: MSI GTX1060 6GB ::.. ..:: i5 3450 Ivy Bridge /w Antec KÜHLER H2O 620 Sluten Vattenkylning ::.. ..:: Corsair 16GB DDR3 600MHz/CL9/VENG ::.. ..:: NoName 650W ::.. ..:: Dell 24" 2408WFP ::.. ..:: Server ::.. ..:: AMD ..:: FX-8320 ::.. ..:: 16GB ::.. ..:: XFX HD6450 ::.. ..::250GB SSD Samsung 840 EVO::.. ..:: 3x 2TB wd black ::.. ..:: VCP6-DCV ::.. ..:: vmware esxi 6.5 ::..

Trädvy Permalänk
Medlem
Registrerad
Sep 2006

Kan det inte vara licensen för VMware som inte stöder det?

EDIT: Det var bara en tanke, som visade sig vara fel
Hittade lite info här du kanske kan ha nytta av http://vmware.com/files/pdf/techpaper/VMW-vSphere4-directpath...
Nog för att det är för vSphere 4, men du kanske får lite tips och kan leta upp liknande för ESX 5.

Dator: https://www.inet.se/kundvagn/bild/9823049/
Server: 2x HP ProLiant Microserver Gen8, 16GB/st, ESXi 6.0
NAS: Synology DS413 4st 3TB | QNAP TS-879 Pro 8st 2TB

Trädvy Permalänk
Medlem
Registrerad
Apr 2002
Skrivet av tjossanmannen:

EDIT: Som det verkar har inte min processor stöd för VT-d, vilket den måste stödja, men den har stöd för vt-x. då kommer det ännu en fråga. vad är skillnaden? jag trodde att vt-x var samma sak som vt-d, bara att det var flera saker i vt-x.

Nej, VT-x och VT-d är olika funktioner. VT-x är det grundläggande virtualiseringsstödet och VT-d är stödet för direktaccess till hårdvara.

http://www.intel.com/technology/itj/2006/v10i3/2-io/7-conclus...

Intel i7 6850k || Asus X99-A II || Evga GTX 980Ti || Kingston HyperX Fury 2666 64GB || Samsung 950 Pro 512GB || XB270HU 1440p IPS G-Sync

Trädvy Permalänk
Medlem
Plats
Hudiksvall
Registrerad
Okt 2004

blir väll tvungen att sno broders processor då vilket bök det blev! varför inte sätta stöd till alla processorer i samma architektur! gah...har 2st 750 prollar. men ingen av dom fungerar ju...vad irriterande. och detta var en av de stora grejerna jag behövde till min server!

..:: Workstation ::.. ..:: Asus P8Z77-v LX ::.. ..:: MSI GTX1060 6GB ::.. ..:: i5 3450 Ivy Bridge /w Antec KÜHLER H2O 620 Sluten Vattenkylning ::.. ..:: Corsair 16GB DDR3 600MHz/CL9/VENG ::.. ..:: NoName 650W ::.. ..:: Dell 24" 2408WFP ::.. ..:: Server ::.. ..:: AMD ..:: FX-8320 ::.. ..:: 16GB ::.. ..:: XFX HD6450 ::.. ..::250GB SSD Samsung 840 EVO::.. ..:: 3x 2TB wd black ::.. ..:: VCP6-DCV ::.. ..:: vmware esxi 6.5 ::..

Trädvy Permalänk
Medlem
Plats
Hudiksvall
Registrerad
Okt 2004

verkar vara många moderkort av desktopslag som inte har stöd för vt-d i bios även fast det står att moderkortet ska ha stöd för det. och det är just det jag har fallit pladask för just nu! bytte med broder men fungerade inte!

typo

..:: Workstation ::.. ..:: Asus P8Z77-v LX ::.. ..:: MSI GTX1060 6GB ::.. ..:: i5 3450 Ivy Bridge /w Antec KÜHLER H2O 620 Sluten Vattenkylning ::.. ..:: Corsair 16GB DDR3 600MHz/CL9/VENG ::.. ..:: NoName 650W ::.. ..:: Dell 24" 2408WFP ::.. ..:: Server ::.. ..:: AMD ..:: FX-8320 ::.. ..:: 16GB ::.. ..:: XFX HD6450 ::.. ..::250GB SSD Samsung 840 EVO::.. ..:: 3x 2TB wd black ::.. ..:: VCP6-DCV ::.. ..:: vmware esxi 6.5 ::..

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Aug 2010

Det är chipsetet på moderkortet som sätter begränsningen, det behövs ett moderkort med Q55/Q57 chip om jag inte misstar mig. Fick själv byta moderkort pga detta, fast till ett med Q67 chip då jag kör på 1155-sockel. Q-chipen har en del andra funktioner som gör att de är mer enterprise-inriktade, så inte så vanligt på konsument-mammabrädor

Här är ett bra lista att utgå från: http://www.vm-help.com//esx40i/esx40_whitebox_HCL.php

Trädvy Permalänk
Medlem
Registrerad
Aug 2002
Skrivet av Hotcpu6:

Det är chipsetet på moderkortet som sätter begränsningen, det behövs ett moderkort med Q55/Q57 chip om jag inte misstar mig. Fick själv byta moderkort pga detta, fast till ett med Q67 chip då jag kör på 1155-sockel. Q-chipen har en del andra funktioner som gör att de är mer enterprise-inriktade, så inte så vanligt på konsument-mammabrädor

Här är ett bra lista att utgå från: http://www.vm-help.com//esx40i/esx40_whitebox_HCL.php

Bara för att förtydliga: det räcker inte med att CPU/Chipset har stöd för VT-d - det måste också finnas stöd i BIOS och utöver det måste det också fungera i ESXi - vilket det nog oftast gör om det finns stöd i hela kedjan så att säga men tydligen funkar det inte alltid ändå.

i5-2500k @ 4.2GHz | ASUS P8Z68V/GEN3 | 4x4GB Kingston DDR3-1333 | ASUS GeForce GTX 1070 Dual OC | Intel 520 480GB | WD Black 3TB | Noctua NH-U12P SE2 | Fractal Design ARC | Be-Quiet Straight Power BQT E9 CM 680W | LG BH08LS20 | ASUS Xonar Essence STX

Trädvy Permalänk
Medlem
Plats
Upplands Väsby
Registrerad
Dec 2010
Skrivet av Micke O:

Bara för att förtydliga: det räcker inte med att CPU/Chipset har stöd för VT-d - det måste också finnas stöd i BIOS och utöver det måste det också fungera i ESXi - vilket det nog oftast gör om det finns stöd i hela kedjan så att säga men tydligen funkar det inte alltid ändå.

Japp, har haft ett moderkort/cpu där allt stöds rent tekniskt men moderkorts tillverkaren hade struntat i korrekt BIOS stöd med resultatet att det inte fungerade.
2 år senare dök det upp en BIOS uppdatering där stödet plötsligt var med och så fungerade VT-d korrekt med ESXi. Fast då hade jag redan skaffat nya prylar för att uppgradera VMware servern. Duh! :-/

Trädvy Permalänk
Medlem
Plats
Hudiksvall
Registrerad
Okt 2004

märkte nu att min bror hade en komplett desktop version som stödde vt-d i bios, 1156 med chipset H55 istället för P55, med en 650 processor. så ska byta moderkort med broder också, bara för att, han kommer fortfarande ha samma prestanda då det handlar om processorbyte i princip! och då kommer jag kunna få min HTPC gäst! om det nu fungerar! får hålla tummarna! Om det inte fungerar får jag väll sälja grejerna, för det är bland annat det och labb denna burk kommer att agera som, dock så kommer jag ha fin labbmiljö ändå på jobbet

..:: Workstation ::.. ..:: Asus P8Z77-v LX ::.. ..:: MSI GTX1060 6GB ::.. ..:: i5 3450 Ivy Bridge /w Antec KÜHLER H2O 620 Sluten Vattenkylning ::.. ..:: Corsair 16GB DDR3 600MHz/CL9/VENG ::.. ..:: NoName 650W ::.. ..:: Dell 24" 2408WFP ::.. ..:: Server ::.. ..:: AMD ..:: FX-8320 ::.. ..:: 16GB ::.. ..:: XFX HD6450 ::.. ..::250GB SSD Samsung 840 EVO::.. ..:: 3x 2TB wd black ::.. ..:: VCP6-DCV ::.. ..:: vmware esxi 6.5 ::..