Kixtart script för att lägga in custom lockscreen vid logon

Trädvy Permalänk
Medlem
Registrerad
Aug 2011

Kixtart script för att lägga in custom lockscreen vid logon

Hej,

Har ett kixtart script som jag utökat med 2 rader kod. Tanken är att uppdatera hela domänens lockscreens på windows 7 maskiner.

del av problematiken är att man inte får flytta direkt in i system32 mappen från en share. Jag har då valt att flytta den lokalt på C: först, för att sen anropa ROBOCOPY för att kopiera filen från C: till system32\oobe\etc etc

Så här ser sciptet ut
;Flytta lockscreen jpg till C:
copy "\\SERVER\sysvol\domain.local\scripts\logonscreen\backgroundDefault.jpg" "C:\logonscreen\" /h /r
SHELL "%COMSPEC% /e:1024 /c ROBOCOPY.EXE ROBOCOPY C:\logonscreen\ C:\Windows\System32\oobe\info\backgrounds\ /r:2 /w:2 /IS"

Resultatet blir att den först flyttar till C: men sen inte vidare. Kör man scriptet igen efter inloggning. Så fungerar det och filen kopieras från C: till system32

2 Tänkbara scenarion:
1. När användaren loggar in så är backgroundDefault.jpg i användning och användaren får då självklart inte skriva över filen.
2. Filen flyttas för sent och robocopy försöker flytta något som inte finns ännu.

Skulle helst vilja fortsätta använda KIXTART, men vet att via GPO går det att göra liknande grejjer. Servern är en Server 2003 sp2

Det behöver inte heller vara perfekt, tanken är att bara ha det här i en vecka så att samtliga datorer i domänen får sin locksreen bytt, sen ta bort det för att slippa onödig trafik.

[Moderkort]: ASUS P8Z68-V PRO [CPU]: i7 3770k @Stock [Minne]: Corsair 2x8Gb Vengeance LP [GPU]: Sapphire RX480 8gb Nitro+ OC [Systemdisk]: Corsair SSD Force 3 90Gb [Storage]: Crucial M4 64Gb, 4Tb SATA 7200rpm [PSU]: Corsair AX750W [Chassi]: Coolermaster CM690 II Adv

Trädvy Permalänk
Medlem
Registrerad
Sep 2006

Hej

Ja alltså. Jag föredrar ju GPO alla dagar i veckan. Får man fråga varför du inte väljer det istället?

Dator: https://www.inet.se/kundvagn/bild/9823049/
Server: 2x HP ProLiant Microserver Gen8, 16GB/st, ESXi 6.0
NAS: Synology DS413 4st 3TB | QNAP TS-879 Pro 8st 2TB

Trädvy Permalänk
Medlem
Registrerad
Aug 2011

Har massor i scriptet redan, så tiden det tar att lägga upp alltd i GPOn istället är väl haken.

Det arbetet kommer troligen påbörjas först vid nästa serverbyte istället.

[Moderkort]: ASUS P8Z68-V PRO [CPU]: i7 3770k @Stock [Minne]: Corsair 2x8Gb Vengeance LP [GPU]: Sapphire RX480 8gb Nitro+ OC [Systemdisk]: Corsair SSD Force 3 90Gb [Storage]: Crucial M4 64Gb, 4Tb SATA 7200rpm [PSU]: Corsair AX750W [Chassi]: Coolermaster CM690 II Adv

Trädvy Permalänk
Medlem
Registrerad
Sep 2006

Okej. Men du kan ju göra GPOer nu ändå och sedan migrera dem när du byter server. Så kör detta som en GPO :).

Dator: https://www.inet.se/kundvagn/bild/9823049/
Server: 2x HP ProLiant Microserver Gen8, 16GB/st, ESXi 6.0
NAS: Synology DS413 4st 3TB | QNAP TS-879 Pro 8st 2TB

Trädvy Permalänk
Medlem
Registrerad
Aug 2011

Ingen aning hur man gör detta i GPOn för Server 2003, lust att förklara ?

[Moderkort]: ASUS P8Z68-V PRO [CPU]: i7 3770k @Stock [Minne]: Corsair 2x8Gb Vengeance LP [GPU]: Sapphire RX480 8gb Nitro+ OC [Systemdisk]: Corsair SSD Force 3 90Gb [Storage]: Crucial M4 64Gb, 4Tb SATA 7200rpm [PSU]: Corsair AX750W [Chassi]: Coolermaster CM690 II Adv

Trädvy Permalänk
Medlem
Registrerad
Sep 2006

Hittade jättemycket när jag googlade på det Så det ska inte vara några bekymmer.

Dator: https://www.inet.se/kundvagn/bild/9823049/
Server: 2x HP ProLiant Microserver Gen8, 16GB/st, ESXi 6.0
NAS: Synology DS413 4st 3TB | QNAP TS-879 Pro 8st 2TB

Trädvy Permalänk
Medlem
Registrerad
Aug 2011

Om du inte har något vettigt att säga, sluta posta i tråden.

Jag har googlat och hittar ingen lösning på problemet, annars hade jag inte postat och frågat om hjälp här, eller hur?

[Moderkort]: ASUS P8Z68-V PRO [CPU]: i7 3770k @Stock [Minne]: Corsair 2x8Gb Vengeance LP [GPU]: Sapphire RX480 8gb Nitro+ OC [Systemdisk]: Corsair SSD Force 3 90Gb [Storage]: Crucial M4 64Gb, 4Tb SATA 7200rpm [PSU]: Corsair AX750W [Chassi]: Coolermaster CM690 II Adv

Trädvy Permalänk
Medlem
Registrerad
Sep 2006

Jag ber om ursäkt för att jag försökte hjälpa dig. Eftersom du inte ville testa GPO från början så har du ju uppenbarligen inte googlat efter det.
Lös problemet själv istället för att sura då.

Dator: https://www.inet.se/kundvagn/bild/9823049/
Server: 2x HP ProLiant Microserver Gen8, 16GB/st, ESXi 6.0
NAS: Synology DS413 4st 3TB | QNAP TS-879 Pro 8st 2TB

Trädvy Permalänk
Medlem
Plats
Tranemo
Registrerad
Aug 2006
Trädvy Permalänk
Medlem
Registrerad
Dec 2008

Xperts exchange är lite fula. Du måste komma från google för att se svaren i botten av tråden. Gratis kan du inte se det svar som är märkt rätt. Googlade mig in och fick detta som svar, dvs. med admiinkonsollen i windows 7 eller server 2008 kan man få 2003 att skicka ut en policy som är ny i de versionerna.

Citat:

I tested this very issue awhile back, putting in a background image on login on my new windows 7 PC's from a 2003 server.

A few things you need to do.
1: Install AD Administrative Tools on a Windows 7 or server 2008 (r2) PC. You can use GPO Tools from a non windows server, as long as your authenticated as an administrator with access to AD resources. The only caveat is, the windows server 2003 will not be able to see these GPO's, or deal with them.

This link describes a simular situation that you have.
http://social.technet.microsoft.com/Forums/eu/winserverGP/thr...

How to install the Windows 7/2008 ect Administrative Tools for AD http://www.symantec.com/connect/blogs/installing-admin-tools-...

If it is a server 2008, or you notice some 'missing' things, you can add a GPO Administrative Templates download to the administrative tools:

windows 7 GPO Administrative Templates: http://www.microsoft.com/en-us/download/details.aspx?id=6243

2: Two Group Policies need to be setup from the windows 7/2008 pc with the templates installed.

You have one of them that you already know you need,
But here is a writeup that you probly stumbled upon

http://mikecrowley.wordpress.com/tag/group-policy/

Essentially the link above shows you what you already have, and the one extra step of
making a background image.

"In the Group Policy Management Console, edit the GPO to change following settings.
Computer Configuration => Preferences => Windows Settings => Files => New File
set the parameters as following image."

And
Goto "Computer Configuration\Policies\Administrative Templates\System\Logon.
Once there, select “Always use custom logon background” and set it to “Enabled”.

Trädvy Permalänk
Medlem
Plats
Tranemo
Registrerad
Aug 2006

Va fult. Det visste jag faktiskt inte om.