SSD fastnar i boot

Trädvy Permalänk
Medlem
Plats
Karlstad
Registrerad
Aug 2012

SSD fastnar i boot

Hallå swec

Har haft ett problem med min ssd ett tag nu..
Den funkar prima i windows och inga problem alls med öppning av saker lagrat på SSDn. Enda problem är att när jag startar datorn så fastnar den på "Windows is starting" och stannar på den bilden i cirka 30sec.. Från början bootade det snabbt och kom i princip in i windows direkt, sedan efter ett tag så började det här problemet men var ganska sällan..
Nu är det så varje gång jag startar datorn, något problem som är vanligt eller vad kan det vara som spökar?

Har en Intel 520 180gb, 400i drivrutin (som jag tror är senaste(?))

Moderkort: MSI Z77A-GD55 | CPU: i5 3570k (Kylare: Hyper 212 EVO) | RAM: Corsair Vengeance 1600Mhz 8GB | GPU: Gigabyte GTX 780 | PSU: Corsair PSU 600W GS 80 Plus | Chassi: Fractal Design Define R4 | SSD: Intel 520 Series 180GB | HDD: Seagate Barracuda 2GB 7200 rpm | Monitor: Samsung 2233rz

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Mar 2013

Kör du Windows 7? Har du senaste uppdateringarna installerade? Windows 8 bootar upp på 1-2 sekunder för mig (no joke), och det är en gammal install på en ännu äldre SSD. Jag misstänker att det är något annat än SSDn som är boven i dramat, men för att vara säker dra ner något benchmark/errortesting program och diagnostera din SSD med den!

Trädvy Permalänk
Medlem
Plats
Karlstad
Registrerad
Aug 2012
Skrivet av Haikarainen:

Kör du Windows 7? Har du senaste uppdateringarna installerade? Windows 8 bootar upp på 1-2 sekunder för mig (no joke), och det är en gammal install på en ännu äldre SSD. Jag misstänker att det är något annat än SSDn som är boven i dramat, men för att vara säker dra ner något benchmark/errortesting program och diagnostera din SSD med den!

http://i.imgur.com/B7CNxiB.png här är testet, ska nog försöka formatera disken.. och dra på windows 8, har 7 nu.

Moderkort: MSI Z77A-GD55 | CPU: i5 3570k (Kylare: Hyper 212 EVO) | RAM: Corsair Vengeance 1600Mhz 8GB | GPU: Gigabyte GTX 780 | PSU: Corsair PSU 600W GS 80 Plus | Chassi: Fractal Design Define R4 | SSD: Intel 520 Series 180GB | HDD: Seagate Barracuda 2GB 7200 rpm | Monitor: Samsung 2233rz

Trädvy Permalänk
Medlem
Registrerad
Aug 2005

Gör en boot trace, antagligen är det något som inte laddar som det ska. Man kan då se vad som tar tid och googla efter en lösning.

http://www.msfn.org/board/topic/140247-trace-windows-7-bootsh...

Eller om du har windows 8:

http://www.msfn.org/board/topic/158252-trace-why-windows-8-bo...

En ssd som baseras på en kontroller från sandforce komprimerar data för ökad prestanda/livslängd. AS-SSD använder data som inte går att komprimera och ger då sämsta möjliga resultat, ATTO använder data som är lätt att komprimera och ger bästa möjliga resultat. Eftersom program/os/spel ofta går att komprimera någorlunda bra så hamnar den verkliga prestandan någonstans mellan dessa resultat vid normal användning.

Trädvy Permalänk
Medlem
Plats
Karlstad
Registrerad
Aug 2012
Skrivet av Frispel:

Gör en boot trace, antagligen är det något som inte laddar som det ska. Man kan då se vad som tar tid och googla efter en lösning.

http://www.msfn.org/board/topic/140247-trace-windows-7-bootsh...

Eller om du har windows 8:

http://www.msfn.org/board/topic/158252-trace-why-windows-8-bo...

Ok, gjorde som guiden förklarade.. och har fått ut detta, bilden, men är inte riktigt säker på vad som är det jag beskrev. Alltså "windows starting" delen.
Möjligt att du kanske vet?

Moderkort: MSI Z77A-GD55 | CPU: i5 3570k (Kylare: Hyper 212 EVO) | RAM: Corsair Vengeance 1600Mhz 8GB | GPU: Gigabyte GTX 780 | PSU: Corsair PSU 600W GS 80 Plus | Chassi: Fractal Design Define R4 | SSD: Intel 520 Series 180GB | HDD: Seagate Barracuda 2GB 7200 rpm | Monitor: Samsung 2233rz

Trädvy Permalänk
Medlem
Registrerad
Aug 2005
Skrivet av jsnAke:

Ok, gjorde som guiden förklarade.. och har fått ut detta, bilden, men är inte riktigt säker på vad som är det jag beskrev. Alltså "windows starting" delen.
Möjligt att du kanske vet?

Det som verkar ta lång tid för dig är SMSSInit som tar ca 32 sekunder för dig, läser man guiden så står det så här om den delen av uppstarten:

Citat:

SMSSInit Subphase

What Happens in This Subphase
The SMSSInit subphase begins when the kernel passes control to the session manager process (Smss.exe). During this subphase, the system initializes the registry, loads and starts the devices and drivers that are not marked BOOT_START, and starts the subsystem processes. SMSSInit ends when control is passed to Winlogon.exe.

Visual Cues
There are no explicit visual cues for the start of SMSSInit, but the blank screen that appears between the splash screen and the logon screen is part of SMSSInit. It ends before the logon screen appears.

SMSSInit Performance Vulnerabilities
Video drivers are a common source of performance problems in the SMSSInit subphase. The video driver must be initialized first in the system session and then in the user session. Reduction of video driver initialization time leads to a direct wall-clock reduction in boot time.
Initialization in the user session is typically much faster than in the system session because Windows performs common initialization tasks during the system session.

So if the SMSSInit Phase takes too long, try to get an graphic card driver update.

Kort sagt, kolla om det finns någon ny drivrutin för grafikkort, alternativt googla och se om det finns andra vanliga källor till lång väntan vid just SMSSInit

Annars så ska det gå att öppna etl-filen för att se mer i detalj vad som tar tid

En ssd som baseras på en kontroller från sandforce komprimerar data för ökad prestanda/livslängd. AS-SSD använder data som inte går att komprimera och ger då sämsta möjliga resultat, ATTO använder data som är lätt att komprimera och ger bästa möjliga resultat. Eftersom program/os/spel ofta går att komprimera någorlunda bra så hamnar den verkliga prestandan någonstans mellan dessa resultat vid normal användning.

Trädvy Permalänk
Medlem
Plats
Karlstad
Registrerad
Aug 2012
Skrivet av Frispel:

Det som verkar ta lång tid för dig är SMSSInit som tar ca 32 sekunder för dig, läser man guiden så står det så här om den delen av uppstarten:

Kort sagt, kolla om det finns någon ny drivrutin för grafikkort, alternativt googla och se om det finns andra vanliga källor till lång väntan vid just SMSSInit

Annars så ska det gå att öppna etl-filen för att se mer i detalj vad som tar tid

Blev absolut snabbare än va de va innan, hade 13.1 drivers.. senaste va 13.4 så uppdaterade det och startade om, och genast bättre boot tid.
Tack för hjälp!

Moderkort: MSI Z77A-GD55 | CPU: i5 3570k (Kylare: Hyper 212 EVO) | RAM: Corsair Vengeance 1600Mhz 8GB | GPU: Gigabyte GTX 780 | PSU: Corsair PSU 600W GS 80 Plus | Chassi: Fractal Design Define R4 | SSD: Intel 520 Series 180GB | HDD: Seagate Barracuda 2GB 7200 rpm | Monitor: Samsung 2233rz

Trädvy Permalänk
Medlem
Registrerad
Aug 2005
Skrivet av jsnAke:

Blev absolut snabbare än va de va innan, hade 13.1 drivers.. senaste va 13.4 så uppdaterade det och startade om, och genast bättre boot tid.
Tack för hjälp!

Vad blev det för tid nu efter förbättringen?

Som sagt så kan du om du vill öppna .etl filen i xperf och se grafiskt hur/vad som tar tid:

http://windows-scripting.org/2011/06/10/xbootmgr-solve-window...

En ssd som baseras på en kontroller från sandforce komprimerar data för ökad prestanda/livslängd. AS-SSD använder data som inte går att komprimera och ger då sämsta möjliga resultat, ATTO använder data som är lätt att komprimera och ger bästa möjliga resultat. Eftersom program/os/spel ofta går att komprimera någorlunda bra så hamnar den verkliga prestandan någonstans mellan dessa resultat vid normal användning.

Trädvy Permalänk
Medlem
Plats
Karlstad
Registrerad
Aug 2012
Skrivet av Frispel:

Vad blev det för tid nu efter förbättringen?

Som sagt så kan du om du vill öppna .etl filen i xperf och se grafiskt hur/vad som tar tid:

http://windows-scripting.org/2011/06/10/xbootmgr-solve-window...

Ok, så problemet med seg "windows starting" är bättre. Men nu fastnar den på en black screen som kommer direkt efter, och stannar där i 20sec istället.
Den andra du länkade tyckte jag verkade lite krånglig. Tror jag ska formatera disken ändå nu, och dra på windows 8.. lär ju bli ändring på boot tiden då

Moderkort: MSI Z77A-GD55 | CPU: i5 3570k (Kylare: Hyper 212 EVO) | RAM: Corsair Vengeance 1600Mhz 8GB | GPU: Gigabyte GTX 780 | PSU: Corsair PSU 600W GS 80 Plus | Chassi: Fractal Design Define R4 | SSD: Intel 520 Series 180GB | HDD: Seagate Barracuda 2GB 7200 rpm | Monitor: Samsung 2233rz