Extern HD, Går ej att allokera...?

Trädvy Permalänk
Medlem
Registrerad
Dec 2012

Extern HD, Går ej att allokera...?

Har en WD Extern HD 2TB, som syns inte alls bland andra hårddiskar och externa hdd under Datorn.
Det jag kan se är under, diskhanteraren så finns min externa hdd listade som Disk 2. Men den är inte allokerat och vid högerklick får jag inget alternativ för att göra det.

Hur kan jag allokera den för att senare namnge disken med ett bokstav och förhoppningsvis öppna disken och få tillgång till mina filer igen.

Tackar på förhand!

Trädvy Permalänk
Inaktiv
Registrerad
Mar 2013

EaseUS® Partition Master Free Edition brukar funka bra när det är problem i windows http://www.partition-tool.com/personal.htm

Trädvy Permalänk
Medlem
Registrerad
Dec 2012
Skrivet av palleralla:

EaseUS® Partition Master Free Edition brukar funka bra när det är problem i windows http://www.partition-tool.com/personal.htm

Tackar skall ta o testa d med n gång, men hur gör jag så att disken blir allokerat?

Trädvy Permalänk
Medlem
Registrerad
Dec 2012
Skrivet av palleralla:

EaseUS® Partition Master Free Edition brukar funka bra när det är problem i windows http://www.partition-tool.com/personal.htm

Går inte att fixa det via det programmet då den kräver att allting skall vara allokerat ....

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Sep 2007

I diskhanteraren. Testa alternativen som inte är grå markerade. Ta bort partitionen mm.

Gör diskhanterar fönstret STÖRRE. Du ser du hårddisken (partitionen) på 2-3 olika ställen. Beroende på om du höger klickar i den vänstra (disk 0, 1 osv) eller högra rutan(bilden) så får du upp olika val i menyn som dyker upp. När disken är formaterad så dyker den upp längst upp i diskhanterar fönstret vilket blir totalt 3 ställen.

Trädvy Permalänk
Medlem
Registrerad
Dec 2012
Skrivet av panpo98:

I diskhanteraren. Testa alternativen som inte är grå markerade. Ta bort partitionen mm.

Gör diskhanterar fönstret STÖRRE. Du ser du hårddisken (partitionen) på 2-3 olika ställen. Beroende på om du höger klickar i den vänstra (disk 0, 1 osv) eller högra rutan(bilden) så får du upp olika val i menyn som dyker upp. När disken är formaterad så dyker den upp längst upp i diskhanterar fönstret vilket blir totalt 3 ställen.

Se bilden nedan. som du ser, så får jag ingen alternativ alls när jag h. klickar på disken, samtidigt som hela disken är ej allokerat, så nu återstår frågan hur kan jag allokera denna disk så att senare namnge disken och på så sätt få tillgång till filerna.
Ps: finns det annat sätt att komma åt filer, då när Windows inte upptäcker hdd?

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Feb 2007

Högerklicka på rutan där bl.a texten "Inte initierad" står och välj att initiera den.

Grundregel för felsökning: Bryt och begränsa.

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Sep 2007

ftp_zilla:
Du har inte alls högerklickat på stället där du ritat röda cirkeln så du har inte alls gjort det du påstått. Man ser tydligt i bilden att du höger klickat i den svarta högra rutan för att få menyn i bilden.

Hade du höger klickat på den vänstra rutan där du ritat den röda cirkeln hade du fått upp en helt annan menyn där även alternativet som Veni snackar om finns.

Trädvy Permalänk
Medlem
Registrerad
Dec 2012
Skrivet av Veni:

Högerklicka på rutan där bl.a texten "Inte initierad" står och välj att initiera den.

Får följande felmeddelande, "Begäran kunde inte utföras pga ett fel i en I/O-enhet."
Jag kanske har formulerat mig fel, men syftade på att det är Disk2 som är det aktuella disken och som måste allokeras och initieras.
Kan tillägga att, vid val av MBR eller GPT så resulterar det till samma felmeddelande - se ovan!

Alltså, det går varken att initiera eller allokera disken - så hur gör jag nu?

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Feb 2007

Ladda ner GParted eller PartedMagic och kör den mot den externa lagringsenheten.
Välj Device-->Create Partition Table-->typen skall vara MS-DOS(skall redan vara förvald).
Skapa sedan även en NTFS partition på den med hjälp av ovanstående program.

Om detta fungerar, kör lagringsenheten i ditt Windows operativ och välj att formattera den som NTFS.

Grundregel för felsökning: Bryt och begränsa.

Trädvy Permalänk
Medlem
Registrerad
Dec 2012
Skrivet av Veni:

Ladda ner GParted eller PartedMagic och kör den mot den externa lagringsenheten.
Välj Device-->Create Partition Table-->typen skall vara MS-DOS(skall redan vara förvald).
Skapa sedan även en NTFS partition på den med hjälp av ovanstående program.

Om detta fungerar, kör lagringsenheten i ditt Windows operativ och välj att formattera den som NTFS.

Okej, men jag har otroligt viktiga filer i form av barndomsbilder, filmsekvenser etc. som jag måste komma åt, innan jag kan formatera disken.
Tror du att jag kan göra det genom att använda mig av GParted eller PartedMagic?

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Feb 2007
Skrivet av ftp_zilla:

Okej, men jag har otroligt viktiga filer i form av barndomsbilder, filmsekvenser etc. som jag måste komma åt, innan jag kan formatera disken.
Tror du att jag kan göra det genom att använda mig av GParted eller PartedMagic?

Oj, det missade jag, att där fanns viktiga filer. Hur kommer det sig att den lagt av? Jag gick i tankarna att detta var en ny och tom enhet. PartedMagic kan kanske montera enheten så att du kan bläddra på den och eventuellt kopiera/flytta filerna till en annan enhet.

Men nu blir jag lite rädd, att Du har andra problem än något som är filsystemsrelaterat när Windows pekar på att lagringsenheten inte är initierad samt initiering misslyckats(tack o lov förvisso).

Om inte PartedMagic kan montera enheten så att Du kan bläddra på den, så prova att byta nätdel till den om Du har en likvärdig eller bättre tillgänglig.

Grundregel för felsökning: Bryt och begränsa.

Trädvy Permalänk
Medlem
Registrerad
Dec 2012
Skrivet av Veni:

Oj, det missade jag, att där fanns viktiga filer. Hur kommer det sig att den lagt av? Jag gick i tankarna att detta var en ny och tom enhet. PartedMagic kan kanske montera enheten så att du kan bläddra på den och eventuellt kopiera/flytta filerna till en annan enhet.

Men nu blir jag lite rädd, att Du har andra problem än något som är filsystemsrelaterat när Windows pekar på att lagringsenheten inte är initierad samt initiering misslyckats(tack o lov förvisso).

Om inte PartedMagic kan montera enheten så att Du kan bläddra på den, så prova att byta nätdel till den om Du har en likvärdig eller bättre tillgänglig.

Det hela började med att HDDn la av helt och hållet, utan yttre påverkan, har ej tappat det på golvet eller liknande.
När man ansluter HDDn till datorn, så spinnar den upp, men windows kan inte hitta hddn och öppna den samtidigt som den inte finns listade under min Dator, efter att den varit ansluten till datorn i kanske 1-1,5 minuter så ger den ifrån sig ett "klickande ljud" som en gammal klocka "tik-tak,tik-tak" och så fortsätter det utan någon som helst avbrott.

Har testat att byta ut mönsterkortet, PCBn på den mot en annan mönsterkort som jag hade liggandes från en 1TB Hdd som också var WD, men även det fungerade inte. Kanske inte så konstigt med tanke på att min var 2TB och den jag bytte till var 1TB, kan vara det, men vet ej!

Trädvy Permalänk
Moderator
Registrerad
Mar 2006

*** tråd modererad ***

Jag har raderat ett inlägg som bryter mot forumreglerna § 4 angående att bumpa trådar. Det är däremot möjligt att uppdatera en tråd med mer eller ny information.

/KimTjik

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Feb 2007
Skrivet av ftp_zilla:

den ifrån sig ett "klickande ljud" som en gammal klocka "tik-tak,tik-tak" och så fortsätter det utan någon som helst avbrott.

Detta ljud gillar jag inte. Brukar betyda omläsning, men inte 100% alltid det. Kan också betyda omstart utav motorn och således även omkalibrering utav armen när där inte kommer tillräckligt med elektrisk energi.

Prova att slänga in den i frysen(-24 grader) i runt 30-60 minuter och starta den sedan på studs. Om den håller i sig så har Du minst en komponent som spikar energiförbrukning vid uppstart och en eller flera skydd utlöser.

Om inga tips fungerar(glöm inte det med kompatibel annan nätdel) och ingen annan kommer med andra tips och Du är seriös med att rädda informationen så prova med www.ibas.se.

Grundregel för felsökning: Bryt och begränsa.

Trädvy Permalänk
Medlem
Registrerad
Dec 2012
Skrivet av Veni:

Detta ljud gillar jag inte. Brukar betyda omläsning, men inte 100% alltid det. Kan också betyda omstart utav motorn och således även omkalibrering utav armen när där inte kommer tillräckligt med elektrisk energi.

Prova att slänga in den i frysen(-24 grader) i runt 30-60 minuter och starta den sedan på studs. Om den håller i sig så har Du minst en komponent som spikar energiförbrukning vid uppstart och en eller flera skydd utlöser.

Om inga tips fungerar(glöm inte det med kompatibel annan nätdel) och ingen annan kommer med andra tips och Du är seriös med att rädda informationen så prova med www.ibas.se.

Tror du att det dar med att slanga den i frysen, hjalper?
Kan den inte forstora hela HDDn?

Trädvy Permalänk
Medlem
Registrerad
Dec 2012

Denna screenshot kanske ger något er som vill få mer info:
Den "trasiga disken" är den tredje längst ner!

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Feb 2007
Skrivet av ftp_zilla:

Tror du att det dar med att slanga den i frysen, hjalper?
Kan den inte forstora hela HDDn?

Nopp.

Har själv gjort det flera gånger med polares, kunders och chefens hårddiskar. Jag tog frysen när jag hade bråttom. Det fungerar även med kylskåpet men tar längre tid. Idén är att kyla ner kretsarna men inte låta kondens bildas på skivorna eller någon komponent som kommer i kontakt med lagringsytan på skivorna. -24 graders frys med luftburen lösning har jag kört med. Då lägger jag den i ett av facken helt naken, dvs ingen plastpåse eller dylikt med kretskortssidan uppåt.

Ibas har dessutom räddat hårddiskar som kraschlandat i saltvatten :D, så dom små rackarna är tåliga.

Du kan prova kortare tid i frysen, men jag har fått någon gång köra uppemot 60 minuter, men då kan frysen ha varit inställd på -16 grader. Prova 5-15 minuter och provstarta den omgående efter att Du plockat ut den ur frysen.

Men som sagt tidigare, prova gärna med en alternativ kompatibel nätdel. Har varit med om det en gång på en Lacie. Och är det det, så kan Du slakta enheten och stoppa in hårddisken direkt i datorn om Du har en stationär med ledig plats och säkerhetskopiera den.

Du kan även prova att slakta WD'n om Du inte har en alternativ kompatibel nätdel i närheten.

Grundregel för felsökning: Bryt och begränsa.

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Feb 2007
Skrivet av ftp_zilla:

Denna screenshot kanske ger något er som vill få mer info:
Den "trasiga disken" är den tredje längst ner!

http://imageshack.us/a/img547/2903/rhc.png

13 osäkra sektorer(den är inte helt säker på att de är kassa) och jäkligt många läsfel. 93 uppstarter pga on/off. 4089 problem med att hitta rätt när den sökt. Men där är några saker jag inte kan tyda, bara 25h i drift? Är detta någon form av säkerhetskopieringsenhet?

Prova gärna att ladda ner SpeedFan och kör ut en skärmdump från hans S.M.A.R.T bild.

Grundregel för felsökning: Bryt och begränsa.

Trädvy Permalänk
Medlem
Registrerad
Dec 2012
Skrivet av Veni:

13 osäkra sektorer(den är inte helt säker på att de är kassa) och jäkligt många läsfel. 93 uppstarter pga on/off. 4089 problem med att hitta rätt när den sökt. Men där är några saker jag inte kan tyda, bara 25h i drift? Är detta någon form av säkerhetskopieringsenhet?

Prova gärna att ladda ner SpeedFan och kör ut en skärmdump från hans S.M.A.R.T bild.

Det är enbart en externhårddisk som jag har haft bilder och lite andra viktiga filer i den. Har inte varit kopplat till datorn mycket då pga att något oförväntat skulle hända denna disk, och så händer det just det ;P lol
Här kommer Screenshoten

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Feb 2007

402 i felläsningsfrekvens
105 stycken start/stopp.
0 stycken omplacerade sektorer.
4094 i sökfelsfrekvens.
25h driftstid.
98 gånger har enheten startats om(kallstart).
33 grader celsius.
0 omkalibreringar.
13 sektorer avvaktar att bli flaggade som friska eller trasiga.
0 sektorer flaggade som trasiga.

Har Du något mer om Du bläddrar ner med draglisten?

Min slutsats är att den ser ut som en trött men hyfsad ny hårddisk, även om det kan låta konstigt. Den har problem att läsa och söka men annars har den inte definitivt hittat några trasiga sektorer. Sedan så finns där risk för att S.M.A.R.T variablarna fylls på fort om t.ex strömförsörjningen börjar spöka så att det ackumuleras fler incidenttillfällen i dessa variablar och då kan man bli lurad att tro att det är fel på plattorna och/eller magnethuvudena.

Sen att den skriver "error found in unknown place" är inget jag sett förrut. Kan vara att en okänd variabel har överskridit sitt maxvärde, men då skall den skrivas ut i listan med sitt s.k platsnummer i S.M.A.R.T listan när t.ex SpeedFan inte kan tolka positionen.

Det Du enklast kan göra för att kolla om det är någon komponent som blir för varm vid uppstart är just en kort nerkylning. Det andra är att prova med en annan nätdel. Och om ingen annan har några tips så är det sådana som bl.a Ibas som kan hjälpa dig att få ut informationen till en peng på runt max 10kkr för privatpersoner.

Grundregel för felsökning: Bryt och begränsa.

Trädvy Permalänk
Medlem
Registrerad
Dec 2012
Skrivet av Veni:

402 i felläsningsfrekvens
105 stycken start/stopp.
0 stycken omplacerade sektorer.
4094 i sökfelsfrekvens.
25h driftstid.
98 gånger har enheten startats om(kallstart).
33 grader celsius.
0 omkalibreringar.
13 sektorer avvaktar att bli flaggade som friska eller trasiga.
0 sektorer flaggade som trasiga.

Har Du något mer om Du bläddrar ner med draglisten?

Min slutsats är att den ser ut som en trött men hyfsad ny hårddisk, även om det kan låta konstigt. Den har problem att läsa och söka men annars har den inte definitivt hittat några trasiga sektorer. Sedan så finns där risk för att S.M.A.R.T variablarna fylls på fort om t.ex strömförsörjningen börjar spöka så att det ackumuleras fler incidenttillfällen i dessa variablar och då kan man bli lurad att tro att det är fel på plattorna och/eller magnethuvudena.

Sen att den skriver "error found in unknown place" är inget jag sett förrut. Kan vara att en okänd variabel har överskridit sitt maxvärde, men då skall den skrivas ut i listan med sitt s.k platsnummer i S.M.A.R.T listan när t.ex SpeedFan inte kan tolka positionen.

Det Du enklast kan göra för att kolla om det är någon komponent som blir för varm vid uppstart är just en kort nerkylning. Det andra är att prova med en annan nätdel. Och om ingen annan har några tips så är det sådana som bl.a Ibas som kan hjälpa dig att få ut informationen till en peng på runt max 10kkr för privatpersoner.

Har Du något mer om Du bläddrar ner med draglisten?

Följande två fanns med:
- UltraATA CRC Error Rate (value 200, Worst 200)
- Write Error Rate (value 100, Worst 253)

Gällande nedkyllning av hddn, skall jag ta ut själva hårddisken ur kabinett och lägga den i en Antistatpåse och sedan lämna den i frysen i ca 5-15 min eller är det något mer jag behöver göra utöver det?

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Feb 2007
Skrivet av ftp_zilla:

Har Du något mer om Du bläddrar ner med draglisten?

Följande två fanns med:
- UltraATA CRC Error Rate (value 200, Worst 200)
- Write Error Rate (value 100, Worst 253)

Gällande nedkyllning av hddn, skall jag ta ut själva hårddisken ur kabinett och lägga den i en Antistatpåse och sedan lämna den i frysen i ca 5-15 min eller är det något mer jag behöver göra utöver det?

Hårddisk plockas ut ur kabinetten. Läggs i frysen utan någon påse. Vi vill inte ha någon temperaturdifferens som en påse bidrar till en stund tills kylan har fått grepp om det hela. Läggs med kretskortssidan uppåt, dvs kretskortet skall ej komma i kontakt med din frys. Helt enkelt så skall man undvika att vidröra kretskortet eller någon komponent på kretskortet. Kolla att frysen ligger på -24 grader eller kallare. Frysen bör vara en sådan som inte har någon som helst isbildning trots -24 grader. Om det är en självavfrostande frys så kolla att den inte påbörjat sin avfrostning. Om det är en frys med luftfläkt, kolla att den pumpar ut luft in i själv frysdelen/livsmedelsdelen. Trissa annars upp frysen så att den börjar pumpa ut kallluft. Låt hårddisken nu kylas ner i frysen i cirka 15 minuter.

Sedan snabbt in i kabinetten(även om jag hade föredragit att starta upp den direkt i en HDD<-->USB docka då det är så jag gjort själv) och köra igång det hela med fåtal skruvar ifall processen behöver göras om med längre kyltid.

Förresten, vilka "Raw" värden hade dom värden Du postade senast?

Grundregel för felsökning: Bryt och begränsa.

Trädvy Permalänk
Medlem
Registrerad
Dec 2012
Skrivet av Veni:

Hårddisk plockas ut ur kabinetten. Läggs i frysen utan någon påse. Vi vill inte ha någon temperaturdifferens som en påse bidrar till en stund tills kylan har fått grepp om det hela. Läggs med kretskortssidan uppåt, dvs kretskortet skall ej komma i kontakt med din frys. Helt enkelt så skall man undvika att vidröra kretskortet eller någon komponent på kretskortet. Kolla att frysen ligger på -24 grader eller kallare. Frysen bör vara en sådan som inte har någon som helst isbildning trots -24 grader. Om det är en självavfrostande frys så kolla att den inte påbörjat sin avfrostning. Om det är en frys med luftfläkt, kolla att den pumpar ut luft in i själv frysdelen/livsmedelsdelen. Trissa annars upp frysen så att den börjar pumpa ut kallluft. Låt hårddisken nu kylas ner i frysen i cirka 15 minuter.

Sedan snabbt in i kabinetten(även om jag hade föredragit att starta upp den direkt i en HDD<-->USB docka då det är så jag gjort själv) och köra igång det hela med fåtal skruvar ifall processen behöver göras om med längre kyltid.

Förresten, vilka "Raw" värden hade dom värden Du postade senast?

Förresten, vilka "Raw" värden hade dom värden Du postade senast?

En massa nollor, inga andra siffror efter.

Skall testa med detta metod hoppas det löser problemet