Långsam överföring av stora filer intern HDD

Trädvy Permalänk
Medlem
Registrerad
Aug 2013

Långsam överföring av stora filer intern HDD

Förra veckan så installerade jag en SDD disk som startdisk i min dator. Då den tidigare startdisken (jag kallar den fortsättningsvis för E: ) innehöll en massa annat än bara OS och mina program, så kopierade jag det jag ville behålla till andra HDD. Under denna kopiering så var hastigheterna normala. Så, igår var allt kopierande klart och jag beslöt mig för att formatera E:. Jag satte igång en vanlig formatering, men då jag efter några timmar inte såg några som helst tecken i indikatorn att det gick framåt så blev jag ivrig och tryckte på avbryt. Då började det strula lite, med att datorn gick segt och så. Så jag startade om och snabbformaterade den istället.

Då trodde jag att allt var ok och jag började kopiera över mitt gamla material. Nu till det märkliga: alla filer under 500 Mb ungefär går i normal hastighet (80-90 MB/s) men när jag skall kopiera större filer så börjar det bra, men hastigheten sjunker snabbt till 70, 50, 20 och till sist till entaliga MB/s.
Jag har testat att koppla bort den då jag haft datorn avstängd, sätta på datorn igen. Stänga av den och koppla in den igen. Jag har felkontrollerat den fullständigt, inga fel. Kollat så att den har de senaste drivrutinerna. Kollat i BIOS om just E: har andra inställningar än de andra diskarna.

Det enda jag gjorde, som var lite förhastat kanske, var att jag kom på att jag hade glömt att i BIOS koppla över IDE till AHCI (tror jag att det var, jag följde en guide, minns inte exakt och kan inte kolla då E: håller på att formateras) innan jag installerade nytt OS på SSD. Så det gjorde jag innan jag formatterade E: för första gången igår. Detta resulterade i att datorn inte gick att starta och att Windows inte kunde reparera sig. Den gick tillbaka till en återställningspunkt. Så jag ställde tillbaka det i BIOS och sedan verkade allt ok. Kan det ha varit detta som ställde till det? Men varför är alla mina andra HDD ok?

Igår kväll så satte jag igång en normal formatering och nu har den stått i över 12 timmar och det finns inget i förloppsindikatorn som tyder på att den gjort några framsteg.

Nu är jag rådvill och vet inte vad jag mer kan göra än att vänta på formateringen. Jag har sökt och läst på olika fora, men hittar inte just detta problem. Det jag stöter på är mest att den är allmänt slö (PIO) och så. Bör jag avbryta formateringen och installera HD Tune och ta det därifrån?
Mitt system är Win 7, 64 bitar. HDD är en Samsung HD 204UI ATA Device (på 2 TB).

Hoppas att ngn kan hjälpa mig!

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Mar 2008

Ska inte ta så lång tid att formatera en hd.. måste ha hänt något med den.

Ta ur din ssd och pröva att formatera den med Windows 7 skivan istället.. kolla om det hjälper..

NZXT 810 Switch, Corsair AX860i, Maximus V Formula, I7 3770K ,Asus GTX 680, Corsair vengance 1866Mhz 32gb Ram, Samsung 850 Pro 256Gb, Samsung 840 basic 500Gb, WD 2Tb Caviar Green,120GB, Komplett vattenkylning

Trädvy Permalänk
Medlem
Registrerad
Aug 2013

Ok, tack! Testar det.

Trädvy Permalänk
Medlem
Registrerad
Okt 2011

Om en HDD plötsligt körs i PIO läge så tyder det på problem.
Windows byter nämligen till PIO om man har massor av fel med skrivningar/läsningar under en viss tid.
Det kan vara trasiga kablar, minnesfel, överklockning etc etc som ligger bakom.

En fullständig formattering på en stor hårddisk kan ta väldigt lång tid.
3 TB med en hastighet at 50MB/s blir ju över 16 timmar, men normalt så tar det runt 6 timmar.

Trädvy Permalänk
Medlem
Registrerad
Aug 2013

Nej, Akarr, ingen lycka där. Samma märkliga överföringshastigheter beroende på storleken på filen. Testar att ominstallera OS på SSD igen, denna gång i AHCi läge från början.

Trädvy Permalänk
Medlem
Registrerad
Aug 2013
Skrivet av Svensktiger:

Om en HDD plötsligt körs i PIO läge så tyder det på problem.
Windows byter nämligen till PIO om man har massor av fel med skrivningar/läsningar under en viss tid.
Det kan vara trasiga kablar, minnesfel, överklockning etc etc som ligger bakom.

En fullständig formattering på en stor hårddisk kan ta väldigt lång tid.
3 TB med en hastighet at 50MB/s blir ju över 16 timmar, men normalt så tar det runt 6 timmar.

Fast jag vet inte riktigt hur du menar. Menar du att Windows byter till PIO i bakgrunden? När jag kollat disken så har den ju inte rapporterat några fel alls, så det är konstigt om den plötsligt upptäcker fel. Vad det verkar ha att göra med är ju storleken på filerna jag försöker kopiera. Upp till 500 MB går bra, över det så sjunker hastigheten till sirap. Överklockning har jag inte gjort, jag ska ta och kolla minnet samt byta ut kabeln.

Trädvy Permalänk
Moderator
Plats
Sverige
Registrerad
Dec 2005

Det låter som om disken har trasiga sektorer och börjar sin långa eller ibland mycket korta vandring till de sällare jaktmarkerna.

Windows sätter ner interfacehastigheten om den anslutna enheten börjar få problem, ja. Ibland utan att meddela. Iofs var detta något jag upplevde med W98 och har inte sett mycket av det sedan dess, har väl lärt mig att ta bättre hand om diskarna helt enkelt.

Seghet kan bero på logiskt filsystemfel också, så kör några checkdisk efter varandra och se om det hjälper.

Synpunkter på min moderering? Hör av dig via PM eller mail.

W7, Intel 5820K, Asus X99-S, Crucial DDR4 2133MHz 32GB, Sapphire 290X Tri-X, Intel 730 SSD, WD Black+Green+HGST, Silverstone FT02, Corsair AX1200, Corsair K90, Logitech MX518, Eizo 2736w, Eaton 5115 UPS. Huawei P10 Plus
* Stolt paragrafryttare *

Trädvy Permalänk
Medlem
Registrerad
Aug 2013
Skrivet av MultiMan:

Det låter som om disken har trasiga sektorer och börjar sin långa eller ibland mycket korta vandring till de sällare jaktmarkerna.

Windows sätter ner interfacehastigheten om den anslutna enheten börjar få problem, ja. Ibland utan att meddela. Iofs var detta något jag upplevde med W98 och har inte sett mycket av det sedan dess, har väl lärt mig att ta bättre hand om diskarna helt enkelt.

Seghet kan bero på logiskt filsystemfel också, så kör några checkdisk efter varandra och se om det hjälper.

Ja, jag skall köra några checkdisks. Bra input.

Fast 10 minuter innan jag gjorde den första formateringen (den som jag avbröt) så funkade den perfekt. Så jag vet inte, fast någon gång så måste ju vandringen till de sälla jaktmarkerna börja. De kanske var under de 10 minuterna, vem vet?

Jag funderar på lågnivåformatering. Jag har inte gjort det sedan win95 eller -98. Är det ngn som har erfarenhet av det nuförtiden?

Trädvy Permalänk
Medlem
Registrerad
Aug 2013

Fixat, tror jag!

Jag skiftade datakabeln mellan 2 HDD och då plötsligt så blev det fart i den tidigare långsamma medan den HDD som fick den andres kabel blev långsam. Så jag stoppade i en ny kabel och då plötsligt så var allt som förr. Den tidigare långsamma gick att formatera ordentligt och den har inga skador. Hastigheten ligger på acceptabla 90-110 MB/s för stora ISO- och IMG-filer, alltså som innan.

Tack till er alla som som läste och kom med olika förslag!

Trädvy Permalänk
Medlem
Registrerad
Okt 2011

BTW så går det inte att lågformattera längre, och har inte gått på väääldigt länge
Diskarna har helt enkelt ett lager av mjukvara som ligger ivägen för direktåtkomst av läsarm/skrivhuvud.
Det är inte som förrut där OS'et styrde diskarna direkt.

Trädvy Permalänk
Moderator
Plats
Omnipresent
Registrerad
Okt 2004
Skrivet av Svensktiger:

BTW så går det inte att lågformattera längre, och har inte gått på väääldigt länge
Diskarna har helt enkelt ett lager av mjukvara som ligger ivägen för direktåtkomst av läsarm/skrivhuvud.
Det är inte som förrut där OS'et styrde diskarna direkt.

Inte ens med verktyg från tex Ultimate Boot Disc?

Gud är Död! - Nietzsche
Nietzsche är Död! - Gud

Trädvy Permalänk
Medlem
Registrerad
Okt 2011
Skrivet av Jalle64:

Inte ens med verktyg från tex Ultimate Boot Disc?

Nej.
Och inte heller från BIOS, på de moderkort som eventuell fortfarande har det.
Inte sen stenåldern, typ 80 talet

http://en.wikipedia.org/wiki/Disk_formatting#Low-level_format...