BSOD Och udda beteende från datorn. (LÖST)

Trädvy Permalänk
Medlem
Registrerad
Jan 2012

BSOD Och udda beteende från datorn. (LÖST)

Hej Sweclockers!
Såhär lyder historien: För ett par månader sedan kraschade min dåvarande Seagate 2TB Barracuda Hdd. Jag skaffade sedan en ny WD Green 2TB (WD20EARX). Hade ingen backup så fick installera om allt från scratch (man lär dig av sina misstag).

På senaste har jag haft problem med BSOD av typen
MEMORY_MANAGEMENT och
SYSTEM_SERVICE_EXCEPTION.
PFN_LIST_CORRUPT.
(Ibland IRQL_NOT_LESS_OR_EQUAL_TO)

Bild 1.
Bild 2.
Bild 3.

Detta har utförts än så länge:
SCANNOW command
Drivrutiner har uppdaterats.
Antivirusprogram har bytts ut (Löste ett nätverksrelaterat problem jag hade tidigare)
Minnen har testats(Memtest + Windows Memory Diagnostic)
Hårddisk har testats(Defrag + Hårdvarukontroll.)
Har testat att fysiskt placera om, byta kablar etc till komponenter i datorn.

Inget av ovanstående har gjort mig något visare angående problemet tyvärr.

Jag är ganska säker på att det är ett mjukvaruproblem/drivrutinproblem, men då det var ett par månader sedan jag installerade dessa på min dator är det extremt svårt för mig att felsöka vilken av dessa som skulle kunna krascha datorn. Det har varit tentaperiod och en del annan stress som har hindrat mig från att ta tag i problemet, vilket jag nu i efterhand får sota för.

Värt att nämna är följande:
BSOD sker nästan enbart vid startup (ca 10-20 sekunder efter att skrivbordet kommer fram)
BSOD sker vid ca 50% utav alla startups.
Programvaran tillhörandes moderkortets ljuddel "sounds" i windows har spökat en del, tar ibland fler minuter att få upp inställningarna vid behov. (anar därför att det har med någon drivrutin tillhörandes moderkortet att göra)

Specs:
Operativsystem: Microsoft Windows 7 Ultimate och (förhoppningsvis) senaste drivrutinerna.
Processor: Intel Core i5 2500K
Processorkylare: Thermalright MUX-120 OEM S1156/1155
Moderkort: Gigabyte Z68AP-D3
Minne: Corsair 8GB (2x4096MB) CL9 1600Mhz VENGEANCE LP
Grafikkort: PowerColor Radeon HD7950 3072MB PCS+
Hårddisk: WD Green 2TB WD20EARX
Nätaggregat:Corsair XFX Core Edition 650W 80+ Bronze
Övrig kylning: 1x140mm och 3x80mm.
Övriga komponenter: DTSOFT Virtual DVD Brännare

Min fråga till dig kära läsare är, vad kan jag mer göra?
Om det har med drivrutenerna till moderkortet att göra, hur gör jag för att identifiera boven? Eller ska jag bara avinstallera alla drivrutiner tillhörandes moderkortet och installera de på nytt?

Finns det något smidigt sätt att 'nollställa' sin maskin rent drivrutinsmässigt utan att gå miste om viktig data?

Jag är medveten om att jag kan behöva installera om windows, men då jag har runt 1TB data som jag vill spara och inget sätt att backup:a denna till ny installation är ser jag helst detta som en sista utväg, if all else fails.

Vad är mina alternativ kära läsare?(Jag ber om ursäkt för väggen med text)
Oändlig tacksam för svar!

LÖSNING: Ominstallation av OS (Costum installation, så att jag fick behålla den data jag ville.)

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Sep 2007

Ladda ned memtest och testa minnena.

Att bara uppdatera eller installera ovanpå nuvarande räcker ofta inte om felet är nånstans i Windows på disken. Ofta blir det korrupta/buggiga kvar i nån mapp.

Måste åtminstone avinstallera. Sen ta bort kvarlämnade mappar innan man försöker lägga in det igen. Så gör man oavsett om man misstänker eller har problem med drivrutiner, program spel osv.

Dock räcker det många gånger inte ens det för man får inte alltid bort allt och det finns oändligt mycket i Windows på disken som kan ställa till det. Ända sättet att utesluta Windows är att ta bort och installera om allt.

Ha bara 1 disk kopplad. Speciellt om du installera om Windows för att slippa fel och för att det kan vara en av dina andra diskar inne eller utanför datorn. Test byta båda kablarna och SATA port som SATA kabeln är kopplad till.

Trädvy Permalänk
Medlem
Registrerad
Jan 2012

Har varit i skolan hela dagen tills nu så kunde tyvärr inte svara.
Okej, har laddat ner memtest och körde det i en timme, verkar inte vara några som helst problem med minnena :S.
Finns det något effektivt sätt att identifiera/eliminera dess korrupta delar? Att installera om windows är någonting jag gärna undviker då jag har ca 1 TB data på den nya disken - det är klart att det kan komma till det, men isåfall är det en sista utväg. Några idéer på fler tester jag kan utföra för att vidare undersöka problemet?

När jag installerar drivrutiner ska jag alltså först ta bort den gamla drivrutinen? Även om den nya drivrutinen har en inbyggd funktion som tar bort den gamla? Ska testa att flytta om minnen fysiskt i datorn + flytta SATA kablar + Boota med enbart ena hårddisken + köra en 'ren' bootning. Återkommer med resultat + Screendump på eventuell BSOD.

Tack för förslagen panpo!

Trädvy Permalänk
Medlem
Plats
Norrköping
Registrerad
Jun 2008

När du körde memtest, hur länge körde du det?
Det borde köras ett par timmar innan man kan vara säker.
har du fler än ett ram minne så kan du ju plocka ur alla förutom en och pröva dig fram där.

Tror du att det är drivrutinproblem eller liknande så kan ju en formatering hjälpa dig, så att införskaffa en extern DISK för att spara viktig information osv på vore smart!

Trädvy Permalänk
Medlem
Registrerad
Jan 2012

Kört Memtest vid ett par olika tilfällen, kört på allt minne under tvåsiffrigt antal timmar om jag inte minns fel. Jag tror inte det är här problemet ligger.

Om jag ska formattera om så blir det nog så att jag ominstallerar allt och ser om samma problem uppstår, men som sagt, hade helst sett att det går att lösa på ett mer budgetanpassat vis om man säger så (inte pengarna till en extern i nuläget).

Jag går till sängs nu, svarar på inlägg så fort jag vaknar så om någon har någoting på hjärtat så är det bara att skriva ett svar.
Tack på förhand!

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Apr 2011
Skrivet av Daggmus:

Kört Memtest vid ett par olika tilfällen, kört på allt minne under tvåsiffrigt antal timmar om jag inte minns fel. Jag tror inte det är här problemet ligger.

Om jag ska formattera om så blir det nog så att jag ominstallerar allt och ser om samma problem uppstår, men som sagt, hade helst sett att det går att lösa på ett mer budgetanpassat vis om man säger så (inte pengarna till en extern i nuläget).

Jag går till sängs nu, svarar på inlägg så fort jag vaknar så om någon har någoting på hjärtat så är det bara att skriva ett svar.
Tack på förhand!

Har du uppdaterat bios till det senaste för ditt moderkort, har du klockat din processor och om du har det, har du använt dig utav moderkortets automatiska överklockningsfunktion eller har du bara ökat multipeln på turboläget?

Silverstone RV02-E "vit", Z97-DELUXE/USB 3.1, 4790K@4,4GHz, Corsair 1600MHz 16GB, Intel 730 480GB, GTX Titan X, Phillips BDM4350UC@3840x2160 ,HRT Music Streamer II, Sennheiser HDVA600, HD800.

Trädvy Permalänk
Medlem
Registrerad
Jan 2012

BIOS är Touch Bios, och jag tror inte att de uppdateras nuförtiden (uppdaterat 2012-02-12) På tillverkarens hemsida finns det en annan typ av BIOS (EUFI). Är det någonting jag vill uppdatera till? eller ska jag välja något annat?
http://www.gigabyte.se/products/product-page.aspx?pid=4015#bi... (rev 2.0).

Jag har inte överklockat någonting i min dator med motivering att jag ville hålla datorn stabil (ironiskt nog).

Värt att nämna: Min dator förlorar ibland kontakt med externa komponenter kan det verka som. Ibland då jag går ifrån datorn längre än säg 10 minuter så förlorar skärmarna helt kontakten med datorn och kan inte få tillbaks den förrän datorn startas om. Kan gissa på att detta är Moderkortrelaterat ev Grafikkort?

Ska testa att ominstallera ett par drivrutiner och se om det hjälper.

Trädvy Permalänk
Medlem
Registrerad
Jan 2012

Okej, Jag har ominstallerat Ljuddrivrutiner, uppdaterat BIOS. Ställde in BIOS på fail safe inställningar. Problemet återstår.
Jag har haft problem med drivrutiner till grafikkortet innan men dessa har jag uppdaterat kontinuerligt...
Några andra idéer?
Tacksam för alla svar!

Trädvy Permalänk
Medlem
Registrerad
Jan 2012

(Tråden slogs ihop med min gammla tråd med samma problem, därför är datum-märkningen lite off, ber om ursäkt för detta + double-posting.)

Trädvy Permalänk
Medlem
Plats
karlskrona
Registrerad
Maj 2008

Den sista bilden du lade upp av 3 visar på felkoden 0x3b vilket i överklockningssammanhang kan visa på för låg Vcore. Med anledning av det så kan man ju gissningsvis misstänka att PSU levererar ojämn spänning. Detta skulle även kunna förklara att diskarna pajat. Så det kunde ju varit intressant ifall du kunde låna en PSU från annan dator att testa med.

En annan sak som kan vara en möjlighet i sammanhanget är självklart att analysera dina dumpfiler från BSOD´s. Finns många olika prog för det men t.ex. Whocrashed fixar detta enkelt. Jämför sedan tidpunkterna för BSOD med loggfiler i windows/system och program för att spåra samband. Kan vara riktigt klurigt, men ibland ger det faktiskt en del tips som kan vara användbara.

Du kan bränna en Ubuntu live-cd som ett exempel och prova boota från den. All hårdvara som fungerar utan problem borde då monteras av Ubuntu, du bör även komma åt filer på disk. Fungerar det så backa upp och installera om, för då är det antagligen mjukvara som spökar. I många fall är en formatering av disk samt nyinstallation vägen att gå, hur jobbigt det än är.

Trädvy Permalänk
Medlem
Registrerad
Jan 2012

Enda nätagget jag har liggandes hemma är ett gammalt integrerat nätaggregat från min första dator "Black Thunder Miditower Black 400W ATX" Jag är inte helt säker på om 400W räcker för att köra min nuvarande maskin? Om ni/du tror att det fungerar ska jag definitivt sätta mig och mecka lite sen.

Har vid tidigare tillfälle försökt analysera dumpfiler och jämföra med eventloggen, dessvärre utan framsteg. Whocrashed säger i 9 fall av 10 att det med stor sannolikhet beror på felaktig mjukvara/drivrutin. Körde precis en instans av "chkdsk /f", vet inte om det hjälpte eller inte, datorn krascha ej vid startup, men det är 50/50 som sagt.

Har forskat lite i Ubuntu live-cd och det är nog ett enklare sätt att testa om problemet ligger i mjuk- eller hårdvara än att manuellt byta ut delarna. Det går väl bara till så att man bootar från en cd med Ubuntu på och väljer "Try Ubuntu without any change to your computer"? Och sen ser jag om allt fungerar som det ska under X antal startups? På så vis utesluter jag hårdvaruproblem. Vad ger Ubuntu för feedback vid systemkrasch (ekvivalent till BSOD)?

Trädvy Permalänk
Medlem
Registrerad
Jan 2012

Tänkte bara informera om att jag löste problemet genom att helt enkelt installera om mitt OS så att jag fick mina gamla filer i windows.old map, alla problem är nu lösta. Tack för all hjälp och tips, om inte annat så lärde jag mig ett och annat! Tackar!

Trädvy Permalänk
Medlem
Plats
karlskrona
Registrerad
Maj 2008
Skrivet av Daggmus:

Tänkte bara informera om att jag löste problemet genom att helt enkelt installera om mitt OS så att jag fick mina gamla filer i windows.old map, alla problem är nu lösta. Tack för all hjälp och tips, om inte annat så lärde jag mig ett och annat! Tackar!

Har missat att du svarat tidigare, använd gärna citeraknappen om du förväntar dig ett svar. Då blir den du citerar notifierad med ett + tecken vid ordet citat under inloggningsnamnet.

Men det var ju bra att det löste sig för dig!