Trädvy Permalänk
Medlem
Registrerad
Nov 2013

Asus RT-N56u mediaserverproblem!

Hej!

Jag prövade att använda funktionen media server på min router, vilket fungerade dugligt på alla mina enheter (ps3, mobil, surfplatta). Dock kunde det ibland hända att jag la upp en fil på hårddisken som agerade media server, men filen syntes inte då jag skulle spela upp den från mina enheter. Jag kontaktade ASUS, fick svaret "så fungerar vår firmware, vet inte när det fixas. Kolla på Custom Firmware istället". Så jag gjorde det. Men jag får det helt enkelt inte till att fungera med de mediaservrar(Ushare visar filerna, men den fastnar i laddningsstadiet. minidlna kommer inte ens upp som mediaserver och jag kan vad jag förstått inte lägga upp mina filer som jag vill se med Xupnpd.) som fanns tillgängliga till Custom Firmware versionen! (denna är det: https://code.google.com/p/rt-n56u/)

Jag är enormt less, jag vet inte varför det inte fungerar på något sätt, så det jag söker är ifall någon har råkat ut för samma problem som mig eller sitter i samma sits som jag gör, och skulle denna person kanske ha någon möjlighet att hjälpa mig med olika tillvägagångssätt?

Tack.

Trädvy Permalänk
Medlem
Registrerad
Nov 2013

Det är ingen annan som har problem med mediaserverlösningen på deras ASSU Rt-N56u?

Trädvy Permalänk
Medlem
Registrerad
Nov 2013

Tänkte passa på att skriva i denna tråd så att de som stöter på samma problem som jag gjort kanske får lite hjälp:

Det jag har gjort är att använda filsystemet Ext3 på min hårddisk, kopplad till min n56u router som använder custom firmware (länk längre upp).

Jag tog bort alla tidigare partitioner, lade in Ext3 och kopplade in hårddisken i routern. Sedan gick jag in på Advanced Settings > USB Application.
Jag valde "yes" på "Auto Check Filesystem on USB Storage Plug?" och "Optware Legacy" på "Allow Run Optware?". Jag aktiverade "Enable FTP Server?" och "Enable UPnP/DLNA Media Server?", där jag valde bort media files source path (av en enda anledning: Jag fattade inte varför jag skulle behöva den när jag ändå bara använder "browse folders"). Jag valde apply och detta gjorde att min router gick att se via UPnP.

För att föra över filerna till hårddisken över nätverket gick jag in i "Dator" (i Windows alltså), högerklickade, "lägg till nätverksplats" och skrev sedan in min routers ftp (finns guider på internet om hur du gör detta, så googla lite). Därefter är det bara att copypastea.

Har du problem med att routern inte kan mounta hårddisken? "Auto Check Filesystem on USB Storage Plug?" valt med "yes" fixade detta för mig efter att jag dragit ut och satt in USB-sladden till hårddisken ett antal ggr. Har du fortfarande problem att mounta? Rensa alla partitioner på hårddisken och pröva Ext2, det ska vara stöd för det också till denna router. Fungerar inte det? Hell, kolla denna sida lite grann: https://code.google.com/p/rt-n56u/wiki/HowToConfigureOptware (Scrolla ner lite så ser du "USB formatting" instruktioner).

Tror det var allt jag gjorde för att få det att fungera, men det är bara att pröva sig fram. Jag lägger in mitt "issue" från Custom Firmware-sidan här så att ni kan se ifall jag uppdaterar framtida problem eller om de löser det på ett bättre sätt: https://code.google.com/p/rt-n56u/issues/detail?id=1056&thank...

Har ni frågor så kan ni kanske skriva här, får vi se om jag eller någon annan kan svara.

Tjenis.

Trädvy Permalänk
Medlem
Registrerad
Apr 2005

Hej!

Jag har samma problem som du beskriver i din första post med min RT-N56U. Otroligt irriterande problem som förstör själva funktionen. Jag måste ladda om hela databasen varje gång jag lagt till material som det är nu. Tidigare hade jag en datorn kopplad till TVän och använde då inte DLNA utan spelade filerna direkt från hårddisken bara. Nu har jag dock en Smart TV som kräver DLNA för att kunna strömma media vilket gör att jag är väldigt besviken på funktionaliteten i routern. Värdelöst att behöva bygga om databasen vid varje uppdatering av mediabiblioteket!!

Vill helst inte hålla på med custom firmware då jag inte vet om garantin gäller då m.m. Har du något tips så får du gärna peka mig i rätt riktning iaf. Som det är nu så kommer detta inte att fungera i längden!

R

Trädvy Permalänk
Medlem
Registrerad
Nov 2013

Hej!

Jag hittade ingen lösning utöver att gå till Custom Firmware. Asus svarar endast med att man får vänta på deras uppdateringar, det finns inget annat man kan göra om man inte vill gå till Firmware.

Ledsen att jag inte kan vara till någon bättre hjälp.

Trädvy Permalänk
Medlem
Registrerad
Apr 2005

Och då körde du på den firmware som du länkar till i ditt första inlägg? Körde du DLNA builden då eller? Hur fungerar den mjukvaran? Enkel att installera? Har kommit fram till att jag nog måste installera en custom firmware iaf. Frågan är vilken...

R

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Jan 2010
Skrivet av DJHogi:

Och då körde du på den firmware som du länkar till i ditt första inlägg? Körde du DLNA builden då eller? Hur fungerar den mjukvaran? Enkel att installera? Har kommit fram till att jag nog måste installera en custom firmware iaf. Frågan är vilken...

R

Testa du med Padavans fw. Alla versionerna som är tillgängliga där är ju mycket nyare än alla Fakefaxers tester från i höstas.

Trädvy Permalänk
Medlem
Registrerad
Apr 2005

Fast de han länkar till är väl ju Padavans firmware? Dock i senare version. Skulle ju egentligen vilja ha bekräftat att DLNA-server funktionerna fungerar som de ska innan jag slänger in ny mjukvara som tar bort all garanti.

R

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Jan 2010
Skrivet av DJHogi:

Fast de han länkar till är väl ju Padavans firmware? Dock i senare version. Skulle ju egentligen vilja ha bekräftat att DLNA-server funktionerna fungerar som de ska innan jag slänger in ny mjukvara som tar bort all garanti.

R


Peta du bara tillbaka original fw om du får problem.
Svårare än så är det inte.

Trädvy Permalänk
Medlem
Registrerad
Apr 2005
Skrivet av NoSubstitute:


Peta du bara tillbaka original fw om du får problem.
Svårare än så är det inte.

Oj, iofs. Men är orolig att något går fel och att jag brickar routern eller så. Ska se om jag får lite tid över att testa slänga in den nya mjukvaran i helgen.

Trädvy Permalänk
Medlem
Registrerad
Nov 2013

Ser nu att jag är en mycket dålig TS. DLNA fungerar inte till ps3, jag får DLNA 2104 protocol error, men det verkar inte riktigt vara bara något jag upplever utan rätt vanligt. Allt är lätt att installera och vad jag förstått är det inte så troligt att man brickar routern med dessa builds. Sen far inte garantin vad jag vet och det är bara att lägga in original om man vill det sen igen. Det är helt dött på Asus egna uppdateringsfront, så custom-grejen är bästa kortet om man vill utnyttja denna router, tyvärr.

Trädvy Permalänk
Medlem
Registrerad
Maj 2012

Hej folk,

Fungerar inte denna router som media server om man har sin dator avstängd?
Jag hade förhoppningar om att min router skulle kunna dela ut de filer jag har på HDD:n utan att behöva ha datorn igång.

Jag streamar till en Philips-tv och det funkar fint när datorn är igång, men ej när den är svstängd.

CoolerMaster N400 - Intel Core i5-4670K 3.4Ghz - Gigabyte Z87-HD3 - 2x 4 096 MB Kingston DDR3 @ 800 MHz - Gigabyte Radeon R9 280X WF OC - CoolerMaster 750W

Trädvy Permalänk
Medlem
Registrerad
Apr 2005

Håller på och testar massa nu med Padavan's firmware. Installerat och klart är det och tycker nog att WiFi är mer stabilt än innan. Dock har jag inte fått ordning på DLNA-funktionerna än. Min hårddisk slutar inte att spinna. Spelar ingen roll vad jag sätter HDD Spindown Timeout till för läge. Jag ser att det är något som använder disken i.o.m att lampan på den blinkar. Ser dock inte vad det är när jag kollar i loggen för routern.

Några tips eller länkar som kan peka mig i rätt riktning vore kanon!

EDIT:

Den verkar numera spinna ner. Har ställt HDD Spindown till 15 min, men den håller igång längre än så för mig. Men så länge den faktiskt slutar snurra så är det okej. Nu ska jag bara se om miniDLNA fungerar som den ska och lägger till filer i databasen utan att bygga om hela.

R

Trädvy Permalänk
Medlem
Registrerad
Nov 2013
Skrivet av bogani:

Hej folk,

Fungerar inte denna router som media server om man har sin dator avstängd?
Jag hade förhoppningar om att min router skulle kunna dela ut de filer jag har på HDD:n utan att behöva ha datorn igång.

Jag streamar till en Philips-tv och det funkar fint när datorn är igång, men ej när den är svstängd.

Den kan helt klart fungera som mediaserver även om datorn är avstängd, det är dock viktigt att mediaformatet går att spela upp på tvn. Exempelvis kan jag inte spela upp MKV på PS3an via routern (när jag väl kunde använda PS3an tillsammans med routern).

Dock tycker jag att det är viktigt att använda Padavans firmware. Det är inte jobbigt alls att installera, de har gjort det väldigt lätt och ASUS sa till och med till mig att använda custom firmware när deras inte fungerade, vilket säger en hel del om vilken ambition ASUS har på denna router.

Skrivet av DJHogi:

Håller på och testar massa nu med Padavan's firmware. Installerat och klart är det och tycker nog att WiFi är mer stabilt än innan. Dock har jag inte fått ordning på DLNA-funktionerna än. Min hårddisk slutar inte att spinna. Spelar ingen roll vad jag sätter HDD Spindown Timeout till för läge. Jag ser att det är något som använder disken i.o.m att lampan på den blinkar. Ser dock inte vad det är när jag kollar i loggen för routern.

Några tips eller länkar som kan peka mig i rätt riktning vore kanon!

EDIT:

Den verkar numera spinna ner. Har ställt HDD Spindown till 15 min, men den håller igång längre än så för mig. Men så länge den faktiskt slutar snurra så är det okej. Nu ska jag bara se om miniDLNA fungerar som den ska och lägger till filer i databasen utan att bygga om hela.

R

Jag vet inte varför din hårddisk spinner ut, men jag hade samma problem med en annan hårddisk jag hade. Vilken modell är det på din? Jag har en Seagate nu som det fungerar bra med, men det fungerade inte med en HP för mig då den aldrig gick ner i varvtal.

Trädvy Permalänk
Medlem
Registrerad
Apr 2005
Skrivet av Fakefaxer:

Den kan helt klart fungera som mediaserver även om datorn är avstängd, det är dock viktigt att mediaformatet går att spela upp på tvn. Exempelvis kan jag inte spela upp MKV på PS3an via routern (när jag väl kunde använda PS3an tillsammans med routern).

Dock tycker jag att det är viktigt att använda Padavans firmware. Det är inte jobbigt alls att installera, de har gjort det väldigt lätt och ASUS sa till och med till mig att använda custom firmware när deras inte fungerade, vilket säger en hel del om vilken ambition ASUS har på denna router.

Jag vet inte varför din hårddisk spinner ut, men jag hade samma problem med en annan hårddisk jag hade. Vilken modell är det på din? Jag har en Seagate nu som det fungerar bra med, men det fungerade inte med en HP för mig då den aldrig gick ner i varvtal.

Ledsen för sent svar! Har problem igen. Hårddisken är en WD MyBook 1TB från 2008. Kanske är disken som gör att det spökar börjar jag tro. Installerade senaste mjukvaran (version 3.0.3.8-080) igår då den innan inte lägre visade hårddisken som media server, utan enbart som en nätverksenhet under Nätverk i utforskaren. Har varit svajigt att föra över filer till disken också på sistone. Igår kopplade jag in den i datorns USB-port och fick efter ett tag ett felmeddelande om att det fanns filer som inte var bra på disken och att den därmed kanske inte kunde fungera som den ska. Gjorde inget åt det då, men funderar på att formatera det till EXT3 istället för NTFS som det är nu. Bara för att se om det hjälper. Disken har inte så mycket på sig än då den blev mystiskt formaterad när jag kopplade in den i routern efter först mjukvaruupdateringen jag gjorde till custom firmware. Kanske borde försöka kontrollera disken i windows. Och sen göra ett test med En större USB-sticka som medium för lagring för att se om det fungerar bättre då.

Har någon förslag på en lösning så kom gärna med förslag!

R

Trädvy Permalänk
Medlem
Registrerad
Nov 2013
Skrivet av DJHogi:

Ledsen för sent svar! Har problem igen. Hårddisken är en WD MyBook 1TB från 2008. Kanske är disken som gör att det spökar börjar jag tro. Installerade senaste mjukvaran (version 3.0.3.8-080) igår då den innan inte lägre visade hårddisken som media server, utan enbart som en nätverksenhet under Nätverk i utforskaren. Har varit svajigt att föra över filer till disken också på sistone. Igår kopplade jag in den i datorns USB-port och fick efter ett tag ett felmeddelande om att det fanns filer som inte var bra på disken och att den därmed kanske inte kunde fungera som den ska. Gjorde inget åt det då, men funderar på att formatera det till EXT3 istället för NTFS som det är nu. Bara för att se om det hjälper. Disken har inte så mycket på sig än då den blev mystiskt formaterad när jag kopplade in den i routern efter först mjukvaruupdateringen jag gjorde till custom firmware. Kanske borde försöka kontrollera disken i windows. Och sen göra ett test med En större USB-sticka som medium för lagring för att se om det fungerar bättre då.

Har någon förslag på en lösning så kom gärna med förslag!

R

Det absolut bästa är att formatera till EXT2, EXT3 eller EXT4 som det står i instruktionerna, detta för att det inte verkar vara stabilt med NTFS. Det kan vara det som är ditt problem. Jag använde "MiniTool Partition Wizard Home Edition", vilken är bra. kör på den, låt det ta sin tid och sen borde det vara rätt löst tror jag. Skriv här igen om du har problem!

Trädvy Permalänk
Medlem
Registrerad
Apr 2005
Skrivet av Fakefaxer:

Det absolut bästa är att formatera till EXT2, EXT3 eller EXT4 som det står i instruktionerna, detta för att det inte verkar vara stabilt med NTFS. Det kan vara det som är ditt problem. Jag använde "MiniTool Partition Wizard Home Edition", vilken är bra. kör på den, låt det ta sin tid och sen borde det vara rätt löst tror jag. Skriv här igen om du har problem!

Ironiskt nog fick jag det att fungera igår igen när jag fibblade lite med inställningarna i routern efter lite tips i projektforumet. Får se hur länge det fungerar denna gång. Annars ska jag följa ditt råd med formateringen! Tankade hem något program som skulle kunna göra om til olika EXT-format iaf.

R

Trädvy Permalänk
Medlem
Registrerad
Nov 2013
Skrivet av DJHogi:

Ironiskt nog fick jag det att fungera igår igen när jag fibblade lite med inställningarna i routern efter lite tips i projektforumet. Får se hur länge det fungerar denna gång. Annars ska jag följa ditt råd med formateringen! Tankade hem något program som skulle kunna göra om til olika EXT-format iaf.

R

Då hoppas vi på det bästa!

Jag har för övrigt för andra läsare gett upp att få denna router att fungera med ps3an gällande protocol error 2104 och köpt en Raspberry Pi istället, ska se om det kan fixa det som jag vill ha det.

Trädvy Permalänk
Medlem
Registrerad
Nov 2013

Jahapp, då var vi tillbaka i detta igen:

- Jag kan inte hitta filer jag lagt in på hårddisken via UPNP, men via FTP ser den alla filer.

- När jag skapar mappar så hoppar de runt lite överallt, om jag till exempel försöker skapa en undermapp till "serier" hamnar den ibland bredvid "serier" istället.

Får försöka arbeta på detta, kom gärna med tips om ni vet något!

Trädvy Permalänk
Medlem
Plats
Leksand
Registrerad
Maj 2009

Hej!

Även jag har problem med detta. Fick hem en 4TB extern disk av märket WD idag. Och vill köra den så jag har åtkomst på den när jag inte är hemma.

Men pluggar jag in den i routern och ska välja AIcloud eller vilket annat tillägg som helst får jag "Ingen USB-Enhet funnen"

Kan det vara så att det inte fungerar med NTFS?

Bara för att jag är snäll idag får ni fraktfritt på Inet.=) https://www.inet.se/artikel/6101343/

Asus G75VX - Samsung Pro 256 GB - ASUS G751JY ASUS ROG Strix GL702VM

Trädvy Permalänk
Medlem
Registrerad
Nov 2013
Skrivet av Dassh:

Hej!

Även jag har problem med detta. Fick hem en 4TB extern disk av märket WD idag. Och vill köra den så jag har åtkomst på den när jag inte är hemma.

Men pluggar jag in den i routern och ska välja AIcloud eller vilket annat tillägg som helst får jag "Ingen USB-Enhet funnen"

Kan det vara så att det inte fungerar med NTFS?

Tjena! Jag håller rätt dålig koll på den här tråden numer, därför jag är seg att svara. Det fungerar riktigt dåligt med NTFS, så jag rekommenderar att du byter till EXT4, det är det jag kör min USB på nu (i väntan på att en hårddisk ska uppenbara sig)!

Hoppas det hjälpte!

Trädvy Permalänk
Medlem
Plats
Leksand
Registrerad
Maj 2009
Skrivet av Fakefaxer:

Tjena! Jag håller rätt dålig koll på den här tråden numer, därför jag är seg att svara. Det fungerar riktigt dåligt med NTFS, så jag rekommenderar att du byter till EXT4, det är det jag kör min USB på nu (i väntan på att en hårddisk ska uppenbara sig)!

Hoppas det hjälpte!

Tack för svar iallafall.

Nej jag har bestämt mig för att sälja disken och köpa in en mindre som jag vet ska fungera.

Bara för att jag är snäll idag får ni fraktfritt på Inet.=) https://www.inet.se/artikel/6101343/

Asus G75VX - Samsung Pro 256 GB - ASUS G751JY ASUS ROG Strix GL702VM