Problem med defragmentering [Win 8.1]

Trädvy Permalänk
Medlem
Registrerad
Jul 2011

Problem med defragmentering [Win 8.1]

Hej,
Jag tänkte defragmentera en disk och det blir såhär:
klickar på analyse och det står "Needs optimisation (21% defragmented)". Jag klickar på optimise och de står "Pass 1: 0% relocated och efter det avbryts det och kommer upp Needs optimisation (21% defragmented).

Hur ska jag fixa detta?

sweclockers prestandaindex

Kan ibland låta ofrivilligt otrevlig.

Trädvy Permalänk
Medlem
Registrerad
Maj 2012

Kanske en dum fråga men är det en vanlig HDD eller en SSD du försöker defragmentera?

Trädvy Permalänk
Medlem
Plats
Sthlm
Registrerad
Apr 2004

Hur mycket ledigt utrymme har du på hårddisken?

Trädvy Permalänk
Medlem
Registrerad
Jul 2011
Skrivet av Pake:

Kanske en dum fråga men är det en vanlig HDD eller en SSD du försöker defragmentera?

En HDD.

Skrivet av henkiii:

Hur mycket ledigt utrymme har du på hårddisken?

648 GB utav 931 GB

Tack för era svar

sweclockers prestandaindex

Kan ibland låta ofrivilligt otrevlig.

Trädvy Permalänk
Medlem
Plats
Sthlm
Registrerad
Apr 2004

Du kan alltid börja med att köra en fullständig scandisk, och sedan prova defrag igen.

Om detta inte fungerar kan du starta defrag med utökad loggning för att se vad den klagar på.
1) Starta en Command Prompt/Kommandotolken ( cmd.exe) som Administratör.
2) Skriv defrag.exe D: /U /V
D: är ditt enhetsbokstav
/U visar progressmätare
/V visar utökad loggning.

Trädvy Permalänk
Medlem
Registrerad
Jul 2011
Skrivet av henkiii:

Du kan alltid börja med att köra en fullständig scandisk, och sedan prova defrag igen.

Om detta inte fungerar kan du starta defrag med utökad loggning för att se vad den klagar på.
1) Starta en Command Prompt/Kommandotolken ( cmd.exe) som Administratör.
2) Skriv defrag.exe D: /U /V
D: är ditt enhetsbokstav
/U visar progressmätare
/V visar utökad loggning.

Steg ett fungerade inte så körde steg 2.
The parameter is incorrect. <0x80070057>
Efter att googlat lite så verkar folk få detta problemet främst med windows 7 och sen med installeringar utav windows 8 :/

sweclockers prestandaindex

Kan ibland låta ofrivilligt otrevlig.

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jun 2010

För att starta en kommandoprompt som admin så finns det en genväg i Win+X menyn (eller högerklick på start).

Sen ska man väl inte behöva defragmentera längre, Windows ska väl sköta det själv på senare versioner, eller är jag helt ute och cyklar?

Trädvy Permalänk
Medlem
Registrerad
Jul 2011

Trodde det var fixat genom att följa http://support.microsoft.com/kb/982736/en denna guiden. Icke...

Edit: Antar i steg ett att jag både ska ha , och .? Testar med bara . och återkommer!

Samma problem återstår. Håller disken på att ge upp? Den har ett par åt på nacken och använts flitigt så vore väl inte så konstigt i så fall.

sweclockers prestandaindex

Kan ibland låta ofrivilligt otrevlig.

Trädvy Permalänk
Medlem
Plats
Sthlm
Registrerad
Apr 2004

Är det när du skriver defrag som du får "the parameter is incorrect"?

Trädvy Permalänk
Medlem
Registrerad
Jul 2011
Skrivet av henkiii:

Är det när du skriver defrag som du får "the parameter is incorrect"?

Ursäkta att jag dröjde med svaret!
Ja, precis. Såhär ser det ut: BILD

sweclockers prestandaindex

Kan ibland låta ofrivilligt otrevlig.

Trädvy Permalänk
Medlem
Registrerad
Maj 2012

Du har skrollat ner i fönstret så man ser inte vad du har skrivit för att starta defrag.