Komma åt FTP(S) utifrån? Skumma redirections av portar.

Trädvy Permalänk
Medlem
Registrerad
Jun 2011

Komma åt FTP(S) utifrån? Skumma redirections av portar.

Tänkte göra om min SSH-server (SFTP) till en regelrätt FTP server med SSL-kryptering istället då det är ett snabbare protokoll och jag har fått ett behov av ett mer frekvent användande av FTP:n. Har efter några finjusteringar fått servern att fungera precis som jag vill lokalt, och kan ansluta antingen via standardporten via implict ftps eller en tilldelad port via explict ftpes, problemet är att när jag istället försöker ansluta över internet istället så kommer jag inte åt servern alls, ser i loggarna att andra random portar försöker användas, alternativt lyckas anslutningen men jag kan inte lista innehållet. Både standardporten samt implict-porten är forwardade i mina brandväggar och allt är frid och fröjd den vägen.

Någon som har någon ide?

EDIT: Fixade problemet med att inte komma åt servern alls genom att begränsa passive-portarna till en portrange om 3 portar som jag öppnat i brandväggarna, nu återstår bara det skumma problemet till varför jag kan ansluta till servern, men inte lista innehållet som jag kan om jag ansluter via localhost.

Trädvy Permalänk
Moderator
Registrerad
Aug 2007

En ftp behöver flera portar öppna. Normalt kopplar den upp på port 21 för att initiera överföringen, så port 21 måste alltid vara öppen mot servern. Vad som sedan händer beror på hur du har konfigurerat server respektive klient. Det bästa om man kör en server är att tillåta den att vara passiv, vilket betyder att klienten öppnar alla portar, vilket i sin tur betyder att klienten kan vara bakom en brandvägg osv. Men det betyder också att du måste vara mycket tydlig med vilka portar du använder och då i detta fallet har forwardat. Dessutom måste servern ofta veta ditt externa ip.

Listan med innehållet skickas som en dataström. Eftersom du verkar ha satt upp en portrange som servern kan använda för data och forwardat dessa så skulle jag tro att du har missat att ange ditt externa ip i serverinställningarna.

Använd gilla för att markera nyttiga inlägg!

Trädvy Permalänk
Medlem
Registrerad
Jun 2011

Tackar för svar, blev dock tyvärr inte klokare av det. Glömde skriva det i startinlägget men det är alltså passive mode jag använder mig av (därav portrangen mellan 3 portar), alltså både standardporten (21) och mina passiva portar i rangen är forwardade och fungerar som de skall. Även provat avaktivera mjukvarubrandväggen helt då jag hört folk som haft svårigheter att få mjukvarubrandväggar att lira fint med FTP, dock inga framsteg på den fronten heller. Tror dock inte problemet ligger i portarna eller brandväggen faktiskt, jag lyckas ansluta till servern, den hittar mitt externa IP och visar dokumentroten, som dock är tom. Byter jag ut mitt externa IP mot localhost upprepas exakt samma procedur med skillnaden att servern visar en dokumentrot som är full av de filer jag delat ut.

Trädvy Permalänk
Moderator
Registrerad
Aug 2007

Jaha. Sitter du på ditt interna nät och försöker koppla upp till ditt externa IP? Det har jag aldrig fått att funka med ftp. Men det kan också vara beroende på vilken router du har om det funkar eller ej. Jag rekommenderar dig att koppla upp via din mobiltelefon eller liknande för att testa så att du kommer helt utifrån.

Men jag undrar om du läste vad jag skrev. Listan över innehållet i dokumentroten skickas som en dataström. Dataströmmarna använder de passiva portarna som du satt upp. Det är den delen som inte funkar. Min ftpserver krävde att man angav sitt externa ipnr. Har du gjort detta? Vilken ftpserver använder du?

Förresten kom jag på en sak. Det skickas ett antal kommandon över port 21 mellan server och klient. Dessa brukar man kunna se i sin klient. Har du kollat om det som skickas när det gäller IPnr och portar verkar vettigt?

Använd gilla för att markera nyttiga inlägg!

Trädvy Permalänk
Medlem
Registrerad
Jun 2011

Det borde funka utan problem då jag kört på denna metoden för servern då den var inställd på ssh/sftp istället. Har angett mitt externa IP i settings, när jag körde ssh-server räckte det att ange en domän som är kopplad mot mitt ip men med ftps så har jag istället angett IP:t rakt av utan krusiduller.

Efter att jag begränsade portrangen till endast ett fåtal portar som jag har sett till att forwarda hela vägen så verkar det stämma, användaridentifiering, lösenord, handshake och directory listening funkar som de skall enligt loggen, och jag är alltså inloggad på ftp-servern, men finns inget i dokumentroten.

Trädvy Permalänk
Moderator
Registrerad
Aug 2007
Skrivet av Tuborgarn:

Det borde funka utan problem då jag kört på denna metoden för servern då den var inställd på ssh/sftp istället. Har angett mitt externa IP i settings, när jag körde ssh-server räckte det att ange en domän som är kopplad mot mitt ip men med ftps så har jag istället angett IP:t rakt av utan krusiduller.

Efter att jag begränsade portrangen till endast ett fåtal portar som jag har sett till att forwarda hela vägen så verkar det stämma, användaridentifiering, lösenord, handshake och directory listening funkar som de skall enligt loggen, och jag är alltså inloggad på ftp-servern, men finns inget i dokumentroten.

Då är det din server som inte funkar som den ska.

Använd gilla för att markera nyttiga inlägg!