Diablo 3 & sli? fps spikes...

Trädvy Permalänk
Medlem
Registrerad
Aug 2011

Diablo 3 & sli? fps spikes...

var inte säker om jag kunde lägga tråden här eller inte, men då problemet är specifikt för diablo 3 och sli så hoppas jag att någon annan här kanske har lite god nyheter åt mig.

Som det är nu så får jag fps drops imellanåt med SLI aktiverat på min nya dator, (2x 780 lightning)
det fungerar bra i andra spel, när det händer så spikar GPU usage till 100% på GPU2, sen tillbaks till normalt igen. upplevde samma sak i WoW, men gav upp där...

visst går där att spela med 1 kort aktiverat, men har man 2, vill man ju nytta båda..

någon med tips?

New:| 4930k 6 core @ 4.4ghz | 16gb corsair platinum 1866mhz | Asus X79 Deluxe | sli 780 lightning | Cooler master v1000w+ | Corsair 540 air |

old:| i7 2600k @ 4.5ghz | 16gb Corsair Vengeance | MSI-P67A-GD65 | MSI GTX680 Lightning | Corsair TX650 | Fractal Design R3 |

Trädvy Permalänk
Medlem
Registrerad
Jun 2011

Vad handlar det om för FPS? Är det konstant att den går upp och ner eller handlar det om ett specifikt ställe i spelet? T.ex så i Act3 i Rakkis så är det nästan oundvikligt att du droppar, brukar själv ligga på stabila 120-140FPS men i Rakkis droppar jag till 10-15.

Vad ligger GPU2 på annars? Det normala borde vara 100%

Guide för felsökning av Bluescreen! (tack till m4goo2 som gjort denna)
Chassi: Antec Twelve Hundred | Moderkort: Asus z170-A | CPU: I7 6700K @ 4.7GHz | Corsair H80 | RAM-minnen: Corsair Vengeance LPX 16GB@2666MHz | GPU: MSI NVIDIA GTX 1070 Gaming G8 | Nätagg: EVGA SuperNova G2 750w | HDD: Samsung 850 EVO 500GB, OCZ Vertex3 120GB, 4x Seagate Barracuda Green 2TB, 1x Western Digital My Book 3TB, Western Digital My Book 4TB.

Trädvy Permalänk
Medlem
Plats
Helsingborg
Registrerad
Feb 2011

Jag får inte ens igång xfire på Diablo, kör fullscreen. Men det andra kortet kickar inte igång. :/

Skärm: QNIX QX2710 2560x1440p@ 120hz CHASSI: Fractal Design R4 MOBO: MSI Z87 G-45 CPU: Inte Core i5 4670k @ 4.4ghz MINNE: HyperX 8gb 1600 mhz CPU COOLER: Corsair A50 GPU: 2x R9 290x Sapphire/Gigabyte LAGRING: Kingston 120 SSD Samsung 500gb

"U can't ride two horses with one ass"

Trädvy Permalänk
Avstängd
Registrerad
Aug 2012
Skrivet av LaFace:

var inte säker om jag kunde lägga tråden här eller inte, men då problemet är specifikt för diablo 3 och sli så hoppas jag att någon annan här kanske har lite god nyheter åt mig.

Som det är nu så får jag fps drops imellanåt med SLI aktiverat på min nya dator, (2x 780 lightning)
det fungerar bra i andra spel, när det händer så spikar GPU usage till 100% på GPU2, sen tillbaks till normalt igen. upplevde samma sak i WoW, men gav upp där...

visst går där att spela med 1 kort aktiverat, men har man 2, vill man ju nytta båda..

någon med tips?

Det finns inget officiellt SLI stöd i Diablo 3 (eller cross fire för den delen). Det SLI "stöd" som Nvidia fixat för Diablo 3 med sina drivers är ett ful-hack som fungerar mycket dåligt eftersom spelet i sig inte har stöd för det.

https://us.battle.net/support/en/article/diablo-iii-supported...

Samma sak gäller WoW, finns inget SLI/Crossfire stöd för WoW.

Trädvy Permalänk
Medlem
Plats
Trollhättan
Registrerad
Sep 2007

Jag hade samma problem vid release av Diablo III.
Då hade jag 2x 560ti, jag hade konstant 120 fps men det upplevdes väldigt ryckigt.

För mig så hjälpte det konstigt nog att köra windowed fullscreen och tabba ut och in ett par gånger. Tyvärr fann jag aldrig någon permanent lösning på problemet innan jag slutade spela.

Trädvy Permalänk
Medlem
Plats
Mitten av Skåne
Registrerad
Dec 2004

Innan 2.0.1-patchen låg jag på 199 fps hela tiden, nu efter ligger jag runt 80-90.. men har inte orkat kolla mer på det, då det funkar bra ändå
Förutom A3 Rakkis.

Om jag skitet pengar, hade jag suttet och krystat i just denna stund.
Asus P8Z68-V || i7 2600K 3,4GHz @ 4,3GHz || Corsair 8GB 1600Mhz VENGEANCE || Samsung 830 128GB || Gigabyte GeForce GTX 970 WF 3X OC 4GB || Corsair RM850 850W || Fractal Design Define XL || Antec KÜHLER H2O 620 || Acer 27" Predator XB271HU

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Jun 2013

Om jag har crossfire aktiverat i Diablo flimmrar skärmen som om den vore trasig. Bara att avaktivera och slå på vsync så ligger man stadigt på 60 fps

#1: x99 Deluxe-II | i7 6800k | GTX 980 | 64GiB | 950 Pro 512GB | Xonar STX | HD650
#2: Microserver Gen8 | G1610T | 16GiB ECC #3: QNAP TS-639 Pro | 6x4TB Raid6
#4: Intel S2600CP4 | 2x Xeon E5-2670 | 128GiB ECC | UnRAID 6.3.5 | 41TB
Smartphone: LG G5 | Android 6.0 | Shure SE535

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2001

I senaste drivrutinen till GTX så står det som följande:

Upgrade your rig with a second NVIDIA GeForce GTX GPU to activate SLI, the multi-GPU technology of choice for gamers. NVIDIA SLI intelligently scales graphics performance by combining multiple GeForce GTX GPUs on an SLI certified motherboard, increasing performance by up to 2x.

Bound by Flame – Updated Profile
Diablo III – Updated Profile
DOTA 2 – Updated Profile
Need For Speed Rivals – Updated DX11 Profile
Watch Dogs – Updated Profile

Tycker att det blev lite bättre med flytet efter nya drivrutinen.

And Jesus said "Come forth and I will grant you eternal life!" I came fifth and won a blender.
| MSI X99A Raider | i7-6850K | 16GB Crucial DDR4 2133 | Palit GTX 1080 Super Jetstream | ASUS ROG Swift PG279Q |

Trädvy Permalänk
Medlem
Plats
Katrineholm
Registrerad
Sep 2010

Det finns ingen anledning att lira SLI med dina grafikkort, de presterar bra nog med bara ett.

Dator: (Kommer senare)

Trädvy Permalänk
Avstängd
Registrerad
Dec 2013

Från 335.23-drivarnas release notes, under "fixed issues":

[SLI][Diablo III Patch 2.0.1]: The game frame rate drops with SLI and the Reflections
game setting enabled. [1469204]

///M4

Trädvy Permalänk
Medlem
Plats
127.0.0.1
Registrerad
Sep 2003
Skrivet av comp1337:

Innan 2.0.1-patchen låg jag på 199 fps hela tiden, nu efter ligger jag runt 80-90.. men har inte orkat kolla mer på det, då det funkar bra ändå
Förutom A3 Rakkis.

Du har inte kopplat på reflections då? (relativt ny grafikinställning)
Dom har ju ändå piffat upp grafiken lite sedan i sommras...

1: Intel i7-3930K | 32GB Corsair Dominator GT | Asus Rampage IV Extreme x79 | 2 x 1080 GameRock Premium 8GB | 2 x Samsung Pro 840 512GB | Corsair AX1200i | BenQ XL2411 24" / W1070 135" | Bose QC25 | Windows 10 Pro x64 | HTC Vive |
2: Intel Core i7-4700HQ | 32GB RAM | Intel HM87 Express | GTX 780M | 17" | Windows 10 x64 |

Trädvy Permalänk
Medlem
Plats
Mitten av Skåne
Registrerad
Dec 2004
Skrivet av Dalton Sleeper:

Du har inte kopplat på reflections då? (relativt ny grafikinställning)
Dom har ju ändå piffat upp grafiken lite sedan i sommras...

Kan vara så, kollar i eftermiddag. Ligger det under grafikinställningarna är det säkert igång, satte allt på det högsta där. Vad gör reflections?

Om jag skitet pengar, hade jag suttet och krystat i just denna stund.
Asus P8Z68-V || i7 2600K 3,4GHz @ 4,3GHz || Corsair 8GB 1600Mhz VENGEANCE || Samsung 830 128GB || Gigabyte GeForce GTX 970 WF 3X OC 4GB || Corsair RM850 850W || Fractal Design Define XL || Antec KÜHLER H2O 620 || Acer 27" Predator XB271HU

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2004
Skrivet av TiasE:

Vad handlar det om för FPS? Är det konstant att den går upp och ner eller handlar det om ett specifikt ställe i spelet? T.ex så i Act3 i Rakkis så är det nästan oundvikligt att du droppar, brukar själv ligga på stabila 120-140FPS men i Rakkis droppar jag till 10-15.

Vad ligger GPU2 på annars? Det normala borde vara 100%

Det där var jäkligt intressant. Har själv fps drops just där, verkligen extrema sådana när jag börjar slåss med mobs. Trodde det var något fel på min drivrutin eller rentav kortet.

Sen har jag även stuttering (60fps trots att det "hackar" till) men det är en helt annan sak och händer lite varstans in/out of combat. Är inte ensam om att ha det och det verkar vara något fel på att spelet inte löser Vsync på ett korrekt sätt. Dessutom ignorerar det NVCPL eller andra programs Vsync tvång och kör sitt eget race.

OnT : Testa att sänka sound channels till 32 och se hur det blir då. Skall själv testa det hemma sen.

[Intel 6700K @ 4500MHz]--[MSI Core Frozr L]--[MSI Z170 Gaming M5]--[Corsair 16GB 2666MHz DDR4]--[MSI 1080Ti Gaming X @ 2038/12006MHz]--[EVGA Supernova G2 850W]--[Fractal Design Define S]--[Windows 10 x64]--[Acer XB270HU]--[Corsair Strafe RGB MX Silent]--[Mionix Naos 7000]--[HyperX Cloud II]--[Creative Gigaworks T20]

Trädvy Permalänk
Medlem
Plats
Katrineholm
Registrerad
Sep 2010

Mitt D3 flyter bra med 80-110 vid rakkis blir det typ 90-100. Inga konstigheter här inte. Tror inte ens att crossfire används i det här spelet. Men det funkar ju bra ändå!

Dator: (Kommer senare)

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Aug 2012
Skrivet av LaFace:

var inte säker om jag kunde lägga tråden här eller inte, men då problemet är specifikt för diablo 3 och sli så hoppas jag att någon annan här kanske har lite god nyheter åt mig.

Som det är nu så får jag fps drops imellanåt med SLI aktiverat på min nya dator, (2x 780 lightning)
det fungerar bra i andra spel, när det händer så spikar GPU usage till 100% på GPU2, sen tillbaks till normalt igen. upplevde samma sak i WoW, men gav upp där...

visst går där att spela med 1 kort aktiverat, men har man 2, vill man ju nytta båda..

någon med tips?

Har tidigare haft rätt konstiga problem med fps i D3 med 2x760. Vid cryptruns osv med mycket stora mängder mobs frös hela spelet, detta var dock ett problem för hela gruppen. Fick även stora spikes vid tex Rakkis. Däremot fick jag bättre fps efter nya patchen, det enda problemet jag hade kvar var "flimmer" då fps:en gick från 60-240 osv. Satt max fps på ~61 och problemet sluta. Har åtminstone inte sett något ännu. Pre-patch så kunde man se via Nvidias kontrollpanel - SLI-mätaren att det var rejäla spikes i hur SLI funka. Men med nya drivrutiner samt patch funkar det bra för mig.
Om det inte funkar, även fast du har senast drivers kan du prova att förbättra prestandan genom att ändra i diablopreference.txt (kommer ej ihåg exakt namn). I denna fil finns en rad text "HardwareClass "5" högsta siffra kan vara fem (1-5), var iaf så före patch 2.0.1. Du kan testa att sänka den för att få lite bättre flyt. Kan vara en idé att göra en säkerhetskopia på filen

Trädvy Permalänk
Medlem
Registrerad
Jun 2011
Skrivet av BASSiC:

Mitt D3 flyter bra med 80-110 vid rakkis blir det typ 90-100. Inga konstigheter här inte. Tror inte ens att crossfire används i det här spelet. Men det funkar ju bra ändå!

Du måste vara den enda jag hört talas om som INTE har problem i Rakkis
Ensam flyter det hyffsat men så fort det är 2 eller fler spelare så blir Rakkis i princip ospelbart för de flesta.

Guide för felsökning av Bluescreen! (tack till m4goo2 som gjort denna)
Chassi: Antec Twelve Hundred | Moderkort: Asus z170-A | CPU: I7 6700K @ 4.7GHz | Corsair H80 | RAM-minnen: Corsair Vengeance LPX 16GB@2666MHz | GPU: MSI NVIDIA GTX 1070 Gaming G8 | Nätagg: EVGA SuperNova G2 750w | HDD: Samsung 850 EVO 500GB, OCZ Vertex3 120GB, 4x Seagate Barracuda Green 2TB, 1x Western Digital My Book 3TB, Western Digital My Book 4TB.

Trädvy Permalänk
Medlem
Plats
Katrineholm
Registrerad
Sep 2010
Skrivet av TiasE:

Du måste vara den enda jag hört talas om som INTE har problem i Rakkis
Ensam flyter det hyffsat men så fort det är 2 eller fler spelare så blir Rakkis i princip ospelbart för de flesta.

Har faktist inte upplevt det problemet, va ju därför jag var tvungen att testa att lira där. Men testet var iofs. i single player.

Dator: (Kommer senare)

Trädvy Permalänk
Medlem
Registrerad
Aug 2011

inga problem med 1 kort, ligger i regel på 200+ fps överallt med min dator utan sli.. och ingen skillnad för mig på rakkis.. dock laggar min polare något djävulskt där..

synd att där inte finns något officielt stöd, dessa spikes i fps är samma som jag får i wow med sli.. aja.. för nöjja mig med 1 kort där helt enkelt..

New:| 4930k 6 core @ 4.4ghz | 16gb corsair platinum 1866mhz | Asus X79 Deluxe | sli 780 lightning | Cooler master v1000w+ | Corsair 540 air |

old:| i7 2600k @ 4.5ghz | 16gb Corsair Vengeance | MSI-P67A-GD65 | MSI GTX680 Lightning | Corsair TX650 | Fractal Design R3 |