Trädvy Permalänk
Medlem
Registrerad
Jan 2009

PfSense problem

Min pfsense ger alltid LAN men inte Internet. Internet funkar bara om jag kopplar den till en Netgear wgr614 (router->switch->wgr614).
Men om jag kopplar den direkt (router -> switch) eller router -> switch -> Netgear ProSafe managed switch - så ger den inget internet.

Jag kan inte komma på någon anledning till detta, och båda switcharna i fråga ska ha default inställningarna. Routern kan inte heller fetcha uppdateringar då, så det är inget DNS problem..

Trädvy Permalänk
Medlem
Registrerad
Maj 2014

Vad har du för inställningar på WAN? Är det så att du har satt en statisk IP adress? I sådana fall måste du nog ställa in DHCP.

Kan det ha varit så att du fått en DHCP utav wgr614 och att den inte timat ut, alternativt att det är ARP-cachen som ligger kvar? I båda fallen kan en omstart av pfsence kanske lösa det.

Trädvy Permalänk
Medlem
Registrerad
Jan 2009
Skrivet av Talisker00:

Vad har du för inställningar på WAN? Är det så att du har satt en statisk IP adress? I sådana fall måste du nog ställa in DHCP.

Kan det ha varit så att du fått en DHCP utav wgr614 och att den inte timat ut, alternativt att det är ARP-cachen som ligger kvar? I båda fallen kan en omstart av pfsence kanske lösa det.

Så vitt jag vet ska jag ha dynamisk och privat ip från Bahnhof.
Dessvärre hjälpte en omstart inte något.

Trädvy Permalänk
Medlem
Registrerad
Maj 2014
Skrivet av spel565:

Så vitt jag vet ska jag ha dynamisk och privat ip från Bahnhof.
Dessvärre hjälpte en omstart inte något.

Har du ställt PFsense för DHCP på WAN? Får den en IP adress tilldelad om den kopplar upp sig mot någon annat än den vanliga routern?

Trädvy Permalänk
Medlem
Registrerad
Jan 2009
Skrivet av Talisker00:

Har du ställt PFsense för DHCP på WAN? Får den en IP adress tilldelad om den kopplar upp sig mot någon annat än den vanliga routern?

Ska ha princip default inställningarna. Och jag får alltid en IP-adress och ser den i routern..

Trädvy Permalänk
Medlem
Registrerad
Maj 2014

På den övre bilden så får du 192.168.1.131 på WAN, samtidigt som du på LAN har 192.168.1.1.
Det innebär att du har nätet 192.168.1.0/24 på både in och utsidan. Det kan ALDRIG fungera bra.
Kan du byta ip på LAN till någonting annat? (Exempelvis skulle nätet 172.16.0.0/24 fungera).

I den nedre skulle jag gissa att det är den fungerande routern, för då delas 10.0.0.0/24 ut och då är det alltså olika nät på ut- och insidan.

Notis:
Privata IP adresser finns att använda från följande spann.
192.168.0.0- 192.168.255.255.
172.16.0.0 - 172.31.255.255
10.0.0.0 - 10.255.255.255
Det överlägset vanligaste hemma är 192.168.1.0 följt utav 192.168.0.0.

Trädvy Permalänk
Medlem
Registrerad
Maj 2014

Alternativet är att du kopplar in din dator i den icke- fungerande routern. Surfar in på den och byter dess interna nät till ett annat nätverk.

Trädvy Permalänk
Medlem
Registrerad
Dec 2008

Du menar att när du skiftar från din gamla wgr614 och kopplar pfsense mot internet så fungerar det inte? Plugga ur över natten och koppla in. Kan var arp-cachear, macfilter, dhcp leasar osv som ställer till det och behöver time:a ut. Prova om du kan släppa adressen i wgr614 innan du kopplar ur den. Kan gå i vissa routrar.

Trädvy Permalänk
Medlem
Plats
Töreboda
Registrerad
Aug 2009

Har du satt en statisk dns server? Det kan i såfall vara problemet. När du byter enhet som är uppkopplad till bahnhofs tjänst ska man komma till en sida för att registrera sin nya enhet när man öppnar en webläsare och väljer valfri sida.

Trädvy Permalänk
Medlem
Registrerad
Jan 2009
Skrivet av Talisker00:

På den övre bilden så får du 192.168.1.131 på WAN, samtidigt som du på LAN har 192.168.1.1.
Det innebär att du har nätet 192.168.1.0/24 på både in och utsidan. Det kan ALDRIG fungera bra.
Kan du byta ip på LAN till någonting annat? (Exempelvis skulle nätet 172.16.0.0/24 fungera).

I den nedre skulle jag gissa att det är den fungerande routern, för då delas 10.0.0.0/24 ut och då är det alltså olika nät på ut- och insidan.

Notis:
Privata IP adresser finns att använda från följande spann.
192.168.0.0- 192.168.255.255.
172.16.0.0 - 172.31.255.255
10.0.0.0 - 10.255.255.255
Det överlägset vanligaste hemma är 192.168.1.0 följt utav 192.168.0.0.

Skrivet av Talisker00:

Alternativet är att du kopplar in din dator i den icke- fungerande routern. Surfar in på den och byter dess interna nät till ett annat nätverk.

Jag bytte till 192.168.2.0/24 på pfsense men då kom jag inte in på den.. borde inte det fungera? Datorn säger dock att gateway är 192.168.1.1 fortfarande så något verkar lurt..
Känns lite onödigt att byta för alla på hela nätverket (om jag byter på routern).

Skrivet av jocke92:

Du menar att när du skiftar från din gamla wgr614 och kopplar pfsense mot internet så fungerar det inte? Plugga ur över natten och koppla in. Kan var arp-cachear, macfilter, dhcp leasar osv som ställer till det och behöver time:a ut. Prova om du kan släppa adressen i wgr614 innan du kopplar ur den. Kan gå i vissa routrar.

Jag började med att koppla den "direkt i väggen" (router ->switch->pfsense) sen testade jag olika konfigurationer då det inte funkade, så låter konstigt. Även testat att starta om den flera gånger samt haft den urkopplad under natten.

Skrivet av maltenizer:

Har du satt en statisk dns server? Det kan i såfall vara problemet. När du byter enhet som är uppkopplad till bahnhofs tjänst ska man komma till en sida för att registrera sin nya enhet när man öppnar en webläsare och väljer valfri sida.

Verkar inte vara dns problem om jag inte ens kan pinga någon annan sida.

Trädvy Permalänk
Medlem
Registrerad
Maj 2014
Skrivet av spel565:

Jag bytte till 192.168.2.0/24 på pfsense men då kom jag inte in på den.. borde inte det fungera? Datorn säger dock att gateway är 192.168.1.1 fortfarande så något verkar lurt..
Känns lite onödigt att byta för alla på hela nätverket (om jag byter på routern).

Jo, det kan tyckas onödigt. Speciellt om man har saker med fast IP adress såsom skrivare osv. Dock kan man inte ha samma IP nät på bägge sidorna så då måste du byta på utisdan
I ditt fall måste du inte bara byta IP adress på din PFSense, utan också tala om för den att den ska dela ut nätet 192.168.2.X för DHCP. Risken är att det inte hängde med i PFSense (som är en brandvägg jag inte kan), eller att du helt enkelt bara behövt förnya IP adressen på din dator. (från kommando-prompt "ipconfig /release", "ipconfig -renew"

Skrivet av spel565:

Jag började med att koppla den "direkt i väggen" (router ->switch->pfsense) sen testade jag olika konfigurationer då det inte funkade, så låter konstigt. Även testat att starta om den flera gånger samt haft den urkopplad under natten.

Verkar inte vara dns problem om jag inte ens kan pinga någon annan sida.

Kan du pinga till 192.36.125.18 (som är ping.sunet.se)? Jag menar om du inte kan resolva dns-namnet, så kan du inte pinga dit heller. Det kan ju vara problemet.
Sedan var den någon här som sa att man måste registrera sin brandvägg/router/dator mot Bahnhof så kolla hur man gör det. Det kan räcka.

Trädvy Permalänk
Medlem
Registrerad
Jan 2009
Skrivet av Talisker00:

Jo, det kan tyckas onödigt. Speciellt om man har saker med fast IP adress såsom skrivare osv. Dock kan man inte ha samma IP nät på bägge sidorna så då måste du byta på utisdan
I ditt fall måste du inte bara byta IP adress på din PFSense, utan också tala om för den att den ska dela ut nätet 192.168.2.X för DHCP. Risken är att det inte hängde med i PFSense (som är en brandvägg jag inte kan), eller att du helt enkelt bara behövt förnya IP adressen på din dator. (från kommando-prompt "ipconfig /release", "ipconfig -renew"

Kan du pinga till 192.36.125.18 (som är ping.sunet.se)? Jag menar om du inte kan resolva dns-namnet, så kan du inte pinga dit heller. Det kan ju vara problemet.
Sedan var den någon här som sa att man måste registrera sin brandvägg/router/dator mot Bahnhof så kolla hur man gör det. Det kan räcka.

Omstart hjälpte inte. Tidigare pingade jag 8.8.8.8 utan lycka så antog att det inte var DNS problem.
Registrera dator mot Bahnhof? Förstår inte, kör dessutom NAT så dom borde inte märka något (?).

Trädvy Permalänk
Medlem
Plats
stockholm
Registrerad
Mar 2007

Förstår inte riktigt hur du har testat koppla det i och med dina bilder och den första posten. Får du olika adresser (wan) tilldelade beroende på vad du kopplar in EFTER pfsense-burken?

Annars tänker jag mig att det är, som tidigare sagts, problem med ett lån eller att du behöver registrera något. Testa kopiera routerns mac-address (wgr614) och lägga in den på ditt wan-interface i pfsense.

Trädvy Permalänk
Medlem
Registrerad
Jan 2009
Skrivet av petterg:

Förstår inte riktigt hur du har testat koppla det i och med dina bilder och den första posten. Får du olika adresser (wan) tilldelade beroende på vad du kopplar in EFTER pfsense-burken?

Annars tänker jag mig att det är, som tidigare sagts, problem med ett lån eller att du behöver registrera något. Testa kopiera routerns mac-address (wgr614) och lägga in den på ditt wan-interface i pfsense.

wgr614 ligger innan pfsense

Trädvy Permalänk
Medlem
Plats
Finspång
Registrerad
Okt 2003
Skrivet av spel565:

wgr614 ligger innan pfsense

Ta och rita upp hur du har kopplat och vilka nät du har

Trädvy Permalänk
Medlem
Registrerad
Jan 2009
Skrivet av niclasc:

Ta och rita upp hur du har kopplat och vilka nät du har

Likt jag skrev tidigare:

Fiber -> router -> switch -> wgr614 -> PfSense (Internet)
Fiber -> router -> switch -> PfSense (ej Internet)
Fiber -> router -> switch ->ProSafe -> PfSense (ej Internet)

Router Cisco
Switch Netgear 20portar, un-managed

Trädvy Permalänk
Medlem
Registrerad
Apr 2013
Skrivet av spel565:

Likt jag skrev tidigare:

Fiber -> router -> switch -> wgr614 -> PfSense (Internet)
Fiber -> router -> switch -> PfSense (ej Internet)
Fiber -> router -> switch ->ProSafe -> PfSense (ej Internet)

Router Cisco
Switch Netgear 20portar, un-managed

WTF varför en brandvägg m.m i slutet av den kedjan? Skydda dig från dom andra på ditt lan?

Trädvy Permalänk
Medlem
Plats
Karlstad
Registrerad
Mar 2008

Varför har du en cisco router och en pfsensemaskin efteråt. Jag kan se behovet men det är ganska speciellt..

Får du samma IP från Bahnhof på WAN om du kopplar direkt pfsense->fiberkonverteraren ?
Om ja : Du kan ringa Bahnhof och begära att få en publik ip-adress. Du har nu blivit satt bakom deras nat.

Jag har kopplat så här med min pfsense.
Fiberkonverterar->pfsense->switch.
Och det är så du borde koppla. Kolla över dina DHCP inställningar på pfsense för lan. Så det inte krockar något.

Lill-server(2010): SFF NAS Zotac H55ITX-C-E, Lian Li PC-Q08B, Intel Core i3 540
Stor-server(2014): SuperMicro X10SL7-F, 20GB ECC RAM, 4x2TB WD Green, E3-1230v3, 2xIntel Dual Gigabit Nic

Trädvy Permalänk
Medlem
Registrerad
Dec 2008

Vad fyller den du kallar router för funktion tror du? Vad har den för modellbeteckning?

Trädvy Permalänk
Medlem
Registrerad
Jan 2009
Skrivet av aluser:

WTF varför en brandvägg m.m i slutet av den kedjan? Skydda dig från dom andra på ditt lan?

Skrivet av Docker:

Varför har du en cisco router och en pfsensemaskin efteråt. Jag kan se behovet men det är ganska speciellt..

Får du samma IP från Bahnhof på WAN om du kopplar direkt pfsense->fiberkonverteraren ?
Om ja : Du kan ringa Bahnhof och begära att få en publik ip-adress. Du har nu blivit satt bakom deras nat.

Jag har kopplat så här med min pfsense.
Fiberkonverterar->pfsense->switch.
Och det är så du borde koppla. Kolla över dina DHCP inställningar på pfsense för lan. Så det inte krockar något.

Skrivet av jocke92:

Vad fyller den du kallar router för funktion tror du? Vad har den för modellbeteckning?

Tänkte ha saker bakom pfsense, och tänkte att pfsense skulle agera brandvägg (Internet och blocka all övrig LAN trafik som går till subnätet)
Och det funkar ju bra.. när jag kopplar den till wgr614.

Så åter till frågan, går det att fixa så jag slipper ha wgr614 emellan?

Routern är en Cisco RV180W. Föreslå gärna andra operativ system om det finns någon bättre för mina behov.

Trädvy Permalänk
Medlem
Registrerad
Dec 2008
Skrivet av spel565:

Tänkte ha saker bakom pfsense, och tänkte att pfsense skulle agera brandvägg (Internet och blocka all övrig LAN trafik som går till subnätet)
Och det funkar ju bra.. när jag kopplar den till wgr614.

Så åter till frågan, går det att fixa så jag slipper ha wgr614 emellan?

Routern är en Cisco RV180W. Föreslå gärna andra operativ system om det finns någon bättre för mina behov.

Då får du svarta(privata) ip-adresser från din RV180W? Men din pfsense får inga IP-adresser från den?
Varför inte bara köra pfsense som router/brandvägg?
Finns en inställning som blockerar näten specade i RFC1918m är den urbockad?

Trädvy Permalänk
Medlem
Registrerad
Jan 2009
Skrivet av jocke92:

Då får du svarta(privata) ip-adresser från din RV180W? Men din pfsense får inga IP-adresser från den?
Varför inte bara köra pfsense som router/brandvägg?
Finns en inställning som blockerar näten specade i RFC1918m är den urbockad?

Får privata addresser (192.168.1.1/24) av Router. Den är urbockad.
Tänkte ha en annan brandvägg till detta subnätet därmed inskaffade jag en pfsense låda.

Nu fixade jag så LAN ligger på 10.0.0.2 på pfsense och den får WAN av cisco på 192.168.1.1.
PfSense har nu internet (även utan att sitta i netgear som innan).
PfSense kan pinga t ex 8.8.8.8, men det kan inte min dator som sitter direkt i PfSense.
Datorn har en ip-address (10.0.0.3) och når pfsense webGUI!
Har startat om allt.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Dec 2009

Du behöver tillåta trafiken från LAN
Skapa en ny regel i brandväggen på LAN-interfacet och tillåt allt.
Se till att NAT står på automatic.

Trädvy Permalänk
Medlem
Plats
Karlstad
Registrerad
Mar 2008
Skrivet av spel565:

Får privata addresser (192.168.1.1/24) av Router. Den är urbockad.
Tänkte ha en annan brandvägg till detta subnätet därmed inskaffade jag en pfsense låda.

Nu fixade jag så LAN ligger på 10.0.0.2 på pfsense och den får WAN av cisco på 192.168.1.1.
PfSense har nu internet (även utan att sitta i netgear som innan).
PfSense kan pinga t ex 8.8.8.8, men det kan inte min dator som sitter direkt i PfSense.
Datorn har en ip-address (10.0.0.3) och når pfsense webGUI!
Har startat om allt.

Du kör nu NAT->NAT.. Det är aldrig bra. Kommer vara problem.

Lill-server(2010): SFF NAS Zotac H55ITX-C-E, Lian Li PC-Q08B, Intel Core i3 540
Stor-server(2014): SuperMicro X10SL7-F, 20GB ECC RAM, 4x2TB WD Green, E3-1230v3, 2xIntel Dual Gigabit Nic

Trädvy Permalänk
Medlem
Registrerad
Jan 2009
Skrivet av tomle:

Du behöver tillåta trafiken från LAN
Skapa en ny regel i brandväggen på LAN-interfacet och tillåt allt.
Se till att NAT står på automatic.

Ah tack!

Skrivet av Docker:

Du kör nu NAT->NAT.. Det är aldrig bra. Kommer vara problem.

Låter rimligt, men verkar ju funka.. Kommer något protokoll i kläm eller vad kan hända?

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Registrerad
Apr 2013
Skrivet av spel565:

Ah tack!

Låter rimligt, men verkar ju funka.. Kommer något protokoll i kläm eller vad kan hända?

Skickades från m.sweclockers.com

Förrutom att du inför extra latency så är det oftast protokoll som behöver behandlas speciellt som t ex ftp som kan hamna i kläm men majoriteten kommer fungera men dom gånger det inte fungerar kommer det vara mycket konstiga fel som kan vara svårtyda.