Trädvy Permalänk
Medlem
Registrerad
Jul 2013

Hastighet på lokalt nätverk

Inskaffade nyligen en NAS som jag för över filer från dator till.

I mitt närverk har jag en 1GB/s router (TP-Link) som hade 4 portar, behövde fler så köpte en switch som även den stödjer 1GB/s (Netgear GS105).

Allt är trådat och när jag kopplade in NASen genom switchen så hade jag en överföringshastighet på 1,1mb/s. Satte in NASen direkt i routern istället och fick hastigheten upp till 62mb/s. Vad är det som gör att switchen drar ner så enromt mycket på hastigheten?

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jan 2013

Det ska inte vara så. Den enda försämring av prestanda du "ska" få är eventuellt lite ökad latens. Om flera enheter i switchen ska kommunicera mot routern så får de såklart dela på 1 Gbit, men det bör ge minst 25 MB/sekund/enhet om det delas lika.

Hur har du kopplat, sitter NAS och datorn i switchen, eller sitter datorn i routern?

Skickades från m.sweclockers.com

Oh, squiggly line in my eye fluid, I see you there, lurking in the periphery of my vision. But when I try to look at you, you scurry away. Are you shy, squiggly line? Why only when I ignore you do you return to the center of my eye? Oh, squiggly line, it's all right. You are forgiven.

S. Griffin

Trädvy Permalänk
Medlem
Plats
Schlätta
Registrerad
Mar 2012

Jag har samma switch som du utan några som helst problem. (Och då har jag ändå ett riktigt fulkopplat hemnätverk. I värsta fall kan en filöverföring behöva passera 5 switchar mellan två olika datorer.)

Edit: Testa att byta kabeln mellan router och switch, är den skadad kan det bli dålig hastighet. Cat5e funkar utmärkt, jag drar alla fasta kopplingar med Cat6 men Cat5e går att hitta snorbilligt och håller nästan samma kvalitet.

Gamerigg: | Win10 | InWin 303 | ASUS X99-A | Intel i7-5820K | Gamerstorm Captain 240 | Intel 600p 256GB | MSI R9 380 Gaming 4GB | 32GB DDR4 2400Mhz | Corsair RM650x |

Trädvy Permalänk
Medlem
Registrerad
Jul 2013

Datorn satt från början i routern och NASen i switchen, när jag flyttade NASen till routern också fick jag upp hastigheten. Hade inga andra enheter igång vid tillfället.

Kabeln mellan router switch är helt ny, men testade ändå att byta utan någon förbättring.

Trädvy Permalänk
Medlem
Plats
Bjuv
Registrerad
Jun 2005
Skrivet av Asklepios:

Det ska inte vara så. Den enda försämring av prestanda du "ska" få är eventuellt lite ökad latens. Om flera enheter i switchen ska kommunicera mot routern så får de såklart dela på 1 Gbit, men det bör ge minst 25 MB/sekund/enhet om det delas lika.

Hur har du kopplat, sitter NAS och datorn i switchen, eller sitter datorn i routern?

Skickades från m.sweclockers.com

Du har lite fel varje nod i en switch får en dedikerad 1gb anslutning. Det är hubbar som delar på bandbredden och trådlösa routrar (På den trådlösa delen inte i den trådade switchen).

http://sv.wikipedia.org/wiki/Switch

Skrivet av SleepingBear:

Datorn satt från början i routern och NASen i switchen, när jag flyttade NASen till routern också fick jag upp hastigheten. Hade inga andra enheter igång vid tillfället.

Kabeln mellan router switch är helt ny, men testade ändå att byta utan någon förbättring.

Kolla med att plugga in kabel från router i annan port. Byt till cat 5e kablar hjälper inte det kolla med cat 6. Hjälper inte något av detta låna en switch av någon av ett annat fabrikat för det kan vara så att du har ett kompatibilitets problem. Jag själv fick knas med det när jag fick hem d-link nätverks kort å försökte anv till min 24 portars Intel switch slö hastighet och allmänt ostabilt nät

Phenom II X6 1090T BE, GA-790x-ud3p, 8gb Corsair XMS2 800Mhz, Radeon R9 270x, 120gb Kingston HyperX Fury, 500GB Seagate, 2TB Seagate.

Trädvy Permalänk
Medlem
Plats
Vänersborg
Registrerad
Jul 2012

Koppla bort allt ur switchen förutom dator samt koppla in nasen i den.
Bra hastighet = Bra kablar, bra switch.
Raka/Korsade kablar spelar ingen roll, utrustningen skall känna av detta och justera sig till vad som behövs.
Skulle det fungera bra, låt nasen sitta kvar, koppla in datorn i routern och starta om routern.
Testa igen.

Trädvy Permalänk
Medlem
Registrerad
Maj 2014
Skrivet av Demonlord:

Du har lite fel varje nod i en switch får en dedikerad 1gb anslutning. Det är hubbar som delar på bandbredden och trådlösa routrar (På den trådlösa delen inte i den trådade switchen).

http://sv.wikipedia.org/wiki/Switch

Absolut, men mot routern blir det ändå så att alla enheter får dela på en 1Gbps. Själva kabeln mot den kan inte gå fortare.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Mar 2004

Jag kör en gigabitswitch i mitt hobbyrum där jag har NAS, speldator, musikdator och kontorsdator inkopplade. Switchen är inkopplad i routern. All trafik mellan NAS och datorerna går då endast genom switchen (eftersom trafiken inte behöver gå till routern först).
Märker en viss försämring i överföringshastighet om jag vill kopiera filer till min HTPC som sitter i routern, men dock inte så anmärkningsvärda som du beskriver.

Switch: D-Link DGS-10005D (Green)
Router: ASUS RT-N66U

“Problems that remain persistently insoluble should always be suspected as questions asked in the wrong way.” ― Alan W. Watts

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jan 2013
Skrivet av Demonlord:

Du har lite fel varje nod i en switch får en dedikerad 1gb anslutning. Det är hubbar som delar på bandbredden och trådlösa routrar (På den trådlösa delen inte i den trådade switchen).

Skrivet av Talisker00:

Absolut, men mot routern blir det ändå så att alla enheter får dela på en 1Gbps. Själva kabeln mot den kan inte gå fortare.

Precis. Upplänken från switchen (mot routern i detta fallet) delas ju mellan alla anslutna enheter. Mellan portarna på switchen blir det givetvis 1Gbps, om det inte är en kass switch med klent bakplan.

Skrivet av Optimist:

Koppla bort allt ur switchen förutom dator samt koppla in nasen i den.
Bra hastighet = Bra kablar, bra switch.
Raka/Korsade kablar spelar ingen roll, utrustningen skall känna av detta och justera sig till vad som behövs.
Skulle det fungera bra, låt nasen sitta kvar, koppla in datorn i routern och starta om routern.
Testa igen.

Precis min tanke. Generellt är får man ju bäst överföringshastighet mellan enheter inom sitt LAN om så många enheter som möjligt är anslutna till samma switch. Man slipper ju då att upplänken ska delas enligt ovan.

Att switchen sedan måste kopplas till routern för internetåtkomst är i praktiken inget problem - så länge din internetuppkoppling är långsammare än upplänken switch-router så är det ju ändå uppkopplingen som begränsar.

Oh, squiggly line in my eye fluid, I see you there, lurking in the periphery of my vision. But when I try to look at you, you scurry away. Are you shy, squiggly line? Why only when I ignore you do you return to the center of my eye? Oh, squiggly line, it's all right. You are forgiven.

S. Griffin

Trädvy Permalänk
Medlem
Registrerad
Jul 2013

Tackar för svaren änsålänge, ska testa lite i helgen om jag hinner och återkommer med resultet.

Trädvy Permalänk
Medlem
Plats
Bjuv
Registrerad
Jun 2005

Kolla om switchen har en dedikerad uplink port. Dom portarna har oftast en högre throughput än resterande portar

Phenom II X6 1090T BE, GA-790x-ud3p, 8gb Corsair XMS2 800Mhz, Radeon R9 270x, 120gb Kingston HyperX Fury, 500GB Seagate, 2TB Seagate.