Går ej ändra från public till private för ethernet LAN

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Apr 2009

Går ej ändra från public till private för ethernet LAN

Tja

Har 2 datorer med Windows 8.1 Pro, den ena (en Asus laptop) har fått för sig att vara inställd som Public network för ethernet, LAN. Kan således ej ansluta till hemgrupp mot min stationära som har inställt Private network för ethernet, LAN.

Har följt olika guider men får inte ens upp alternativet: "Find devices and content" enligt ex. följande, och kan därför inte ändra den switchen, för den finns inte...

Hjälp?!

Niklas

Trädvy Permalänk
Medlem
Plats
Plats
Registrerad
Jul 2008

hur ser det ut i din Network and sharing center - Change advanced sharing settings?
Och jämför bägge datorers settings för att se om nåt skiljer

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Apr 2009
Skrivet av fAkkFejz:

hur ser det ut i din Network and sharing center - Change advanced sharing settings?
Och jämför bägge datorers settings för att se om nåt skiljer

Precis samma inställningar rakt över, den enda skillnaden är som sagt att den stationära är inställd på private (vilket jag vill ha) och laptopen på public (vilket jag INTE vill ha).

Har aldrig satt en dator på annat än private (möjligtvis av misstag, men fattar inte hur...)

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Apr 2009

Problemet är att följande val inte alls finns!!

Från Microsoft support sida:

Citat:

Reglaget Hitta enheter och innehåll är inaktiverat.
Så här söker du efter datorer, enheter och innehåll i nätverket

Svep in från skärmens högerkant, tryck på Inställningar och sedan på Ändra datorinställningar.
(Om du använder en mus pekar du i det nedre högra hörnet av skärmen, flyttar pekaren uppåt, klickar på Inställningar och väljer sedan Ändra datorinställningar.)
Tryck eller klicka på Nätverk och aktivera sedan reglaget Hitta enheter och innehåll.

Funktionerna för nätverksidentifiering är avstängda.

Aktivera reglaget Hitta enheter och innehåll enligt anvisningarna i föregående avsnitt.

Trädvy Permalänk
Medlem
Plats
Plats
Registrerad
Jul 2008
Skrivet av ApeviaX:

Problemet är att följande val inte alls finns!!

Från Microsoft support sida:

http://forumbilder.se/DEVJI/skarmklipp-2014-12-26-11-47-39.pn...

ev. Off topic: nu vet jag inte om det har med saken att göra, men har du lokala konton på datorerna eller microsoft-konton på dom?
annars menar jag hur dina settings ser ut i kontrollpanelen?
så här: själv har jag microsoft-acc.

På Guest or Public har jag OFF på allt under den sektionen, men används ju endå inte.

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Apr 2009
Skrivet av fAkkFejz:

ev. Off topic: nu vet jag inte om det har med saken att göra, men har du lokala konton på datorerna eller microsoft-konton på dom?
annars menar jag hur dina settings ser ut i kontrollpanelen?
så här: själv har jag microsoft-acc.
http://i.imgur.com/7tLvpWl.png

På Guest or Public har jag OFF på allt under den sektionen, men används ju endå inte.

Lokala konton och med inställningar att dela så som du visar på din bild.

Niklas

Trädvy Permalänk
Medlem
Plats
Plats
Registrerad
Jul 2008
Skrivet av ApeviaX:

Lokala konton och med inställningar att dela så som du visar på din bild.

Niklas

Jaa då är iaf. skillnaden lokala acc vs ms acc.
så frågan är om det är orsaken?
Förr vet jag iaf i win8 att det gick att ha private network på lokala accs.
vet ej om det är ändrat nu, nån annan vet kanske.

annars här borde finnas nån lösning på ditt problem

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jan 2013

Det är lätt att ändra med Powershell:

Starta Powershell genom att söka vid startskärmen. Öka sedan dina befogenheter:

Start-Process PowerShell.exe -verb RunAs

I det nya fönstret du får upp:

Get-NetConnectionProfile

Vilket ger:

Name : XYZ InterfaceAlias : Wi-Fi InterfaceIndex : 3 NetworkCategory : Public IPv4Connectivity : Internet IPv6Connectivity : LocalNetwork

Om du bara har ett nätverk anslutet visas endast detta, och du kan köra:

Set-NetConnectionProfile -NetworkCategory Private

Om du får upp flera nätverk måste du kolla på InterfaceIndex och ändra rätt:

Set-NetConnectionProfile -InterfaceIndex 3 -NetworkCategory Private

Om du vill kan du kolla att ändringen gått igenom:

Get-NetConnectionProfile

Vilket bör ge:

Name : XYZ InterfaceAlias : Wi-Fi InterfaceIndex : 3 NetworkCategory : Private IPv4Connectivity : Internet IPv6Connectivity : LocalNetwork

Oh, squiggly line in my eye fluid, I see you there, lurking in the periphery of my vision. But when I try to look at you, you scurry away. Are you shy, squiggly line? Why only when I ignore you do you return to the center of my eye? Oh, squiggly line, it's all right. You are forgiven.

S. Griffin

Trädvy Permalänk
Medlem
Registrerad
Sep 2006
Skrivet av ApeviaX:

Problemet är att följande val inte alls finns!!

Det är för att du inte är lokal administratör.

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Apr 2009
Skrivet av Asklepios:

Det är lätt att ändra med Powershell:

Starta Powershell genom att söka vid startskärmen. Öka sedan dina befogenheter:

Start-Process PowerShell.exe -verb RunAs

I det nya fönstret du får upp:

Get-NetConnectionProfile

Vilket ger:

Name : XYZ InterfaceAlias : Wi-Fi InterfaceIndex : 3 NetworkCategory : Public IPv4Connectivity : Internet IPv6Connectivity : LocalNetwork

Om du bara har ett nätverk anslutet visas endast detta, och du kan köra:

Set-NetConnectionProfile -NetworkCategory Private

Om du får upp flera nätverk måste du kolla på InterfaceIndex och ändra rätt:

Set-NetConnectionProfile -InterfaceIndex 3 -NetworkCategory Private

Om du vill kan du kolla att ändringen gått igenom:

Get-NetConnectionProfile

Vilket bör ge:

Name : XYZ InterfaceAlias : Wi-Fi InterfaceIndex : 3 NetworkCategory : Private IPv4Connectivity : Internet IPv6Connectivity : LocalNetwork

Fick detta att fungera igår, det verkar dock ej vara en permanent lösning?
Idag står allt som Public igen och jag fick göra om allt enligt din guide...

Spelade Age of Mythology Titans igår som LAN setup. Men idag kan man ej connecta, man kan se varandras spel men ej connecta...
Någon idé?

Niklas

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Apr 2009
Skrivet av Softie:

Det är för att du inte är lokal administratör.

Jo, tyvärr var det inte så enkelt. Jag är lokal admin...

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Apr 2009

Upptäckte att IP adresserna ser lite märkliga ut idag... Igår började båda på 192.168.1.x sås om det bör göra...

Idag har min dator (den stationära): 192.168.56.1 och laptopen har 169.254.231.44 varför är den så knas?

Är det det som är felet? Alltså anledningen till att jag kan se båda datorerna inne i spelet oavsett vem som är host men man kan inte joina... blir timeout....

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Apr 2009

Jag kan pinga sambons laptop och får svar direkt. Men när jag försöker pinga från hennes dator mot min stationära så står det:

Citat:

PING: Transmit failed. General failure.

Provade att sätta statisk IP address, min till 192.168.1.80 och sambons till 192.168.1.79
Gör jag så så funkar ping perfekt, i spelet står hennes dator med samma IP adress som ovan 192.168.1.79 mern om jag går in som host står det 192.168.1.69?

Provade att pinga mot min dator med spelets föreslagna 192.168.1.69, det går, så jag ändrade min statiska IP address från 192.168.1.80 till 192.168.1.69 och då får man reply vid ping men med felmeddelandet:

Citat:

Reply from 192.168.1.79. Destination host unreachable.

Den pingar alltså sig själv då?

Tillbaka på automatisk tilldelning av IP address. ipconfig i CMD ger då min dator 169.254.169.120 och sambons 169.254.231.44 nu går båda att piunga, vi syns i spelet men själva connection biten gör timeout...

Blir tokig, skiten funkade ju igår efter guiden som Asklepios skrev.

Niklas

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jan 2013

Det verkar ju som att DHCP-servern inte svarar som den ska eftersom du fick Windows automatiska IP (169...).
Om Windows håller på och ändrar mellan public och private hela tiden beror det ofta på att den inte känner igen nätverket den är ansluten till. Normalt sett brukar ju detta inträffa när man ansluter till ett nytt nätverk på en ny plats (med en bärbar), eller har skaffat en ny router.

Sammantaget låter detta som att det är något skumt på gång med din router. Har du testat att starta om den?

Oh, squiggly line in my eye fluid, I see you there, lurking in the periphery of my vision. But when I try to look at you, you scurry away. Are you shy, squiggly line? Why only when I ignore you do you return to the center of my eye? Oh, squiggly line, it's all right. You are forgiven.

S. Griffin

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Apr 2009
Skrivet av Asklepios:

Det verkar ju som att DHCP-servern inte svarar som den ska eftersom du fick Windows automatiska IP (169...).
Om Windows håller på och ändrar mellan public och private hela tiden beror det ofta på att den inte känner igen nätverket den är ansluten till. Normalt sett brukar ju detta inträffa när man ansluter till ett nytt nätverk på en ny plats (med en bärbar), eller har skaffat en ny router.

Sammantaget låter detta som att det är något skumt på gång med din router. Har du testat att starta om den?

Tjena

Jag har inte routern inblandad i detta nätverk. Utan har en CAT 5e kabel mellan datorerna. Det jag har noterat är dock att ingen dator kan identifiera nätverket. Utan även när det funkar så står det Unidentified....

Lyckades lösa det hela igår till slut genom dina tips samt att ändra IP adresserna till statiska, 192.168.10.1 respektive 192.168.10.2

Idag funkar det dock inte och jag fastnar åter vid Attemting to connect ... xxx sec (countdown) så man kan som sagt se den som är Host, trycka på Join och sen så kan inte spelet koppla upp. Ska detta bara funka varannan dag eller vad? XD Fattar inte varför en fungerande lösning inte funkar dagen efter?!

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jan 2013
Skrivet av ApeviaX:

Jag har inte routern inblandad i detta nätverk. Utan har en CAT 5e kabel mellan datorerna. Det jag har noterat är dock att ingen dator kan identifiera nätverket. Utan även när det funkar så står det Unidentified....

Lyckades lösa det hela igår till slut genom dina tips samt att ändra IP adresserna till statiska, 192.168.10.1 respektive 192.168.10.2

Till att börja med så har du förklaringen till de mystiska adressändringarna här. Jag antar att du har varit ansluten till en router tidigare, eftersom du från början hade fått en automatisk IP på 192.168.xxx.xxx. Detta är ju de vanligaste privata adresserna som konsumentroutrar använder.
När du sedan kör utan router, kopplar du också bort den i routern inbyggda DHCP-servern som tilldelar adresser. När Windows då försöker förnya sin DHCP-lease, så svarar såklart inte DHCP-servern. Det finns inbyggda funktioner i DHCP som gör att adressen kan hållas kvar en stund, men till slut tilldelas en privat adress av Windows självt (APIPA), och då blir det enligt modellen 169.254.xxx.xxx. Detta är inte i samma subnät som 192.168.xxx.xxx så kommunikationen fungerar inte.

Skrivet av ApeviaX:

Idag funkar det dock inte och jag fastnar åter vid Attemting to connect ... xxx sec (countdown) så man kan som sagt se den som är Host, trycka på Join och sen så kan inte spelet koppla upp. Ska detta bara funka varannan dag eller vad? XD Fattar inte varför en fungerande lösning inte funkar dagen efter?!

Har du kvar de statiska IP-adresserna? Samma nätmask? Om inte, så bör du köra på det. APIPA ska göra så att två datorer ska kunna kommunicera utan statiska IP eller DHCP-server i nätet, men min erfarenhet är att det oftast strular. Jag har inte orkat bråka med det och ta reda på varför, utan jag kör med statiska IP om jag behöver koppla samman två datorer utan annan utrustning.

Sen, hela cirkusen med private eller public network: detta system bygger ju på att Windows ska "känna igen" nätverket det är anslutet till, och då kunna välja rätt nätverkstyp enligt tidigare gjorda val. Utifrån denna nätverkstyp görs sedan lämpliga säkerhetsinställningar. Om nätverket står som Oidientifierat/Unidentified så kommer detta inte att fungera, av uppenbara skäl. Det är (sannolikt) detta som även gör att public/private-valet inte finns. Du får nog ändra vid varje inkoppling.

Det enklaste sättet att komma runt allt detta är nog att stänga av Windows brandvägg när du kör direktanslutet mellan datorerna. Förhoppningsvis litar du på att din sambo inte hittar på några hyss, och du har ju inte heller någon internetuppkoppling som kan utgöra någon risk.

Testa detta! Om det inte fungerar får jag fundera lite till...

Oh, squiggly line in my eye fluid, I see you there, lurking in the periphery of my vision. But when I try to look at you, you scurry away. Are you shy, squiggly line? Why only when I ignore you do you return to the center of my eye? Oh, squiggly line, it's all right. You are forgiven.

S. Griffin

Trädvy Permalänk
Rekordmedlem
Plats
Salstad
Registrerad
Feb 2009

Varför ska du prompt koppla ad hoc i stället för via en router ?

Phenom 2 960T (körs x6) med passivt Ninja på Asus Crosshair 4 Asus 4850 och en väldig massa masslagring.Passiv kyld Northq nätdel 450W Antec P 180 med Schyte o Sharkoon fläktar via en t-balancer, väldigt tyst, oftast passivt. Datorljud 2kanal: ljudkort/dsp Behringer DCX2496, högtalare Truth B3031A, Truth B2092A Har också Oscilloskop och mätmikrofon.

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Apr 2009
Skrivet av Asklepios:

Till att börja med så har du förklaringen till de mystiska adressändringarna här. Jag antar att du har varit ansluten till en router tidigare, eftersom du från början hade fått en automatisk IP på 192.168.xxx.xxx. Detta är ju de vanligaste privata adresserna som konsumentroutrar använder.
När du sedan kör utan router, kopplar du också bort den i routern inbyggda DHCP-servern som tilldelar adresser. När Windows då försöker förnya sin DHCP-lease, så svarar såklart inte DHCP-servern. Det finns inbyggda funktioner i DHCP som gör att adressen kan hållas kvar en stund, men till slut tilldelas en privat adress av Windows självt (APIPA), och då blir det enligt modellen 169.254.xxx.xxx. Detta är inte i samma subnät som 192.168.xxx.xxx så kommunikationen fungerar inte.

Har du kvar de statiska IP-adresserna? Samma nätmask? Om inte, så bör du köra på det. APIPA ska göra så att två datorer ska kunna kommunicera utan statiska IP eller DHCP-server i nätet, men min erfarenhet är att det oftast strular. Jag har inte orkat bråka med det och ta reda på varför, utan jag kör med statiska IP om jag behöver koppla samman två datorer utan annan utrustning.

Sen, hela cirkusen med private eller public network: detta system bygger ju på att Windows ska "känna igen" nätverket det är anslutet till, och då kunna välja rätt nätverkstyp enligt tidigare gjorda val. Utifrån denna nätverkstyp görs sedan lämpliga säkerhetsinställningar. Om nätverket står som Oidientifierat/Unidentified så kommer detta inte att fungera, av uppenbara skäl. Det är (sannolikt) detta som även gör att public/private-valet inte finns. Du får nog ändra vid varje inkoppling.

Det enklaste sättet att komma runt allt detta är nog att stänga av Windows brandvägg när du kör direktanslutet mellan datorerna. Förhoppningsvis litar du på att din sambo inte hittar på några hyss, och du har ju inte heller någon internetuppkoppling som kan utgöra någon risk.

Testa detta! Om det inte fungerar får jag fundera lite till...

Mkt intressant tankebana, ska läsa en gång till och se till att jag händer med här.

Får dock pinsamt nog tillägga följande: Har haft Windows brandvägg avstängd hela tiden (iaf för private network) och jag har alltså en router som är konstant uppkopplad mot båda datorerna via Wi-Fi för internet. Så dessa två parametrar kan säkerligen förändra något... ?

Skrivet av mrqaffe:

Varför ska du prompt koppla ad hoc i stället för via en router ?

Har inte sagt att jag prompt ska köra denna typ av nätverk, men tänkte att det kunde vara enklare att utesluta en router för ett enkelt LAN? Och har dessutom endast 1 ledig nätverkskabel som funkar, så kan ju inte koppla in den ena datorn annars... (Går skaffa en till, jag vet, men när LAN via 2 datorer direktanslutna har funkat så känns det som att det är en bra lösning).

Trädvy Permalänk
Rekordmedlem
Plats
Salstad
Registrerad
Feb 2009
Skrivet av ApeviaX:

Mkt intressant tankebana, ska läsa en gång till och se till att jag händer med här.

Får dock pinsamt nog tillägga följande: Har haft Windows brandvägg avstängd hela tiden (iaf för private network) och jag har alltså en router som är konstant uppkopplad mot båda datorerna via Wi-Fi för internet. Så dessa två parametrar kan säkerligen förändra något... ?

Har inte sagt att jag prompt ska köra denna typ av nätverk, men tänkte att det kunde vara enklare att utesluta en router för ett enkelt LAN? Och har dessutom endast 1 ledig nätverkskabel som funkar, så kan ju inte koppla in den ena datorn annars... (Går skaffa en till, jag vet, men när LAN via 2 datorer direktanslutna har funkat så känns det som att det är en bra lösning).

Det är för det mesta bara mer komplicerat att utesluta en router om man vill ha ett "enkelt lan"
Du antyder även att du använder 2 anslutningar per dator eller var kommer wifin ifrån ? Det skapar i sig en del "problem" som kan göra att det krävs ytterligare manuell konfigurering.

Phenom 2 960T (körs x6) med passivt Ninja på Asus Crosshair 4 Asus 4850 och en väldig massa masslagring.Passiv kyld Northq nätdel 450W Antec P 180 med Schyte o Sharkoon fläktar via en t-balancer, väldigt tyst, oftast passivt. Datorljud 2kanal: ljudkort/dsp Behringer DCX2496, högtalare Truth B3031A, Truth B2092A Har också Oscilloskop och mätmikrofon.

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Apr 2009
Skrivet av mrqaffe:

Det är för det mesta bara mer komplicerat att utesluta en router om man vill ha ett "enkelt lan"
Du antyder även att du använder 2 anslutningar per dator eller var kommer wifin ifrån ? Det skapar i sig en del "problem" som kan göra att det krävs ytterligare manuell konfigurering.

Jaså, jag som tänkte att det var ytterligare en parameter som kunde krångla

Yes, laptopen har inbyggt Wi-Fi och den stationära kör jag via en usb nätverkssticka från D-Link.
Så med kabeln blir det alltså 2 anslutningar per dator ja. Det inser jag kan strula till det, men har tänkt att datorn borde "fatta" att kabel är kabel och Wi-Fi är Wi-Fi

Trädvy Permalänk
Rekordmedlem
Plats
Salstad
Registrerad
Feb 2009
Skrivet av ApeviaX:

Jaså, jag som tänkte att det var ytterligare en parameter som kunde krångla

Yes, laptopen har inbyggt Wi-Fi och den stationära kör jag via en usb nätverkssticka från D-Link.
Så med kabeln blir det alltså 2 anslutningar per dator ja. Det inser jag kan strula till det, men har tänkt att datorn borde "fatta" att kabel är kabel och Wi-Fi är Wi-Fi

Ja datorn fattar det och den skiljer på anslutningarna, den stora frågan är egentligen om du talar om för respektive program vilken anslutning det ska använda till vad och att du inte kopplar nån loop som dödar nätverket osv.
Det brukar vara enklare att koppla allt via en "hemmarouter" än att konfa själv om det bara handlar om att få det att fungera och man inta har några krav på avancerade funktioner.

Phenom 2 960T (körs x6) med passivt Ninja på Asus Crosshair 4 Asus 4850 och en väldig massa masslagring.Passiv kyld Northq nätdel 450W Antec P 180 med Schyte o Sharkoon fläktar via en t-balancer, väldigt tyst, oftast passivt. Datorljud 2kanal: ljudkort/dsp Behringer DCX2496, högtalare Truth B3031A, Truth B2092A Har också Oscilloskop och mätmikrofon.

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Apr 2009
Skrivet av mrqaffe:

Ja datorn fattar det och den skiljer på anslutningarna, den stora frågan är egentligen om du talar om för respektive program vilken anslutning det ska använda till vad och att du inte kopplar nån loop som dödar nätverket osv.
Det brukar vara enklare att koppla allt via en "hemmarouter" än att konfa själv om det bara handlar om att få det att fungera och man inta har några krav på avancerade funktioner.

Ja se där, att tala om för programmet/spelet vad det ska använda för anslutning har jag icke gjort...

Har en taskig router som följde med bredbandet via Bredbandsbolaget. en Zyxel router som inte riktigt är vad jag önskar av en router. Så har väll blivit lite "rädd" för att strula med den om ej nödvändigt.

Trädvy Permalänk
Rekordmedlem
Plats
Salstad
Registrerad
Feb 2009
Skrivet av ApeviaX:

Ja se där, att tala om för programmet/spelet vad det ska använda för anslutning har jag icke gjort...

Har en taskig router som följde med bredbandet via Bredbandsbolaget. en Zyxel router som inte riktigt är vad jag önskar av en router. Så har väll blivit lite "rädd" för att strula med den om ej nödvändigt.

Men den ska bara agera switch och dhcpserver i lanet, det sker ingen routing inom samma nät och behöver du flera portar kan du köra via en switch.

Phenom 2 960T (körs x6) med passivt Ninja på Asus Crosshair 4 Asus 4850 och en väldig massa masslagring.Passiv kyld Northq nätdel 450W Antec P 180 med Schyte o Sharkoon fläktar via en t-balancer, väldigt tyst, oftast passivt. Datorljud 2kanal: ljudkort/dsp Behringer DCX2496, högtalare Truth B3031A, Truth B2092A Har också Oscilloskop och mätmikrofon.