SSD i RAID0 långsammare än ensam SSD

Trädvy Permalänk
Medlem
Plats
På snedden i Dirty South
Registrerad
Dec 2001

SSD i RAID0 långsammare än ensam SSD

Jag köpte igår en Samsung 850 PRO i tanken att sätta den i RAID0 med min 840 PRO (båda 128 GB).
Efter installation av Windows 10 märkte jag att jag fick sämre benchmarks än tidigare med den ensamma 840n, och tänkte då att felet låg i att Windows 10 inte är färdigutvecklat.

Så jag installerade Windows 7 igen, men prestandan är ungefär halverad mot vad jag tidigare fick med den ensamma 840n.
Vad kan detta bero på?

Så här ser det ut nu:

Så här ser det ut med en ensam disk, efter ett tags användning t.om:

Båda diskarna körs på Intels SATA III-kontakter, RAID0 är satt i BIOS, sladdarna är nya och fräscha, har kört diskkontroll både genom RST och Windows utan anmärkning.
Prefetch är av, ReadyBoost är av, temp & växlingsfil ligger på en mekanisk HDD (så hade jag det innan jag formaterade, utan prestandaförlust), defragmentering är av, energialternativet är hög prestanda, inget viloläge eller skärmsläckare, senaste drivers från Intel både till RAID (RST) och chipset, cachen är satt till write-back i RST och avstängd i Enhetshanteraren.
Fler tips?

Relevant(?) hårdvara:
ASUS P8H67-M
Intel i5 2500K
XFX AMD R9 280 DD 3 GB
Corsair HX520W
Samsung 840 PRO 128 GB
Samsung 850 PRO 128 GB
Western Digital Black 1 TB

Jag rear ut min själ, allt ska bort - - Fractal Design Define R3 | Corsair RM750i | Corsair H100i GTX & 2 x Noctua NF-F12 PWM | XFX DD R9 280 3GB & Sapphire Dual-X R9 280X 3GB OC | 840 PRO 128 GB + 850 PRO 128 GB + Spinpoint F3 1 TB + NETGEAR ReadyNAS RN204 2x8 + 2x6 TB RAID5 & Synology DS216se 2x3 TB JBOD | BenQ XL2411T + AOC E2461FWH + AOC E2476VWM6 | Corsair Gaming Strafe RGB Cherry MX Red + Logitech G502 | ASUS FX502VM-DM265T/GL502-VMZ + 24 GB RAM + Intel 600p M.2 256 GB + 850 EVO 500 GB

Trädvy Permalänk
Medlem
Registrerad
Jun 2011

Har du testat din nya 850 pro ensam för att se att det inte är något problem med den?
Sen ska du ju tänka på att när du raidar 2 enheter med olika specs så är det alltid den långsammare som bestämmer takten.

Guide för felsökning av Bluescreen! (tack till m4goo2 som gjort denna)
Chassi: Antec Twelve Hundred | Moderkort: Asus z170-A | CPU: I7 6700K @ 4.7GHz | Corsair H80 | RAM-minnen: Corsair Vengeance LPX 16GB@2666MHz | GPU: MSI NVIDIA GTX 1070 Gaming G8 | Nätagg: EVGA SuperNova G2 750w | HDD: Samsung 850 EVO 500GB, OCZ Vertex3 120GB, 4x Seagate Barracuda Green 2TB, 1x Western Digital My Book 3TB, Western Digital My Book 4TB.

Trädvy Permalänk
Medlem
Plats
Plats
Registrerad
Jul 2008

jadu? själv har jag asus moderkort och kör intels IRST-driver.
13.2.4.1000 finns tydligen en nyare.

13.6.0.1002 heter den
https://downloadcenter.intel.com/product/55005/Intel-Rapid-St...-
Men felet borde va något annat än bara drivern, ganska stor skillnad på prestanda.
själv ligger jag på knappa 2000 i score med 2st 840.
så antingen är raid-controllen kass/sämre än vanligt eller så gillar inte diskarna att raidas.
finns inte så mycket att ställa in fel i raid-biosen imo.

Trädvy Permalänk
Medlem
Plats
På snedden i Dirty South
Registrerad
Dec 2001
Skrivet av TiasE:

Har du testat din nya 850 pro ensam för att se att det inte är något problem med den?
Sen ska du ju tänka på att när du raidar 2 enheter med olika specs så är det alltid den långsammare som bestämmer takten.

Ja men då borde den ju inte gå under vad den var på före formateringen.
Har så klart inte testat den nya disken, utgick från att den skulle vara felfri :/

Skrivet av fAkkFejz:

jadu? själv har jag asus moderkort och kör intels IRST-driver.
13.2.4.1000 finns tydligen en nyare.

13.6.0.1002 heter den
https://downloadcenter.intel.com/product/55005/Intel-Rapid-St...-
Men felet borde va något annat än bara drivern, ganska stor skillnad på prestanda.
själv ligger jag på knappa 2000 i score med 2st 840.
så antingen är raid-controllen kass/sämre än vanligt eller så gillar inte diskarna att raidas.
finns inte så mycket att ställa in fel i raid-biosen imo.

Får testa den också, men det känns skumt att det skulle vara drivern precis som du säger.

Jag rear ut min själ, allt ska bort - - Fractal Design Define R3 | Corsair RM750i | Corsair H100i GTX & 2 x Noctua NF-F12 PWM | XFX DD R9 280 3GB & Sapphire Dual-X R9 280X 3GB OC | 840 PRO 128 GB + 850 PRO 128 GB + Spinpoint F3 1 TB + NETGEAR ReadyNAS RN204 2x8 + 2x6 TB RAID5 & Synology DS216se 2x3 TB JBOD | BenQ XL2411T + AOC E2461FWH + AOC E2476VWM6 | Corsair Gaming Strafe RGB Cherry MX Red + Logitech G502 | ASUS FX502VM-DM265T/GL502-VMZ + 24 GB RAM + Intel 600p M.2 256 GB + 850 EVO 500 GB

Trädvy Permalänk
Medlem
Registrerad
Jun 2011
Skrivet av ZaInT:

Ja men då borde den ju inte gå under vad den var på före formateringen.
Har så klart inte testat den nya disken, utgick från att den skulle vara felfri :/

Nej den andra meningen var mest för info om du missat detta
Tycker du ska testa din 850 ensam för att se om den presterar som den ska för att utesluta fel på de individuella enheterna.

Guide för felsökning av Bluescreen! (tack till m4goo2 som gjort denna)
Chassi: Antec Twelve Hundred | Moderkort: Asus z170-A | CPU: I7 6700K @ 4.7GHz | Corsair H80 | RAM-minnen: Corsair Vengeance LPX 16GB@2666MHz | GPU: MSI NVIDIA GTX 1070 Gaming G8 | Nätagg: EVGA SuperNova G2 750w | HDD: Samsung 850 EVO 500GB, OCZ Vertex3 120GB, 4x Seagate Barracuda Green 2TB, 1x Western Digital My Book 3TB, Western Digital My Book 4TB.

Trädvy Permalänk
Medlem
Plats
På snedden i Dirty South
Registrerad
Dec 2001

Jag vet inte vad jag lyckades utöva för svart magi men jag ställde om cache-inställningarna till de som skulle ge dataintegritet istället för prestanda och helt plöstligt

Tycker att den understa poängen är låg men det kanske är jag som drömmer för mycket.
Tack för hjälpen iaf

Jag rear ut min själ, allt ska bort - - Fractal Design Define R3 | Corsair RM750i | Corsair H100i GTX & 2 x Noctua NF-F12 PWM | XFX DD R9 280 3GB & Sapphire Dual-X R9 280X 3GB OC | 840 PRO 128 GB + 850 PRO 128 GB + Spinpoint F3 1 TB + NETGEAR ReadyNAS RN204 2x8 + 2x6 TB RAID5 & Synology DS216se 2x3 TB JBOD | BenQ XL2411T + AOC E2461FWH + AOC E2476VWM6 | Corsair Gaming Strafe RGB Cherry MX Red + Logitech G502 | ASUS FX502VM-DM265T/GL502-VMZ + 24 GB RAM + Intel 600p M.2 256 GB + 850 EVO 500 GB

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Aug 2005
Skrivet av ZaInT:

Jag vet inte vad jag lyckades utöva för svart magi men jag ställde om cache-inställningarna till de som skulle ge dataintegritet istället för prestanda och helt plöstligt
http://i.imgur.com/GMHofUH.png

Tycker att den understa poängen är låg men det kanske är jag som drömmer för mycket.
Tack för hjälpen iaf

Tycker det ser ganska långsamt ut ändå?

Jag har ett par ganska gamla Intel SSDer i raid-0 som systemvolym och jag får dom här resultaten.

[Workstation] [i7 3770K | Sabertooth Z77 | EVGA GTX 1080 SC WC | AX1200 | 16GB DDR3 | 1TB 850 Evo]
[Server/NAS] [ESXi] [Xeon E3-1275 V3 | Silverstone DS380 | 16GB DDR3 ECC | 8 x WD RED 3TB | LSI MEGARAID 9271-8I]
[Bärbar] [Macbook Pro Retina 15 | 512GB SSD | 16GB Ram]

Trädvy Permalänk
Medlem
Registrerad
Jun 2011
Skrivet av ZaInT:

Jag vet inte vad jag lyckades utöva för svart magi men jag ställde om cache-inställningarna till de som skulle ge dataintegritet istället för prestanda och helt plöstligt
http://i.imgur.com/GMHofUH.png

Tycker att den understa poängen är låg men det kanske är jag som drömmer för mycket.
Tack för hjälpen iaf

Skrivet av wRRM:

Tycker det ser ganska långsamt ut ändå?

Jag har ett par ganska gamla Intel SSDer i raid-0 som systemvolym och jag får dom här resultaten.

http://i.imgur.com/GvfUTGN.png

Tycker också det känns som lite låga siffror, speciellt på write men även 4k read med tanke på att det ju är 2 enheter i raid.
Vet inte exakt hur 840 Pro ligger till i AS SSD i vanliga fall men dina siffror känns låga, är inte insatt i degrationen i 840-serien men påverkar den även Pro modellen? Kanske kan vara läge för en firmware uppdatering oavsett.

Nu presterar visserligen större SSD bättre än de mindre men tycker ändå siffrorna dina känns låga.
Är precis hemkommen med en ny 850 Evo som är snäppet långsammare än 850 Pro och här är mina resultat (ej raid)

Guide för felsökning av Bluescreen! (tack till m4goo2 som gjort denna)
Chassi: Antec Twelve Hundred | Moderkort: Asus z170-A | CPU: I7 6700K @ 4.7GHz | Corsair H80 | RAM-minnen: Corsair Vengeance LPX 16GB@2666MHz | GPU: MSI NVIDIA GTX 1070 Gaming G8 | Nätagg: EVGA SuperNova G2 750w | HDD: Samsung 850 EVO 500GB, OCZ Vertex3 120GB, 4x Seagate Barracuda Green 2TB, 1x Western Digital My Book 3TB, Western Digital My Book 4TB.

Trädvy Permalänk
Rekordmedlem
Plats
Salstad
Registrerad
Feb 2009

Det är inte så att du mäter med och utan rapid mode ? Samsung har ju gjort en ramdiskcache och du kanske ändrar den ?

Phenom 2 960T (körs x6) med passivt Ninja på Asus Crosshair 4 Asus 4850 och en väldig massa masslagring.Passiv kyld Northq nätdel 450W Antec P 180 med Schyte o Sharkoon fläktar via en t-balancer, väldigt tyst, oftast passivt. Datorljud 2kanal: ljudkort/dsp Behringer DCX2496, högtalare Truth B3031A, Truth B2092A Har också Oscilloskop och mätmikrofon.

Trädvy Permalänk
Medlem
Plats
På snedden i Dirty South
Registrerad
Dec 2001
Skrivet av wRRM:

Tycker det ser ganska långsamt ut ändå?

Jag har ett par ganska gamla Intel SSDer i raid-0 som systemvolym och jag får dom här resultaten.

http://i.imgur.com/GvfUTGN.png

Skrivet av TiasE:

Tycker också det känns som lite låga siffror, speciellt på write men även 4k read med tanke på att det ju är 2 enheter i raid.
Vet inte exakt hur 840 Pro ligger till i AS SSD i vanliga fall men dina siffror känns låga, är inte insatt i degrationen i 840-serien men påverkar den även Pro modellen? Kanske kan vara läge för en firmware uppdatering oavsett.

Nu presterar visserligen större SSD bättre än de mindre men tycker ändå siffrorna dina känns låga.
Är precis hemkommen med en ny 850 Evo som är snäppet långsammare än 850 Pro och här är mina resultat (ej raid)
http://i.imgur.com/1N0Ek9n.png

Nej, PRO-modellerna lider inte av någon degradering eller problem som EVO-serien gjorde. Båda diskar har ändå senaste firmware.
Disken ensam ser ni på översta bilden, då tyckte jag iallafall att den fungerade bra men det är mycket möjligt att den kunde fungerat ännu bättre.
Men ja, 840 PRO 128 GB är specad till 390 MB/s skrivhastighet, så visst är det väl lite lågt egentligen.
Frågan är bara vad man gör åt detta, förutom den uppenbara lösningen att strunta i RAID.

Skrivet av mrqaffe:

Det är inte så att du mäter med och utan rapid mode ? Samsung har ju gjort en ramdiskcache och du kanske ändrar den ?

Man kan inte aktivera RAPID överhuvudtaget när man kör RAID, Samsung Magician kan inte ens ändra Windowsinställningar av någon anledning.

Jag rear ut min själ, allt ska bort - - Fractal Design Define R3 | Corsair RM750i | Corsair H100i GTX & 2 x Noctua NF-F12 PWM | XFX DD R9 280 3GB & Sapphire Dual-X R9 280X 3GB OC | 840 PRO 128 GB + 850 PRO 128 GB + Spinpoint F3 1 TB + NETGEAR ReadyNAS RN204 2x8 + 2x6 TB RAID5 & Synology DS216se 2x3 TB JBOD | BenQ XL2411T + AOC E2461FWH + AOC E2476VWM6 | Corsair Gaming Strafe RGB Cherry MX Red + Logitech G502 | ASUS FX502VM-DM265T/GL502-VMZ + 24 GB RAM + Intel 600p M.2 256 GB + 850 EVO 500 GB

Trädvy Permalänk
Medlem
Plats
Norrköping
Registrerad
Jul 2006

Set att du kör H67 moderkort. Kom ihåg att TRIM inte fungerar under raid på dessa.

R5-1600X, GA-AB-350M-G3, 16GB DDR4 @ 2666, HD7970, Corsair CX650M Rev2

Trädvy Permalänk
Medlem
Registrerad
Jun 2011
Skrivet av ZaInT:

Nej, PRO-modellerna lider inte av någon degradering eller problem som EVO-serien gjorde. Båda diskar har ändå senaste firmware.
Disken ensam ser ni på översta bilden, då tyckte jag iallafall att den fungerade bra men det är mycket möjligt att den kunde fungerat ännu bättre.
Men ja, 840 PRO 128 GB är specad till 390 MB/s skrivhastighet, så visst är det väl lite lågt egentligen.
Frågan är bara vad man gör åt detta, förutom den uppenbara lösningen att strunta i RAID.

Har ingen bra lösning tyvärr, men du kommer inte märka någon skillnad vid vardaglig användning ändå även om du skulle få upp de syntetiska siffrorna dit de borde vara.
Men trots det kan man ju tycka att 2 raidade enheter borde klå en ensam i mer än bara sekventiell läsning.

Guide för felsökning av Bluescreen! (tack till m4goo2 som gjort denna)
Chassi: Antec Twelve Hundred | Moderkort: Asus z170-A | CPU: I7 6700K @ 4.7GHz | Corsair H80 | RAM-minnen: Corsair Vengeance LPX 16GB@2666MHz | GPU: MSI NVIDIA GTX 1070 Gaming G8 | Nätagg: EVGA SuperNova G2 750w | HDD: Samsung 850 EVO 500GB, OCZ Vertex3 120GB, 4x Seagate Barracuda Green 2TB, 1x Western Digital My Book 3TB, Western Digital My Book 4TB.

Trädvy Permalänk
Medlem
Plats
Plats
Registrerad
Jul 2008
Skrivet av ZaInT:

Nej, PRO-modellerna lider inte av någon degradering eller problem som EVO-serien gjorde. Båda diskar har ändå senaste firmware.
Disken ensam ser ni på översta bilden, då tyckte jag iallafall att den fungerade bra men det är mycket möjligt att den kunde fungerat ännu bättre.
Men ja, 840 PRO 128 GB är specad till 390 MB/s skrivhastighet, så visst är det väl lite lågt egentligen.
Frågan är bara vad man gör åt detta, förutom den uppenbara lösningen att strunta i RAID.

Man kan inte aktivera RAPID överhuvudtaget när man kör RAID, Samsung Magician kan inte ens ändra Windowsinställningar av någon anledning.

Exakt rätt, en raid0 array syns inte ens i magician.

Skrivet av ZaInT:

Jag vet inte vad jag lyckades utöva för svart magi men jag ställde om cache-inställningarna till de som skulle ge dataintegritet istället för prestanda och helt plöstligt
http://i.imgur.com/GMHofUH.png

Tycker att den understa poängen är låg men det kanske är jag som drömmer för mycket.
Tack för hjälpen iaf

Själv har jag mina 840s i en annan del av forumet som du får länk till ifall du vill jämföra lite siffror.
Men är oxå större diskar som ger mer krut.
#14975389

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Maj 2014

Det låter som att något päron till SSD inte gillar att bli sammankopplade till ett äpple/banad eller mandarin till SSD. De två 850 och 840 skiljer sig rätt mycket under huven.
Att RAIDa 2 olika gen diskar brukar ofta bli dåligt, då de har olika IOPs, olika kontrollers, olika Cache, olika TRIM/GC funktioner och olika bandbredd till NAND.

Personligen anser jag att man inte bör köpa någon 120/128GB SSD idag, om man har råd med större. Och en 250GB mellan-klass SSD är smartare val än 850 PRO 128GB, om du inte specifikt måste ha "just den".
Tom att köpa en begagnad 128GB 840 PRO hade varit bättre alternativ i detta fallet, imho.

Du kan testa andra stripe storlekar, byta plats på diskarna, byta Sata kablar till diskarna osv.
Men jag hade iaf börjat med att verifiera hur bra de fungerar som individuella diskar, för vad för spec Samsung ger, stämmer bara om resten av din dators moderkort/kontroller mm klarar av det.