Partition vägrar få enhetsbokstav *LÖST*

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Maj 2014

Partition vägrar få enhetsbokstav *LÖST*

Jag har stött på ett mycket underligt fel, och tyckts inte få rätta på det, så jag vädrar till super guru:na där ute...
Informationen är inte kritiskt, utan det är spel, nerladdningar och cache partition. Jag vill dock undvika formatera om den om jag måste.

Det hela började med att en ssd som tillsammans med VeloSSD (mjukvara) låg och cachade denna partition. Jag råkade komma åt Sata kablaget och systemdisken hängde sig. Inget direkt problem, jag startade om och datorn starta upp, (med D: disken intakt), men cache SSDn hade då råkat hoppat loss, så jag stänger av igen. Jag fixade dem och har nu tömt dem för jag skulle ha 2 st i RAID istället.

När jag kom tillbaka till Windows så är D: disken borta... jag tänker, skumt. Den ser intakt ut, men vill inte få enhetsbokstav.
Kort sagt, jag har testat avinstallera cachen, använda 3:e part partitionsprogram och får den inte att fungera.
Dock kan jag i minitool partition wizard se allt på partitionen, så de verkar intakt.

Jag noterade att i diskpart (kommando fönstret) så var den först "hidden". Så jag lyckades ta bort detta med minitool part...

Fortfarande vill den inte. Försöker jag med assign i diskpart får jag felmeddelande (se bilderna). Försöker jag med 3:e part verktyg, så säger den allt genomfört, men disken får ingen enhetsbeteckning. Jag har även testat andra bokstäver än D: och det vill inte heller. MiniTool hittar inga "fel" på något heller. Notera att systemet har kört RAID läge i flera månader, så det är inget AHCI/RAID fel. Windows och systemdisken fungerar fint.
Här är lite detaljer och bilder så ni kanske få förståelse:

Blir någon klok på detta?

Får jag inte rätta på det så får jag väl se om jag kan köra recovery så jag iaf slipper ladda ner alla spel igen och sen ta bort/formatera partitionen. Men det är värt en fråga till kunnigt folk här först

Trädvy Permalänk
Medlem
Plats
Finspång
Registrerad
Okt 2003

Du har ju inte valt nån disk i diskpart. Står i felmeddelandet

Prova med "Select volume 4" och sedan "assign letter=D"

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Maj 2014
Skrivet av niclasc:

Du har ju inte valt nån disk i diskpart. Står i felmeddelandet

Prova med "Select volume 4" och sedan "assign letter=D"

Jag har valt partition 1, kolla på list partition, du ser * där.
Volym 4 är E: disken. Jag kan inte välja något annat... :=/

Men du har en poäng, verkar som jag inte kan välja den... vilket är skumt.

EDIT: @niclasc du fick mig att snubbla på något väldigt konstigt, och mycket väl grunden till felet.
Jag kan inte ens välja disken och ta egenskaper, något man kan på allt och alla andra partitioner.
Gör jag det får jag samma fel som i den grafiska versionen ovan.

Något måste vara fel i nån referens som ska "peka" på partitionen...

Jag letar vidare

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Maj 2014

Tack @niclasc din kommentar fick mig faktiskt på rätt spår.

Jag hittade "felet". Exakt varför vet jag inte, men volymen hade inte installerats rätt i enhetshanteraren. Därför vägrade den göra något. Jag tog bort "allmän volym" med fel ikon och även HDDn i enheter (bara för att), startade om, och tada... D: fungerar som den ska igen.

Råkade komma in på denna sida:
https://support.microsoft.com/en-us/kb/2001877

Kan mycket väl varit så att något med cachen fubara detta, men strunt samma, nu fungerar det