Två SSD med olika OS, kan ej ta bort ena?

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Apr 2007

Två SSD med olika OS, kan ej ta bort ena?

Denna tråd kan väl även ligga under både stationär/support och Mjukvara/Windows, men här känns väl "mest rätt" antar jag.

När jag startat Windows senaste tiden har datorn sackat ihop ett par sekunder efter uppstart, dvs den man kom till skrivbordet och sedan var det kört. Efter idelt problemlösande i cmd, där bland annat "scanning" av hårddiskarna avbröts av oklar anledning kom jag fram till att det antagligen var något fel på min OS-SSD. Bestämde mig därför för att blåsa hela skiten och installera om på nytt, om det gick, vilket det gjorde. Fick tag på ett bootbart USB med W8 som hjälpte mig på vägen.

Jag vill dock ha W7 så tog samma USB-minne och laddade det med W7 istället, och eftersom min OS-SSD tidigare varit lite opålitlig så tänkte jag istället installera 7an på min andra SSD som tidigare använts bara för installationer av större programvara och spel.

När jag sedan ville formatera den SSD med W8 gick inte detta, den listades inte ens vid installationen som ett möjligt alternativ till att installera W7 på. Tänkte "aja, kan väl göra det sen istället". Så nu har jag ett fungerande W7 och vill istället ha min tidigare SSD (nu med W8 på) som lagringsenhet. Problemet är att jag inte tillåts att formatera den, alternativet är "gråat" i diskhanteringen. Jag vill ha W7-disken som C:/ och jag kan ändra W8-disken från C:/ till någonting annat men tillåts inte ändra W7-disken till C:/ utan får ett felmeddelande.

En annan finess är att ifall jag har W7-disken som nummer 1 i bootprioriteringen i BIOS så påstår datorn att det inte finns något operativsystem. Om jag istället tar W8-disken som nummer 1 startar datorn och jag får därefter välja mellan att ladda in W7 eller W8.

Så det verkar på något sett som att datorn tror att jag vill ta bort "det enda operativsystemet" när jag vill formatera disken? Eller vad kan det vara?

Tack på förhand.

Trädvy Permalänk
Hjälpsam
Plats
Karlskoga
Registrerad
Jan 2007
Skrivet av bingoberra:

Denna tråd kan väl även ligga under både stationär/support och Mjukvara/Windows, men här känns väl "mest rätt" antar jag.

När jag startat Windows senaste tiden har datorn sackat ihop ett par sekunder efter uppstart, dvs den man kom till skrivbordet och sedan var det kört. Efter idelt problemlösande i cmd, där bland annat "scanning" av hårddiskarna avbröts av oklar anledning kom jag fram till att det antagligen var något fel på min OS-SSD. Bestämde mig därför för att blåsa hela skiten och installera om på nytt, om det gick, vilket det gjorde. Fick tag på ett bootbart USB med W8 som hjälpte mig på vägen.

Jag vill dock ha W7 så tog samma USB-minne och laddade det med W7 istället, och eftersom min OS-SSD tidigare varit lite opålitlig så tänkte jag istället installera 7an på min andra SSD som tidigare använts bara för installationer av större programvara och spel.

När jag sedan ville formatera den SSD med W8 gick inte detta, den listades inte ens vid installationen som ett möjligt alternativ till att installera W7 på. Tänkte "aja, kan väl göra det sen istället". Så nu har jag ett fungerande W7 och vill istället ha min tidigare SSD (nu med W8 på) som lagringsenhet. Problemet är att jag inte tillåts att formatera den, alternativet är "gråat" i diskhanteringen. Jag vill ha W7-disken som C:/ och jag kan ändra W8-disken från C:/ till någonting annat men tillåts inte ändra W7-disken till C:/ utan får ett felmeddelande.

En annan finess är att ifall jag har W7-disken som nummer 1 i bootprioriteringen i BIOS så påstår datorn att det inte finns något operativsystem. Om jag istället tar W8-disken som nummer 1 startar datorn och jag får därefter välja mellan att ladda in W7 eller W8.

Så det verkar på något sett som att datorn tror att jag vill ta bort "det enda operativsystemet" när jag vill formatera disken? Eller vad kan det vara?

Tack på förhand.

För det första verkar det som att Windows laggt in en bootloader på den disk som har ditt gamla operativsystem, BIOS börjar alltså ladda denna för att senare börja ladda den med W7.
Ett tips är att koppla in den din OS-disk på SATA 0 och koppla bort alla andra diskar innan installation.

För att ta bort en gammal Windowskatalog, döp om den till Windows.old, då bör du kunna ta bort den.

Mitt råd är att koppla bort alla diskar utom OS-disken, se till att den ligger på SATA0 och installera om W7.

Om den kan vara någon tröst, jag har gått på samma mina som du har.

AMD Ryzen 7 1700 | https://valid.x86.fr/bvpyq6 | Stockkylaren | Bitfenix Whisper M 750W | Corsair 600T Graphite vit.
AMD FX8350 | https://valid.x86.fr/0q5pkm | Cooler Master V 700W | 32 GB ECC-Minnen.
HTPC | https://valid.x86.fr/ez1zxw |

Trädvy Permalänk
Medlem
Plats
Örnsköldsvik
Registrerad
Aug 2006

@bingoberra: Om du hade båda SSD inkopplad under Windows 7 installationen så lägger installationen bootfler (MBR) för W7 på den den första windows installationen som finns i datorn och i ditt fall är det W8 installationen, och det gör att du inte kan boota W7 om SSD med W8 är från kopplad och du kan inte formatera W8 SSD:n eftersom W7 använder bootfilerna som ligger på W8 SSD.n.

Detta problem kan man undvika genom att endast ha en SSD/HDD inkopplad när man gör en windows installation.

Om du inte vill göra en ny W7 installationen så kan du testa att fixa MBR för W7 genom att koppla bort SATA kabeln till W8 SSD:n. boota sedan USB minnet som innehåller W7 installationsfilerna och när skärmbilden Installera nu kommer upp så väljer du att klicka på “Repair your computer” och välj sedan Startup Repair som är det tredje alternativet (Using the Automated Startup Repair) på denna sida http://www.howtogeek.com/howto/32523/how-to-manually-repair-w...

Det är mycket möjligt att du måste köra 3 st Startup Repair med omstart av datorn mellan varje reparation för att fixa MBR för din W7 installation.

janee

Trädvy Permalänk
Hjälpsam
Plats
Karlskoga
Registrerad
Jan 2007

@janee: Ja att försöka reparera är onekligen ett bra tips, borde jag tänkt på.

AMD Ryzen 7 1700 | https://valid.x86.fr/bvpyq6 | Stockkylaren | Bitfenix Whisper M 750W | Corsair 600T Graphite vit.
AMD FX8350 | https://valid.x86.fr/0q5pkm | Cooler Master V 700W | 32 GB ECC-Minnen.
HTPC | https://valid.x86.fr/ez1zxw |

Trädvy Permalänk
Medlem
Plats
Örnsköldsvik
Registrerad
Aug 2006
Skrivet av Ratatosk:

@janee: Ja att försöka reparera är onekligen ett bra tips, borde jag tänkt på.

Om windows installationen bara är någon dag gammal så hade jag valt en ny installation eftersom det inte är helt säkert att reparationen fungerar.

@bingoberra: Man kan även göra partitionen Active som Windows 7 ligger på innan reparationen för att underlätta reparationen http://www.sevenforums.com/tutorials/71432-partition-mark-act...

janee

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Apr 2007

@janee:

Tack för alla svar. Jag tog mitt USB men datorn ville inte boota det, vetefan varför då det fungerade innan. Ska göra om den och se ifall det fungerar, blev sent igår så orkade inte fixa. Försökte med en fullösning och installerade W7 (från USB men genom att gå via "den här datorn") på den disk med W8 för att på så sätt göra den andra SSDn "den första", men inte helt oväntat fungerade det inte :p. Ska göra nya försök med mitt USB ikväll.

Edit: For the record så fixade jag mitt USB, bootade och formaterade båda diskarna. Stängde av och kopplade ur ena samt installerade W7 på nytt. Nu verkar allt vara i sin ordning (reparation fungerade inte).

Tack för all hjälp!