Android studio, varför kan jag inte refera till mina strängar?

Trädvy Permalänk
Medlem
Plats
Skåne
Registrerad
Jan 2011

Android studio, varför kan jag inte refera till mina strängar?

Håller för första gången på med Android Studio och tror jag blir tokig snart. Vad jag har förstått så ska jag deklarera Strängar i Strings.xml, något i den här stilen:

<String name="what_to_do">Att starta en Activity</String>

Sedan har jag lagt in en textview i content_how_to-xml med texten @string /what_to_do
Men detta ger mig ett fel som säger att det är en unknown resource type.

Värt att nämna att ifall jag gör likadant med t ex en knapp funkar det alldeless utmärkt.

Asrock P67 Extreme 4 | i5 2500K@4,5Ghz | Asus GTX 970 black | 2x Intel 520 180gb, 2x WD blue 5tb | 8GB Corsair XMS3 + 8GB Hyper x Fury | EVGA Supernova G2 750W Gold | Silverstone FT02

https://prism-break.org/sv/

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Apr 2006

Har du testat göra en sökning?
http://developer.android.com/guide/topics/resources/string-re...
http://developer.android.com/guide/topics/resources/accessing...

Om du är ny så kan det vara värt att läsa på lite innan du börjar koda så du vet grundprinciperna.

INTEL CORE I7 3930K 3.20GHZ 12MB S-2011, FRACTAL DESIGN MIDITOWER DEFINE R3, CORSAIR HX 1050W, ASUS RAMPAGE IV FORMULA, Asus STRIX GTX970, CORSAIR 16GB DDR3 DOMINATOR QUAD 1866MHZ CL9 (4X4GB) Ljud: ASUS Xonar D2X/XDT 7.1 | Elac 5.1 +förstärkare | Cambridge dacmagic plus | Astro gaming A40 | Sennheiser HD 650
You ask me if I have a god complex? Let me tell you something, I am god!

Trädvy Permalänk
Medlem
Plats
Skåne
Registrerad
Jan 2011
Skrivet av IceDread:

Har du testat göra en sökning?
http://developer.android.com/guide/topics/resources/string-re...
http://developer.android.com/guide/topics/resources/accessing...

Om du är ny så kan det vara värt att läsa på lite innan du börjar koda så du vet grundprinciperna.

Ja och jag vet hur det fungerar. Dock förstår jag inte varför det fungerar ibland.

Asrock P67 Extreme 4 | i5 2500K@4,5Ghz | Asus GTX 970 black | 2x Intel 520 180gb, 2x WD blue 5tb | 8GB Corsair XMS3 + 8GB Hyper x Fury | EVGA Supernova G2 750W Gold | Silverstone FT02

https://prism-break.org/sv/

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Apr 2006
Skrivet av Baxtex:

Ja och jag vet hur det fungerar. Dock förstår jag inte varför det fungerar ibland.

Jag har aldrig haft problem med det.
Om du däremot tex har flera språk och har en basfil på tex engelska som saknar en rad som finns i tex en _sv fil så kan det bli knas.
Får du några warnings i android studio? De brukar kunna hjälpa till.

INTEL CORE I7 3930K 3.20GHZ 12MB S-2011, FRACTAL DESIGN MIDITOWER DEFINE R3, CORSAIR HX 1050W, ASUS RAMPAGE IV FORMULA, Asus STRIX GTX970, CORSAIR 16GB DDR3 DOMINATOR QUAD 1866MHZ CL9 (4X4GB) Ljud: ASUS Xonar D2X/XDT 7.1 | Elac 5.1 +förstärkare | Cambridge dacmagic plus | Astro gaming A40 | Sennheiser HD 650
You ask me if I have a god complex? Let me tell you something, I am god!

Trädvy Permalänk
Medlem
Plats
Skåne
Registrerad
Jan 2011
Skrivet av IceDread:

Jag har aldrig haft problem med det.
Om du däremot tex har flera språk och har en basfil på tex engelska som saknar en rad som finns i tex en _sv fil så kan det bli knas.
Får du några warnings i android studio? De brukar kunna hjälpa till.

Jag lyckades lösa det tillslut, jag hade lyckats skriva ett stort S istället för ett litet. Jag är van vid Eclipse och Android Studio är inte lika hjälpande. Vissa saker rödmarkererar den men inte allt.

Asrock P67 Extreme 4 | i5 2500K@4,5Ghz | Asus GTX 970 black | 2x Intel 520 180gb, 2x WD blue 5tb | 8GB Corsair XMS3 + 8GB Hyper x Fury | EVGA Supernova G2 750W Gold | Silverstone FT02

https://prism-break.org/sv/