IIS, microsoft sql server express 2014 & PHP

Trädvy Permalänk
Medlem
Plats
Piteå
Registrerad
Okt 2004

IIS, microsoft sql server express 2014 & PHP

Jag håller på att koda en egen blogg, modell simpel. Allting fungerar i princip. Men då jag hämtar information från databasen till min sida så blir åäö till �.... Då jag kollar i microsoft sql server management studio så är det lagrat rätt, varför blir det inte rätt när jag plockar ner informationen?

Försökt googla fram nånting vettigt, men alla poster handlar om MysQL i princip...

CPU: AMD Ryzen 1700x @ 3.8GHz || Mem: 16GB Corsair LPX 3000mhz || Mobo: Asus x370 Prime || GPU: EVGA Geforce GTX1070 SC || SSD: WD black 500GB m2 || OS: Linux Mint/Win 10 || Monitor: Dell 43" 4K P4317Q

Citera om du vill ha svar :)

Trädvy Permalänk
Medlem
Plats
i din garderob
Registrerad
Sep 2007
Skrivet av pellski87:

Jag håller på att koda en egen blogg, modell simpel. Allting fungerar i princip. Men då jag hämtar information från databasen till min sida så blir åäö till �.... Då jag kollar i microsoft sql server management studio så är det lagrat rätt, varför blir det inte rätt när jag plockar ner informationen?

Försökt googla fram nånting vettigt, men alla poster handlar om MysQL i princip...

Innehållet i din databas har teckenkodning ISO-8859-1 eller Windows-1252, men din server säger att informationen är i UTF-8. Rekommendationen är att du ställer om din databas så den sparar data i UTF-8.

Bilanaloger är som Volvo — varenda svenne kör med dem

Trädvy Permalänk
Medlem
Plats
Piteå
Registrerad
Okt 2004
Skrivet av Teknocide:

Innehållet i din databas har teckenkodning ISO-8859-1 eller Windows-1252, men din server säger att informationen är i UTF-8. Rekommendationen är att du ställer om din databas så den sparar data i UTF-8.

AA förstår det är nå sånt, hur tusan gör jag det? Har inte hittat det nånstans...

CPU: AMD Ryzen 1700x @ 3.8GHz || Mem: 16GB Corsair LPX 3000mhz || Mobo: Asus x370 Prime || GPU: EVGA Geforce GTX1070 SC || SSD: WD black 500GB m2 || OS: Linux Mint/Win 10 || Monitor: Dell 43" 4K P4317Q

Citera om du vill ha svar :)

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Maj 2009
Skrivet av pellski87:

AA förstår det är nå sånt, hur tusan gör jag det? Har inte hittat det nånstans...

Min dator: Silent Base 600 | 1700X @ 3.9Ghz | MSI Gaming X 1080TI | RM750X | 512Gb M2 | 16Gb 3200mhz Ram | S34E790C @ 3440x1440
Tjejens dator: Define r4 | i5 3570k @ 4.2ghz | GTX Titan | 750w Supernova | 240gb SSD | 32gb ram
Citera/Tagga för svar!

Trädvy Permalänk
Medlem
Plats
Piteå
Registrerad
Okt 2004

Finns inte... finns bara Finnish_swedish_CI_AS osv osv

CPU: AMD Ryzen 1700x @ 3.8GHz || Mem: 16GB Corsair LPX 3000mhz || Mobo: Asus x370 Prime || GPU: EVGA Geforce GTX1070 SC || SSD: WD black 500GB m2 || OS: Linux Mint/Win 10 || Monitor: Dell 43" 4K P4317Q

Citera om du vill ha svar :)

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Maj 2009
Skrivet av pellski87:

Finns inte... finns bara Finnish_swedish_CI_AS osv osv

precis, så som jag visade ska de se ut. du sparar i iso-8859-1, du ska spara i utf8

Min dator: Silent Base 600 | 1700X @ 3.9Ghz | MSI Gaming X 1080TI | RM750X | 512Gb M2 | 16Gb 3200mhz Ram | S34E790C @ 3440x1440
Tjejens dator: Define r4 | i5 3570k @ 4.2ghz | GTX Titan | 750w Supernova | 240gb SSD | 32gb ram
Citera/Tagga för svar!

Trädvy Permalänk
Medlem
Plats
Piteå
Registrerad
Okt 2004
Skrivet av Christley:

precis, så som jag visade ska de se ut. du sparar i iso-8859-1, du ska spara i utf8

Jo jag förstår det, men utf-8 finns inte med i listan....

Visst förstår du att det inte är mysql jag använder va?

CPU: AMD Ryzen 1700x @ 3.8GHz || Mem: 16GB Corsair LPX 3000mhz || Mobo: Asus x370 Prime || GPU: EVGA Geforce GTX1070 SC || SSD: WD black 500GB m2 || OS: Linux Mint/Win 10 || Monitor: Dell 43" 4K P4317Q

Citera om du vill ha svar :)

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Maj 2009
Skrivet av pellski87:

Jo jag förstår det, men utf-8 finns inte med i listan....

Visst förstår du att det inte är mysql jag använder va?

ja, jag förstår det.
mssql använder utf8 per default, och kräver att du har nvarchar som storage för att kunna spara i unicode

Min dator: Silent Base 600 | 1700X @ 3.9Ghz | MSI Gaming X 1080TI | RM750X | 512Gb M2 | 16Gb 3200mhz Ram | S34E790C @ 3440x1440
Tjejens dator: Define r4 | i5 3570k @ 4.2ghz | GTX Titan | 750w Supernova | 240gb SSD | 32gb ram
Citera/Tagga för svar!

Trädvy Permalänk
Medlem
Plats
Piteå
Registrerad
Okt 2004
Skrivet av Christley:

ja, jag förstår det.
mssql använder utf8 per default, och kräver att du har nvarchar som storage för att kunna spara i unicode
http://puu.sh/n8HTy/3d5386f0c9.png

Jag har satt till nvarchar hade varchar tidigare men får ändå samma

CPU: AMD Ryzen 1700x @ 3.8GHz || Mem: 16GB Corsair LPX 3000mhz || Mobo: Asus x370 Prime || GPU: EVGA Geforce GTX1070 SC || SSD: WD black 500GB m2 || OS: Linux Mint/Win 10 || Monitor: Dell 43" 4K P4317Q

Citera om du vill ha svar :)

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jan 2004

Indikerar du på din sida att det är UTF8 som datan är i då?
Ex :

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

Trädvy Permalänk
Medlem
Plats
Piteå
Registrerad
Okt 2004
Skrivet av iXam:

Indikerar du på din sida att det är UTF8 som datan är i då?
Ex :

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

Jajjemän!

CPU: AMD Ryzen 1700x @ 3.8GHz || Mem: 16GB Corsair LPX 3000mhz || Mobo: Asus x370 Prime || GPU: EVGA Geforce GTX1070 SC || SSD: WD black 500GB m2 || OS: Linux Mint/Win 10 || Monitor: Dell 43" 4K P4317Q

Citera om du vill ha svar :)

Trädvy Permalänk
Medlem
Plats
Piteå
Registrerad
Okt 2004
Skrivet av Christley:

ja, jag förstår det.
mssql använder utf8 per default, och kräver att du har nvarchar som storage för att kunna spara i unicode
http://puu.sh/n8HTy/3d5386f0c9.png

Hittade felet: var tvungen att lägga till "CharacterSet" => "UTF-8" i min connection array

CPU: AMD Ryzen 1700x @ 3.8GHz || Mem: 16GB Corsair LPX 3000mhz || Mobo: Asus x370 Prime || GPU: EVGA Geforce GTX1070 SC || SSD: WD black 500GB m2 || OS: Linux Mint/Win 10 || Monitor: Dell 43" 4K P4317Q

Citera om du vill ha svar :)