Trädvy Permalänk
Medlem
Plats
I en mörk gränd
Registrerad
Okt 2001

Kan inte resolva lokala hostnames

Tjo
Mitt modem rasade här om dagen så jag köpt ett nytt (D-link dwr921) och började använda modemets inbyggda router ist för den raspberry pi med Open WRT jag kört tidigare. När jag fått upp den nya routern så märkte jag att jag inte kommer åt vissa maskiner via deras hostname. Förut kunde jag ansluta till "lillen", som är en ubuntu-burk men nu måste jag använda ip-numret. Min synology diskstation kommer jag fortfarande åt på "diskstation" vilket är lite märkligt. Vad kan det här bero på? Kan man göra nåt för att hostnames ska börja fungera igen?

"Say unto thine own heart, I am mine own redeemer"
Don't touch me when I'm crazy off that airplane glue

Trädvy Permalänk
Medlem
Registrerad
Mar 2012
Skrivet av DarkBob:

Tjo
Mitt modem rasade här om dagen så jag köpt ett nytt (D-link dwr921) och började använda modemets inbyggda router ist för den raspberry pi med Open WRT jag kört tidigare. När jag fått upp den nya routern så märkte jag att jag inte kommer åt vissa maskiner via deras hostname. Förut kunde jag ansluta till "lillen", som är en ubuntu-burk men nu måste jag använda ip-numret. Min synology diskstation kommer jag fortfarande åt på "diskstation" vilket är lite märkligt. Vad kan det här bero på? Kan man göra nåt för att hostnames ska börja fungera igen?

Du behöver en DNS för ditt hemmanät vilket nog saknas i din nya router.

Lättast är väl att köra din Pi som DNS samt editera din egna zon-fil. Alternativt fixa en router som stödjer det.

Trädvy Permalänk
Medlem
Registrerad
Dec 2008

en del saker stödjer netbios, dvs. din nas. Medan linuxburken inte gör det och kräver en intern DNS vilken din gamla router troligen hade.

Trädvy Permalänk
Inaktiv
Registrerad
Mar 2010

Finns rätt många sätt det där kan fungerat, exempelvis kan din DHCP server automatiskt lägga in ett record i WINS/NETBIOS/DNS-CACHE så fort den delar ut en IP adress då dhcp servern alltid får namnet på hosten när en gör en DHCP fråga.