IPTV tillsammans med netgear switch med vlan funkar inte

Trädvy Permalänk
Medlem
Registrerad
Dec 2016

IPTV tillsammans med netgear switch med vlan funkar inte

Hej,

Jag hoppas någon kan hjälpa mig lite här. Jag har sökt och hittat en del trådar om detta men får det inte att fungera.

Vad jag vill är i korta drag ha både internet och IPTV via en enda fast cat5e-kabel från tvättstugan till vårt vardagsrum. Telia har dragit in fibern till en Inteno tjänstefördelare där tele, tv och internet kommer ut på olika utgångar. Tydligen kommer all trafik (inkl vlan) ut även på internet (enligt andra forum) och man ska där kunna suga ur tele (ointressant) och IPTV på separata VLAN (845 eller 243). Jag köpte därför en netgear gs-108Ev3 switch som stödjer vlan och IGMP multicasting.

Efter att följt flera guider och misslyckats med att få någonting till TV:n börjar jag misströsta. Därför testade jag att fabriksreseta switchen och koppla Intenons IPTV-utgång -> switch -> TV-box. Inte ens då får jag någon connection. TV-boxen säger bara att den inte är ansluten bla bla bla.

I övrig har jag testat att koppla som den här guiden beskriver http://hb-ios.blogspot.se/2013/12/att-bli-fri-fran-telia-smar... vilket jag tycker verkar vara logiskt att det bör fungera (om något ska fungera alltså).

Vi har bredband och TV via Viasat kan jag tillägga om det på något sätt ger några ledtrådar.

Måste switchen ha fast ip-adress? Ska den ligga på samma subnät som gateway (som jag får hårdkoda in i så fall. Kommer inte åt switchen efter utan att reseta den efter det)?
Låser sig TV-boxen mot tjänsteleverantörens lådor på något sätt och det är därför det inte fungerar att stoppa in något emellan?
Skulle det fungerar bättre med en Asus router som är förberedd för IPTV?

Jag kikade lite på trafiken i wireshark och såg att det kommer några förfrågningar om broadcast membership med IGMP och ICMP (har jag för mig). Sabbar mellanliggande burkar responsen på dessa så att inte telias/viasats burkar kör igång broadkasten till min TV-box? Eller är det så att broadcasten på något sätt kräver att Intenons TV-utgång används?

Många frågor blir det, jag hoppas någon vänligt person har några bra tips.

Trädvy Permalänk
Medlem
Registrerad
Apr 2014

hej jag har oxå internet och IPTV från telia.

jag har kopplat så här

Internet: Inteno (internet port) ------> Roouter ------> Netgear switch

IPTV: Inteno (IPTV port gul tror jag) --------> netgear switch (samma som efter Router) ottaggad Vlan 100 ---------> TV taggad vlan 100

du behöver inte ha vlan 845 eftersom du har Inteno switch du kan ha vilken vlan du vill

edit:
förlåt såg nu att du hade Viasat men det ska nog fungera som telia....

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jun 2007

@patrick356: Har du kollat med Telias kundtjänst, så att allt är OK med kopplingarna i Inteno-burken?

Det är konstigt att du inte får bild på boxen med bara switchen mellan tjänstefördelaren och Viasat-boxen. Har du testat att köra kabel direkt från Intenons TV-utgång till boxen? Om inte det funkar så är nog felet i tjänstefördelaren. Är det ett nytt abonnemang, kanske inte är aktiverat i alla led ännu?

Trädvy Permalänk
Medlem
Registrerad
Dec 2016

@es0n: Jodå, det fungerar med sladd direkt från TV-porten på Intenon. Men inte när jag kopplar switchen emellan TV-port och TV-box vilket jag tycker jättekonstigt. Switchen tillför ju inte så mycket då men det borde i alla fall fungera tycker jag.

Trädvy Permalänk
Medlem
Registrerad
Dec 2016

@dbeg: Tack för tipset, ska testa den varianten också. Fast jag blir lite skeptisk när det inte ens fungerar med Inteno tv-port -> okonfad switch -> TV-box. Det fungerar när man kör sladd direkt från Inteno tv-port -> TV-box. Switchen påverkar på något sätt som jag inte förstår.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jun 2007
Trädvy Permalänk
Medlem
Registrerad
Jun 2005

Du måste aktivera igmp snooping i switchen.
Kopplar du via den gula porten behöver du inte bry dig om vlan 845. En helt vanlig unmanaged switch ska fungera att sprida trafik till flera boxar. Alltså inte i din lösning, men generellt. Ska man ha all trafik med en kabel så bör man koppla från den gula porten till en vlanswitch, knyta den trafiken till ett specifikt vlan, och surf till nästa port, och knyta den trafiken till ett.

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Registrerad
Dec 2016

@es0n: Ja, tyvärr gör jag ju det....

Trädvy Permalänk
Medlem
Registrerad
Dec 2016

@joalin: OK! Jag tror IGMP snooping är aktivt som standard på alla vlan efter factory reset men ska dubbelkolla det i dag. Har för för mig att det stog enabled men inte aktiverat för något specifikt vlan nummer.

Trädvy Permalänk
Medlem
Registrerad
Apr 2014
Skrivet av patrick356:

@dbeg: Tack för tipset, ska testa den varianten också. Fast jag blir lite skeptisk när det inte ens fungerar med Inteno tv-port -> okonfad switch -> TV-box. Det fungerar när man kör sladd direkt från Inteno tv-port -> TV-box. Switchen påverkar på något sätt som jag inte förstår.

jag har Netgera GS108PEv3 där det kommer in IPTV. om du har hemma en "dumswitch" kanske du kan testa att kolla om det fungerar med den. det kan vara så att något i din smarta switch inte släpper trafiken. jag kan inte se något annat.
så här har jag gjort i mina smarta switch

Inteno ------> Netgear GS108pev3 (in port 7 otaggat, ut från switcen port 1 taggat) ----------> Netgear GS108Tv2 (in port 1 taggat, till TV port 8 otaggat), på båda switcharna MultiCast enable och IGMP snooping on VLAN 100.

detta fungerar för mig på 4 tv apparater. jag har dock IPTV från telia men det ska funka så även från viasat.

edit:
du kan förstås använda bara en switch men tänk på att kabel som går från digital boxen ska vara otaggad (untagged. Ii switchen plockade jag bort port 7 från vlan 1 (vanligt internet) och kör Port PVID vlan 100 på den.

om vi leker med tanken att du använder port 3 och 4 för din IPTV och Vlan 100 så skulle jag göra så här.
Inteno ----->port 3 untagged vlan 100, PVID vlan 100 port 3
Digitalboxen ------> port 4 untagged vlan 100, PVID vlan 100 port 4
MultiCast enable, IGMP snooping on VLAN 100

Trädvy Permalänk
Inaktiv
Registrerad
Mar 2010
Skrivet av patrick356:

@joalin: OK! Jag tror IGMP snooping är aktivt som standard på alla vlan efter factory reset men ska dubbelkolla det i dag. Har för för mig att det stog enabled men inte aktiverat för något specifikt vlan nummer.

Verkar bara vara igång på VLAN 1 som default. Sen kan du kolla om din IP-TV box får en IP adress av Viasats (eller vems det nu är) DHCP server, din box måste ha en unicast IP adress för att kunna joina en multicast ström.

Trädvy Permalänk
Medlem
Registrerad
Dec 2016

@dbeg: OK, efter några omstarter hit och dit så går i alla fall digitalboxen igång som den ska. Alltså fungerar Inteno TV -> switch -> digitalbox. Jag tror jag gör som du och köper en till switch och lägger Intenons TV-utgång på ett vlan och internetlinan på ett annat.

Det verkar inte fungera för mig att packa upp IPTV:s vlan direct i switchen från Intenons internetutgång som en del andra verkar ha lyckats med. Jag tror jag ger upp de försöken om inte någon har ett jättebra tips för att få igång det.

Trädvy Permalänk
Medlem
Registrerad
Apr 2014

skönt att det fungerar.

Skrivet av patrick356:

Det verkar inte fungera för mig att packa upp IPTV:s vlan direct i switchen från Intenons internetutgång som en del andra verkar ha lyckats med. Jag tror jag ger upp de försöken om inte någon har ett jättebra tips för att få igång det.

jag tror att det du har läst till dig och den du länkade till är dom som har Telias router och inte Inteno switch. Där kör Telia med Vlan 845 tror jag och då kan man ha bara en switch som kör vlan 845 för IPTV och annan port för internet. alltså samma sak som Inteno switch gör.

Trädvy Permalänk
Medlem
Registrerad
Dec 2016

@dbeg: Kan vara så att jag snurrat till det. Men en del påstår att all trafik är tillgänglig på Intenons internetutgång och de andra utgångarna bara är specifika vlan som taggats ut från internetutgångens trafik. Kanske är helt felaktigt eller är gammal information.

Trädvy Permalänk
Medlem
Registrerad
Apr 2014
Skrivet av patrick356:

@dbeg: Kan vara så att jag snurrat till det. Men en del påstår att all trafik är tillgänglig på Intenons internetutgång och de andra utgångarna bara är specifika vlan som taggats ut från internetutgångens trafik. Kanske är helt felaktigt eller är gammal information.

okey men jag känner inte till att det är så, men jag är ingen expert så du kan ha rätt.
för mig var det viktigt att slippa (lite lat ) dra dubbla kablar för internet och iptv, men ville oxå slippa trådlöst till TV för den lösningen telia har med dom där technicolor är bara för fula och stora. jag har nu 3 st. som jag kanske säljer. har på sommaren tv på altanen och då kört trådlöset men funderar nu att dra kabel ut från köket och köra ute med.

Trädvy Permalänk
Medlem
Registrerad
Jun 2005
Skrivet av patrick356:

@dbeg: Kan vara så att jag snurrat till det. Men en del påstår att all trafik är tillgänglig på Intenons internetutgång och de andra utgångarna bara är specifika vlan som taggats ut från internetutgångens trafik. Kanske är helt felaktigt eller är gammal information.

Exakt, Intenon är helt enkelt en mediaconverter och vlanswitch i ett. En sk bredbandsswitch. Finns en mycket bra tråd om detta här nedan. Detta är egentligen rätt så självklart eftersom man inte annars skulle kunna ansluta en router till internetporten och från routern få ut både internet och tv samtidigt. För de flesta blir det lättast att skaffa 2 vlanswitchar som ts valt. Det går även som i tråden nedan att köra via en.

https://m.sweclockers.com/forum/trad/845719-telia-fiberlan-vl...

Trädvy Permalänk
Medlem
Registrerad
Dec 2016

@joalin: Tack för tipset. Jag har testat på det sättet men får det inte att fungera. Har inte analyserat trafiken närmare mellan switch och digitalbox med den konfigurationen så jag vet inte varför digitalboxen säger att den inte får någon anslutning.

Ska åka iväg på lunchen idag och skaffa en andra switch och hoppas jag får till det.

Trädvy Permalänk
Medlem
Registrerad
Dec 2016

@dbeg: Jag kopplade som du och det fungerar! Tack för hjälpen!
Nu fungerar allt utom min iphone till en Dovado wlan access. De verkar inte tycka om varandra. Konstigt ändå att datorer och skrivare fungerar till den accesspunkten utan problem men min iphone bara kopplar ifrån. Alltid är det något...

Trädvy Permalänk
Medlem
Registrerad
Apr 2014
Skrivet av patrick356:

@dbeg: Jag kopplade som du och det fungerar! Tack för hjälpen!
Nu fungerar allt utom min iphone till en Dovado wlan access. De verkar inte tycka om varandra. Konstigt ändå att datorer och skrivare fungerar till den accesspunkten utan problem men min iphone bara kopplar ifrån. Alltid är det något...

kul att det fungerar.
Dovado? nej det är inget jag använder men i sådana situationer brukar det vara bra att kolla om du har senaste firmware i din router och göra upgrade. fast jag vet inte det är märke jag aldrig använt till något vad jag minns.

Trädvy Permalänk
Medlem
Registrerad
Dec 2016

@dbeg: Nä, det var egentligen helt orelaterat till tråden i övrigt. Jag nedgraderade firmwaren ett snäpp så löste det sig!

Trädvy Permalänk
Medlem
Registrerad
Jun 2005

Härligt att det hoppade igång!

Trädvy Permalänk
Moderator
Registrerad
Aug 2007
Skrivet av patrick356:

Vi har bredband och TV via Viasat kan jag tillägga om det på något sätt ger några ledtrådar.

Skrivet av patrick356:

@dbeg: Nä, det var egentligen helt orelaterat till tråden i övrigt. Jag nedgraderade firmwaren ett snäpp så löste det sig!

Jag vet inte vad du gjorde för att få igång det, men det verkar som om du har Telia Öppen Fiber? I så fall kan du glömma allt med de andra trådarna angående Telia, de gäller om du har bredband och TV från Telia och inget annat.

Använd gilla för att markera nyttiga inlägg!