Hur HP taggar sina VLAN, hjälp med exempel!

Trädvy Permalänk
Medlem
Registrerad
Maj 2015

Hur HP taggar sina VLAN, hjälp med exempel!

Hej!

Jag skulle behöva lite lite hjälp med hur HP taggar sina VLAN.

Scenariot ser ut som följande:

Allokeringen av portar på STNS006, ser ut som följande:

Port 1-12,37-48 = Untagged, VLAN1
Port 13-24 = Untagged VLAN22
Port 25-36 = Tagged VLAN22
Port 44 = Tagged VLAN22 (Uplink)
På port 25-36 ligger det virtuella maskiner, som kan använda olika VLAN (men i detta fall VLAN1 samt VLAN22).
Portar 1-12,37-48 används för management och ligger på VLAN1.
Portar 13-24 känner inte av VLAN, utan ska enbart ligga som en accessport i VLAN22.

Mina tanke är att alla dessa VLAN, ska gå via STNS006 => STNS001 => STNS003 => STF001.

Har jag förstått det rätt om man följer nedstående konfiguration? Väldigt tacksam för hjälp, känns som man blir lite yr i huvudet när man går från Ciscos syn på VLAN till HP's:

STNS006:
vlan 1
name "DEFAULT_VLAN"
untagged 1-12,37-48
ip address 172.16.5.12 255.255.255.0
tagged 25-36
no untagged 13-24
exit
vlan 22
name "SERVER_VLAN"
untagged 13-24
no ip address
tagged 25-36,44 (Uplink)
exit

STNS001:
vlan 1
name "DEFAULT_VLAN"
untagged 1-28
ip address 172.16.5.5 255.255.255.0
exit
vlan 22
name "SERVER_VLAN"
tagged 19, 25 (Uplink)
no ip address
exit

STNS003:
vlan 1
name "DEFAULT_VLAN"
untagged 1-28
ip address 172.16.5.7 255.255.255.0
exit
vlan 22
name "SERVER_VLAN"
tagged 24,26-28 (Uplink)
no ip address

Ytterligare frågor:

Kommer enbart VLAN22 gå från STNS006 ner till STNF001? För satte jag Port 44 som tagged i VLAN1, förlorade jag möjligheten att använda t.ex. ping. Eller går VLAN1 på något default sätt via tagged portar? I detta scenario har jag full konnektivitet, men är väldigt osäker på varför det egentligen fungerar.

Uppskattar verkligen svar. Hoppas förklaringen inte är alltför luddig.

/ Juntao

Trädvy Permalänk
Medlem
Registrerad
Jul 2004

En detalj där som förvirrar lätt är att VLAN 1 untagged och ett taggat VLAN (22?) kan finnas på samma port och det är okej enligt standard (samma i cisco). Så, har du satt IP på VLAN 1 så har du konnektivitet via detta fenomen genom nätet. Normalt sett så ska du undvika/sky VLAN 1 som pesten, det ställer till det bara.

Det som är rörigt är hur det skrivs ut när du listar grejerna i cli, deras webb-grej är lite enklare att förstå. (Fast, med det menar jag inte att det är "bra").

CPU: I7 4770K Grafik: Poseidon Platinum GeForce GTX 980Ti Moderkort: Asus Maximus VI Hero Z87 RAM: 16Gb Corsair Dominator Platinum CL9 Nätagg: Corsair HX1050 Gold SSD: Corsair Force GT 240Gb SSHD: Seagate Desktop 4TB Låda: Corsair Graphite 600T

Trädvy Permalänk
Medlem
Plats
Skarpnäck
Registrerad
Mar 2011

Skillnaden mellan Cisco och HP är att untagged betyder access och tagged betyder trunk. Du ska ha trunk portar mellan alla switchar som går ihop. Klienter sätter du på access så vidare det inte är speciellt utrustning som ska taggas in på ett specifikt vlan.

Gaming:[Asus Zenith]-[AMD TR 1950X]-[Corsair Dominator 3000mhz 32GB]-[GTX 1080 Ti SLI]-[CL SMA8]:.(soon)
Server(ESXi):[Supermicro X10SDV-8C-TLN4F]-[Intel Xeon D1541]-[32GB ECC]-[32GB SataDom + 1TB Samsung 960EVO]:.
Server(unRAID):[Supermicro X10SL7-F]-[Intel Xeon 1240L V3]-[32GB ECC]-[40TB WD Re + 500GB Curcial MX100]:.

Trädvy Permalänk
Medlem
Registrerad
Maj 2015

Men om vi tar den konfigurationen jag precis har gjort nu, och översätter den till en Cisco konfiguration, hur hade det sett ut?

Jag är med på grejjen att:

Untagged = Accessport
Tagged = Trunk

Men om man t.ex. har en Cisco switch, så jag gjorde:

STNS006(config)#interface fastethernet0/44
STNS006(config-if)switchport mode trunk
STNS006(config-if)switchport trunk allowed vlan 1,22

Då hade alltså FastEthernet0/44, vart en trunk, och trunkat VLAN1 samt VLAN22.

Men går VLAN1 över trunken (tagget) porten nu? Enbart Port 44 är taggad med VLAN22, eller?

Tackar för all hjälp, blir lite klurigt för mig att gå från Cisco i 3 år, till HP. Blir lite nytänk Finns det förresten något simuleringsprogram
likt Packet-Tracer för HP? Har testat och googla, men fick fram till att det fanns till Comware med inte till ProVision.

P.S. Jag är även med på att i HP-världen, så är en trunk LACP.