Trädvy Permalänk
Medlem
Plats
Luleå
Registrerad
Maj 2008

Problem med SFTP (port forwarding?)

Jag har nu hållet på i 4 dagar för att försöka få upp en SFTP server och jag tror problemet har något med routern att göra för har testat att sätta upp både FTP och SFTP från olika hårdvaror utan framgång annat än på lokala nätverket. Freenas SFTP & FTP, routerns egna FTP samt nu sitter jag med en synology nas och SFTP.

Kan i bästa fall koppla upp mig lokalt alternativt via NAT loopback. Men aldrig lyckats få kontakt utifrån (har testat med mobil samt kompis dator), har ställt upp en DDNS via routern mot no-ip.org vilket verkar fungera bra men har även testat att manuellt skriva in WAN IP.
Via routerns webinterface har jag slagit på port forwarding på en port med högt nummer som inte ska användas av någon standard applikation (har testat många olika portar utan skillnad), pekar på lokal port som jag kan koppla upp mig med via lokal IP. Så SFTPn borde vara korrekt uppställd på lokala nätverket, bara pipen utifrån stora värden som saknas.

Jag har en Asus RT AC66U med senaste Merlin FW 378.56_2 (har även gjort många(alla?) tester på en kanske 1,5 år gammal merlin FW).

Börjar bli lite desperat för vet inte vad som kan vara problemet för det borde inte vara så svårt. Väldigt uppskattat med tips på vad jag kan göra för att testa vars felet ligger. Jag är ingen expert så kan vara något helt annat också men jag tror på något med routern och port forward.

Trädvy Permalänk
Medlem
Plats
Câmara de Lobos, Madeira, Portugal
Registrerad
Nov 2005

Är det SFTP du försöker med eller FTPS? FTP och FTPS fodrar att du forwardar 2 portar (kommando och data) medan SFTP är ett tillägg till SSH. För SFTP bör du ha en SSH-server.

Fagerja

Trädvy Permalänk
Medlem
Plats
Luleå
Registrerad
Maj 2008
Skrivet av fagerja:

Är det SFTP du försöker med eller FTPS? FTP och FTPS fodrar att du forwardar 2 portar (kommando och data) medan SFTP är ett tillägg till SSH. För SFTP bör du ha en SSH-server.

Jag har framförallt försökt med SFTP (SSH) men även testat FTP i hopp om att få något att fungera men utan resultat.

På synology nasen jag har aktiv nu så har den en inbyggd SFTP server som jag startat samt konfigurerat med användare och portnummer. Där är det inga problem att koppla upp sig med användare och lokal ip adress

Trädvy Permalänk
Inaktiv
Registrerad
Mar 2010

Kan du inte forwarda en webserver bara för att testa att du gör rätt i din router? Förmodligen är det något du missat.

Trädvy Permalänk
Medlem
Registrerad
Dec 2016
Skrivet av QRikard:

Via routerns webinterface har jag slagit på port forwarding på en port med högt nummer som inte ska användas av någon standard applikation (har testat många olika portar utan skillnad), pekar på lokal port som jag kan koppla upp mig med via lokal IP. Så SFTPn borde vara korrekt uppställd på lokala nätverket, bara pipen utifrån stora värden som saknas.

Är du säker på att du tillåter trafik till den externa porten i brandväggen?
Du kan nå Internet från din server?

Om du försöker SSHa till den externa porten med följande kommando,

ssh -vvv -p <EXTERN PORT> <EXTERN IP-ADRESS>

Vad får du fram då?
Du kan även testa en vanlig telnet bara för att se att du får fram rätt headers, t.ex,

$ telnet <EXTERN IP-ADRESS> <EXTERN PORT> Trying <EXTERN IP-ADRESS>... Connected to <EXTERN IP-ADRESS>. Escape character is '^]'. SSH-2.0-OpenSSH_6.7p1 Debian-5+deb8u3

Så borde du se att du når din server i varje fall.
Om du inte gör det så låter det som att du behöver göra något mer i din brandvägg.

Trädvy Permalänk
Medlem
Plats
Luleå
Registrerad
Maj 2008
Skrivet av studiox_swe:

Kan du inte forwarda en webserver bara för att testa att du gör rätt i din router? Förmodligen är det något du missat.

Förklara gärna hur jag gör det. Testar gärna och det är inte alls omöjligt att det är något enkelt jag missat.

Skrivet av kantarellsas:

Är du säker på att du tillåter trafik till den externa porten i brandväggen?
Du kan nå Internet från din server?

Om du försöker SSHa till den externa porten med följande kommando,

ssh -vvv -p <EXTERN PORT> <EXTERN IP-ADRESS>

Vad får du fram då?
Du kan även testa en vanlig telnet bara för att se att du får fram rätt headers, t.ex,

$ telnet <EXTERN IP-ADRESS> <EXTERN PORT> Trying <EXTERN IP-ADRESS>... Connected to <EXTERN IP-ADRESS>. Escape character is '^]'. SSH-2.0-OpenSSH_6.7p1 Debian-5+deb8u3

Så borde du se att du når din server i varje fall.
Om du inte gör det så låter det som att du behöver göra något mer i din brandvägg.

Synologyn kommer ut på nätet, har hämtat uppdateringar och även kommit in via remote login till webinterfacet så det är något skumt med portarna.
Jag är inte säker på att jag tillåter trafik till porten, hur gör jag det?
Jag har satt port forwarding från extern port till intern och enablat port forwarding. Brandväggen är igång men har även testat att stänga den utan resultat. Något mer jag kan göra? Hittar inget liknande i routern och under "system log->port forwarding" finns en lista på ipadress och port som det ska vara. Jag har kört forward på både TCP och UDP.

Har laddat hem cygwin för att kunna köra ssh och telnet.

$ telnet <ext-ip> <extern port> Trying <ext-ip>... telnet: Unable to connect to remote host: Connection timed out

$ ssh -vvv -p <extern port> <ext-ip> OpenSSH_7.4p1, OpenSSL 1.0.2j 26 Sep 2016 debug2: resolving "<ext-ip>" port <extern port> debug2: ssh_connect_direct: needpriv 0 debug1: Connecting to <ext-ip> [<ext-ip>] port <extern port>. debug1: connect to address <ext-ip> port <extern port>: Connection timed out ssh: connect to host <ext-ip> port <extern port>: Connection timed out

Extern ip hittade jag via DDNS menyn på synologyn och det är även samma adress jag får när jag går in på tex https://www.whatismyip.com/ från stationära datorn.
Däremot säger routern en helt annan wan-ip vilket även är ipadressen som kommer när jag kör mot DDNS som jag satt upp via no.ip. Jag får samma resultat med ssh och telnet kommandona med denna ip också så ingen mer info där.

Allt ovan var med NAT loopback = Disabled
Om jag sätter NAT loopback till Merlin (finns även ASUS) tror bara det är lite detaljer som skiljer i implementering men det är enabled iaf.

$ telnet <DDNS server> <ext-ip> Trying <DDNS IP>... Connected to <DDNS server>. Escape character is '^]'. SSH-2.0-OpenSSH_6.8p1-hpn14v6

Får time out om jag kör på externa ip adressen som fås via synologyn / my ip.
Så där kom något fram men om jag förstått det rätt så måste jag ha loopback avslaget för att testa hur det blir vis uppkoppling utifrån. Rätta mig gärna om jag har fel.

Trädvy Permalänk
Medlem
Registrerad
Dec 2016
Skrivet av QRikard:

Jag är inte säker på att jag tillåter trafik till porten, hur gör jag det?
Jag har satt port forwarding från extern port till intern och enablat port forwarding. Brandväggen är igång men har även testat att stänga den utan resultat. Något mer jag kan göra? Hittar inget liknande i routern och under "system log->port forwarding" finns en lista på ipadress och port som det ska vara. Jag har kört forward på både TCP och UDP.

Det borde räcka.
Vilken port har du satt som extern, och vilken forwardar du till internt NAS:en?
T.ex, extern port sätter du som port 2222, och sedan skickar du detta till port 22 på NAS:en.

Konfigurerar du via webgui, eller hur fungerar den biten?
Om så, kan du bifoga en screenshot från webguit?

Skrivet av QRikard:

Har laddat hem cygwin för att kunna köra ssh och telnet.

$ telnet <ext-ip> <extern port> Trying <ext-ip>... telnet: Unable to connect to remote host: Connection timed out

$ ssh -vvv -p <extern port> <ext-ip> OpenSSH_7.4p1, OpenSSL 1.0.2j 26 Sep 2016 debug2: resolving "<ext-ip>" port <extern port> debug2: ssh_connect_direct: needpriv 0 debug1: Connecting to <ext-ip> [<ext-ip>] port <extern port>. debug1: connect to address <ext-ip> port <extern port>: Connection timed out ssh: connect to host <ext-ip> port <extern port>: Connection timed out

Gör du detta inifrån ditt nätverk, eller testar du med en dator utifrån?

Skrivet av QRikard:

Extern ip hittade jag via DDNS menyn på synologyn och det är även samma adress jag får när jag går in på tex https://www.whatismyip.com/ från stationära datorn.
Däremot säger routern en helt annan wan-ip vilket även är ipadressen som kommer när jag kör mot DDNS som jag satt upp via no.ip. Jag får samma resultat med ssh och telnet kommandona med denna ip också så ingen mer info där.

Det borde vara samma ipadress som är på routerns externa interface, som du får via t.ex whatismyip.
IP adressen på routern är ingen 10..., 172.16... eller 192.168 adress i varje fall?

Skrivet av QRikard:

Allt ovan var med NAT loopback = Disabled
Om jag sätter NAT loopback till Merlin (finns även ASUS) tror bara det är lite detaljer som skiljer i implementering men det är enabled iaf.

$ telnet <DDNS server> <ext-ip> Trying <DDNS IP>... Connected to <DDNS server>. Escape character is '^]'. SSH-2.0-OpenSSH_6.8p1-hpn14v6

Får time out om jag kör på externa ip adressen som fås via synologyn / my ip.
Så där kom något fram men om jag förstått det rätt så måste jag ha loopback avslaget för att testa hur det blir vis uppkoppling utifrån. Rätta mig gärna om jag har fel.

Borde vara avslaget, om du inte vill nå någon tjänst som du presenterar på den externa ipadressen inifrån ditt lokala nätverk
[quote]
NAT loopback, also known as NAT hairpinning or NAT reflection, is a feature in many consumer routers which permits the access of a service via the public IP address from inside the local network
[quote]

Trädvy Permalänk
Medlem
Registrerad
Maj 2008

Vad har du för ISP? Känns rent spontant som att din ISP NATar vilket innebär att det inte kommer fungera. Oftast kan man kontakta sin ISP för att få det verifierat och samtidigt be om en publik IP-adress.

Intel Core i7 3930K@ 4,7Ghz (Noctua NH-D14) | Asus Rampage IV Formula | Corsair Vengeance DDR3 16GB | MSI GTX 1080Ti Gaming X | Corsair AX 850W |
Ljud: Asus Essence STX -> Audio-GD DAC 19 -> Heed Canamp -> AKG K701

Trädvy Permalänk
Medlem
Plats
Luleå
Registrerad
Maj 2008
Skrivet av kantarellsas:

Det borde räcka.
Vilken port har du satt som extern, och vilken forwardar du till internt NAS:en?
T.ex, extern port sätter du som port 2222, och sedan skickar du detta till port 22 på NAS:en.

Konfigurerar du via webgui, eller hur fungerar den biten?
Om så, kan du bifoga en screenshot från webguit?

Har testat att forwarda flera portar bland annat 45003, 4007 m.f till lokal port 32. port 20, 21, 22 är inte rekommenderade eftersom routern använder dessa för sin egen FTP/SSH tjänst. Jag har uppdaterat synologyns port till 32 för SFTP tjänsten så det ska stämma och fungerar bra med lokal ip och port 32.

Jag konfigurerar via webgui, ska gå att konfigurera via telnet/ssh också men jag är tyvärr väldigt dålig på terminaler så har inte satt mig in i det.
Stulen bild men samma interface men med mina ip adresser och portar. Jag är rätt säker på att den biten är rätt, om jag går in på "System Log -> Port forwarding" så finns alla forwards i listan där så dom ska vara aktiva. Jag har satt både TCP och UDP.

Skrivet av kantarellsas:

Gör du detta inifrån ditt nätverk, eller testar du med en dator utifrån?

Det borde vara samma ipadress som är på routerns externa interface, som du får via t.ex whatismyip.
IP adressen på routern är ingen 10..., 172.16... eller 192.168 adress i varje fall?

Borde vara avslaget, om du inte vill nå någon tjänst som du presenterar på den externa ipadressen inifrån ditt lokala nätverk
[quote]
NAT loopback, also known as NAT hairpinning or NAT reflection, is a feature in many consumer routers which permits the access of a service via the public IP address from inside the local network
[quote]

Jag testar framförallt med min stationära dator på lokala nätverket men har även testat med en FTP klient från telefonen (android - andFTP) samt en kompis har fått försöka logga in från sin dator med filezilla (samma klient som jag kör lokalt). Samma resultat på alla (timeout).

Nu visar routern 100.xxx... och synologyn samt whatsmyip från stationära ger 185.xxx... Underligt för har för mig att båda varit samma 185 adress tidigare. Denna adress har ändrats under veckan men min DDNS som jag satt upp har följt efter routern (som definierat) men nu är det lite underligt då jag får två olika och det har jag ingen förklaring på.
Lokalt är det 192.168.xxx.xxx som gäller och statiska adresser låsta på MAC till alla enheter.

Skrivet av Saodie:

Vad har du för ISP? Känns rent spontant som att din ISP NATar vilket innebär att det inte kommer fungera. Oftast kan man kontakta sin ISP för att få det verifierat och samtidigt be om en publik IP-adress.

Bredband 2 AB (enligt https://www.whatismyip.com/). Är inkluderat i hyran så har inget eget avtal med operatören därav inte 100% säker.
Har skickat ett mail till dom nu och frågat om NAT, spärrade portar samt IP s hoppas det kan vara där problemet ligger.

Trädvy Permalänk
Medlem
Plats
Västerås
Registrerad
Mar 2011
Skrivet av Saodie:

Vad har du för ISP? Känns rent spontant som att din ISP NATar vilket innebär att det inte kommer fungera. Oftast kan man kontakta sin ISP för att få det verifierat och samtidigt be om en publik IP-adress.

Skrivet av QRikard:

Nu visar routern 100.xxx... och synologyn samt whatsmyip från stationära ger 185.xxx...

Dvs CGN (NAT hos operatören) - precis som Saodie skrev.

Trädvy Permalänk
Medlem
Registrerad
Dec 2016

Det verkar inte bättre än som Saodie och Tanis säger.
Så bäst att kontakta ISPn och sedan förhoppningsvis få en publik IP address direkt på din router.
Om du använder bahnhof så finns det en tråd här som kanske är till hjälp, http://www.sweclockers.com/forum/trad/1221271-bahnhof-byter-t...

Trädvy Permalänk
Medlem
Plats
Luleå
Registrerad
Maj 2008
Skrivet av Tanis:

Dvs CGN (NAT hos operatören) - precis som Saodie skrev.

Skrivet av kantarellsas:

Det verkar inte bättre än som Saodie och Tanis säger.
Så bäst att kontakta ISPn och sedan förhoppningsvis få en publik IP address direkt på din router.
Om du använder bahnhof så finns det en tråd här som kanske är till hjälp, http://www.sweclockers.com/forum/trad/1221271-bahnhof-byter-t...

Ni har helt rätt.
Bredband2 har privata IP adresser bakom NAT. För att göra allt "bättre" så ingår mitt bredband i hyran så kan jag inte få en publik IP adress utan måste skaffa ett nytt/eget abonnemang för att få tillgång till den tjänsten...

Trädvy Permalänk
Medlem
Registrerad
Maj 2016

kan tipsa om OVPN.se de har VPN tunnlar om statiska IP adresser