Trädvy Permalänk
Medlem
Registrerad
Mar 2005

Konfigurera Edgerouter lite

Hej!

Har köpt mig lite nya nätverkspryttlar, en EdgeRouter Lite och en NetGear GS108v3. Jag har fiber 100/10, kopplat till eth0, switchen kopplat till eth1 och en gammal asus som AP på eth2. Har tänkt att köpa en AC Pro att ersätta asusen med snart.
I alla fall, allt funkar, det är bra fart i grejerna, men jag har några Raspberry Pi's som kör Libreelec med Kodi som jag använder mobilen till att styra (iOS och appen Sybu Kodi). Efter att jag kopplat in de nya nätverksgrejerna så hittar inte appen mina RPis och jag antar att jag behöver öppna port 8080. Men hur f*n gör man? Har sökt men inte kunnat hitta. Så kan nån peka mig i rätt riktning eller förklara för en nätverksnovis (som kanske har tagit sig vatten över huvudet med senaste inköpen) så vore jag fruktansvärt tacksam!

Mvh

Edit: Jag kan inte logga in på switchen eftersom jag sitter på Mac. Tydligen funkade deras programvara endast med windows...

Trädvy Permalänk
Medlem
Plats
Helsingborg
Registrerad
Maj 2003

Du ska väl kunna använda web-interfacet oavsett vilket OS du kör?
B!

Allting jag skriver är om inget annat uttrycks, min åsikt! Ingenting måste vara dagens sanning enligt din åsikt, och gör du antaganden baserade på mina åsikter hoppas jag att du övervägt mer än bara just min åsikt.

Trädvy Permalänk
Medlem
Registrerad
Mar 2005
Skrivet av -=Mr_B=-:

Du ska väl kunna använda web-interfacet oavsett vilket OS du kör?
B!

På Netgear-switchen alltså. Den har inget webbinterface. På routern kommer jag in!

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Plats
Finspång
Registrerad
Okt 2003

@blackheim: Du måste öppna porten på routern

Trädvy Permalänk
Medlem
Registrerad
Mar 2005
Skrivet av niclasc:

@blackheim: Du måste öppna porten på routern

Jepp, så långt är jag med. Men hur? Jag körde guiden i webos, men det funkade inte. Jag är dock inte så haj, så jag vet inte exakt hur jag ska skriva. Porten är 8080, men sen då? Är det IP-numret till RPi? Eller routern?

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Plats
Gotland
Registrerad
Apr 2013

GS108v3 är en omanagerbar dumswitch, den går inte och skall inte att gå in i över huvud taget!

Trädvy Permalänk
Medlem
Plats
Helsingborg
Registrerad
Maj 2003

NetGear GS108v3 är en dum-switch, NetGear GS108Ev3 är administrerbar.
Om den ÄR administrerbar, ska den ha / får den en IP från routern. DEN IP'n är det du ska ansluta mot, för att konfigurera switchen. (Och, bara för sakens skull. Ev3 är web-administrerbar, om man inte har möjlighet att köra deras mjukvara.)
B!

Allting jag skriver är om inget annat uttrycks, min åsikt! Ingenting måste vara dagens sanning enligt din åsikt, och gör du antaganden baserade på mina åsikter hoppas jag att du övervägt mer än bara just min åsikt.

Trädvy Permalänk
Medlem
Plats
Helsingborg
Registrerad
Sep 2008
Skrivet av blackheim:

Jepp, så långt är jag med. Men hur? Jag körde guiden i webos, men det funkade inte. Jag är dock inte så haj, så jag vet inte exakt hur jag ska skriva. Porten är 8080, men sen då? Är det IP-numret till RPi? Eller routern?

Skickades från m.sweclockers.com

Logga in på EdgeRoutern på IP https://192.168.1.1 eller om du ändrat IP / subnet på den så skriv in den IPn.

Prova denna direktlänk om du inte hittar ändå: https://192.168.1.1/#Security/Port_Forwarding

user: ubnt pass: ubnt som standard.

Välj fliken Firewall / NAT och underfliken Port Forwarding.

Fyll i port 8080 på både Original port och Forwart-to-port, Protocol: Both och interna IPn till din RPi (typ 192.168.1.X).

IPn till din RPi hittar du om du loggar in på den och skriver ifconfig i terminalen.

Edit: Du kopplar nog mobilerna via trådlöst WiFi hemifrån så kan det vara så att ASUS APn inte är i samma subnet som EdgeRoutern eller kabeln mellan dem är kopplad i WAN/Internet uttaget på ASUSen. Prova att koppla den i LAN/ ett av dem fyra uttagen på ASUSen och stäng av DHCP och byt IP till typ 192.168.1.2 mask 255.255.255.0 gateway 192.168.1.1 DNS: 192.168.1.1

Systemadministratör: Server, Klient, Molnet, Nätverk
HP ZBook 14 G2 med Windows 10 Enterprise

Trädvy Permalänk
Medlem
Registrerad
Jul 2015
Skrivet av blackheim:

På Netgear-switchen alltså. Den har inget webbinterface. På routern kommer jag in!

Skickades från m.sweclockers.com

Skrivet av Gaist:

GS108v3 är en omanagerbar dumswitch, den går inte och skall inte att gå in i över huvud taget!

GS108Ev3 är åtkomlig via web-interface. Vilket också är det enda som skiljer den ifrån GS108Ev2 vad jag vet.

Här är informationen för aktuell switch: http://www.downloads.netgear.com/files/GDC/datasheet/en/ProSA...

EDIT: Och den utan "E" i namnet är alltså en "dum" switch som inte kan konfigureras på något sätt.

Trädvy Permalänk
Medlem
Registrerad
Mar 2005
Skrivet av -=Mr_B=-:

NetGear GS108v3 är en dum-switch, NetGear GS108Ev3 är administrerbar.
Om den ÄR administrerbar, ska den ha / får den en IP från routern. DEN IP'n är det du ska ansluta mot, för att konfigurera switchen. (Och, bara för sakens skull. Ev3 är web-administrerbar, om man inte har möjlighet att köra deras mjukvara.)
B!

Det är Ev3 jag har, men jag kommer ändå inte in i den. Kollar IPt i routern, men den bara tuggar när jag skriver in det i chrome. Konstigt, jag tyckte jag läste att det INTE fanns webinterface till den. Måste ha blandat ihop dem då...

Skrivet av carlfilip92:

Logga in på EdgeRoutern på IP https://192.168.1.1 eller om du ändrat IP / subnet på den så skriv in den IPn.

Prova denna direktlänk om du inte hittar ändå: https://192.168.1.1/#Security/Port_Forwarding

user: ubnt pass: ubnt som standard.

Välj fliken Firewall / NAT och underfliken Port Forwarding.

Fyll i port 8080 på både Original port och Forwart-to-port, Protocol: Both och interna IPn till din RPi (typ 192.168.1.X).

IPn till din RPi hittar du om du loggar in på den och skriver ifconfig i terminalen.

Edit: Du kopplar nog mobilerna via trådlöst WiFi hemifrån så kan det vara så att ASUS APn inte är i samma subnet som EdgeRoutern eller kabeln mellan dem är kopplad i WAN/Internet uttaget på ASUSen. Prova att koppla den i LAN/ ett av dem fyra uttagen på ASUSen och stäng av DHCP och byt IP till typ 192.168.1.2 mask 255.255.255.0 gateway 192.168.1.1 DNS: 192.168.1.1

Din edit stämmer mycket väl, jag ska kolla upp det imorgon!
Hur ska jag förresten fylla i det före under Firewall-fliken?
Wan Interface
Hairpin NAT
LAN interface
?

Trädvy Permalänk
Medlem
Plats
Helsingborg
Registrerad
Sep 2008

@blackheim:

Tjena!

Det första jag skrev gäller endast för port forwarding i EdgeRoutern.
Det behöver du bara göra om du ska komma åt dina RPi från utifrån internet.

Men för att svara:

WAN interface: eth0 (den port som internetanslutningen är kopplad i)
Hairpin NAT: Enabled / kryssad
LAN interface: eth1 (den port som switchen och indirekt RPi är kopplade i)

Tänk även på att EdgeRoutern är en router plus brandvägg och inte en switch. Detta innebär att routerns interface är routade och ligger i olika subnet som standard.

Om du kopplar ASUS AP:n i eth2 och switchen i eth1 så kan det bli problem. Mna kan brygga de två intefacen för att skapa en "switch" men då förlorar man prestanda. Kolla på Crosstalk Solutions på Youtube för mer info.

Eller bara koppla in ASUSen LAN sida till NETGEAR-switchen istf direkt i EdgeRoutern.

eth0 publik IP adress från ISP
eth1 192.168.1.1 med /24 mask
eth2 192.168.2.1 med /24 mask

Researchtips:
Local Area Network
Wide Area Network
Network Address Translation (NAT)
IPv4 / IPv6 Subnetting
CIDR-notation
RFC1918
Routed interface
Router vs Switch
Virtual LAN (VLAN)
OSI Model
TCP / IP
Ethernet
MAC Addresses
ARP Address Resolution Protocol
Metro Ethernet (Stadsnät / Fibernät)
Switches
Small Formfactor Pluggable

Systemadministratör: Server, Klient, Molnet, Nätverk
HP ZBook 14 G2 med Windows 10 Enterprise