Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2001

DNS problem

Hej, jag har problem med att iallafall en av mina datorer här hemma, har inte felsökt så mycket mer, väljer fel dns server.

DNS servern är en w2016 server, och den fungerar om jag pekar klienten mot den, men inte om jag väljer "tilldela automatiskt". Istället väljer min client min andra DNS som jag har stående på annan plats och är uppkopplad med en IPsec tunnel. Båda servrarna är domänkontrollanter för samma domän som jag kör här hemma och offsite samt att de agerar DHCP.

Någon setting i DNS att just den här hemma ska vara primär för scopet 10.0.0.0/24 te.x? Vart hittar jag en sån setting isåfall?

Dator: Asus Z87m Pro mAtx, i7 4770k@4.3ghz, 16g ram 2133mhz, MSI GTX 1080ti FoundersE, Fractal Design S, Samsung EVO 250 ssd

Trädvy Permalänk
Medlem
Plats
Södertälje
Registrerad
Aug 2007

Du behöver skriva om frågan. Då vi behöver veta om de bara är DNS eller samtidigt Domäner. Vi behöver desutom veta om de båda domänrena via IPsec ligger på samma subnät.

Någon RRAS inblandad? Eller är det via ike MS mjukvara som tunneln går. Vi vehöver även veta om det är nät till nät med brodkast eller inte, för då kan dhcp krocka. 10 nät skulle jag inte rekomendera då jag tror tela fortfarande köre det i sitt nät det delar on inte bara intärnt. Om du ska ha samma DHCP spann på alla siter så måste de känna till varandra.

Vad är DNS problemet?
Mer specifikt?

Edit:
Om man har grova DNS problem inom samma domän så är det ofta ett routing eller vpn problem vilket är ett routing problem. =(

Kan t.ex vara att det fnns både en extern och intern adress till samma dator.

CPU: i7 3770k@4,50Ghz MB Z77X-D3H RAM: 16GB@2133mhz (10-12-11-27 2T)
GPU: 980Ti@1404,8 HDD: 4x AData SP900 128GB in 2st, 2x Raid-0 16K. 1x Crucial M500 480GB. PSU: FD-PSU-TS2B-800W. Sound: SB-Z -> toslink (DTS)-> old JVC. MB Via to Z-2300 for VOIP. http://valid.x86.fr/nf1u3d http://www.techpowerup.com/gpuz/details.php?id=wa9bw

Trädvy Permalänk
Medlem
Plats
Västerås
Registrerad
Mar 2011
Skrivet av Chichin:

Någon setting i DNS att just den här hemma ska vara primär för scopet 10.0.0.0/24 te.x? Vart hittar jag en sån setting isåfall?

Vad säger din DHCP setup för resp scope? DNS är DHCP-option 6.

Trädvy Permalänk
Inaktiv
Registrerad
Mar 2010
Skrivet av Chichin:

DNS servern är en w2016 server, och den fungerar om jag pekar klienten mot den, men inte om jag väljer "tilldela automatiskt". Istället väljer min client min andra DNS som jag har stående på annan plats och är uppkopplad med en IPsec tunnel. Båda servrarna är domänkontrollanter för samma domän som jag kör här hemma och offsite samt att de agerar DHCP.

Någon setting i DNS att just den här hemma ska vara primär för scopet 10.0.0.0/24 te.x? Vart hittar jag en sån setting isåfall?

Alltså det är inte din DNS server som bestämmer vilka DNS servrar dina klienter ska ha, det gör ju din DHCP server. Lämpligast är väl att du ändrar DHCP scopet för 10.0.0.0/24 att BARA använda den DNS server som du vill ha?

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2001

Ok, ska försöka få med all info här;-)

IPsec tunneln går mellan två stycken pfsense maskiner som agerar routrer på respektive site. Scopet är olika på de två siterna och jag har bara öppnat upp mellan näten i IPsec inställningar samt under "rules" i pfsense.

Det är dock samma domän på de båda siterna, har en kontrollant på varje site, de är även uppsatta som DNS servrar, de pekar dessutom på varandra och här kom jag nog fram till problemet själv kanske...
De båda kontrollanterna har varandra som DNS och sig själva som sekundär.. Har för mig att jag var tvungen att ha det så för att få dem att se varandra, de är alltså "klustrade" eller vad säger man?? Hmm, i pfsense finns funktionen att peka på specifika DNS:er för ett visst scope, dock hittar jag inte den inställningen i w2k16?? Kör för övrigt skrivbordsvarianten av w2k16

Dator: Asus Z87m Pro mAtx, i7 4770k@4.3ghz, 16g ram 2133mhz, MSI GTX 1080ti FoundersE, Fractal Design S, Samsung EVO 250 ssd

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2001
Skrivet av Tanis:

Vad säger din DHCP setup för resp scope? DNS är DHCP-option 6.

Jag hittade ditt option där och la till de servrarna som jag har, la den DNS:en jag har hemma längst upp men verkar inte ha funkat... Kör jag nslookup google.se får jag fortfarande upp DNS:en på remote siten.

*EDIT*

Hmm, när jag ändrar till "specifica" DNS:er under "option 6" får jag upp felmeddelande "The Specified option already exists"

Vad menas??

Dator: Asus Z87m Pro mAtx, i7 4770k@4.3ghz, 16g ram 2133mhz, MSI GTX 1080ti FoundersE, Fractal Design S, Samsung EVO 250 ssd

Trädvy Permalänk
Medlem
Plats
Västerås
Registrerad
Mar 2011
Skrivet av Chichin:

Jag hittade ditt option där och la till de servrarna som jag har, la den DNS:en jag har hemma längst upp men verkar inte ha funkat... Kör jag nslookup google.se får jag fortfarande upp DNS:en på remote siten.

*EDIT*

Hmm, när jag ändrar till "specifica" DNS:er under "option 6" får jag upp felmeddelande "The Specified option already exists"

Vad menas??

Gissningsvis har du har redan lagt DNS option på generisk/server-nivå o gäller då för alla scope. Ta bort på den nivån o lägg på scope-nivå istället.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2001

Ok, nu hittade jag rätt, kollade på fel ställe förut.

Hittade rätt unde "scope options" DNS:en på rmeote siten stod först där, ändrade och nu pekas det rätt!!:-) Tack för hjälpen

Dator: Asus Z87m Pro mAtx, i7 4770k@4.3ghz, 16g ram 2133mhz, MSI GTX 1080ti FoundersE, Fractal Design S, Samsung EVO 250 ssd