Kan jag koppla mitt nätverk såhär?

Trädvy Permalänk
Medlem
Plats
Piteå
Registrerad
Okt 2004

Kan jag koppla mitt nätverk såhär?

Som rubriken säger, kan jag koppla som nedan?

Jag har fått tag på en 24ports poe switch som jag hade tänkt att använda till ett gäng kameror och jag vill att dom ska hamna i samma lan som mina pc's och servrar

Just nu ser mitt nätverk ut sådär förutom att cisco switchen ej är kopplad till min HP switch. Jag provade lite tidigare att koppla ihop dom men då dog mitt internet, så jag vill bara kolla att det är någonting som måste confas helt enkelt.

Anledningen till att jag inte bara kör med cisco switchen är att det är en 10/100..

CPU: AMD Ryzen 1700x @ 3.8GHz || Mem: 16GB Corsair LPX 3000mhz || Mobo: Asus x370 Prime || GPU: EVGA Geforce GTX1070 SC || SSD: WD black 500GB m2 || OS: Linux Mint/Win 10 || Monitor: Dell 43" 4K P4317Q

Citera om du vill ha svar :)

Trädvy Permalänk
Medlem
Registrerad
Maj 2016

Kom ihåg att om du vill ha över VLAN ID till Cisco switchen måstedu sätte en TRUNK till den om konfa VLAN:ID separat på Cisco Switchen sen kan du ju segmentera dem så kamrerna sitter på VLAN 10 övriga enheter på VLAN 30, "använd inte VLAN1" av säkerhetsskäl. det borde du dock skapa ett interface med som är öppen för SSH internt och som "Console"

Trädvy Permalänk
Medlem
Plats
Piteå
Registrerad
Okt 2004
Skrivet av Hansar:

Kom ihåg att om du vill ha över VLAN ID till Cisco switchen måstedu sätte en TRUNK till den om konfa VLAN:ID separat på Cisco Switchen sen kan du ju segmentera dem så kamrerna sitter på VLAN 10 övriga enheter på VLAN 30, "använd inte VLAN1" av säkerhetsskäl. det borde du dock skapa ett interface med som är öppen för SSH internt och som "Console"

Okej, jag förstår mycket av vad du säger men mycket är grekiska för mig men jag tror jag fattar principen. Får se om jag lyckas tillämpa den

CPU: AMD Ryzen 1700x @ 3.8GHz || Mem: 16GB Corsair LPX 3000mhz || Mobo: Asus x370 Prime || GPU: EVGA Geforce GTX1070 SC || SSD: WD black 500GB m2 || OS: Linux Mint/Win 10 || Monitor: Dell 43" 4K P4317Q

Citera om du vill ha svar :)

Trädvy Permalänk
Medlem
Plats
Jönköping
Registrerad
Feb 2005
Skrivet av Hansar:

Kom ihåg att om du vill ha över VLAN ID till Cisco switchen måstedu sätte en TRUNK till den om konfa VLAN:ID separat på Cisco Switchen sen kan du ju segmentera dem så kamrerna sitter på VLAN 10 övriga enheter på VLAN 30, "använd inte VLAN1" av säkerhetsskäl.

Fast om han bara ska använda ett vlan i cisco-switchen så finns det ju ingen poäng med att bygga trunk egentligen?
Sen får du gärna förklara lite utförligare varför man inte ska använda vlan1 "av säkerhetsskäl"..

Workstation "Miranda": P8Z77-V Deluxe | i5 3570K | 2x8Gb DDR3-1333 | GTX 1080 | Samsung Evo 850 + 1TB Lagring | P183 | XenServer "Elize": | Xeon E3| 8Gb DDR3 | Netbook "Ebba": NC10 | Nät: c3550-T12 | c892FSP | c1812 | c881 | c2960G-8TC | HP 1910-8G-PoE+ | Ciscodiplomerad: CCNP-Switch

Trädvy Permalänk
Medlem
Plats
*****
Registrerad
Aug 2006

missar jag något i tråden? för hur ser "Så här Ut"?

Inte Core i7 4790K
Asus Z97-A
Asus Nvidia GTX 970 STRIX
Kingston DDR3 HYPERX 8GB 1600MHZ X 2

Trädvy Permalänk
Medlem
Plats
Piteå
Registrerad
Okt 2004
Skrivet av Neonodia:

missar jag något i tråden? för hur ser "Så här Ut"?

ligger en bild i trådstarten.

CPU: AMD Ryzen 1700x @ 3.8GHz || Mem: 16GB Corsair LPX 3000mhz || Mobo: Asus x370 Prime || GPU: EVGA Geforce GTX1070 SC || SSD: WD black 500GB m2 || OS: Linux Mint/Win 10 || Monitor: Dell 43" 4K P4317Q

Citera om du vill ha svar :)

Trädvy Permalänk
Medlem
Plats
*****
Registrerad
Aug 2006
Skrivet av Pelle:

ligger en bild i trådstarten.

KOnstigt,, Jag ser inget

Inte Core i7 4790K
Asus Z97-A
Asus Nvidia GTX 970 STRIX
Kingston DDR3 HYPERX 8GB 1600MHZ X 2

Trädvy Permalänk
Medlem
Plats
Piteå
Registrerad
Okt 2004

Strange... http://i.imgur.com/AeevsPg.jpg

CPU: AMD Ryzen 1700x @ 3.8GHz || Mem: 16GB Corsair LPX 3000mhz || Mobo: Asus x370 Prime || GPU: EVGA Geforce GTX1070 SC || SSD: WD black 500GB m2 || OS: Linux Mint/Win 10 || Monitor: Dell 43" 4K P4317Q

Citera om du vill ha svar :)

Trädvy Permalänk
Medlem
Plats
*****
Registrerad
Aug 2006
Skrivet av Pelle:

Ah, sitter på jobbet imgur är blockad i vårt content filter.

Inte Core i7 4790K
Asus Z97-A
Asus Nvidia GTX 970 STRIX
Kingston DDR3 HYPERX 8GB 1600MHZ X 2

Trädvy Permalänk
Medlem
Plats
Piteå
Registrerad
Okt 2004
Skrivet av Neonodia:

Ah, sitter på jobbet imgur är blockad i vårt content filter.

okej, fungerar denna då? http://forumbilder.se/G7D9G/asda

CPU: AMD Ryzen 1700x @ 3.8GHz || Mem: 16GB Corsair LPX 3000mhz || Mobo: Asus x370 Prime || GPU: EVGA Geforce GTX1070 SC || SSD: WD black 500GB m2 || OS: Linux Mint/Win 10 || Monitor: Dell 43" 4K P4317Q

Citera om du vill ha svar :)

Trädvy Permalänk
Medlem
Plats
Karlshamn
Registrerad
Apr 2006

Tycker det ser bra ut för en hemmamiljö.
Oavsett om du kör trunk eller inte mellan hp och cisco kan du skriva följande för att konna ansluta till cisco med telnet och ssh.
För att konna konfigurera måste man först skriva "conf t"
Har du användare och lösen?
skriv annars "username Pelle password Plutt

skriv sedan följande:
int vlan 1
ip address 192.168.1.2 255.255.255.0
exit
ip default-gateway 192.168.1.1
line con 0
login local
exit
line vty 0 4
login local
exit

Fungerar inte kommandot "ip deafult-gateway" ersätter du det med "ip route 0.0.0.0 0.0.0.0 192.168.1.1"
för att spara skriver man "wr" men innan dess brukar jag koppla från och koppla upp mig igen för att se att allt fungerar så man kan blåsa switchen genom omstart annars.

192.168.1.x ersätts naturligtvis av det som gäller för ditt nätverk.

edit: jag brukar inte heller använda mig av Vlan 1 i arbetet men hemma vet jag inte om jag hade brytt mig.
om du kan lägga ut confen på ciscon hade det nog underlättat med.
Du visar den genom att skriva " sh run"

Trädvy Permalänk
Medlem
Plats
Piteå
Registrerad
Okt 2004
Skrivet av Lavaguden:

Tycker det ser bra ut för en hemmamiljö.
Oavsett om du kör trunk eller inte mellan hp och cisco kan du skriva följande för att konna ansluta till cisco med telnet och ssh.
För att konna konfigurera måste man först skriva "conf t"
Har du användare och lösen?
skriv annars "username Pelle password Plutt

skriv sedan följande:
int vlan 1
ip address 192.168.1.2 255.255.255.0
exit
ip default-gateway 192.168.1.1
line con 0
login local
exit
line vty 0 4
login local
exit

Fungerar inte kommandot "ip deafult-gateway" ersätter du det med "ip route 0.0.0.0 0.0.0.0 192.168.1.1"
för att spara skriver man "wr" men innan dess brukar jag koppla från och koppla upp mig igen för att se att allt fungerar så man kan blåsa switchen genom omstart annars.

192.168.1.x ersätts naturligtvis av det som gäller för ditt nätverk.

edit: jag brukar inte heller använda mig av Vlan 1 i arbetet men hemma vet jag inte om jag hade brytt mig.
om du kan lägga ut confen på ciscon hade det nog underlättat med.
Du visar den genom att skriva " sh run"

Shit, tack för sjukt utförligt svar jag hann egentligen inte mer än montera in ciscon i skåpet igår, tänkte ta tag i detta ikväll. Återkommer med confen, jag har ej användare och lösen vad jag vet.

CPU: AMD Ryzen 1700x @ 3.8GHz || Mem: 16GB Corsair LPX 3000mhz || Mobo: Asus x370 Prime || GPU: EVGA Geforce GTX1070 SC || SSD: WD black 500GB m2 || OS: Linux Mint/Win 10 || Monitor: Dell 43" 4K P4317Q

Citera om du vill ha svar :)

Trädvy Permalänk
Medlem
Registrerad
Maj 2016

@AtreX: Anledningen till varför inte VLAN1 är för att det är default för allt.

Trädvy Permalänk
Medlem
Plats
Karlshamn
Registrerad
Apr 2006

@Pelle: Är du nöjd med att använda consolekabel för att konfigurerar den behöver du inte användare och lösen.
Jag hade dock rekomenderat det.
Om ditt nätverk slutar fungarera när det kopplar in ciscon känns det som att det antingen är någon konstig konfiguration på den eller att den matar poe på porten mot hpswitchen fast hpswtichen inte begär det.
För att stänga av poe går man in på interfacet och skriver "power inline never"

Trädvy Permalänk
Medlem
Plats
Piteå
Registrerad
Okt 2004
Skrivet av Lavaguden:

@Pelle: Är du nöjd med att använda consolekabel för att konfigurerar den behöver du inte användare och lösen.
Jag hade dock rekomenderat det.
Om ditt nätverk slutar fungarera när det kopplar in ciscon känns det som att det antingen är någon konstig konfiguration på den eller att den matar poe på porten mot hpswitchen fast hpswtichen inte begär det.
För att stänga av poe går man in på interfacet och skriver "power inline never"

Okej, jag kopplade faktiskt in consolekabeln i min server som kör debian, inte undersökt hur jag kommer åt consolen därifrån än dock..

Jag tror faktiskt swtichen stod i "stat" mode när jag kollade

CPU: AMD Ryzen 1700x @ 3.8GHz || Mem: 16GB Corsair LPX 3000mhz || Mobo: Asus x370 Prime || GPU: EVGA Geforce GTX1070 SC || SSD: WD black 500GB m2 || OS: Linux Mint/Win 10 || Monitor: Dell 43" 4K P4317Q

Citera om du vill ha svar :)

Trädvy Permalänk
Medlem
Plats
Jönköping
Registrerad
Feb 2005
Skrivet av Hansar:

@AtreX: Anledningen till varför inte VLAN1 är för att det är default för allt.

Jotack, jag är CCNP-Switch-diplomerad så det är jag fullt medveten om, däremot finns det gott om folk på internet som tror att det på något sätt blir en säkerhetsrisk bara för att det är standard, men ingen jag träffat på har haft något faktiskt argument som förklarar varför det skulle vara en säkerhetsrisk, av den enkla anledningen att det inte är det.

Skrivet av Pelle:

Jag tror faktiskt swtichen stod i "stat" mode när jag kollade

"Stat-mode" avgör bara hur lamporna på switchen blinkar (dvs. vad varje blink/lys betyder), det ändrar ingenting i switchens funktion för övrigt

Workstation "Miranda": P8Z77-V Deluxe | i5 3570K | 2x8Gb DDR3-1333 | GTX 1080 | Samsung Evo 850 + 1TB Lagring | P183 | XenServer "Elize": | Xeon E3| 8Gb DDR3 | Netbook "Ebba": NC10 | Nät: c3550-T12 | c892FSP | c1812 | c881 | c2960G-8TC | HP 1910-8G-PoE+ | Ciscodiplomerad: CCNP-Switch

Trädvy Permalänk
Medlem
Plats
Karlshamn
Registrerad
Apr 2006

Många äldre i branschen som tycker att använder man Vlan 1 har hackaren ett mindre steg att gå men jag håller med Atrex.

Trädvy Permalänk
Medlem
Plats
Piteå
Registrerad
Okt 2004
Skrivet av AtreX:

Jotack, jag är CCNP-Switch-diplomerad så det är jag fullt medveten om, däremot finns det gott om folk på internet som tror att det på något sätt blir en säkerhetsrisk bara för att det är standard, men ingen jag träffat på har haft något faktiskt argument som förklarar varför det skulle vara en säkerhetsrisk, av den enkla anledningen att det inte är det.
"Stat-mode" avgör bara hur lamporna på switchen blinkar (dvs. vad varje blink/lys betyder), det ändrar ingenting i switchens funktion för övrigt

aha okej får ta och kika vidare ikväll

CPU: AMD Ryzen 1700x @ 3.8GHz || Mem: 16GB Corsair LPX 3000mhz || Mobo: Asus x370 Prime || GPU: EVGA Geforce GTX1070 SC || SSD: WD black 500GB m2 || OS: Linux Mint/Win 10 || Monitor: Dell 43" 4K P4317Q

Citera om du vill ha svar :)

Trädvy Permalänk
Medlem
Plats
Jämtland
Registrerad
Aug 2009
Skrivet av AtreX:

Fast om han bara ska använda ett vlan i cisco-switchen så finns det ju ingen poäng med att bygga trunk egentligen?
Sen får du gärna förklara lite utförligare varför man inte ska använda vlan1 "av säkerhetsskäl"..

Cisco praxis att inte använda vlan 1, varken som native eller alls. Helst inte 999 heller.

*Citera för svar*
Work smart, not hard.

Trädvy Permalänk
Medlem
Plats
Jönköping
Registrerad
Feb 2005
Skrivet av Purrfected:

Cisco praxis att inte använda vlan 1, varken som native eller alls. Helst inte 999 heller.

Helt riktigt att det är cisco-praxis, men det innebär inte att det är en säkerhetsrisk, att påstå det är att ha fel

Workstation "Miranda": P8Z77-V Deluxe | i5 3570K | 2x8Gb DDR3-1333 | GTX 1080 | Samsung Evo 850 + 1TB Lagring | P183 | XenServer "Elize": | Xeon E3| 8Gb DDR3 | Netbook "Ebba": NC10 | Nät: c3550-T12 | c892FSP | c1812 | c881 | c2960G-8TC | HP 1910-8G-PoE+ | Ciscodiplomerad: CCNP-Switch

Trädvy Permalänk
Medlem
Plats
här..
Registrerad
Jun 2006

Argumentet att inte använda VLAN 1 är väl helt enkelt att inte få in fel enheter på fel VLAN av misstag. Eller också i förberedelse för att man kanske bil segmentera nätet i framtiden.

Men i det här fallet så är ju det snarare önskat att inte behöva konfa upp portarna innan man stoppar i något.

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Plats
Jämtland
Registrerad
Aug 2009

@AtreX: Nu har jag inte läst varken CEH eller är särskilt bra på hacking själv, läste en brandväggskurs och ccna security på högskolan.
Men detta är vad jag hittade lite snabbt om varför man inte ska använda vlan 1 (punkt 4):
https://www.redscan.com/news/ten-top-threats-to-vlan-security...

Så skulle vilja säga att det är en säkerhetsrisk, det finns säkerligen flera sätt att utnyttja faktumet att de använder vlan 1 på.

Edit:
Iof pratar man ju då om native vlan. Så du kanske har rätt, men better to be safe then sorry, right? ^^

*Citera för svar*
Work smart, not hard.

Trädvy Permalänk
Medlem
Plats
Jönköping
Registrerad
Feb 2005
Skrivet av Purrfected:

@AtreX: Nu har jag inte läst varken CEH eller är särskilt bra på hacking själv, läste en brandväggskurs och ccna security på högskolan.
Men detta är vad jag hittade lite snabbt om varför man inte ska använda vlan 1 (punkt 4):
https://www.redscan.com/news/ten-top-threats-to-vlan-security...

Så skulle vilja säga att det är en säkerhetsrisk, det finns säkerligen flera sätt att utnyttja faktumet att de använder vlan 1 på.

Edit:
Iof pratar man ju då om native vlan. Så du kanske har rätt, men better to be safe then sorry, right? ^^

Din edit är helt korrekt, native-vlan kan vara en säkerhetsrisk om det används fel och det ska man naturligtvis bara använda mot slutnoder, däremot är det ingen som helst skillnad om du använder vlan 1 som native-vlan eller om du använder 3745. Den enda risk som någon någonsin lyckats påvisa för mig faktiskt existerar är om administratören inte vet vad han håller på med och tar bort sista vlan:et på en port som då hamnar i vlan 1, om då vlan 1 används till något så finns det ju en risk att det blir kasst, men det beror ju på skit bakom spakarna, inte att vlan 1 skulle vara mer tekniskt sårbart än något annat som aldeles för många tror.
Edit: tack för länken förresten, lägger den till listan över "saker att läsa igenom mer ordentligt när tid finnes"

Workstation "Miranda": P8Z77-V Deluxe | i5 3570K | 2x8Gb DDR3-1333 | GTX 1080 | Samsung Evo 850 + 1TB Lagring | P183 | XenServer "Elize": | Xeon E3| 8Gb DDR3 | Netbook "Ebba": NC10 | Nät: c3550-T12 | c892FSP | c1812 | c881 | c2960G-8TC | HP 1910-8G-PoE+ | Ciscodiplomerad: CCNP-Switch

Trädvy Permalänk
Inaktiv
Registrerad
Mar 2010
Skrivet av Hansar:

Kom ihåg att om du vill ha över VLAN ID till Cisco switchen måstedu sätte en TRUNK till den om konfa VLAN:ID separat på Cisco Switchen sen kan du ju segmentera dem så kamrerna sitter på VLAN 10 övriga enheter på VLAN 30, "använd inte VLAN1" av säkerhetsskäl. det borde du dock skapa ett interface med som är öppen för SSH internt och som "Console"

Om han vill fortsätta använda default VLAN så behöver han inte skapa någon trunk. Att segementera VLAN är ju bra men då måste han skapa L3 Interface på sin HP, det är ju inte säkert det går, i så fall måste han göra routing i pfsense och det åter lite overkill för några kameror.. Tror KISS är bäst här.

Trädvy Permalänk
Inaktiv
Registrerad
Mar 2010
Skrivet av Hansar:

@AtreX: Anledningen till varför inte VLAN1 är för att det är default för allt.

Så du menar att två Accessportar på vlan 1 är en högre säkerhetsrisk än två accessportar på vlan 19?

Trädvy Permalänk
Medlem
Plats
Piteå
Registrerad
Okt 2004

börjar inse hur lite jag kan om nätverk

men jag ska försöka mig på det som @lavaguden skrev och ta det därifrån tänkte jag

CPU: AMD Ryzen 1700x @ 3.8GHz || Mem: 16GB Corsair LPX 3000mhz || Mobo: Asus x370 Prime || GPU: EVGA Geforce GTX1070 SC || SSD: WD black 500GB m2 || OS: Linux Mint/Win 10 || Monitor: Dell 43" 4K P4317Q

Citera om du vill ha svar :)

Trädvy Permalänk
Medlem
Plats
Karlshamn
Registrerad
Apr 2006

Tycker att vi kan låta bli att spåra iväg med diskussionen i denna tråd för TS skull då det lätt blir rörigt för den oinvigda.
Låter bra @Pelle , återkom med konfigurationsfilen så kan vi säkert bena ut vad för problem du har.

Trädvy Permalänk
Medlem
Plats
Piteå
Registrerad
Okt 2004
Skrivet av Lavaguden:

Tycker det ser bra ut för en hemmamiljö.
Oavsett om du kör trunk eller inte mellan hp och cisco kan du skriva följande för att konna ansluta till cisco med telnet och ssh.
För att konna konfigurera måste man först skriva "conf t"
Har du användare och lösen?
skriv annars "username Pelle password Plutt

skriv sedan följande:
int vlan 1
ip address 192.168.1.2 255.255.255.0
exit
ip default-gateway 192.168.1.1
line con 0
login local
exit
line vty 0 4
login local
exit

Fungerar inte kommandot "ip deafult-gateway" ersätter du det med "ip route 0.0.0.0 0.0.0.0 192.168.1.1"
för att spara skriver man "wr" men innan dess brukar jag koppla från och koppla upp mig igen för att se att allt fungerar så man kan blåsa switchen genom omstart annars.

192.168.1.x ersätts naturligtvis av det som gäller för ditt nätverk.

edit: jag brukar inte heller använda mig av Vlan 1 i arbetet men hemma vet jag inte om jag hade brytt mig.
om du kan lägga ut confen på ciscon hade det nog underlättat med.
Du visar den genom att skriva " sh run"

Current configuration : 1470 bytes ! version 12.2 no service pad service timestamps debug datetime msec service timestamps log datetime msec no service password-encryption ! hostname Switch ! boot-start-marker boot-end-marker ! enable secret 5 $*************** enable password ******* ! ! ! no aaa new-model system mtu routing 1500 ! ! ! ! ! ! ! ! spanning-tree mode pvst spanning-tree extend system-id ! vlan internal allocation policy ascending ! ! ! ! interface FastEthernet0/1 ! interface FastEthernet0/2 ! interface FastEthernet0/3 ! interface FastEthernet0/4 ! interface FastEthernet0/5 ! interface FastEthernet0/6 ! interface FastEthernet0/7 ! interface FastEthernet0/8 ! interface FastEthernet0/9 ! interface FastEthernet0/10 ! interface FastEthernet0/11 ! interface FastEthernet0/12 ! interface FastEthernet0/13 ! interface FastEthernet0/14 ! interface FastEthernet0/15 ! interface FastEthernet0/16 ! interface FastEthernet0/17 ! interface FastEthernet0/18 ! interface FastEthernet0/19 ! interface FastEthernet0/20 ! interface FastEthernet0/21 ! interface FastEthernet0/22 ! interface FastEthernet0/23 ! interface FastEthernet0/24 ! interface GigabitEthernet0/1 ! interface GigabitEthernet0/2 ! interface Vlan1 ip address 192.168.1.2 255.255.255.0 ! ip classless ip http server ip http secure-server ! ! ip sla enable reaction-alerts ! snmp-server community***** RO ! ! line con 0 line vty 0 4 password ********* login line vty 5 15 password ********* login ! end

CPU: AMD Ryzen 1700x @ 3.8GHz || Mem: 16GB Corsair LPX 3000mhz || Mobo: Asus x370 Prime || GPU: EVGA Geforce GTX1070 SC || SSD: WD black 500GB m2 || OS: Linux Mint/Win 10 || Monitor: Dell 43" 4K P4317Q

Citera om du vill ha svar :)

Trädvy Permalänk
Medlem
Plats
Piteå
Registrerad
Okt 2004

allting verkar fungera som det ska nu, tack för hjälpen!

CPU: AMD Ryzen 1700x @ 3.8GHz || Mem: 16GB Corsair LPX 3000mhz || Mobo: Asus x370 Prime || GPU: EVGA Geforce GTX1070 SC || SSD: WD black 500GB m2 || OS: Linux Mint/Win 10 || Monitor: Dell 43" 4K P4317Q

Citera om du vill ha svar :)

Trädvy Permalänk
Medlem
Plats
Karlshamn
Registrerad
Apr 2006

@Pelle: jag svänger ihop en liten guide för dig imorgon måste i säng nu. Om du vill labba lite själv ska du lägga in switchport mode access och switchport access vlan 1 på varje port även gigporten du kopplat mot hp switchen.