Kan inte ansluta till OpenVPN över wifi

Trädvy Permalänk
Medlem
Plats
Norrköping
Registrerad
Okt 2004

Kan inte ansluta till OpenVPN över wifi

Tjena!
Har en OpenVPN access server sedan en tid tillbaka. Har upptäckt nu efter ett routerbyte, att om min mobil eller laptop befinner sig på ett wifi nätverk, inte kan ansluta. Det fungerar bra över 4G

Det jag vet på rak arm är annorlunda nu mot innan routerbytet är att jag har 192.168.0.x istället för 192.168.10.x.

Har en Asus Ac87u router.

Vet inte alls var jag ska börja. Kan jag få lite vägledning och förklaring?

$ grep parts /home/pwntato/thermaltake_core_v21
specs: core i7 6700k, 16GB vengeance lpx, asus maximus viii gene, asus strix 980ti, evga 850p2, samsung 850 evo 250GB, samsung 850 evo 1tb, wd green 1TB

$ echo citera gärna om du vill ha svar snabbare >> /home/pwntato/quote

Trädvy Permalänk
Medlem
Plats
Lindås
Registrerad
Okt 2005

Hej,

Du sitter inte på samma subnät som din openvpn?

Skrivet av pwntato:

Tjena!
Har en OpenVPN access server sedan en tid tillbaka. Har upptäckt nu efter ett routerbyte, att om min mobil eller laptop befinner sig på ett wifi nätverk, inte kan ansluta. Det fungerar bra över 4G

Det jag vet på rak arm är annorlunda nu mot innan routerbytet är att jag har 192.168.0.x istället för 192.168.10.x.

Har en Asus Ac87u router.

Vet inte alls var jag ska börja. Kan jag få lite vägledning och förklaring?

Skickades från m.sweclockers.com

Asus Maximus VII | Intel 4770 3.2GHz | 16GB Kingston 2133MHz | Asus GTX770 2GB SLI | Corsair H70 | Intel PCI Express 256GB SSD | Seagate 2TB HDD

Trädvy Permalänk
Medlem
Plats
Norrköping
Registrerad
Okt 2004
Skrivet av modaset:

Hej,

Du sitter inte på samma subnät som din openvpn?

Skickades från m.sweclockers.com

Jo det gör jag. Om jag ändrar det i OpenVPN, kommer jag ändå åt datorerna i lokala nätverket hemma?

$ grep parts /home/pwntato/thermaltake_core_v21
specs: core i7 6700k, 16GB vengeance lpx, asus maximus viii gene, asus strix 980ti, evga 850p2, samsung 850 evo 250GB, samsung 850 evo 1tb, wd green 1TB

$ echo citera gärna om du vill ha svar snabbare >> /home/pwntato/quote

Trädvy Permalänk
Medlem
Plats
Norrköping
Registrerad
Okt 2004

Bästa kanske vore att ändra subnet på routern på mitt lokala nätverk där vpn servern står, till ett subnet som inte används av typ alla andra nätverk.

Skickades från m.sweclockers.com

$ grep parts /home/pwntato/thermaltake_core_v21
specs: core i7 6700k, 16GB vengeance lpx, asus maximus viii gene, asus strix 980ti, evga 850p2, samsung 850 evo 250GB, samsung 850 evo 1tb, wd green 1TB

$ echo citera gärna om du vill ha svar snabbare >> /home/pwntato/quote

Trädvy Permalänk
Medlem
Plats
Lindås
Registrerad
Okt 2005

@pwntato: Går det att ansluta till tunneln när du sitter anslutet på ditt wifi? Vet inte om din router kan hanterar nat loopback.
Här är ett urklipp ifrån smallnetbuilder forum.

NAT Loopback is known to be broken when HW acceleration is enabled on the AC56/AC68U. Nothing I can do about it, the HW acceleration module is closed source. A fix will have to come from Broadcom or Asus.

Du har inte glömt att öppna portarna som openvpn pratar på?

Asus Maximus VII | Intel 4770 3.2GHz | 16GB Kingston 2133MHz | Asus GTX770 2GB SLI | Corsair H70 | Intel PCI Express 256GB SSD | Seagate 2TB HDD

Trädvy Permalänk
Medlem
Plats
Norrköping
Registrerad
Okt 2004
Skrivet av modaset:

@pwntato: Går det att ansluta till tunneln när du sitter anslutet på ditt wifi? Vet inte om din router kan hanterar nat loopback.
Här är ett urklipp ifrån smallnetbuilder forum.

NAT Loopback is known to be broken when HW acceleration is enabled on the AC56/AC68U. Nothing I can do about it, the HW acceleration module is closed source. A fix will have to come from Broadcom or Asus.

Du har inte glömt att öppna portarna som openvpn pratar på?

De är öppna o jag kan ansluta utifrån, förutsatt att jag inte har min client på ett wifi. Om min client använder 4g så går det bra.
Så t.ex. Jag har min laptop på jobbet, ansluten till jobbets wifi (samma på alla wifi jag provat). Då kan jag inte ansluta till min VPN server. Om jag nu internetdelar från telefonens 4g till laptop o sen ansluter till VPN. Då går de bra!

Skickades från m.sweclockers.com

$ grep parts /home/pwntato/thermaltake_core_v21
specs: core i7 6700k, 16GB vengeance lpx, asus maximus viii gene, asus strix 980ti, evga 850p2, samsung 850 evo 250GB, samsung 850 evo 1tb, wd green 1TB

$ echo citera gärna om du vill ha svar snabbare >> /home/pwntato/quote

Trädvy Permalänk
Medlem
Plats
Lindås
Registrerad
Okt 2005

Jag kan inte komma på vad det skulle kunna beror på. Du kan inte fixa lite screenshots?

Skrivet av pwntato:

De är öppna o jag kan ansluta utifrån, förutsatt att jag inte har min client på ett wifi. Om min client använder 4g så går det bra.
Så t.ex. Jag har min laptop på jobbet, ansluten till jobbets wifi (samma på alla wifi jag provat). Då kan jag inte ansluta till min VPN server. Om jag nu internetdelar från telefonens 4g till laptop o sen ansluter till VPN. Då går de bra!

Skickades från m.sweclockers.com

Asus Maximus VII | Intel 4770 3.2GHz | 16GB Kingston 2133MHz | Asus GTX770 2GB SLI | Corsair H70 | Intel PCI Express 256GB SSD | Seagate 2TB HDD

Trädvy Permalänk
Medlem
Plats
Norrköping
Registrerad
Okt 2004
Skrivet av modaset:

Jag kan inte komma på vad det skulle kunna beror på. Du kan inte fixa lite screenshots?

Jovisst! Börjar med dessa. https://imgur.com/a/yGBBP

Skickades från m.sweclockers.com

$ grep parts /home/pwntato/thermaltake_core_v21
specs: core i7 6700k, 16GB vengeance lpx, asus maximus viii gene, asus strix 980ti, evga 850p2, samsung 850 evo 250GB, samsung 850 evo 1tb, wd green 1TB

$ echo citera gärna om du vill ha svar snabbare >> /home/pwntato/quote

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Mar 2011

Låter som om brandväggen blockar dig.
När du ansluter till olika nätverk så får du olika profiler.
Antagligen är brandväggen ut bara öppnad i en av dessa profiler.

Klient: Intel I7 3820 | ASUS P9X79 Pro | 64GB 1600MHz | Corsair HX 850W | Gigabyte 980 | HAF 922 | Corsair Force 120G | Seagate XT 2TB
Server: Intel XEON E5620 x 2| ASUS Z8PE-D18 | 96GB 1333MHz | Corsair AX 1200W | HAF 932 | WD Black 2TB
HTPC: Intel I7 4770T | 16 GB 1600 | FC8 EVO | Gigabyte GA-H87N-WIFI | Samsung 840 250GB

Trädvy Permalänk
Medlem
Plats
Norrköping
Registrerad
Okt 2004
Skrivet av Prelatur:

Låter som om brandväggen blockar dig.
När du ansluter till olika nätverk så får du olika profiler.
Antagligen är brandväggen ut bara öppnad i en av dessa profiler.

Så du menar att om jag inte kan ansluta när jag befinner mig på en kompis wifi, så kan det bero på brandväggen i hans router? Med andra ord är det inte omöjligt att det skulle funka om jag t.ex befinner mig på ett wifi på stan?

Skickades från m.sweclockers.com

$ grep parts /home/pwntato/thermaltake_core_v21
specs: core i7 6700k, 16GB vengeance lpx, asus maximus viii gene, asus strix 980ti, evga 850p2, samsung 850 evo 250GB, samsung 850 evo 1tb, wd green 1TB

$ echo citera gärna om du vill ha svar snabbare >> /home/pwntato/quote

Trädvy Permalänk
Medlem
Plats
Lindås
Registrerad
Okt 2005

@pwntato: Kan du ansluta dig men du kommer bara inte åt ditt hemnätverk när du kör över wifi och vpn?

För t.ex om du sitter på ett wifi där du får 192.168.1.5 som IP och du försöker komma åt en server hemma hos dig som sitter på samma subnät så kommer du inte kunna komma åt datorn för det krockar med varandra.

Det kan förklara varför det fungerar när du kör via 4G och inte via wifi, dem flesta konsument wifi routers idag delar ut 192.168.1.0 eller 192.168.0.0 nät.

Asus Maximus VII | Intel 4770 3.2GHz | 16GB Kingston 2133MHz | Asus GTX770 2GB SLI | Corsair H70 | Intel PCI Express 256GB SSD | Seagate 2TB HDD

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Mar 2011
Skrivet av pwntato:

Så du menar att om jag inte kan ansluta när jag befinner mig på en kompis wifi, så kan det bero på brandväggen i hans router? Med andra ord är det inte omöjligt att det skulle funka om jag t.ex befinner mig på ett wifi på stan?

Skickades från m.sweclockers.com

Tänkte väl närmast på brandväggen i Windows på klientdatorn.
I Windows finns ju Domän profil, Privat profil och Offentlig profil.
Vilken av dessa som används som används beror ju på vilken uppkoppling som används.
Detta skulle kunna förklara att det fungerar olika beroende på hur klientdatorn är uppkopplad.

Klient: Intel I7 3820 | ASUS P9X79 Pro | 64GB 1600MHz | Corsair HX 850W | Gigabyte 980 | HAF 922 | Corsair Force 120G | Seagate XT 2TB
Server: Intel XEON E5620 x 2| ASUS Z8PE-D18 | 96GB 1333MHz | Corsair AX 1200W | HAF 932 | WD Black 2TB
HTPC: Intel I7 4770T | 16 GB 1600 | FC8 EVO | Gigabyte GA-H87N-WIFI | Samsung 840 250GB

Trädvy Permalänk
Medlem
Plats
Norrköping
Registrerad
Okt 2004
Skrivet av modaset:

@pwntato: Kan du ansluta dig men du kommer bara inte åt ditt hemnätverk när du kör över wifi och vpn?

För t.ex om du sitter på ett wifi där du får 192.168.1.5 som IP och du försöker komma åt en server hemma hos dig som sitter på samma subnät så kommer du inte kunna komma åt datorn för det krockar med varandra.

Det kan förklara varför det fungerar när du kör via 4G och inte via wifi, dem flesta konsument wifi routers idag delar ut 192.168.1.0 eller 192.168.0.0 nät.

Provar att ändra subnätet i routern till typ 192.168.43.0 och i OpenVPN. Känns som det borde va det. Eftersom förra routern med 192.168.10.0 funkade

Skickades från m.sweclockers.com

$ grep parts /home/pwntato/thermaltake_core_v21
specs: core i7 6700k, 16GB vengeance lpx, asus maximus viii gene, asus strix 980ti, evga 850p2, samsung 850 evo 250GB, samsung 850 evo 1tb, wd green 1TB

$ echo citera gärna om du vill ha svar snabbare >> /home/pwntato/quote

Trädvy Permalänk
Medlem
Plats
Lindås
Registrerad
Okt 2005
Skrivet av pwntato:

Provar att ändra subnätet i routern till typ 192.168.43.0 och i OpenVPN. Känns som det borde va det. Eftersom förra routern med 192.168.10.0 funkade

Skickades från m.sweclockers.com

Återkom gärna med hur det gick!

Asus Maximus VII | Intel 4770 3.2GHz | 16GB Kingston 2133MHz | Asus GTX770 2GB SLI | Corsair H70 | Intel PCI Express 256GB SSD | Seagate 2TB HDD

Trädvy Permalänk
Medlem
Plats
Norrköping
Registrerad
Okt 2004

@modaset: Provar i helgen

$ grep parts /home/pwntato/thermaltake_core_v21
specs: core i7 6700k, 16GB vengeance lpx, asus maximus viii gene, asus strix 980ti, evga 850p2, samsung 850 evo 250GB, samsung 850 evo 1tb, wd green 1TB

$ echo citera gärna om du vill ha svar snabbare >> /home/pwntato/quote

Trädvy Permalänk
Medlem
Plats
Norrköping
Registrerad
Okt 2004

@modaset: Ändrade allt här hemma till 192.168.11.x. Nu fungerar det! Antagligen fungerade det alltså inte om jag satt på ett wifi som hade samma subnet som jag har här hemma. Logiskt egt.

$ grep parts /home/pwntato/thermaltake_core_v21
specs: core i7 6700k, 16GB vengeance lpx, asus maximus viii gene, asus strix 980ti, evga 850p2, samsung 850 evo 250GB, samsung 850 evo 1tb, wd green 1TB

$ echo citera gärna om du vill ha svar snabbare >> /home/pwntato/quote

Trädvy Permalänk
Medlem
Plats
Lindås
Registrerad
Okt 2005
Skrivet av pwntato:

@modaset: Ändrade allt här hemma till 192.168.11.x. Nu fungerar det! Antagligen fungerade det alltså inte om jag satt på ett wifi som hade samma subnet som jag har här hemma. Logiskt egt.

Det är riktigt Ha så roligt med din tunnel!

Skickades från m.sweclockers.com

Asus Maximus VII | Intel 4770 3.2GHz | 16GB Kingston 2133MHz | Asus GTX770 2GB SLI | Corsair H70 | Intel PCI Express 256GB SSD | Seagate 2TB HDD