Videouppspelning .mkv hackar / drivrutiner

Trädvy Permalänk
Medlem
Registrerad
Jul 2005

Videouppspelning .mkv hackar / drivrutiner

Hej!

Jag har problem att spela upp .mkv filer i Linux Mint 18.2, det laggar.
Beror detta på druvrutiner?

När jag kollar i "Drivrutinshanteraren" så står det att inga slutna drivrutiner används, och det finns en enhet där som är "Okänd", jag har dock möjlighet att kryssa i "Intel microcode - processor microcode firmware for Intel CPU's"

Det är det enda som finns i listan i Drivrutinshanteraren.

Mitt grafikkort är AMD Radeon HD 7850.
Jag tycks dock komma ihåg att jag hade möjlighet att välja amd-drivers i Drivrutinshanteraren när jag hade Linux Mint 17 (baserat på Ubuntu 14.04).

Om jag går in på amd's hemsida och söker efter drivrutiner så får jag upp denna information:

Citat:

DEL 1:
Distributions supported:

Red Hat Enterprise Linux Suite 7.2, 7.1, 7.0, 6.7, 6.6, 6.5
Ubuntu 12.04.4 LTS, 14.04.2, 14.04.3, 15.04, 15.10
SUSE® Linux Enterprise 11 SP3, 12
OpenSuSE 13.1

DEL 2:
Distribution specific packages are available for:​

Red Hat Enterprise Linux Suite 7.1, 7.0, 6.6, 6.5
Ubuntu 12.04.4 LTS, 14.04.2​

Jag har provat att ladda ned drivrutiner specifikt för Ubuntu men då fick jag klagomål att det var felaktigt OS.

Ska jag prova att ladda ned och installera drivers enligt DEL 1, eller hur gör jag som?

Eller kan jag göra någon inställning i vlc för videouppspelning så att det inte hackar?

.mp4 filer tycks gå bra

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Feb 2005

Ladda hem mediainfo, och klipp och klistra vad den säger om videoformatet för en fil du har problem att spela, att den har filändelsen mkv säger ingenting om vad det är för videoformat.

Edit: också mycket möjligt att ditt kort inte längre har stöd i amds låsta drivrutiner och att du får använda den öppna, radeon. Skulle i vilket fall som helst undvika att ladda hem drivrutiner från amds hemsida och istället använda de som linux mint erbjuder.

Trädvy Permalänk
Medlem
Registrerad
Jul 2005

Jag fick upp mediainfo inuti vlc här:

Skärmdump: https://unsee.cc/rasugide/

Har provat 5st olika .mkv filer nu och alla hackar.

Trädvy Permalänk
Medlem
Registrerad
Jul 2005

Vad det gäller drivrutiner så förmodar jag att jag kör på Xorg just nu, annars hade det väl stått i Drivrutinshanteraren. Men det står inte heller i Drivrutinshanteraren att Xorg används.

EDIT:
-Om jag spelar upp .mkv med vlc så hackar det
-Om jag spelar upp .mkv med ett annat program, "xplayer" så fungerar det.

Finns det någon iställning i vlc som jag kan ställa in så att det inte hackar? Vill helst fortsätta använda vlc då jag är van vid den.

Trädvy Permalänk
Medlem
Plats
root
Registrerad
Jan 2004

@Lexdale finns det något särskilt behov för dig att köra Linux Mint 18 istället för Linux Mint 17 ??

Själv har jag använder jag ett Nvidia kort , MPlayer VDPAU, MPlayer rockar fett !

Trädvy Permalänk
Medlem
Registrerad
Mar 2016

Under inställningarna i VLC kan man välja mellan ett flertal videoaccelereringsmetoder. Prova dig fram.

Trädvy Permalänk
Medlem
Registrerad
Jul 2005
Skrivet av FattarNiInte:

Under inställningarna i VLC kan man välja mellan ett flertal videoaccelereringsmetoder. Prova dig fram.

Kan du vara mer specifik vilket alternativ som du tror löser detta?

Jag pillade massvis på detta igår kväll, men ingenting jag gjorde hjälpte, det måste finnas någon inställning som fixar detta tycker jag.

Trädvy Permalänk
Medlem
Registrerad
Dec 2015
Trädvy Permalänk
Medlem
Registrerad
Jul 2005

Jag har provat att ändrat till alla inställningar enligt bilden ovan, men ingenting har fungerat och det hackar fortfarande och blir pixelerat över hela bilden (vlc).

Jag har smplayer och xplayer som jag testat spela mkv i och det fungerar bra, men jag är van vlc och vill helst fortsätta använda den.

Lösning?

Trädvy Permalänk
Medlem
Plats
Helsingborg
Registrerad
Jan 2015

https://www2.ati.com/drivers/linux/ubuntu/amdgpu-pro-17.30-45...
för bl.a. AMD Radeon™ HD7700/7800/8500/8600 på Ubuntu 16.04, funkar för linux mint 18 om du modifierar installations-scriptet, förklaras här:
http://tutorialforlinux.com/2016/06/24/how-to-install-ati-rad...

Jag hade börjat där, vad du sen kan kolla upp är om du kör senaste versionen av VLC.

Trädvy Permalänk
Medlem
Registrerad
Jul 2005
Skrivet av elBenko:

https://www2.ati.com/drivers/linux/ubuntu/amdgpu-pro-17.30-45...
för bl.a. AMD Radeon™ HD7700/7800/8500/8600 på Ubuntu 16.04, funkar för linux mint 18 om du modifierar installations-scriptet, förklaras här:
http://tutorialforlinux.com/2016/06/24/how-to-install-ati-rad...

Jag hade börjat där, vad du sen kan kolla upp är om du kör senaste versionen av VLC.

Den första länken som du skrev fungerade inte (går till ati.com ). Samt, ska jag inte isåfall gå in på www.amd.com och söka drivers istället för ati.com ? eller är det samma sak?

Jag kör senaste versionen av vlc

Trädvy Permalänk
Medlem
Registrerad
Dec 2015

Har du provat alla alternativ på hardware decoding? det som jag ringade in och FattarNiInte pratade om? Beroende på vilken gpu du har kan du behöva nåt annat än auto där

Trädvy Permalänk
Medlem
Registrerad
Jul 2005
Skrivet av Klubba:

Har du provat alla alternativ på hardware decoding? det som jag ringade in och FattarNiInte pratade om? Beroende på vilken gpu du har kan du behöva nåt annat än auto där

Japp jag har provat alla alternativ där, det var typ 4 eller 5st alternativ.

Jag har för mig att jag för något år sedan hade samma problem med Linux mint 17 och då löste jag det genom att inaktivera hårdvaruacceleration på det stället som var inringat på bilden, men nu funkar inte det.

Trädvy Permalänk
Medlem
Plats
$HOME
Registrerad
Jun 2006

Med AMD är det väl VA-API som gäller för hårdvaruacceleration? Kolla också om du har OpenGL-HQ aktiverat? Det skulle också kunna vara en orsak till problemen du upplever.

Gentoo Linux | Screenshots | dotfiles

Trädvy Permalänk
Medlem
Registrerad
Mar 2016

Ändå märkligt att det fungerat i andra spelare men inte vlc. Har du testat min favoritspelare, smplayer? Den är bäst.

Annars kan du testa beta drivisar från padoka eller oibaf ppa. Eller kanske hellre updaterade drivrutiner från padokas stabila ppa..

Trädvy Permalänk
Medlem
Plats
Helsingborg
Registrerad
Jan 2015

@Lexdale: Ah, vänta, http://support.amd.com/en-us/kb-articles/Pages/AMDGPU-PRO-Dri...

edit: ah, såg precis att det är "pro" drivaren, vet inte riktigt vad som skiljer den från vanliga catalystpaketet.

Trädvy Permalänk
Medlem
Plats
$HOME
Registrerad
Jun 2006
Skrivet av FattarNiInte:

Ändå märkligt att det fungerat i andra spelare men inte vlc. Har du testat min favoritspelare, smplayer? Den är bäst.

Annars kan du testa beta drivisar från padoka eller oibaf ppa. Eller kanske hellre updaterade drivrutiner från padokas stabila ppa..

Fast, om den vore "bäst" - då skulle väl alla använda den?

Gentoo Linux | Screenshots | dotfiles

Trädvy Permalänk
Medlem
Registrerad
Mar 2016

@Hund:
Jo jag tycker själv att det är lite konstigt. Man kan anta att det beror på okunskap, eller gammal vana.

Trädvy Permalänk
Medlem
Registrerad
Mar 2016

@elBenko:
Amd pro drivern har ersatt catalyst som inte längre utvecklas.
Själv tycker jag att amdgpu-pro drivrutinen är rätt usel då det gäller prestanda utom just vulkan- och opencl-bitarna då.
Amd själv säger (via Bridgeman på phoronix forum) att man skall använda mesa för spel och pro för typ compabilitet med jobbgrejer.
Då det gäller vulkan börjar dessutom mesa bli rätt kompetent, Doom mfl flyter utan problem

Trädvy Permalänk
Medlem
Plats
Helsingborg
Registrerad
Jan 2015
Skrivet av FattarNiInte:

@elBenko:
Amd pro drivern har ersatt catalyst som inte längre utvecklas.
Själv tycker jag att amdgpu-pro drivrutinen är rätt usel då det gäller prestanda utom just vulkan- och opencl-bitarna då.
Amd själv säger (via Bridgeman på phoronix forum) att man skall använda mesa för spel och pro för typ compabilitet med jobbgrejer.
Då det gäller vulkan börjar dessutom mesa bli rätt kompetent, Doom mfl flyter utan problem

Ok, ja jag läste en forumpost att amdpro-drivaren är den som gäller nu för de nyare korten, men det andra visste jag ej, tack för infon

Trädvy Permalänk
Medlem
Plats
Borås
Registrerad
Okt 2002

AMDGPU har bara experimentell support för GCN 1.0 Southern Islands (vilket HD 7850 hör till) och jag tror detsamma gäller AMDGPU Pro. Det är heller inte säkert man får bättre prestanda på detta grafikkort så enklast är nog att köra RadeonSI drivrutinen som kommer "out of the box".

Angående videouppspelningsproblemet så testa installera mesa-vdpau-drivers samt vdpauinfo och gör omstart. Verifiera att vdpau är OK med vdpauinfo i terminalen. Ställ sedan in VLC att använda VDPAU och testa om det funkar.