Felaktig Boot.ini fil

Trädvy Permalänk
Medlem
Plats
Vänersborg
Registrerad
Mar 2005

Felaktig Boot.ini fil

Hej!

Jag har ett litet problem som jag nu tänkte ta tag i gällande uppstarten av min dator. När jag startar datorn så får jag upp följande felmeddelande:

"Felaktig boot.ini fil, startar ifrån C:/windows istället"

Den fel texten kommer upp och har gjort ett bra tag och nu tänkte jag ta tag i problemet. Visst startar datorn som vanligt men det tar oerhört mycket längre tid dock.

Vet att det funnits trådar om detta förut, men testat att skapa en ny boot.ini fil. Men det var ett tag sen jag försökte fixa det så minns inte hur man kunde lösa problemet.

Så om nu någon där ute vet hur man gör för att återgärda problemet. Please let me know!

Tack på förhand!

"Jag är inte dum, jag har bara lite otur när jag tänker."

Trädvy Permalänk
Hedersmedlem
Plats
Märsta
Registrerad
Jan 2002

Om inte boot.ini hittas så chansar windows på att det finns på första hårddisken-> första partitionen. Som verkar fungera för dig.
En korrekt boot.ini för detta skulle vara:

[boot loader] timeout=0 default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS [operating systems] multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows Server 2003, Enterprise" /fastdetect /NoExecute=OptOut

Jag ändrade min fil lite. Har du inte XP SP2 eller server 2003 får du ta bort /NoExecute-växeln.

Forumregler | Feedbackforumet | Något som behöver modereras? Tryck på Anmäl inlägget och ge en anledning, någon moderator kommer granska inlägget och göra (egen) bedömning
"Fate. Protects fools, little children and ships named Enterprise." - Riker - ST:TNG

Trädvy Permalänk
Medlem
Plats
Vänersborg
Registrerad
Mar 2005

Hmm, ok. Min boot.ini fil ser nämligen ut så här.

"[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect"

Vad står kommandot timeout för? Har nämligen en annan kompis som hade "3" där istället för "30". Inte för att jag tror det har någon större betydelse.

Förstår fortfarande inte varför jag får upp felmeddelandet om jag har en boot.ini fil som verkar korrekt?

Lite info: kör Win XP Pro, SP2

EDIT: la till lite info

"Jag är inte dum, jag har bara lite otur när jag tänker."

Trädvy Permalänk
Hedersmedlem
Plats
Uppsala
Registrerad
Aug 2002
Citat:

Ursprungligen inskrivet av r3flex
Vad står kommandot timeout för? Har nämligen en annan kompis som hade "3" där istället för "30". Inte för att jag tror det har någon större betydelse.

Hur lång tid innan markerat alternativ blir aktiverat (dvs bootas).

Trädvy Permalänk
Medlem
Plats
Vänersborg
Registrerad
Mar 2005
Citat:

Ursprungligen inskrivet av Kanel
Hur lång tid innan markerat alternativ blir aktiverat (dvs bootas).

Men om jag sätter min sån på 0 så innebär väl inte det att jag slipper mitt jobbiga felmeddelande. Är det ingen som vet hur jag bär mig åt för att få bort mitt felmeddelande?

"Jag är inte dum, jag har bara lite otur när jag tänker."

Trädvy Permalänk
Hedersmedlem
Plats
Uppsala
Registrerad
Aug 2002
Citat:

Ursprungligen inskrivet av r3flex
Men om jag sätter min sån på 0 så innebär väl inte det att jag slipper mitt jobbiga felmeddelande. Är det ingen som vet hur jag bär mig åt för att få bort mitt felmeddelande?

Nej, antagligen inte. Har aldrig hört om detta problem tidigare, så jag har inget förslag direkt.

Trädvy Permalänk
Medlem
Plats
Vänersborg
Registrerad
Mar 2005

Måste väl finnas någon som har någon lösning på hur man fixar till sin boot.ini fil utan att behöva formatera om sin hårddisk?

Vet att det fanns någon tråd förut om detta, men hittar den inte när jag försöker söka upp den, kan visserligen hända att den låg i offtopic.

"Jag är inte dum, jag har bara lite otur när jag tänker."

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2001

fixmbr och fixboot i recovery console kanske kan hjälpa? Starta med XP-cdn och klicka tills du få välja det

Trädvy Permalänk
Medlem
Plats
Kebabens huvudstad
Registrerad
Feb 2005

Varför inte "låna" någons annan boot.ini..?? det kanske inte funkar.. vad vet jag..pluggar ju bara "första" året på TG

Trädvy Permalänk
Medlem
Plats
-
Registrerad
Jul 2002
Citat:

Ursprungligen inskrivet av tcntad
Varför inte "låna" någons annan boot.ini..?? det kanske inte funkar.. vad vet jag..pluggar ju bara "första" året på TG

Tidig Gröngöling

.:Wks: Cooler Master Silencio 650|Core i5 3570 3.4 GHz|Asus P8Z77-V|8 GB| GT 465|1xDell U2311H, 2xAlienware AW2210 2xEizo 19|OCZ Revo 3 Drive 120 + Raptor 150:.
.:Server: Har ett gäng :) :.
-Learn the system, Play the system, Break the system-

Trädvy Permalänk
Medlem
Plats
Datorlabb
Registrerad
Jul 2004
Citat:

Ursprungligen inskrivet av r3flex
Hmm, ok. Min boot.ini fil ser nämligen ut så här.

"[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect"

Vad står kommandot timeout för? Har nämligen en annan kompis som hade "3" där istället för "30". Inte för att jag tror det har någon större betydelse.

Förstår fortfarande inte varför jag får upp felmeddelandet om jag har en boot.ini fil som verkar korrekt?

Lite info: kör Win XP Pro, SP2

EDIT: la till lite info

Pröva med att ändra sista raden till :

="Microsoft Windows XP Professional" /noexecute=optin /fastdetect

"Ge daj inte"

Trädvy Permalänk
Hedersmedlem
Plats
Märsta
Registrerad
Jan 2002

Har du flera partitioner?
Isf vilken har du lagt boot.ini i?
Den ska ligga på den som är märkt "System" i diskmgmt.msc (obs icke "Boot" om det inte är samma).
Kort sagt ska den ju ligga vid ntldr och ntdetect.com som används (om man råkat sprida ut kopior på dem mellan partitionerna).

Citat:

Ursprungligen inskrivet av Ibis
fixmbr och fixboot i recovery console kanske kan hjälpa? Starta med XP-cdn och klicka tills du få välja det

Har inte med problemet att göra. MBR letar efter ntldr. filen. Minns inte om det är ntldr eller ntdetect.com som i sin tur tittar efter boot.ini

Edit:
Jag tror föga på att /noexecute kommer hjälpa. Det är boot.ini som inte hittas eller är felaktig -> dvs vad som står i den har ingen verkan.

Forumregler | Feedbackforumet | Något som behöver modereras? Tryck på Anmäl inlägget och ge en anledning, någon moderator kommer granska inlägget och göra (egen) bedömning
"Fate. Protects fools, little children and ships named Enterprise." - Riker - ST:TNG

Trädvy Permalänk
Medlem
Plats
Skene sinCity
Registrerad
Jun 2004

Denna sida kanske kan hjälpa dig

http://support.microsoft.com/kb/330184/

ps ax | grep 'signatur' | awk '{ print $1}' | xargs kill -HUP

Trädvy Permalänk
Forumledare
Plats
Jönköping
Registrerad
Jun 2004
Citat:

Ursprungligen inskrivet av r3flex
Måste väl finnas någon som har någon lösning på hur man fixar till sin boot.ini fil utan att behöva formatera om sin hårddisk?

Vet att det fanns någon tråd förut om detta, men hittar den inte när jag försöker söka upp den, kan visserligen hända att den låg i offtopic.

Bumpning är inte tillåtet. Genom att bumpa och alltså bryta mot reglerna har du förlorat möjligheten att få hjälp.

*tråd låst*

Kontakta mig direkt vid frågor om eller synpunkter på modereringen/forumet och glöm inte att tala om vilken tråd det handlar om. Kontaktvägar: albert@sweclockers.com, kontaktformuläret och moderatorernas gemensamma pm-konto. Annat användbart: regler och feedbackforumet. Funderar du på att anmäla ett inlägg? Tveka inte! Gör det även om du är osäker. Det är vår sak att bedöma det, inte din.