Hjälp mig installera Ubuntu på min x64 server.

Trädvy Permalänk
Medlem
Plats
Skåne
Registrerad
Feb 2002

Hjälp mig installera Ubuntu på min x64 server.

Hej..
Jag skulle vilja ha lite hjälp med att installera Ubuntu på min server. Jag har installerat debian innan på Xeon EM64T servrar utan problem.
Men nu har jag stora problem med Ubuntu..

Eftersom debian inte vill fungera med AMD64 (IA64 funkar fint) så tänkte jag prova Ubuntu och jag har inga som hellst problem att installera operativsystemet... jag kommer så långt så att jag kan logga in och köra apt-get osv.. Mao så funkar allting prtecis som det ska..

MEN, när jag bootar om maskinen så hänger din sig när den laddar operativet..
Detta är riktigt störigt, då det annars verkar vara ett klockrent operativsystem för min server.

Så snälla, hjälp mig att installera Ubuntu, och säg inte åt mig att gå över till ett annat operativsystem.
Jag provade installera Debian i386 och sen uppgradera kernelen till kernel-image-2.6.11-K8-smp.
När den då bootade om så fick den frispel (antagligen pga av att den inte klarade av min dualcore cpuer) och jag fick upp en jäkla massa siffror och det stog något om cpu1..

Mvh //Magnus

#1: Intel i7-2600K | 8GB RAM | 780 GTX Ti | 8x Samsung EVO raid-10 LSI 9271-8i
#2: Dell XPS 1330
http://www.excellent-servers.se - http://www.excellent-hosting.se

Trädvy Permalänk
Medlem
Registrerad
Jul 2001

Provat söka och ställa frågan på http://www.ubuntuforums.org ?
Helt säker på att det inte är något hårdvaruproblem?

Trädvy Permalänk
Medlem
Plats
Skåne
Registrerad
Feb 2002

w1per.. tro mig.. jag har letat efter ett svar på min fråga..
Det enda jag har kommit fram till är att en person på ubuntu forumet också hade problem med kernelpanic när han hade installerat ubuntu.
Han hade då också Dual Opteron och 8Gb Ram.

Och nej.. det är inget hårdvaru relaterat..
Jag har installerat Windows Server 2003 x64 på den och det fungerade klockrent.

Mvh //Magnus

P.s moderkortet är ett Tyan K8SE du kan ju kolla upp vad det är för hårdvara på det. Och om det skulle kunna orsaka instabilitet.

D.s Jag har iofs bara provat med 5.10, provar med 5.04 nu för att se om det blir ngn skillnad.

#1: Intel i7-2600K | 8GB RAM | 780 GTX Ti | 8x Samsung EVO raid-10 LSI 9271-8i
#2: Dell XPS 1330
http://www.excellent-servers.se - http://www.excellent-hosting.se

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Jul 2001

Tror din maskinvara är lite för häftig för Ubuntu helt ärligt.

hade nog kört Debian-AMD64 med ny fräsch custom kernel

Trädvy Permalänk
Medlem
Plats
Skåne
Registrerad
Feb 2002

maDa: Hadejag haft kunskapen att komilera min egen kernel hade jag gärna gjort det...
Men jag har tyvär inte det..

Såhär ser felmeddelandet ut som jag får.

Mvh //Magnus

P.s Jag trodde inte Debian hade stöd för AMD64 ?
Hittar iaf ingen netinstall för det?

#1: Intel i7-2600K | 8GB RAM | 780 GTX Ti | 8x Samsung EVO raid-10 LSI 9271-8i
#2: Dell XPS 1330
http://www.excellent-servers.se - http://www.excellent-hosting.se

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Jul 2001
Citat:

Ursprungligen inskrivet av ViZioN
maDa: Hadejag haft kunskapen att komilera min egen kernel hade jag gärna gjort det...
Men jag har tyvär inte det..

Såhär ser felmeddelandet ut som jag får.

http://www.excellent-servers.se/error.jpg

Mvh //Magnus

P.s Jag trodde inte Debian hade stöd för AMD64 ?
Hittar iaf ingen netinstall för det?

Jag kan posta en trevlig config, du behöver dock klicka i din processor & kontrollerkort osv.. i menuconfigen. Därefter är det bara att kopiera vmlinuz och System.map till /boot. Och efter det update-grub.

Får en känsla om SMP-fel när jag ser den panicen.

hum.. Jag hittar knappt nån amd64 alls nu.. var har den tagit vägen? Fanns en arch till det förr iaf...

Trädvy Permalänk
Medlem
Plats
Skåne
Registrerad
Feb 2002

Du får gärna posta configen..
Jag provar mer än gärna Debian/Ubuntu då jag kör Debian på mina andra servrar och känner mig hemma i den disten.

Om du orkar får du gärna förklara hur jag ska göra för att få till min egen kernel.

Mvh //Magnus

#1: Intel i7-2600K | 8GB RAM | 780 GTX Ti | 8x Samsung EVO raid-10 LSI 9271-8i
#2: Dell XPS 1330
http://www.excellent-servers.se - http://www.excellent-hosting.se

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Aug 2003

http://www.debian.org/ports/amd64/
http://cdimage.debian.org/cdimage/unofficial/sarge-amd64/iso-...

Visserligen inofficiell, men med tanke på Debians takt på att införa nyheter så lär den vara inoffciell ett par år till...

Trädvy Permalänk
Medlem
Plats
Sundsvall
Registrerad
Feb 2002

Re: Hjälp mig installera Ubuntu på min x64 server.

Citat:

Ursprungligen inskrivet av ViZioN
Hej..
Jag skulle vilja ha lite hjälp med att installera Ubuntu på min server. Jag har installerat debian innan på Xeon EM64T servrar utan problem.
Men nu har jag stora problem med Ubuntu..

Eftersom debian inte vill fungera med AMD64 (IA64 funkar fint) så tänkte jag prova Ubuntu och jag har inga som hellst problem att installera operativsystemet... jag kommer så långt så att jag kan logga in och köra apt-get osv.. Mao så funkar allting prtecis som det ska..

MEN, när jag bootar om maskinen så hänger din sig när den laddar operativet..
Detta är riktigt störigt, då det annars verkar vara ett klockrent operativsystem för min server.

Så snälla, hjälp mig att installera Ubuntu, och säg inte åt mig att gå över till ett annat operativsystem.
Jag provade installera Debian i386 och sen uppgradera kernelen till kernel-image-2.6.11-K8-smp.
När den då bootade om så fick den frispel (antagligen pga av att den inte klarade av min dualcore cpuer) och jag fick upp en jäkla massa siffror och det stog något om cpu1..

Mvh //Magnus

IA64? Fungerade itaniumkärnan på din AMD64?

Trädvy Permalänk
Medlem
Plats
Sollentuna
Registrerad
Okt 2003

det e minnes problem

installera m. typ 512 MB ram och lägg i minnena efter att du installerat ubuntu m. smp tex (om du har dubbla cpu's)

finns flera boot/kernel parameters

¤ SLÅ DET HÄR OM NI KAN ¤
duron 1600 - K7S8X - Diamond Viper z200 32 mB (skit) - 384 mB 2100 DDR - 160 gb Seagate 2 mB

Trädvy Permalänk
Medlem
Plats
Skåne
Registrerad
Feb 2002

jgb_jgb: Kan du förklara lite utförligare..
Ska jag bara ha en minnessticka i när jag installerar Ubuntu ?
Ska det fungera sen när allting är klart, så det bara är att stoppa i alla minnena och sen boota upp?

Mvh //Magnus

#1: Intel i7-2600K | 8GB RAM | 780 GTX Ti | 8x Samsung EVO raid-10 LSI 9271-8i
#2: Dell XPS 1330
http://www.excellent-servers.se - http://www.excellent-hosting.se

Trädvy Permalänk
Medlem
Plats
::1
Registrerad
Jun 2005

Vizion, den inofficiella ISOn som Jaif länkade till fungerade fint på min amd64. Har du provat den?

Trädvy Permalänk
Medlem
Plats
Sollentuna
Registrerad
Okt 2003

har läst om att install kärnan inte kan adressera mycket minne vid install
så prova med 1 512 sticka eller 2 256 stickor samt vanlig kärna utan smp.
smp kärnan kan du lägga till m. apt-get sen

sen finns det special boot/kernel parameters när man trycker F1-F? knapparna.

lycka till

hittade nåt som heter IOMMU som skall finnas i ditt bios ? provat uppgradera ?
http://www.64bit-world.com/forums/archive/index.php/t-2791.ht...

Tyan Thunder K8SE S2892 V1.03

New features and Fixes :
* Added support for Rev E5/E6 Opteron CPU's
* Added AMD PowerNOW options with default setting as [Disabled]
* Added Auto Fan Control Function option for initial duty cycle from 25% to 55%
* Changed the Hot key for POPup BBS menu from [F8] to [F9]
* Added support for AMD BIOS check 2.3.0
* Added support for an AOPEN DVD1648/AAP drive
* Added support for nVidia SATA RAID mix with a regular SATA HDD
* Fixed an error where "CPU reading temperature error" would show during POST messages if you changed CPU's
* Added support to boot to an OS without a Keyboard present
* Added support for a LSI ultra 320 card to operate from a PCI-32 slot under 64 bit windows
* Added Broadcom LAN PXE boot option for port 1 or Port 2
* Added BIOS setup option for enable/disable the "POST errors" messages
* Added "IOMMU" setup option for Linux system
* Added "Memory clock" setup option

¤ SLÅ DET HÄR OM NI KAN ¤
duron 1600 - K7S8X - Diamond Viper z200 32 mB (skit) - 384 mB 2100 DDR - 160 gb Seagate 2 mB