Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Dec 2001

RAID-problem i Slackware

Hejsan!

RR182x [0]: start channel (0) RR182x [0,0]: channel started successfully RR182x [0]: start channel (1) RR182x [0,1]: channel started successfully RR182x [0]: start channel (2) RR182x [0,2]: channel started successfully RR182x [0]: start channel (3) RR182x [0,3]: channel started successfully RR182x: RAID5 write-back enabled scsi0 : hptmv Vendor: RR182x Model: RAID 5 Array Rev: 3.00 Type: Direct-Access ANSI SCSI revision: 00 SCSI device sda: 1758216960 512-byte hdwr sectors (900207 MB) SCSI device sda: drive cache: write through SCSI device sda: 1758216960 512-byte hdwr sectors (900207 MB) SCSI device sda: drive cache: write through sda: Attached scsi disk sda at scsi0, channel 0, id 0, lun 0 Attached scsi generic sg0 at scsi0, channel 0, id 0, lun 0, type 0 Loading Adaptec I2O RAID: Version 2.4 Build 5go Detecting Adaptec I2O RAID controllers... ipr: IBM Power RAID SCSI Device Driver version: 2.0.12 (December 14, 2004) RocketRAID 154x/1640 SATA Controller driver Version 2.13, Compiled Sep 17 2005 19:10:36 RocketRAID 154x/1640 SATA Controller driver

Efter som det står:
Attached scsi disk sda at scsi0, channel 0, id 0, lun 0

...antog jag att det fanns en enhet, i /dev som hette sda. Men det gör det inte. Några tips på vart jag kan hitta denna enhet?

Jag vill altså kunna partitionera, formatera, och skapa ett filsystem på den. Men det är lite svårt när jag inte vet vart den finns.

Tack på förhand!

Mvh,
Marwin

EDIT:

root@dvd:/# cat /proc/scsi/hptmv/0 RocketRAID 182x SATA Controller driver Version 1.12 Physical device list Controller Channel Model Capacity Status Array ------------------------------------------------------------------------ Controller 1 Channel 1 ST3300831AS 286168MB Normal RAID5-0 Controller 1 Channel 2 ST3300831AS 286168MB Normal RAID5-0 Controller 1 Channel 3 ST3300831AS 286168MB Normal RAID5-0 Controller 1 Channel 4 ST3300831AS 286168MB Normal RAID5-0 Logical device list No. sd Type Name Capacity Status ------------------------------------------------------------------------ 1 /dev/sda RAID 5 RAID5-0 858504MB Normal

Som det, även där, står bode /dev/sda vara skapad. Men det konstiga är att det inte finns någon /dev/sd* alls.

EDIT2:

Det var udev som inte, ännu, uppdaterat /dev.

Körde en udevstart för att uppdatera /dev. Fungerar perfekt nu!

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Okt 2004

Kollat om /dev/discs/ existerar, isf, vad innehåller den?
Jag har aldrig pillat med raid, det kanske använder kör andra sökvägar?

Computer science is no more about computers than astronomy is about telescopes.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Dec 2001

Tack ändå monotux!

Trädvy Permalänk
Medlem
Registrerad
Jun 2005

Hej!
Jag har samma problem som du beskriver, men jag vet inte hur man kör en "udevstart". Någon som kan hjälpa mig?

EDIT: Alternativt, kan man formatera partitionen till rätt format via windows istället, så slipper jag fdisk?