Å, Ä och Ö på diverse ställen

Trädvy Permalänk
Medlem
Plats
08-området
Registrerad
Jul 2002

Å, Ä och Ö på diverse ställen

Det här med å, ä och ö för den delen ü är något jag som dyker upp och bråkar lite titt som tätt.
På den tiden jag körde Slackware var detta aldrig några problem, men nu när jag
kör Ubuntu bråkar det allt som oftast.
Jag antar att det har något att göra med UTF-8 vs. ISO- .

Mappar och filnamn som kopieras från extern lagringsenhet (usb-minne, cd-rom etc) märks bl.a. med "invalid encoding" i Nautilus och givetvis icke korrekt visning av å,ä och ö i både terminal och grafisk filhanterare.

Likaså gäller det ett perl-program som indexerar cd-skivor i en mysql db.

Vad gör jag åt detta om jag vill få ordning på å, ä och ö? Frågan gäller kanske främst det perl-relaterade problemet.

| Zepto Znote 4200 | Centrino 1.6 GHz | 512 MB | ATI 9700 | Ubuntu | WinXP Pro | ICQ# 54811730
"Förmågan att idag tänka annorlunda än igår skiljer den vise från den envise." --John Steinbeck
"Self improvement is mastrubation" --T.D.

Trädvy Permalänk
Medlem
Plats
Stockholm, Täby
Registrerad
Jul 2001

Re: Å, Ä och Ö på diverse ställen

Du måste specificera teckenkodningen på dina "Windows-enheter". T.ex: mount -o nls=iso-8859-1 /dev/cdrom /media/cdrom

Trädvy Permalänk
Medlem
Plats
Skogås
Registrerad
Jul 2004

När ändå ämnet om åäö är uppe kanske jag kan klämma in en fråga.

Jag kör mycket med emacs(bara emacs) när jag programmerar.

I X (med fluxbox eller gnome) funkar åäö i emacs, men inte om jag kör utan x... hur kan man fixa det?

Det är GNU Emacs det gäller. På Ubuntu.

People... What a bunch of bastards... | Mac Pro 2x2.26GHz QuadCore - Nehalem, 24GB DDR3, ATI HD4870, 3TB HDD | MacBook Pro 13.3 ", Core 2 Duo - 2.26GHz, 8GB DDR3, 9400M 256MB, 120GB SSD | PowerMac G4 MDD, Dual 1,25GHz, 2GB DDR, 1,45TB HDD | FCNSA | VCP4

Trädvy Permalänk
Medlem
Plats
Stockholm, Täby
Registrerad
Jul 2001
Citat:

Ursprungligen inskrivet av larsrohdin
När ändå ämnet om åäö är uppe kanske jag kan klämma in en fråga.

Jag kör mycket med emacs(bara emacs) när jag programmerar.

I X (med fluxbox eller gnome) funkar åäö i emacs, men inte om jag kör utan x... hur kan man fixa det?

Det är GNU Emacs det gäller. På Ubuntu.

X och har olika system för tangentbordshanteringen så du måste specificera svenskt tangentbord i båda miljöerna. (X är i sig självt som ett OS)

Antingen kan du byta (om och om igen) genom "loadkeys"-kommandot, eller så redigerar man motsvarande tangentbords-fil i sin dist. T.ex: /etc/conf.d/consolefont i Gentoo, /etc/rc.d/rc.keymap i Slackware och/eller /etc/rc.d/rc.local i många övriga system...

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Feb 2004

prova köra 'unicode_start' i konsollen, det funkar för mig,

edit: detta var ett svar till rohdin och det funkar nog bara ifall man kör med utf8

enlisy Systemd
WS1: X2 4400+ | WS2: X2 4000+ | Laptop: Athlon2 P520 | Server: XP 2400+

Trädvy Permalänk
Medlem
Plats
Skogås
Registrerad
Jul 2004
Citat:

Ursprungligen inskrivet av Jonos
prova köra 'unicode_start' i konsollen, det funkar för mig,

edit: detta var ett svar till rohdin och det funkar nog bara ifall man kör med utf8

det gav bara svaret utf8 already running

People... What a bunch of bastards... | Mac Pro 2x2.26GHz QuadCore - Nehalem, 24GB DDR3, ATI HD4870, 3TB HDD | MacBook Pro 13.3 ", Core 2 Duo - 2.26GHz, 8GB DDR3, 9400M 256MB, 120GB SSD | PowerMac G4 MDD, Dual 1,25GHz, 2GB DDR, 1,45TB HDD | FCNSA | VCP4

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Feb 2004

konstigt, här funkar det perfekt i vim i alla fall, har inte kört emacs på ett par år,

enlisy Systemd
WS1: X2 4400+ | WS2: X2 4000+ | Laptop: Athlon2 P520 | Server: XP 2400+

Trädvy Permalänk
Medlem
Plats
Skogås
Registrerad
Jul 2004
Citat:

Ursprungligen inskrivet av Jonos
konstigt, här funkar det perfekt i vim i alla fall, har inte kört emacs på ett par år,

jag provade i VIM och där funkar det.... Har det med emacs att göra då?

People... What a bunch of bastards... | Mac Pro 2x2.26GHz QuadCore - Nehalem, 24GB DDR3, ATI HD4870, 3TB HDD | MacBook Pro 13.3 ", Core 2 Duo - 2.26GHz, 8GB DDR3, 9400M 256MB, 120GB SSD | PowerMac G4 MDD, Dual 1,25GHz, 2GB DDR, 1,45TB HDD | FCNSA | VCP4

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Feb 2004

ditt emacs kanske är kompilerat utan utf8 stöd,

edit: jag såg nu att du kör ubuntu så då är det nog något annat som strular,

enlisy Systemd
WS1: X2 4400+ | WS2: X2 4000+ | Laptop: Athlon2 P520 | Server: XP 2400+

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Aug 2003

Ubuntu använder UTF-8 som standard, och vill du köra nått annat så gör så här:

sudo dpkg-reconfigure locales
Leta sedan upp sv_SE ISO-8859-1 och sv_SE ISO-8859-15 i listan och kryssa i dessa. I nästa fönster väljer du sv_SE ISO-8859-15 som standard.
Starta sedan om X så borde det fungera.

Trädvy Permalänk
Medlem
Plats
Skogås
Registrerad
Jul 2004
Citat:

Ursprungligen inskrivet av Jaif
Ubuntu använder UTF-8 som standard, och vill du köra nått annat så gör så här:

sudo dpkg-reconfigure locales
Leta sedan upp sv_SE ISO-8859-1 och sv_SE ISO-8859-15 i listan och kryssa i dessa. I nästa fönster väljer du sv_SE ISO-8859-15 som standard.
Starta sedan om X så borde det fungera.

Fortfarande ingen skillnad i emacs.

edit: skulle jag ta bort UTF-8?

People... What a bunch of bastards... | Mac Pro 2x2.26GHz QuadCore - Nehalem, 24GB DDR3, ATI HD4870, 3TB HDD | MacBook Pro 13.3 ", Core 2 Duo - 2.26GHz, 8GB DDR3, 9400M 256MB, 120GB SSD | PowerMac G4 MDD, Dual 1,25GHz, 2GB DDR, 1,45TB HDD | FCNSA | VCP4

Trädvy Permalänk
Medlem
Registrerad
Aug 2003

(set-language-environment "Latin-1")
(set-keyboard-coding-system 'latin-1)
(set-terminal-coding-system 'latin-1)
(prefer-coding-system 'latin-1)
har jag i min .emacs, och åäö fungerar även i emacs -nw.

<darren> the hardest part of linux is choosing either a kill bill or an anime wallpaper i wish i didnt have to choose

Trädvy Permalänk
Medlem
Plats
Skogås
Registrerad
Jul 2004
Citat:

Ursprungligen inskrivet av roggles
(set-language-environment "Latin-1")
(set-keyboard-coding-system 'latin-1)
(set-terminal-coding-system 'latin-1)
(prefer-coding-system 'latin-1)
har jag i min .emacs, och åäö fungerar även i emacs -nw.

ok det ska jag prova... snabb fråga: ska .emacs finnas i home? eller måste jag göra en, eller ligger den någon annanstans?

edit: Jag gjorde den i home, det funkar, men bara för åäö inte ÅÄÖ=)

i emacs -nw funkar både åäö och ÅÄÖ men inte om jag skriver i konsollen.

People... What a bunch of bastards... | Mac Pro 2x2.26GHz QuadCore - Nehalem, 24GB DDR3, ATI HD4870, 3TB HDD | MacBook Pro 13.3 ", Core 2 Duo - 2.26GHz, 8GB DDR3, 9400M 256MB, 120GB SSD | PowerMac G4 MDD, Dual 1,25GHz, 2GB DDR, 1,45TB HDD | FCNSA | VCP4

Trädvy Permalänk
Medlem
Plats
08-området
Registrerad
Jul 2002

Re: Re: Å, Ä och Ö på diverse ställen

Citat:

Ursprungligen inskrivet av Sachankara
Du måste specificera teckenkodningen på dina "Windows-enheter". T.ex: mount -o nls=iso-8859-1 /dev/cdrom /media/cdrom

Hmm, vet inte vad jag ska göra åt det här.(?)

b2@bip:$ sudo mount -o nls=iso-8859-1 /dev/cdrom /media/cdrom mount: blockenhet /dev/cdrom är skrivskyddad, monterar som endast läsbar mount: wrong fs type, bad option, bad superblock on /dev/cdrom, missing codepage or other error In some cases useful info is found in syslog - try dmesg | tail or so b2@bip:$ dmesg | tail [fglrx] max Inv = 0 [fglrx] total Inv = 0 [fglrx] total TIM = 0 [fglrx] total FB = 0 [fglrx] total AGP = 16384 UDF-fs: No VRS found ISO 9660 Extensions: Microsoft Joliet Level 3 ISOFS: changing to secondary root cdrom: hdc: mrw address space DMA selected cdrom: hdc: mrw address space DMA selected

Citat:

Ursprungligen inskrivet av Jaif
Ubuntu använder UTF-8 som standard, och vill du köra nått annat så gör så här:

sudo dpkg-reconfigure locales
Leta sedan upp sv_SE ISO-8859-1 och sv_SE ISO-8859-15 i listan och kryssa i dessa. I nästa fönster väljer du sv_SE ISO-8859-15 som standard.
Starta sedan om X så borde det fungera.

Om jag gör så, så slipper jag iaf tillägget (invalid encoding). Dock ändrar sig bara de läsbara å,ä och ö till andra oläsliga tecken. :/

| Zepto Znote 4200 | Centrino 1.6 GHz | 512 MB | ATI 9700 | Ubuntu | WinXP Pro | ICQ# 54811730
"Förmågan att idag tänka annorlunda än igår skiljer den vise från den envise." --John Steinbeck
"Self improvement is mastrubation" --T.D.

Trädvy Permalänk
Medlem
Plats
Stockholm, Täby
Registrerad
Jul 2001

Re: Re: Re: Å, Ä och Ö på diverse ställen

Citat:

Ursprungligen inskrivet av B2
Hmm, vet inte vad jag ska göra åt det här.(?)

b2@bip:$ sudo mount -o nls=iso-8859-1 /dev/cdrom /media/cdrom mount: blockenhet /dev/cdrom är skrivskyddad, monterar som endast läsbar mount: wrong fs type, bad option, bad superblock on /dev/cdrom, missing codepage or other error In some cases useful info is found in syslog - try dmesg | tail or so b2@bip:$ dmesg | tail [fglrx] max Inv = 0 [fglrx] total Inv = 0 [fglrx] total TIM = 0 [fglrx] total FB = 0 [fglrx] total AGP = 16384 UDF-fs: No VRS found ISO 9660 Extensions: Microsoft Joliet Level 3 ISOFS: changing to secondary root cdrom: hdc: mrw address space DMA selected cdrom: hdc: mrw address space DMA selected

Menade "-o nls=iso8859-1". Fungerar det inte så testa med "-o nls=utf-8".

Trädvy Permalänk
Medlem
Plats
08-området
Registrerad
Jul 2002

Re: Re: Re: Re: Å, Ä och Ö på diverse ställen

Citat:

Ursprungligen inskrivet av Sachankara
Menade "-o nls=iso8859-1". Fungerar det inte så testa med "-o nls=utf-8".

Har försökt bägge + iso8859-15 och utf8 utan något annat resultat än ovan.

| Zepto Znote 4200 | Centrino 1.6 GHz | 512 MB | ATI 9700 | Ubuntu | WinXP Pro | ICQ# 54811730
"Förmågan att idag tänka annorlunda än igår skiljer den vise från den envise." --John Steinbeck
"Self improvement is mastrubation" --T.D.

Trädvy Permalänk
Medlem
Plats
Skogås
Registrerad
Jul 2004

Hej! skulle bara säga att nu funkar det för mig. Jag gjorde som roggles och jaif sa. men sedan bytte jag tillbaka till UTF-8 igen. då funkar det med åäö, både stora och små och överallt.

Tack för hjälpen!

People... What a bunch of bastards... | Mac Pro 2x2.26GHz QuadCore - Nehalem, 24GB DDR3, ATI HD4870, 3TB HDD | MacBook Pro 13.3 ", Core 2 Duo - 2.26GHz, 8GB DDR3, 9400M 256MB, 120GB SSD | PowerMac G4 MDD, Dual 1,25GHz, 2GB DDR, 1,45TB HDD | FCNSA | VCP4