SSH-tunnlad VNC direkt in går men ej i tre steg...ska det verkligen vara skillnad???

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2004

SSH-tunnlad VNC direkt in går men ej i tre steg...ska det verkligen vara skillnad???

Skumt som fan. Jag kan logga in med VncViewer tunnlat via SSH till mitt SuSE direkt från XP, men försöker jag skapa tunneln via servern så går det inte, jag får aldrig ens upp nån lösenordsruta av VncViewer.

Hur fasen kan SuSE känna av någon skillnad på tunneln....att den kommer från en dator 2 steg bort istället för 1 steg bort så att säga?

Funkar på den andra SuSE installationen men den gjorde lite andra val vad gällde tillåtande av VNC-administration, men jag fattar inte att direkt VNC kan tillåtas men inte genom en annan dator, och var inställningen kan vara nånstans, i vilken config-fil?

Nackdelen med grafiska installers, man kan välja inställningar utan att det står vad dom egentligen gör och man ser inte vilken fil som det ändras i och hur det ändras

Fan, hoppas det inte blivit för många trådar idag, men denna frågeställning tror jag är väldigt intressant.....hoppas nån känner till sånt här bara

CCNA sedan juni 2006

Trädvy Permalänk
Medlem
Plats
Slottsbron
Registrerad
Jan 2002

WinXP -> server -> SuSE , är det så du vill gå?

skapar du två tunnlar? hur skapar du dom? skulle tro att det är nått med tunnlarna som ställer till det och inte nått i vnc konfigurationen.

peter@server ~ $ uptime
22:26:14 up 30 days, 21:28, 4 users, load average: 21.77, 42.33, 26.94

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2004
Citat:

Ursprungligen inskrivet av Whoracle
WinXP -> server -> SuSE , är det så du vill gå?

skapar du två tunnlar? hur skapar du dom? skulle tro att det är nått med tunnlarna som ställer till det och inte nått i vnc konfigurationen.

Nej nej nej, det är inte tunneln som är fel jag lovar
Och det är bara EN tunnel. Man kan ju göra tex såhär:
SSH -L 5900:localhost:5901 user@SugigSusedator
Då blir tunneln direkt till Suse-datorn och den dyker upp just där (localhost).

Sedan kan man göra en tunnel såhär också...gå via en annan dator, och då blir sista biten inte krypterad men den sker ju ändå alltid (antagligen) lokalt.
SSH -L 5900:SugigSusedator:5901 user@serverdator

Jag lovar att jag vet hur man gör tunnlar

CCNA sedan juni 2006

Trädvy Permalänk
Medlem
Plats
Slottsbron
Registrerad
Jan 2002

okej, jag har aldrig gjort nån tunnel av variant 2... trodde du gjorde 2st tunnlar av variant 1 och då skulle det nog rätt lätt bli nått tankefel i konfigurationen.

peter@server ~ $ uptime
22:26:14 up 30 days, 21:28, 4 users, load average: 21.77, 42.33, 26.94

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2004
Citat:

Ursprungligen inskrivet av Whoracle
okej, jag har aldrig gjort nån tunnel av variant 2... trodde du gjorde 2st tunnlar av variant 1 och då skulle det nog rätt lätt bli nått tankefel i konfigurationen.

Jo tunnlar av variant 2 är rätt så användbara.....har man bara ett IP hemma och port 22 går till servern så är det ju bra om man kan tunnla in till de andra datorerna i nätverket hemma.
Dock verkar jag ha sabbat just den funktionen på något sätt vid ena SuSE-installationen men jag förstår inte var var var inställningen är :S

CCNA sedan juni 2006

Trädvy Permalänk
Medlem
Plats
Sundbyberg
Registrerad
Maj 2003
Citat:

Ursprungligen inskrivet av Seb74
Nej nej nej, det är inte tunneln som är fel jag lovar
Och det är bara EN tunnel. Man kan ju göra tex såhär:
SSH -L 5900:localhost:5901 user@SugigSusedator
Då blir tunneln direkt till Suse-datorn och den dyker upp just där (localhost).

Sedan kan man göra en tunnel såhär också...gå via en annan dator, och då blir sista biten inte krypterad men den sker ju ändå alltid (antagligen) lokalt.
SSH -L 5900:SugigSusedator:5901 user@serverdator

Jag lovar att jag vet hur man gör tunnlar

Kan lika gärna fråga här som att skapa en ny tråd.

jag försöker göra en tunnel enligt Seb74's variant två, fast XP-->Debian-->XP. Det funkar tvvärr inte så bra. Jag ställer in putty såhär:
source port: 22
Destination: 192.168.0.2:5900

sedan ansluter jag med vncviewer med serverip:22

är jag helt ute och cyklar eller är det nåt mindre fel som förstör det för mig??

tacksam för hjälp!

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2004
Citat:

Ursprungligen inskrivet av thazzy
Kan lika gärna fråga här som att skapa en ny tråd.

jag försöker göra en tunnel enligt Seb74's variant två, fast XP-->Debian-->XP. Det funkar tvvärr inte så bra. Jag ställer in putty såhär:
source port: 22
Destination: 192.168.0.2:5900

sedan ansluter jag med vncviewer med serverip:22

är jag helt ute och cyklar eller är det nåt mindre fel som förstör det för mig??

tacksam för hjälp!

Ja det är du

Kom på mitt fel förresten...är väl såklart så att sista biten körs ju inte via SSH så den kräver att 5901 är öppen in till datorn, och min brandvägg är på i den SuSE-datorn så det måste vara så enkelt väl?

Du ställer in putty såhär:
Under Session skriver du user@Debiandator
Sedan går du ner till Tunnels. Där skriver du 5900 som source port, det är alltså port 5900 i XP som ska forwardas vidare. Sedan i Destination skriver du slutgiltiga XP-datorns address : porten den ska dyka upp i.
Sedan, icke att förglömma, tryck på Add för att lägga till tunneln. Sedan Open

CCNA sedan juni 2006

Trädvy Permalänk
Medlem
Plats
Sundbyberg
Registrerad
Maj 2003
Citat:

Ursprungligen inskrivet av Seb74
Ja det är du

Kom på mitt fel förresten...är väl såklart så att sista biten körs ju inte via SSH så den kräver att 5901 är öppen in till datorn, och min brandvägg är på i den SuSE-datorn så det måste vara så enkelt väl?

Du ställer in putty såhär:
Under Session skriver du user@Debiandator
Sedan går du ner till Tunnels. Där skriver du 5900 som source port, det är alltså port 5900 i XP som ska forwardas vidare. Sedan i Destination skriver du slutgiltiga XP-datorns address : porten den ska dyka upp i.
Sedan, icke att förglömma, tryck på Add för att lägga till tunneln. Sedan Open

ok. nu tror jag att jag har fått tunneln rätt iaf. men jag kan fortfarande inte ansluta. jag ansluter med localhost::5900. är jag åtminstone lite i närheten nu?

EDIT: la till ett :

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Aug 2003

Du ska inte skriva in localhost:5900 i vncviewer, skriv localhost bara. Om man vill använda en annan port skriver man istället localhost::port

Trädvy Permalänk
Medlem
Plats
Sundbyberg
Registrerad
Maj 2003
Citat:

Ursprungligen inskrivet av Jaif
Du ska inte skriva in localhost:5900 i vncviewer, skriv localhost bara. Om man vill använda en annan port skriver man istället localhost::port

jag glömde ett : i inlägget. men localhost borde väl vara samma sak som localhost::5900 om 5900 är standardport? resultatet är iaf detsamma. "Failed to connect to server"

tack ändå!

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2004
Citat:

Ursprungligen inskrivet av thazzy
jag glömde ett : i inlägget. men localhost borde väl vara samma sak som localhost::5900 om 5900 är standardport? resultatet är iaf detsamma. "Failed to connect to server"

tack ändå!

Jo det är samma sak.
Skumt att den inte vill connecta. Säkert att du dragit igång Xvnc på sista datorn?

CCNA sedan juni 2006

Trädvy Permalänk
Medlem
Plats
Sundbyberg
Registrerad
Maj 2003
Citat:

Ursprungligen inskrivet av Seb74
Jo det är samma sak.
Skumt att den inte vill connecta. Säkert att du dragit igång Xvnc på sista datorn?

jadå, och det går utmärkt att connecta direkt. det borde väl betyda att det inte är ett brandväggsproblem? Läste nåt om att vncviewer kan krångla när man ansluter till localhost, nåt du hört om? har iaf inte hittat nån lösning på det problemet

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2004
Citat:

Ursprungligen inskrivet av thazzy
jadå, och det går utmärkt att connecta direkt. det borde väl betyda att det inte är ett brandväggsproblem? Läste nåt om att vncviewer kan krångla när man ansluter till localhost, nåt du hört om? har iaf inte hittat nån lösning på det problemet

Failed to connect låter väl som att den inte hittar Xvnc-servern....står ju inte connection refused eller nåt sånt iallafall.
Jag vet inte riktigt vad det kan vara....verkar ju som du skapat tunneln rätt.
Vet inte om det kan va fel i sshd_config, att nån forwarding inte är aktiverad, men det brukar funka med defaultvärdena och dessutom skulle den säkert klaga då när du skapar tunneln.

Kan ju va så att du skapar tunneln fel i putty också. Rätt lätt att råka skriva fel nånstans, eller tänka lite galet.
Tänk på att det måste va helt öppet in till sista XP-burken, så du inte gör samma fel som jag nyss råkade göra när jag skapade denna tråd
Det går ju in i port 22 till Linux, men ut därifrån och in till tredje datorn går det helt öppet på port 5901

CCNA sedan juni 2006

Trädvy Permalänk
Medlem
Plats
Sundbyberg
Registrerad
Maj 2003
Citat:

Ursprungligen inskrivet av Seb74
Failed to connect låter väl som att den inte hittar Xvnc-servern....står ju inte connection refused eller nåt sånt iallafall.
Jag vet inte riktigt vad det kan vara....verkar ju som du skapat tunneln rätt.
Vet inte om det kan va fel i sshd_config, att nån forwarding inte är aktiverad, men det brukar funka med defaultvärdena och dessutom skulle den säkert klaga då när du skapar tunneln.

Kan ju va så att du skapar tunneln fel i putty också. Rätt lätt att råka skriva fel nånstans, eller tänka lite galet.
Tänk på att det måste va helt öppet in till sista XP-burken, så du inte gör samma fel som jag nyss råkade göra när jag skapade denna tråd
Det går ju in i port 22 till Linux, men ut därifrån och in till tredje datorn går det helt öppet på port 5901

Jag tycker att jag gör rätt iaf, men det kan mycket väl vara så att jag gör fel. jag får sova på saken.

tack så mycket för hjälpen så här långt! jag återkommer imorron..;)

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Jul 2001

vncviewers syntax fungerar såhär

host:screen:port

alltså:

192.168.3.27:1:5901

själv ligger min vnc på 5901 av nån anledning. du kan ha flera vnc screens på samma maskin med.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2004
Citat:

Ursprungligen inskrivet av maDa
vncviewers syntax fungerar såhär

host:screen:port

alltså:

192.168.3.27:1:5901

själv ligger min vnc på 5901 av nån anledning. du kan ha flera vnc screens på samma maskin med.

Jo dom brukar ju hamna på 5901, men man connectar ju ändå mot 5900 lokalt....tunneln går ju från 5900 till 5901.
Sedan kör thazzy från XP och antagligen med den grafiska fina vncviewern och där är det bara att knappa in "localhost" så ska det va klart. Antagligen tunnelskapandet via Putty eller också nån brandvägg hos XP i andra änden eller nån config-fil i Linux som spökar....skulle jag tro

CCNA sedan juni 2006