Få tillgång till mina NTSF partitioner i Ubuntu?

Trädvy Permalänk
Medlem
Plats
Lund
Registrerad
Maj 2004

Få tillgång till mina NTSF partitioner i Ubuntu?

Skulle vilja komma åt mina "windows" hårddiskar genom min Ubuntu instalation, men jag hittar dom inte pinsamt nog. Hur skall man gå tillväga?

Trädvy Permalänk
Avstängd
Plats
V-ås - är jag inte söt?
Registrerad
Jul 2001

Det beror förmodligen på att de inte är mountade. Använd "mount".

Coola låtar i massor!
http://revolvermen.com

Trädvy Permalänk
Medlem
Plats
Lund
Registrerad
Maj 2004

ilja: jag är ledsen om det inte framgick med mitt första innläg, men jag är väldigt kass på Linux. Vad skall jag göra? Bara upp med en terminal och skriva "mount" eller? Tack för svaret.

Trädvy Permalänk
Avstängd
Plats
V-ås - är jag inte söt?
Registrerad
Jul 2001

mount [parametrar] [enhet] [katalog att mounta till]
Kör "man mount" för att se exakt vilka parametrar du ska köra.

Coola låtar i massor!
http://revolvermen.com

Trädvy Permalänk
Medlem
Plats
Lidköping
Registrerad
Dec 2003

http://ubuntuguide.org/ har svaren på nästan alla frågor om ubuntu, mycket bra guide.

Först måste du skapa en mapp där du vill att din hdd ska mountas tex:
sudo mkdir /media/windows

Sen mountar du den, eftersom det är ntfs måste du köra read-only vilket åstakomms med detta kommando:
sudo mount /dev/[betäckningen för din disk] /media/windows/ -t ntfs -o nls=utf8,umask=0222

exempel:
sudo mount /dev/hda1 /media/windows/ -t ntfs -o nls=utf8,umask=0222

Grabels Law:
2 is not equal to 3, not even for very large values of 2.

Trädvy Permalänk
Medlem
Plats
Lund
Registrerad
Maj 2004

men hur får jag fram informationen om enheten? är det bara till att skriva "L:\" eller? har försökt läsa igenom hjälp avsnittet men jag är uppenbarligen för korkad att fatta allt.

Edit: skall prova det anders

Trädvy Permalänk
Medlem
Plats
Lidköping
Registrerad
Dec 2003

I linux heter inte diskarna C: D: osv.

Det finns ett logist system över vad de har för betäckning:

hda master på primary ide-kanalen
hdb slave på primary ide-kanalen
hdc master på secondary ide-kanalen
hdd slave på secondary ide-kanalen

Dessa betäckningar efterföljs av en siffra som talar om vilken partition det gäller.
Om masterdisken på priamry ide har 3 partitioner så heter de:
hda1
hda2
hda3

Samma gäller för alla diskar och även cd-läsare. Om en disk bara har en partition så heter den tex:
hdb1

Vet inte om det var detta du undrade över men det är bra att veta när du ska mounta så du slipper gissa så mycket

Grabels Law:
2 is not equal to 3, not even for very large values of 2.

Trädvy Permalänk
Medlem
Plats
Lund
Registrerad
Maj 2004

Ah, tackar. Har lyckats mounta 2 diskar nu. Skall väl snart vara möjligt att få fram dom andra. Tackar.

Edit: Känns lite småfarligt att leka runt såhär, finns inga riskar att pajja nånting när man bara mountar va?

Edit 2: Kan inte få fram min SATA disk, hur gör jag? för jag antar att den inte ligger IDE anslutningarna.

Trädvy Permalänk
Medlem
Plats
Lidköping
Registrerad
Dec 2003

Så länge du inte skriver något till ntfs diskarna ska det inte vara någon fara, tror jag iaf
Skriver man fel när man mountar så kommer det oftast bara ett felmeddelande och så är det inget mer med det.

Jag är inte hundra på hur det är med satadiskarna just i ditt fall. För min egen del så har jag två satadiskar som sitter på en "extern" kontroller som är inbyggd på moderkortet, den fungerar alltså precis som om jag hade haft ett pcikontrollerkort.

På nforce3 och nforce4 chipset så finns det sataportar inbyggda i chipsetet, de fungerar precis som idekontrollerna och behöver inga drivrutiner. Om det är så du har det vet jag inte säkert hur de betäcknas.

Men i mitt fall heter de sda1 och sdb1 (scsi drive, eller om det är special drive inte hundra )

Grabels Law:
2 is not equal to 3, not even for very large values of 2.

Trädvy Permalänk
Medlem
Registrerad
Mar 2004
Citat:

Ursprungligen inskrivet av polygon5
Ah, tackar. Har lyckats mounta 2 diskar nu. Skall väl snart vara möjligt att få fram dom andra. Tackar.

Edit: Känns lite småfarligt att leka runt såhär, finns inga riskar att pajja nånting när man bara mountar va?

Edit 2: Kan inte få fram min SATA disk, hur gör jag? för jag antar att den inte ligger IDE anslutningarna.

Hej

prova
$ ls /sys/block

så ser du vilka block-device som finns tillgängliga. titta runt lite under /sys (cd , ls , cat ) för att bli mer familjär vid systemet . /proc är ett annat bra ställe att titta runt i.

SATA-diskarna brukar heta sd? och partitionerna heter sd?# där ? är en bokstav och # en siffra. I mitt fall:

$ cd /sys/block/sda /sys/block/sda$ ls dev device queue range removable size stat /sys/block/sda$ ls -l device device -> ../../devices/pci0000:00/0000:00:0a.0/host0/target0:0:0/0:0:0:0 /sys/block/sda$ cd device /sys/block/sda$ ls block detach_state driver power queue_type rev state type delete device_blocked model queue_depth rescan scsi_level timeout vendor /sys/block/sda/device$ cat model ST3200822AS

mitt device heter mao "sda" . jag har inga partitioner på den (kör RAID direkt på sda,sdb,sdc och har sedan gjort logiska enheter på raiden med LVM2). Har du partitioner på den kan det se ut så här:

/sys/block/hda$ ls dev device hda1 hda2 hda3 queue range removable size stat /sys/block/hda/hda1$ ls dev size start stat

finns det ett filsystem på partitionen kan man då mounta den genom "sudo mount /dev/hda1 /any/directory"

'udev" heter programmet som har hand om att skapa device-namn under "/dev" i Ubuntu. Genom det kan du få reda på en hel del om olika device (istället för att bläddra runt i /sys).tex:

$ udevinfo -p /sys/block/sda -a
<... mycket info ...>

Med hjälp av denna info kan du sedan tvinga tex en usb-disk att få samma enhetsnamn varje gång du sätter in den (tex genom serienumret). Du har inte alltför stor nytta av detta på fasta diskar.

det går t.o.m att leta upp vilka device som sitter vid ett speciellt PCI-kort. host0,...,host3 är i detta fall mina 4 fysiska SATA-interface på mitt promise-kort

$ lspci ... 0000:00:0a.0 Unknown mass storage controller: Promise Technology, Inc.: Unknown device 3d18 (rev 02) ... $ cd /sys/bus/pci/devices/0000:00:0a.0 /sys/bus/pci/devices/0000:00:0a.0$ $ ls class device host1 irq resource resource3 subsystem_device config driver host2 local_cpus resource0 resource4 subsystem_vendor detach_state host0 host3 power resource2 rom vendor /sys/bus/pci/devices/0000:00:0a.0 $ cd host0/target0:0:0/0:0:0:0 /sys/bus/pci/devices/0000:00:0a.0/host0/target0:0:0/0:0:0:0$ ls -l block block -> ../../../../../../block/sda

observera att jag hamnade på exakt samma ställe denna gång som när jag tog "cd /sys/block/sda/device"

Trädvy Permalänk
Medlem
Plats
Lund
Registrerad
Maj 2004

root@ubuntu5:/home/polygon5 # sudo mount /dev/sd?1 /media/Z/ -t ntfs -o nls=utf8,umask=0222 mount: wrong fs type, bad option, bad superblock on /dev/sda1, missing codepage or other error (aren't you trying to mount an extended partition, instead of some logical partition inside?) In some cases useful info is found in syslog - try dmesg | tail or so

Verkar inte funka. provade andra #, men den hittade inga alls då

Trädvy Permalänk
Medlem
Plats
Borås
Registrerad
Mar 2005

vet inte hur det är i ubuntu men för att andra än admin skall kunna läsa från NTFS partionen så behöves det att man sätter umask=222 eller umask=000 i fdlist (iaf på de 3 distar jag har testat)

Plan9 fan. In glenda we trust.

Trädvy Permalänk
Medlem
Registrerad
Mar 2004
Citat:

Ursprungligen inskrivet av polygon5

root@ubuntu5:/home/polygon5 # sudo mount /dev/sd?1 /media/Z/ -t ntfs -o nls=utf8,umask=0222 mount: wrong fs type, bad option, bad superblock on /dev/sda1, missing codepage or other error (aren't you trying to mount an extended partition, instead of some logical partition inside?) In some cases useful info is found in syslog - try dmesg | tail or so

Verkar inte funka. provade andra #, men den hittade inga alls då

Sorry, blev lite otydligt. Du skall mao byta ut "?" mot en bokstav. Nu kommer troligtvis bash byta ut det där frågetecknet mot något eller några saker. har du bara en disk har du tur. Osäker vad resultatet blivit i ditt fall. Dock verkar det som att du har ett sda1!

Annars följ mitt exempel och bläddra runt i sys så hittar du vad partitionerna heter.

Det andra problemet du fick nu är jag osäker på då jag ej mountar ntfs själv. Det får någon annan svara på.

Trädvy Permalänk
Medlem
Plats
Lund
Registrerad
Maj 2004

root@ubuntu5:/home/polygon5 # sudo mount /dev/sd1 /media/Z/ -t ntfs -o nls=utf8,umask=0222 mount: specialenheten /dev/sd1 finns inte

Som synes så funkade det dåligt...

Edit: Kollade även i sys, där fanns (i mappen block) en mapp, sda, som innehåller sda1 & sda5. var det dessa du menade?

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jan 2005
Citat:

Ursprungligen inskrivet av polygon5

root@ubuntu5:/home/polygon5 # sudo mount /dev/sd1 /media/Z/ -t ntfs -o nls=utf8,umask=0222 mount: specialenheten /dev/sd1 finns inte

Som synes så funkade det dåligt...

Prova detta istället:

sudo mount /dev/sda1 /media/Z/ -t ntfs -o nls=utf8,umask=0222

[EDIT] Kör detta och posta resultatet:

ls /dev/sd*

Trädvy Permalänk
Medlem
Plats
Lund
Registrerad
Maj 2004
Citat:

ls /dev/sd*

/dev/sda /dev/sda1 /dev/sda5

Fick jag utav det. Ditt första förslag fungerade tyvärr inte

mount: wrong fs type, bad option, bad superblock on /dev/sda1, missing codepage or other error (aren't you trying to mount an extended partition, instead of some logical partition inside?) In some cases useful info is found in syslog - try dmesg | tail or so

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jan 2005
Citat:

Ursprungligen inskrivet av polygon5

/dev/sda /dev/sda1 /dev/sda5

Fick jag utav det. Ditt första förslag fungerade tyvärr inte

mount: wrong fs type, bad option, bad superblock on /dev/sda1, missing codepage or other error (aren't you trying to mount an extended partition, instead of some logical partition inside?) In some cases useful info is found in syslog - try dmesg | tail or so

Har du stöd för NTFS i kärnan?

Trädvy Permalänk
Medlem
Plats
Norrköping
Registrerad
Nov 2003

du måste ha skrivit nåt fel eller så, fick själv det felet då jag skulle mounta en ext2-partition och försökte skriva ext3 hela tiden...

För mina NTFS-partitioner kör jag med:
"mount -t ntfs -o umask=0222,nls=utf8 /dev/hda1 /mnt/blabla"

Lian Li PC7SE | Athlon 2800+ | 2x 512MB | Leadtek 6800LE 16/1,6 @ 1,3v 400/870 | 250 + 160 + 2x 200 + 40 = 850GB
Pergo-kuben | Pergomodd2 | PSX-modd | HTPC i CD-spelare | Pergo-tower

Trädvy Permalänk
Medlem
Plats
Lund
Registrerad
Maj 2004
Citat:

Ursprungligen inskrivet av Isbjörnen Igor
Har du stöd för NTFS i kärnan?

Jag har ju mountat mina vanliga hårddiskar som har NTSF om det är det du menade. Och SATAn hat ochså NTSF.

Skall prova ditt sät Ultima.

Edit: funkade inte det heller. Men det verkar ju som Linux inte hittar min Sata disk. Det måste la vara några drivrutiner som fattas eller?

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jan 2005
Citat:

Ursprungligen inskrivet av polygon5
Jag har ju mountat mina vanliga hårddiskar som har NTSF om det är det du menade. Och SATAn hat ochså NTSF.

Skall prova ditt sät Ultima.

Edit: funkade inte det heller. Men det verkar ju som Linux inte hittar min Sata disk. Det måste la vara några drivrutiner som fattas eller?

Är du säker på att du skrev "ntfs" (vilket är rätt) och inte "ntsf" (som två gånger i inlägget) när du mountade?

Trädvy Permalänk
Medlem
Plats
Norrköping
Registrerad
Nov 2003

och tar du verkligen rätt partition då?
Sata blir ju något i stil med /dev/sda1, bara att köra "fdisk -l" annars och kolla upp vad den heter-

Lian Li PC7SE | Athlon 2800+ | 2x 512MB | Leadtek 6800LE 16/1,6 @ 1,3v 400/870 | 250 + 160 + 2x 200 + 40 = 850GB
Pergo-kuben | Pergomodd2 | PSX-modd | HTPC i CD-spelare | Pergo-tower

Trädvy Permalänk
Medlem
Plats
Lund
Registrerad
Maj 2004

Tack för alla svar, det funkar nu. MEN! när jag startar om datorn är alla partitioner borta igen... How come?

Trädvy Permalänk
Avstängd
Plats
V-ås - är jag inte söt?
Registrerad
Jul 2001
Citat:

Ursprungligen inskrivet av polygon5
Tack för alla svar, det funkar nu. MEN! när jag startar om datorn är alla partitioner borta igen... How come?

Lägg till dem i /etc/fstab för att de ska mountas vid uppstart.

Coola låtar i massor!
http://revolvermen.com

Trädvy Permalänk
Medlem
Plats
Lund
Registrerad
Maj 2004

Ok, bara att mounta dom i /etc/fstab/blabla då?

Trädvy Permalänk
Avstängd
Plats
V-ås - är jag inte söt?
Registrerad
Jul 2001
Citat:

Ursprungligen inskrivet av polygon5
Ok, bara att mounta dom i /etc/fstab/blabla då?

Nej, fstab är en fil. Kolla "man fstab" för mer info.

Coola låtar i massor!
http://revolvermen.com

Trädvy Permalänk
Medlem
Plats
Lund
Registrerad
Maj 2004

Jag måste vara jävligt jobbig just nu, men jag har fortfarande inte fattat. jag skall alltså inkludera /etc/fstab/ nånstans inom

mount -t ntfs -o umask=0222,nls=utf8 /dev/hda1 /mnt/blabla

Trädvy Permalänk
Avstängd
Plats
V-ås - är jag inte söt?
Registrerad
Jul 2001
Citat:

Ursprungligen inskrivet av polygon5
Jag måste vara jävligt jobbig just nu, men jag har fortfarande inte fattat. jag skall alltså inkludera /etc/fstab/ nånstans inom

mount -t ntfs -o umask=0222,nls=utf8 /dev/hda1 /mnt/blabla

Nej, det går inte för fstab är inte en katalog. I fstab skriver du in var och hur du vill att dina filsystem ska mountas vid uppstart. Du kan titta i filen för att se hur det ser ut och läs "man fstab" för fler detaljer.

Coola låtar i massor!
http://revolvermen.com

Trädvy Permalänk
Medlem
Plats
Lund
Registrerad
Maj 2004

Okej, jag öppnade config filen:

# /etc/fstab: static file system information. # # <file system> <mount point> <type> <options> <dump> <pass> proc /proc proc defaults 0 0 /dev/hdb3 / ext2 defaults,errors=remount-ro 0 1 /dev/hdb2 /boot ext2 defaults 0 2 /dev/hdc /media/cdrom0 udf,iso9660 ro,user,noauto 0 0 /dev/hdd /media/cdrom1 udf,iso9660 ro,user,noauto 0 0

Det som skall göras är alltså att lägga till

/dev/sda5 /media/Y NTFS

Men vad jag skall skriva på "options" , "dump" & "pass" vet jag inte

Edit: Hm, verkade visst inte alls vara någon config fil.

Trädvy Permalänk
Medlem
Plats
Vallentuna
Registrerad
Jan 2004
Citat:

Ursprungligen inskrivet av polygon5
Edit: Hm, verkade visst inte alls vara någon config fil.

Jo. Dump och Pass kan du skriva 0 på båda, options ska vara nls=utf8,umask=0222

Trädvy Permalänk
Medlem
Plats
Lund
Registrerad
Maj 2004

aha, då får jag väl prova då... får se om jag överlever
Edit:
Det funkade på alla hårddiskar förutom SATA'n

# /etc/fstab: static file system information. # # <file system> <mount point> <type> <options> <dump> <pass> proc /proc proc defaults 0 0 /dev/hdb3 / ext2 defaults,errors=remount-ro 0 1 /dev/hdb2 /boot ext2 defaults 0 2 /dev/hdc /media/cdrom0 udf,iso9660 ro,user,noauto 0 0 /dev/hdd /media/cdrom1 udf,iso9660 ro,user,noauto 0 0 /dev/sda5 /media/Y ntfs nls=utf8,umask=0222 0 0 /dev/hdb5 /media/X ntfs nls=utf8,umask=0222 0 0 /dev/hda5 /media/G ntfs nls=utf8,umask=0222 0 0 /dev/hda1 /media/windows ntfs nls=utf8,umask=0222 0 0

sda5 funkar alltså inte av någon annledning.