Trädvy Permalänk
Medlem
Plats
Norrköping
Registrerad
Nov 2003

M$ IntelliMouse 3.0 config?

Skulle vilja configurera xorg.conf (vad det nu var man gjorde) så att jag kan få min mus, en M$ IntelliMouse 3.0, att fungera med de 2st extra knapparna på sidan som jag ofta brukar använda i browsers o.s.v....

Testade någon config jag hittade, men då brajjade x-servern så det var bara att återställa det igen :S

Lian Li PC7SE | Athlon 2800+ | 2x 512MB | Leadtek 6800LE 16/1,6 @ 1,3v 400/870 | 250 + 160 + 2x 200 + 40 = 850GB
Pergo-kuben | Pergomodd2 | PSX-modd | HTPC i CD-spelare | Pergo-tower

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Mar 2003

Så här ser det ut i min xorg.conf:

Section "InputDevice" Identifier "Mouse1" Driver "mouse" Option "Protocol" "ExplorerPS/2" Option "Device" "/dev/input/mice" Option "Buttons" "7" Option "ZAxisMapping" "6 7" EndSection

Jag minns inte om det var något mer som behövde göras innan det fungerade.

Trädvy Permalänk
Medlem
Plats
Norrköping
Registrerad
Nov 2003

tack, ska testa det hemma
Men är det verkligen 7st knappar, eller räknar upp och ner på scrollhjulet som 2st knappar?

Lian Li PC7SE | Athlon 2800+ | 2x 512MB | Leadtek 6800LE 16/1,6 @ 1,3v 400/870 | 250 + 160 + 2x 200 + 40 = 850GB
Pergo-kuben | Pergomodd2 | PSX-modd | HTPC i CD-spelare | Pergo-tower

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Mar 2003

Scrollhjulet är totalt tre stycken knappar, ja.

Trädvy Permalänk
Medlem
Plats
Norrköping
Registrerad
Nov 2003

funkade inte, får bara meddelanden om att x-servern inte är rätt konvigurerat

Lian Li PC7SE | Athlon 2800+ | 2x 512MB | Leadtek 6800LE 16/1,6 @ 1,3v 400/870 | 250 + 160 + 2x 200 + 40 = 850GB
Pergo-kuben | Pergomodd2 | PSX-modd | HTPC i CD-spelare | Pergo-tower

Trädvy Permalänk
Medlem
Registrerad
Mar 2004

Låter som den mus jag kör med:

Section "InputDevice" Identifier "Configured Mouse" Driver "mouse" Option "CorePointer" Option "Device" "/dev/input/mouse0" # Option "Protocol" "ImPS/2" Option "Protocol" "ExplorerPS/2" Option "Resolution" "180" #Option "Emulate3Buttons" "true" Option "ZAxisMapping" "6 7" Option "Buttons" "7" EndSection

för att vända knapparna "rätt" kör jag med följande kommando (någonstans):
xmodmap -e "pointer = 1 2 3 6 7 4 5"

å andra sidan ser detta ut som den du provade med så du har kanske något annat fel...

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Jan 2005

det här har jag.

Section "InputDevice" Identifier "Mouse1" Driver "mouse" Option "Protocol" "ExplorerPS/2" Option "Device" "/dev/input/mice" Option "Buttons" "7" Option "ZAxisMapping" "6 7" EndSection

har samma mus som du och alla knappar funkar även de på sidan

här är min ~/.xinitrc

xmodmap -e "pointer = 1 2 3 6 7 4 5" imwheel -k -b "67"

det här står i min ~/.imweelrc

".*" None, Up, Alt_L|Left None, Down, Alt_L|Right "(null)" None, Up, Alt_L|Left None, Down, Alt_L|Right

du måste ha packetet imweel installerat, - ja kör debian så det var bara att köra apt-get

.:aixelsyd:.
Remember Google isn't the web! But do use it's power!

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Aug 2003
Trädvy Permalänk
Hedersmedlem
Plats
Stockholm
Registrerad
Dec 2002

Se till så att din config inte letar efter Mouse0 eller liknande.

Vim
Kinesis Classic Contoured (svart), Svorak (A5)
Medlem i signaturgruppen Vimzealoter.