Får inte ati-drivrutinerna att funka

Trädvy Permalänk
Medlem
Registrerad
Feb 2005

Får inte ati-drivrutinerna att funka

Jag installerade dom senaste drivrutinerna från ati med installern.
Sedan bytte jag ut ati mot flgrx i xorg.conf.
Men den verkar forfarande köra mesa/vesa eller vad det heter.
När jag kör glxinfo så står det så här:

name of display: :0.0 display: :0 screen: 0 direct rendering: No server glx vendor string: SGI server glx version string: 1.2 server glx extensions: GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context, GLX_OML_swap_method, GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_fbconfig client glx vendor string: ATI client glx version string: 1.3 client glx extensions: GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context, GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_ATI_pixel_format_float, GLX_ATI_render_texture GLX version: 1.2 GLX extensions: GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context, GLX_ARB_multisample OpenGL vendor string: Mesa project: www.mesa3d.org OpenGL renderer string: Mesa GLX Indirect OpenGL version string: 1.2 (1.5 Mesa 6.2.1) OpenGL extensions: GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp, GL_ARB_texture_cube_map, GL_ARB_texture_env_add, GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3, GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color, GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add, GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3, GL_EXT_texture_lod_bias glu version: 1.3 glu extensions: GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat ---------------------------------------------------------------------- 0x23 24 tc 0 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 1 0 None 0x24 24 tc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 1 0 None 0x25 24 tc 0 32 0 r y . 8 8 8 8 0 16 8 16 16 16 16 1 0 None 0x26 24 tc 0 32 0 r . . 8 8 8 8 0 16 8 16 16 16 16 1 0 None 0x27 24 dc 0 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 1 0 None 0x28 24 dc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 1 0 None 0x29 24 dc 0 32 0 r y . 8 8 8 8 0 16 8 16 16 16 16 1 0 None 0x2a 24 dc 0 32 0 r . . 8 8 8 8 0 16 8 16 16 16 16 1 0 None

Vad jag vet så brukar det inte se ut så?
Det gjorde inte så innan vad jag kommer ihåg i alla fall.
Behövs xorg.conf också?

Tack i förhand

Trädvy Permalänk
Medlem
Plats
Lund
Registrerad
Mar 2003

Vilken distribution använder du?

Trädvy Permalänk
Medlem
Plats
Halmstad
Registrerad
Nov 2002

Testa att köra modprobe fglrx

Trädvy Permalänk
Medlem
Registrerad
Feb 2005

Jag kör Ubuntu

modprobe fglrx gav:
FATAL: Module fglrx not found.

hmm... betyder det att den inte är installerad eller vad?

Trädvy Permalänk
Medlem
Plats
Halmstad
Registrerad
Nov 2002

Kolla installationsloggen - /usr/share/fglrx/fglrx-install.log

Trädvy Permalänk
Medlem
Registrerad
Feb 2005

I loggen står det:

[Message] Kernel Module : Trying to install a precompiled kernel module. [Message] Kernel Module : Precompiled kernel module version mismatched. [Error] Kernel Module : No kernel module build environment - please consult readme.

Vad menas?

Trädvy Permalänk
Medlem
Registrerad
Sep 2004

Det betyder väl att du inte har GCC?
Tror iaf att det är det.

EDIT: Kolla i readme filen om det står vilken version av gcc du behöver.

Laptop: Zepto Znote 3215W | Intel C2D T7250 2.0ghz | 2GB ram | Intel X3100 GPU | 120 GB 5400rpm hdd | Intel 4965 AGN | 9-cell batteri
Kamera: Nikon D80 + batterigrepp | Nikkor AF-S DX 18-55mm 3.5-5.6G VR | Nikkor AF-S 70-300/4.5-5.6 G VR IF-ED | Nikkor AF 50mm 1.8D | Nikon SB-600 blixt

Trädvy Permalänk
Medlem
Registrerad
Feb 2005

Var hittar jag readme? Den fanns inte i samma mapp som loggen.

Trädvy Permalänk
Medlem
Registrerad
Sep 2004

Den borde väl finnas i samma mapp som drivrutinerna kom i?
Ska gå och lägga mig nu tyvärr, men annars så bara installera alla gcc paket som finns eller nåt

Laptop: Zepto Znote 3215W | Intel C2D T7250 2.0ghz | 2GB ram | Intel X3100 GPU | 120 GB 5400rpm hdd | Intel 4965 AGN | 9-cell batteri
Kamera: Nikon D80 + batterigrepp | Nikkor AF-S DX 18-55mm 3.5-5.6G VR | Nikkor AF-S 70-300/4.5-5.6 G VR IF-ED | Nikkor AF 50mm 1.8D | Nikon SB-600 blixt

Trädvy Permalänk
Medlem
Registrerad
Feb 2005

Drivrutinerna kom ju i en sån där installer.
Jag hade redan flera olika gcc-paket och installern kompilerar väl inget?

Trädvy Permalänk
Medlem
Plats
Kalmar
Registrerad
Jul 2004

Vet inte hur det är med Ubuntu. Kör Suse. Men jag installerade nyss ATIs drivrutiner. Så det kan ju vara en fördel. Testa med att installera linux-kernel head något skit paketet. Borde finnas på rmp.pbone.net Så löste jag mitt problem och då tror jag att det stod så där som det gjorde för dig. Förresten använder du ATIs run fil?

// Sebastian

Trädvy Permalänk
Medlem
Registrerad
Feb 2005

Får testa det senare, måste sova nu, men tack för alla svar jag fått

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jun 2005

Jag använder Slackware, så det kan hända att detta inte funkar, men förhoppningsvis så:
efter att du installerat paket: (antagligen måste du vara root eller sudo:a)
cd /lib/modules/fglrx/build_mod
chmod u+x make.sh
./make.sh
cd ..
chmod u+x make_install.sh
./make_install.sh
modprobe fglrx

starta sedan om x, som nu förhoppningsvis har fungerande drivare.

Stationär: Intel-baserad, Arch + KDE
Bärbar: Dell XPS 13, Arch + KDE

Trädvy Permalänk
Medlem
Registrerad
Sep 2004
Citat:

Ursprungligen inskrivet av SebastianE
Vet inte hur det är med Ubuntu. Kör Suse. Men jag installerade nyss ATIs drivrutiner. Så det kan ju vara en fördel. Testa med att installera linux-kernel head något skit paketet. Borde finnas på rmp.pbone.net Så löste jag mitt problem och då tror jag att det stod så där som det gjorde för dig. Förresten använder du ATIs run fil?

Ja, just det. Har också för mig att man måste ha "kernel-headers" som stämmer med din kernelversion.

Laptop: Zepto Znote 3215W | Intel C2D T7250 2.0ghz | 2GB ram | Intel X3100 GPU | 120 GB 5400rpm hdd | Intel 4965 AGN | 9-cell batteri
Kamera: Nikon D80 + batterigrepp | Nikkor AF-S DX 18-55mm 3.5-5.6G VR | Nikkor AF-S 70-300/4.5-5.6 G VR IF-ED | Nikkor AF 50mm 1.8D | Nikon SB-600 blixt

Trädvy Permalänk
Medlem
Plats
under en bro
Registrerad
Dec 2001

Det är betydligt lättare att installera ATI's drivrutin med apt-get i ubuntu.

Sök på fglrx i synaptic eller vad du nu använder, jag minns inte vad paketet heter.

Jan-banan: Om alla mailar och frågar eller stämmer MS så kanske dom måste släppa koden?

Trädvy Permalänk
Medlem
Plats
Halmstad
Registrerad
Nov 2002

Hade samma problem, tror dock att jag endast behövde ända vissa saker i kerneln, sen fungerade installationen fint.

Läs här för mer info under "Section 2 - Kernel configuration": http://odin.prohosting.com/wedge01/gentoo-radeon-faq.html

Jag har själv inte fått drivrutinerna att fungera helt ännu, går segt som en hest när det ska ritas saker med texturer. Får ~4500 Fps i glxgears.

Trädvy Permalänk
Medlem
Registrerad
Feb 2005

Jag avinstallerade 8.18-något och installerade 8.16-något med apt-get och följde instruktionerna påhttp://ubuntuforums.org/showthread.php?t=75378 .
Det stog någonstans att det inte var någon prestandaskillnad mellan dom, bara att den senaste fixade något med upplösningen.
En annan grej bara, när jag kör glxgears så printar den inte ut min fps, någon som har en aning om varför?

Tack till alla som har svarat!

EDIT: Det är detta komando du måste köra:

glxgears -iacknowledgethatthistoolisnotabenchmark