Formatera+montera hårddisk??? Hur då??

Trädvy Permalänk
Medlem
Registrerad
Okt 2005

Formatera+montera hårddisk??? Hur då??

Ok. Jag formaterade min andra hårddisk som jag ska använda för att ladda ner saker på, körde detta:

sudo mkfs.ext3 /dev/hdb

vilket borde göra att den är formaterad om jag fattat det rätt.

Körde sen detta:

sudo mount /dev/hdb1 /media/disk ext3 defaults,utf=000 0 0

sen provade jag detta:

sudo mount /dev/hdb1 /media/disk ext3 defaults,user 0 0

I båda fallen fick jag upp detta:

Användning: mount -V : visa version
mount -h : visa denna hjälptext
mount : visa monterade filsystem
mount -l : samma, inklusive volymetiketter
Det var den informativa delen. Nu kommer vi till montering.
Kommandot är "mount [-t filsystemstyp] någonting här".
Detaljer som kan hittas i /etc/fstab kan utelämnas.
mount -a [-t|-O] ... : montera allt i /etc/fstab
mount enhet : montera enhet på den kända platsen
mount katalog : montera känd enhet här
mount -t typ enhet kat : vanligt monteringskommando
Observera att man egentligen inte monterar en enhet, utan ett
filsystem (av angiven typ) som finns på enheten.
Man kan också montera ett redan synligt katalogträd någon annanstans:
mount --bind gammalkatalog nykatalog
eller flytta ett underträd:
mount --move gammalkatalog nykatalog
En enhet kan anges med namn, exempelvis /dev/hda1 eller /dev/cdrom,
eller med etikett, genom att använda -L etikett eller med uuid,
genom att använda -U uuid.
Andra flaggor: [-nfFrsvw] [-o flaggor] [-p lösenordfd].
Säg man 8 mount för många fler detaljer.

Hur ska jag göra?

Trädvy Permalänk
Medlem
Plats
Limbo
Registrerad
Jun 2004

Skippa "sudo mount" och lägg in resten i din /etc/fstab

This sonet is devoted to that alleycat of the year after.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2002

börja med att partitionera disken (med t.ex. fdisk eller cfdisk). Om du skapar en enda partition över hela disken kommer den heta /dev/hdb1.
Det går att köra ett filsystem över hela disken utan partitionering, men det är bara en massa besvär.

Sen ska det bara vara att montera med
mount /dev/hdb1 /media/disk

Min dator är tuffare än din.

Trädvy Permalänk
Medlem
Registrerad
Okt 2005

Ok. Tack så mycket för de snabba svaren! Men nu blev jag förvirrad. Ska jag köra in det direkt i fstab, eller måste jag först skapa en partition?

Edit: Ok. Jag lade in: /dev/hdb1 /media/disk ext3 defaults,utf=000 0 0 i fstab

Sen körde jag: sudo mount /dev/hdb1 /media/disk

Får då detta: mount: du måste ange filsystemstypen.

Så här:

sudo mount /dev/hdb1 /media/disk
mount: du måste ange filsystemstypen

Trädvy Permalänk
Medlem
Plats
Norrköping
Registrerad
Nov 2003

du kan inte bara köra "sudo mount /dev/hdb1 /media/disk", utan du måste köra nåt i stil med:
"sudo mount -t ext3 -o defaults,utf=000 /dev/hdb1 /media/disk"

Lian Li PC7SE | Athlon 2800+ | 2x 512MB | Leadtek 6800LE 16/1,6 @ 1,3v 400/870 | 250 + 160 + 2x 200 + 40 = 850GB
Pergo-kuben | Pergomodd2 | PSX-modd | HTPC i CD-spelare | Pergo-tower

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jan 2005

Gör detta:

$ su - # fdisk /dev/hdb ** Skapa en partition som täcker hela disken. Se "man fdisk" ** # mke2fs -j /dev/hdb1 # logout

Lägg sedan detta i /etc/fstab:

/dev/hdb1 /media/disk ext3 defaults 0 0

För mer info, läs detta:
http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=1...
http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=1...

Trädvy Permalänk
Medlem
Registrerad
Okt 2005
Citat:

Ursprungligen inskrivet av ultima
du kan inte bara köra "sudo mount /dev/hdb1 /media/disk", utan du måste köra nåt i stil med:
"sudo mount -t ext3 -o defaults,utf=000 /dev/hdb1 /media/disk"

Om jag kör det så får jag: mount: specialenheten /dev/hdb1 finns inte

Men om jag kör: sudo mount /dev/hdb /media/disk , dvs utan ettan, så kommer den helt plötsligt upp(trots att det är hdb1 i fstab), men disken är konstig. Den ligger en mapp i disken som heter "lost+found" men den kan jag inte ta bort, för jag har inte "rättigheter". Om jag ändrar till hdb bara i fstab, och kör: mount /dev/hdb/ media/disk, så händer samma sak. En mapp på hårddisken som jag inte kan komma åt.

Om jag kör: sudo mount -t ext3 -o defaults,utf=000 /dev/hdb /media/disk (dvs utan ettan, och utan ettan i fstab) så får jag följande:

mount: wrong fs type, bad option, bad superblock on /dev/hdb,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so
Kan det hela ha någonting med partitionering att göra?

Citat:

Gör detta:

code:
$ su -
# fdisk /dev/hdb
** Skapa en partition som täcker hela disken. Se "man fdisk" **
# mke2fs -j /dev/hdb1
# logout

Lägg sedan detta i /etc/fstab:

code:
/dev/hdb1 /media/disk ext3 defaults 0 0

För mer info, läs detta:
http://www.gentoo.org/doc/en/handbo...rt=1&chap=4
http://www.gentoo.org/doc/en/handbo...rt=1&chap=8

Kommer inte in på su - "fel password" - hur resettar jag detta?

Det funkade en gång tror jag, dock. Men jag gick ut igen, nu kommer jag inte in. Jag gick in med sudo -s -H istället.

"** Skapa en partition som täcker hela disken. Se "man fdisk" **"

Valde "n" lägg till en ny partition, antar att det är rätt. Valde sen primär partition.

Matade sen in: mke2fs -j /dev/hdb1 men någon formatering verkar inte ha skett....

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Jul 2001

I Debians orginalkernels så måste jag alltid starta om för att hitta nya partitioner... dumt men sant.. Sen kan du inte formatera en hårrdisk (hdb) utan partitioner, du måste göra en partiton (hdb1), sen formatera den.

tips! cfdisk är betydligt lättare och smidigare än fdisk

Lägg in din rad i /etc/fstab
därefter kör "mount -a", då kommer den montera allt från fstab

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jun 2005
Citat:

Ursprungligen inskrivet av oki
Om jag kör det så får jag: mount: specialenheten /dev/hdb1 finns inte

ls /dev/hd*

och skriv din output här, för att se vilka partitioner du har.

Stationär: Intel-baserad, Arch + KDE
Bärbar: Dell XPS 13, Arch + KDE

Trädvy Permalänk
Medlem
Registrerad
Okt 2005

/dev/hda /dev/hda1 /dev/hda2 /dev/hda5 /dev/hdb /dev/hdc

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jun 2005

i fstab, testa att byta ut
/dev/hdb1
mot
/dev/hdb
förhoppningsvis hamnar den inte i lost + found nu.

Stationär: Intel-baserad, Arch + KDE
Bärbar: Dell XPS 13, Arch + KDE

Trädvy Permalänk
Medlem
Registrerad
Okt 2005

Om jag kör med: /dev/hdb /media/disk ext3 defaults,utf=000 0 0 (utan ettan) i fstab och mountar med: sudo mount /dev/hdb /media/disk (utan ettan) så kommer hårddisken upp, men disken innehåller en mapp "lost+found"... som jag inte kommer in i, och jag kan inte spara nåt på disken.

Trädvy Permalänk
Medlem
Plats
Stockholm, Täby
Registrerad
Jul 2001
Citat:

Ursprungligen inskrivet av oki
Om jag kör med: /dev/hdb /media/disk ext3 defaults,utf=000 0 0 (utan ettan) i fstab och mountar med: sudo mount /dev/hdb /media/disk (utan ettan) så kommer hårddisken upp, men disken innehåller en mapp "lost+found"... som jag inte kommer in i, och jag kan inte spara nåt på disken.

1. Endast root har access till HD:n från början. Det ändrar du genom chown.
2. Lost+found ska inte vanliga användare kunna läsa för där läggs återställd data.
3. Som det skrevs tidigare, skapa en partition på HD:n i stället och formatera den.
4. Angående ettan, så är det bättre att skapa en katalog på enheten och ge en användare fullständiga rättigheter på den men inte på rooten av enheten.
5. Man måste inte speca utf=000. Ta bort det...