Trädvy Permalänk
Medlem
Plats
Nora
Registrerad
Aug 2004

router

nu har jag iptables å 2 nätverkskort å allt i min Linux server (Debian).

de ända ja nu skulle vilja ha är DHCP så ja får ipn auto från servern till de lokala, hur fixar ja de?:P

behöver ja säga va de är för saker i servern?nic pcu osv?då får ni säga de

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Jul 2001

Du behöver en DHCP-server, apt-get'a ner en sånn (t.ex dhcpd)

Här har du ett exempel på /etc/dhcpd.conf

# main default-lease-time 600; max-lease-time 7200; ddns-update-style none; ddns-updates off; # default scopes subnet 192.168.1.0 netmask 255.255.255.0 { range 192.168.1.10 192.168.1.100; option routers 192.168.1.1; option domain-name "blattis.local"; option domain-name-servers 192.168.1.1; }

därefter får du köra igång tjänsten med /etc/init.d/dhcpd restart eller något likande...

Trädvy Permalänk
Medlem
Plats
Nora
Registrerad
Aug 2004

maDa, ja va där inne å kika förut, men hur vet man vilket nätverkskort de hamnar på?asså själva DHCPserver?

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Jul 2001

Det hamnar på det kortet (subnet) som de finns ett scope upplaggt för

detta fallet t.ex 192.168.1.1

Trädvy Permalänk
Medlem
Plats
Nora
Registrerad
Aug 2004

ja du, så här ser en bit i början ut, ja råka ändra utan att ja tänkte på va ja gjorde, ja ändrare me vim. kan man ändar tillbaka på något sätt?

"#
# Sample configuration file for ISC dhcpd for Debian
#
# $Id: dhcpd.conf,v 1.4.2.2 2002/07/10 03:50:33 peloy Exp $
#

# option definitions common to all supported networks...
option domain-name "blattis.2soft.se";
option domain-name-servers toccata.fugue.com;

option subnet-mask 255.255.255.0;
default-lease-time 600;
max-lease-time 7200;

#subnet 10.90.90.0 netmask 255.255.255.0 {
# range 10.90.90.1 10.90.90.50;
# option broadcast-address 204.254.239.31;
# option routers prelude.fugue.com;
#}

# The other subnet that shares this physical network
#subnet 204.254.239.32 netmask 255.255.255.224 {
# range dynamic-bootp 204.254.239.10 204.254.239.20;
# option broadcast-address 204.254.239.31;
# option routers snarg.fugue.com;
#}

#subnet 192.5.5.0 netmask 255.255.255.224 {
# range 192.5.5.26 192.5.5.30;
# option name-servers bb.home.vix.com, gw.home.vix.com;
# option domain-name "vix.com";
# option routers 192.5.5.1;
# option subnet-mask 255.255.255.224;
# option broadcast-address 192.5.5.31;
# default-lease-time 600;
# max-lease-time 7200;
"

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Jul 2001

blås hela configen och kör me den ja visa istället.. bara ändra efter eget behov..

dessutom är vi/vim onödigt krånglig, testa nano istället.

Trädvy Permalänk
Hedersmedlem
Plats
Stockholm
Registrerad
Dec 2002

maDa: Absolut inte onödigt krångligt när man väl lärt sig det, dock kan det vara lite jobbigt i början om man inte läser hjälp-filerna.

Vim
Kinesis Classic Contoured (svart), Svorak (A5)
Medlem i signaturgruppen Vimzealoter.

Trädvy Permalänk
Medlem
Plats
Nora
Registrerad
Aug 2004

aja ska testa me "# main
default-lease-time 600;
max-lease-time 7200;
ddns-update-style none;
ddns-updates off;

# default scopes
subnet 192.168.1.0 netmask 255.255.255.0 {
range 192.168.1.10 192.168.1.100;
option routers 192.168.1.1;
option domain-name "blattis.local";
option domain-name-servers 192.168.1.1;"

bara de i min cfg, eller ja rätta ipn å så, '

MEN allt som står i min den där cfgn nu, va är allt de bra för?ja menar den lär väl göra någon nytta nu?

Trädvy Permalänk
Medlem
Registrerad
Aug 2001

om jag inte minns helt fel så måste du ändra i filen dhcp som ligger i >>> /etc/default/

annars kommer dhcp servern klaga på att det inte finns något nätverkskort.

Trädvy Permalänk
Medlem
Plats
Nora
Registrerad
Aug 2004

hehe, ska testa i kväll då, tack ska ni ha, har ni något mer å säga som är bra så säg de ffs, tveka inte

EDIT:
fan ja fick de inte att funka, fick massa errors å skit, återkommer med vad