Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Nov 2001

åäö i Terminal.app

Nu känns det som om jag försökt allt med Terminal.app i OS X. Jag skulle gärna använda denna terminal eftersom den "känns" snabbare än t.ex iTerm. Det är bara det att den inte hanterar åäö helt perfekt.

T.ex när jag sshar till min server och försöker köra irssi i en screen så blir det en hel massa kosntiga tecken när jag trycker på å,ä eller ö. Det kan se ut såhär VåVäVö. Någon som vet vad det kan bero på?

Det kan tänkas att det är servern det är fel på men det tvekar jag på.

Nåväl. Någon som har fungerande inställningar för Terminal.app kan väll skriva ner dom här?

Edit: Glömde nämna att backspace inte fungerar när jag loggar in i screen via ssh. Det fungerar dock utmärkt när jag kör screen lokalt. Mycket lustigt tycker jag.

Tack på förhand. Jocke

Datateknik på Kungliga Tekniska Högskolan.

Trädvy Permalänk
Medlem
Plats
Västerås
Registrerad
Jul 2001
Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Nov 2001

hm, när jag kör screen i utf8läge så får jag bara skräptecken. Det är nog inte det jag vill. Jag vill köra screen i iso latin1 läge. Jag antar att man gör det per default. Det är därför jag tycker det är lite konstigt att det inte fungerar.

Datateknik på Kungliga Tekniska Högskolan.

Trädvy Permalänk
Medlem
Plats
Västerås
Registrerad
Jul 2001

Då får du byta till "Western (ISO Latin 1)" i Window Settings -> Display -> Character Set Encoding

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jan 2005
Citat:

Ursprungligen inskrivet av elk
Då får du byta till "Western (ISO Latin 1)" i Window Settings -> Display -> Character Set Encoding

Jag har samma problem, men det där hjälper inte för mig.

[EDIT] Detta är vad jag får.
Western (Iso Latin 1):
å - \345
ä - \344
ö - \366
Å - \305
Ä - \304
Ö - \326

Unicode (UTF-8):
å - \303\245
ä - \303\244
ö - \303\266
Å - \303\205
Ä - \303\204
Ö - \303\226

Detta gäller när jag skriver efter bashprompten. Med Western fungerar det utmärkt i VIM, men inte i nano eller några andra program jag testat.

Trädvy Permalänk
Medlem
Plats
/home/pa
Registrerad
Jul 2004

för mig funka det att byta till ISO Latin1 för att få åäö när jag sshar däremot så fungerar inte åäö om jag inte sshar och sedan så kommer det ett automatsikt enter efter varje (förrutsatt att man använder någon textediterare) i irssi läggs det till ett V framför ex vä så man får gå tillbaka ett snäpp och sudda lite :).

Chassi: Fractal Design Node 304, GPU: EVGA GeForce GTX 670, CPU: Intel i5 3570K Kylare: Antec 620, SSD: Samsung 840 120GB, PSU: Fractal Design Integra R2 650W, Mobo: ASRock Z77E-ITX, RAM: Corsair Vengeance LP 2x8GB, OS: Win7 Pro

Trädvy Permalänk
Medlem
Plats
n
Registrerad
Maj 2004