Efter Ubuntu installation går klockan fel i XP

Trädvy Permalänk
Medlem
Plats
Norrland
Registrerad
Jan 2003

Efter Ubuntu installation går klockan fel i XP

Jag kör dualboot med Ubuntu 5.10 och XP. Efter att jag installerat Ubuntu så går klockan ofta fel när jag sedan byter till XP. Tiden i Ubuntu visas korrekt, medans klockan i XP var två timmar efter. Någon som kan ha en susning om vad som orskar det här?

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Apr 2002

Har du ställt in rätt tidszon? Är biosklockan ställd efter lokal tid eller UTC? kolla upp något i stil med /etc/localtime eller /etc/timezone vilket ska vara länkat till rätt /usr/share/zoneinfo/plats.

your lichen-covered corpuscles are filthy to my fist
infection is your finest flower mildewed in the mist

Trädvy Permalänk
Medlem
Plats
Nora
Registrerad
Aug 2004

2pac, så va de för mej med förut, men ja kommer inte ihåg va ja gjorde för att de funka bra igen :S

Trädvy Permalänk
Medlem
Plats
Norrköping
Registrerad
Nov 2003

har samma problem att linux ställer in sig på rätt tid, men samtidigt så ändrar sig windows-tiden två timmar fel, har då rätt tidszon inställt..
Jag löste det genom att ställa in i linux så man använde en tidszon två timmar tidigare, tror det var på kanarieöarna eller liknande

Lian Li PC7SE | Athlon 2800+ | 2x 512MB | Leadtek 6800LE 16/1,6 @ 1,3v 400/870 | 250 + 160 + 2x 200 + 40 = 850GB
Pergo-kuben | Pergomodd2 | PSX-modd | HTPC i CD-spelare | Pergo-tower

Trädvy Permalänk
Medlem
Plats
Norrland
Registrerad
Jan 2003

Jag vill ha rätt tid i båda operativsystemen, så att ställa in linux klockan enligt en annan tidszon känns inte aktuellt, men tack för tipset

Trädvy Permalänk
Medlem
Plats
Lund
Registrerad
Mar 2003

Re: Efter Ubuntu installation går klockan fel i XP

Citat:

Ursprungligen inskrivet av 2pac
Jag kör dualboot med Ubuntu 5.10 och XP. Efter att jag installerat Ubuntu så går klockan ofta fel när jag sedan byter till XP. Tiden i Ubuntu visas korrekt, medans klockan i XP var två timmar efter. Någon som kan ha en susning om vad som orskar det här?

Ja, har samma sak jag med. Inte för att jag bryr mig så mycket, jag dualbootar bara för att spela spel. Säg till om du hittar en lösning!

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Apr 2002
Citat:

Ursprungligen inskrivet av ultima
har samma problem att linux ställer in sig på rätt tid, men samtidigt så ändrar sig windows-tiden två timmar fel, har då rätt tidszon inställt..
Jag löste det genom att ställa in i linux så man använde en tidszon två timmar tidigare, tror det var på kanarieöarna eller liknande

Vilket förmodligen beror på att ditt system förväntar sig att biosklockan är ställd efter GMT men du har den ställd efter lokal tid. Sätt UTC=no i /etc/defaults/rcS

your lichen-covered corpuscles are filthy to my fist
infection is your finest flower mildewed in the mist

Trädvy Permalänk
Medlem
Plats
Norrland
Registrerad
Jan 2003
Citat:

Ursprungligen inskrivet av Shibuya-Kei
Vilket förmodligen beror på att ditt system förväntar sig att biosklockan är ställd efter GMT men du har den ställd efter lokal tid. Sätt UTC=no i /etc/defaults/rcS

Men skillnaden mellan GMT och lokaltid är bara en timme, inte två.

Nåväl, jag ska prova ditt förslag.

Trädvy Permalänk
Medlem
Plats
Staden
Registrerad
Sep 2003

Det blir två timmars skillnad med sommartid.

Trädvy Permalänk
Medlem
Plats
Norrland
Registrerad
Jan 2003

Nu är problemet fixat. Som Shib etc skrev så justerar man det hela genom att sätta UTC=no.

Här är en mer detaljerad how to.

From Ubuntuguide.org:

How to disable system time/date from being reset to UTC (GMT)?

sudo cp /etc/default/rcS /etc/default/rcS_backup
sudo gedit /etc/default/rcS

3. Find this line

...
UTC=yes
...

4. Replace with the following line

UTC=no

5. Save the edited file (sample)
6. System -> Administration -> Time and Date

Set the correct time/date

7.

sudo /etc/init.d/hwclock.sh restart

Trädvy Permalänk
Medlem
Plats
Norrköping
Registrerad
Nov 2003

tack för tipset, då kan man köra på det "riktiga" sättet, inte för att det gör mig något

Lian Li PC7SE | Athlon 2800+ | 2x 512MB | Leadtek 6800LE 16/1,6 @ 1,3v 400/870 | 250 + 160 + 2x 200 + 40 = 850GB
Pergo-kuben | Pergomodd2 | PSX-modd | HTPC i CD-spelare | Pergo-tower