Debian, xserver hänger sig i uppstart.

Trädvy Permalänk
Medlem
Plats
127.0.0.1
Registrerad
Feb 2004

Debian, xserver hänger sig i uppstart.

Har precis kört en distupgrade på debian burken och efter det så kraschar X när jag startar burken. Behöver kommandot som man kör för att starta burken utan att boota X. Vet att man kan skriva något i GRUB som gör att man inte bootar gdm och på så sätt kan kolla i syslogen. Någon som vet vad jag menar?

Problemet löst!

Lösning: Starta i "Recovery mode" ändra från "nvidia" till "nv" i /etx/X11/xorg.conf

Något program hade ändrat i xorg.conf filen när jag körde en dist-upgrade.

4 8 15 16 23 42
Workstation: 2.8 Ghz Prescott | CLUB 3D ATI 9800 PRO | 1024 MB DDRRAM | 120+200+200 GB HDD
En polygon kan aldrig bli snyggare än en pixel.

Trädvy Permalänk
Medlem
Registrerad
Aug 2005

Har du provat med ctrl+alt+F2 för att byta tty?

Trädvy Permalänk
Medlem
Plats
127.0.0.1
Registrerad
Feb 2004
Citat:

Ursprungligen inskrivet av lefant
Har du provat med ctrl+alt+F2 för att byta tty?

det blir en fetkrasch när den försöker start X så jag kan inte trycka någonting på tgbordet. Men jag kom in i safemode. En gång. nu fungerar det inte nå mer. Då stod det något att agpgart inte funkade. Tänkte att det borde ha att göra med grafikkortet. Ska jag testa att instalera om drivrutinerna? Det stod att den gick ner först till 4X agp. Sen 2X. Sen hoppade den fram och tillbaka tills den kraschade.

EDIT: Kom in igen. Hittade en /var/log/gdm/:0.log och där stod det att NVIDIA(0) failed to load glx. inge bra. sååå. Borde jag instalera om nvidia?

EDIT2: Det löste sig. Tydligen så hade något ändrat min xorg.conf så att det stod "nvidia" istället för "nv" vid driver. men nu så ska den fungera tror jag. tack för hjälpen iaf.

4 8 15 16 23 42
Workstation: 2.8 Ghz Prescott | CLUB 3D ATI 9800 PRO | 1024 MB DDRRAM | 120+200+200 GB HDD
En polygon kan aldrig bli snyggare än en pixel.