Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Maj 2003

Make i Ubuntu

Nybörjare här som försöker få till WPA på min Ubuntu-installation, vilket går ganska dassigt, jag kan inte köra "make"!

Tex för att göra det här:

http://tvilda.tigbis.lt/dokuwiki/doku.php?id=ubuntu__intel_pr...

Får jag bara make: command not found. Vad göra?

4930k @ 4.4Ghz | X79 | 32GB @ 2400Mhz | GTX980Ti SLI | Samsung 950Pro | LG 34UM95 | AKG Q701 & Essence STU[br]
Canton Vento 890DC, 856DC, GLE410 | 2*XTZ W10.17 | Marantz SR6010 | Emotiva XPA3 3*200W | Samsung JS9500 65" |

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Sep 2003

Nu är jag ingen linuxexpert men 'sudo apt-get install make' borde väl vara rimligt?

Core 2 Quad Q6600 | Gigabyte GA-P35-DS3 | Corsair XMS2-6400 2x2048MB | Corsair HX 520W | BFG 8800GT

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Mar 2004

agpt-get build-essential burkar ta ner det man behöver

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Nov 2004
Citat:

Ursprungligen inskrivet av dent42
agpt-get build-essential burkar ta ner det man behöver

Jag klargör med lite rättskrivning:

sudo apt-get install build-essential

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Maj 2003
Citat:

Ursprungligen inskrivet av ilmarinen
Jag klargör med lite rättskrivning:

sudo apt-get install build-essential

Jo, så mkt har jag lärt mig iaf Men det skadar ju aldrig med lite extra klarhet.

Man tackar för svaren, fick iofs nåt felmeddelande om att allt i build-essentials inte kunde hittas och att ja skulle köra en apt-get update, det resulterade dock i att den inte hitta nå paket alls.

Fick hursomhelst in make o ska försöka lösa WPA-konfigurationen nu. Tack!

4930k @ 4.4Ghz | X79 | 32GB @ 2400Mhz | GTX980Ti SLI | Samsung 950Pro | LG 34UM95 | AKG Q701 & Essence STU[br]
Canton Vento 890DC, 856DC, GLE410 | 2*XTZ W10.17 | Marantz SR6010 | Emotiva XPA3 3*200W | Samsung JS9500 65" |

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2002

Med bara make kommer du nog inte hela vägen, om du inte fick nåt mer av build-essentials. Ubuntu innehåller inga verktyg alls för att kompilera program (de har tänkt att de allra flesta ska få slippa, vänligt nog). Även om du har make kommer du säkert behöva en hel drös andra verktyg (t.ex. gcc). Se till att få fason på apt-systemet först (det låter som du har nåt felinställt nånstans), och ta hela build-essentials-paketet (det är väl bara ett meta-paket som har dependencies till en massa annat).

Min dator är tuffare än din.

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Nov 2004

försökte du hämta paketet build-essential eller build-essentials?
Jag vet inte vad den heter på rak arm (med eller utan s alltså). Försök med båda.

Trädvy Permalänk
Medlem
Registrerad
Sep 2004

Det ska vara utan 'S'

Laptop: Zepto Znote 3215W | Intel C2D T7250 2.0ghz | 2GB ram | Intel X3100 GPU | 120 GB 5400rpm hdd | Intel 4965 AGN | 9-cell batteri
Kamera: Nikon D80 + batterigrepp | Nikkor AF-S DX 18-55mm 3.5-5.6G VR | Nikkor AF-S 70-300/4.5-5.6 G VR IF-ED | Nikkor AF 50mm 1.8D | Nikon SB-600 blixt