Betydlig sämre ljud i FluxBox vs. KDE

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Jul 2003

Betydlig sämre ljud i FluxBox vs. KDE

Jag har börjat köra Flux mer och mer, och har märkt att all musik knastrar när jag kör i min kära lilla fönsterhanterare.

Jag kör samma program (XMMS och Amarok (med XINE-engine)) i både KDE och Flux, men i KDE låter allt felfritt.

Hur börjar jag felsöka en sån sak?

Allt bra blir bättre med öppen källkod.

Trädvy Permalänk
Medlem
Plats
Bollnäs
Registrerad
Maj 2002

Går till öronläkaren och får placebopiller?

Vad kör du för Fluxboxversion?

Trädvy Permalänk
Medlem
Plats
Jo, det är så här va eh..
Registrerad
Jun 2005

Det lär ha med ljudservern att göra.

Testa:

killall esd
artsd &

Trädvy Permalänk
Medlem
Registrerad
Nov 2002

Den vanligaste orsaken till knaster är att PCM-volymen är för hög.

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Jul 2003
Citat:

Ursprungligen inskrivet av VRMS
Den vanligaste orsaken till knaster är att PCM-volymen är för hög.

Vad menar du?

Jag testade att sänka volymen både på förstärkaren och i programmen, men det knastrar ändå. Det knastrar mer på vissa frekvenser verkar det som - alltså viss typ av musik låter sämre än andra. Jazz knastrar som fan, men techno och basigare metal är inte lika hårt plågade.

EDIT

Märkte precis att efter omstart låter allt bra igen. Innan jag stängde av maskinen var jag inne i KDE och stängde av audio-någonting (Configuration -> KDE -> Audio -> ???) (samma ställe som man kan sätta buffer och prioritet för ljud). Kanske har med det att göra? o_0

Skönt att det fungerar nevertheless. Nu vill jag bara få lineakd att sammarbeta [swec] också...

Allt bra blir bättre med öppen källkod.